Information ausblenden
Das Digital Eliteboard ist ein Kostenloses Forum. Wenn du alle Bereiche sehen möchtest oder Fragen hast, musst du dich zunächst Registrieren.

Jetzt Registrieren

Gelöst Oscam startet aus unerklärlichen Gründen neu

Dieses Thema im Forum "OScam Archiv" wurde erstellt von AnnaLu, 24. Juni 2012.

  1. AnnaLu
    Offline

    AnnaLu Ist oft hier

    Registriert:
    19. April 2010
    Beiträge:
    116
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    Hallo,

    habe auf meinem Debian zu Hause IPC installiert und dort schon seit 2 Jahren problemlos IPC mit Oscam am laufen gehabt. Da ich nur DSL light habe, habe ich jetzt ein VPS gemietet und dort gestern IPC+Oscam installiert. Habe gestern Oscam um 14:45 Uhr gestartet und alles lief problemlos bis 20:52 Uhr, dann hat sich Oscam neu gestartet bzw. im log von oscam-watchdog steht, dass es neugestartet wurde. Das selbe dann um 1:49 Uhr. Habe zur selben zeit den Ram und die CPU kontrolliert, Ram war bei 10% Auslastung und CPU bei 2%. Dann habe ich heute morgen den VPS rebootet und bis eben keine Probleme gehabt und eben hat sich Oscam neugestartet und im Oscam-Watchdog.log steht dass es neugestartet wurde.
    Hier mal die Oscam.log:

    2012/06/24 23:11:42 8DF8B60 c user1 (1702&000000/0000/002A/93:120A): found (853 ms) by sky (P/1/1/2)
    2012/06/24 23:11:43 841E6D8 c user2 (1830&000000/0000/EF75/92:7E01): found (394 ms) by hdplus (P/1/1/2)
    2012/06/24 23:11:49 8DF8B60 c user1 (1702&000000/0000/002A/93:C87C): found (729 ms) by sky (P/1/1/2)
    2012/06/24 23:11:50 841E6D8 c user2 (1830&000000/0000/EF75/92:E6A3): found (393 ms) by hdplus (P/1/1/2)
    2012/06/24 23:11:53 8D73318 c cccam(s) user3: connection closed by client, n=-1.
    2012/06/24 23:11:53 8D73318 c user3 disconnected from XX.XXX.XXX.XX


    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Sun Jun 24 23:12:01 2012
    -------------------------------------------------------------------------------
    2012/06/24 23:12:01 0 s starting thread log_list_thread
    2012/06/24 23:12:01 0 s log_list_thread thread started
    2012/06/24 23:12:01 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #7010 (i486-linux-gnu)
    2012/06/24 23:12:01 0 s version=1.20-unstable_svn, build #7010, system=i486-linux-gnu, nice=0
    2012/06/24 23:12:01 0 s client max. idle=120 sec, debug level=0
    2012/06/24 23:12:01 0 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2012/06/24 23:12:01 0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
    2012/06/24 23:12:01 0 s services reloaded: 0 services freed, 24 services loaded, rejected 0
    2012/06/24 23:12:01 0 s userdb reloaded: 23 accounts loaded, 0 expired, 0 disabled
    2012/06/24 23:12:01 0 s signal handling initialized (type=sysv)
    2012/06/24 23:12:01 0 s 144 service-id's loaded in 1ms
    2012/06/24 23:12:01 0 s can't open file "/var/etc/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/06/24 23:12:01 0 s 940 provid's loaded

    Hier gerade nochmal passiert:

    2012/06/24 23:36:19 B7611D50 c starting thread save lb stats
    2012/06/24 23:36:19 B7611D50 c save lb stats thread started
    2012/06/24 23:36:19 B7611D50 c user1 (1702&000000/0000/002A/93:7008): found (704 ms) by sky (P/1/1/2)
    2012/06/24 23:36:19 0 loadbalancer: statistic saved 205 records to /tmp/stat in 1ms
    2012/06/24 23:36:20 B761CBD0 c user2 (1830&000000/0000/EF75/92:6089): found (397 ms) by hdplus (P/1/1/2)
    2012/06/24 23:36:23 B7613810 c cccam(s) user3: connection closed by client, n=-1.
    2012/06/24 23:36:23 B7613810 c user3 disconnected from XX.XXX.XXX.XX
    2012/06/24 23:36:23 B7613810 c thread B776FB70 ended!


    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Sun Jun 24 23:37:01 2012
    -------------------------------------------------------------------------------
    2012/06/24 23:37:01 0 s starting thread log_list_thread
    2012/06/24 23:37:01 0 s log_list_thread thread started
    2012/06/24 23:37:01 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #7010 (i486-linux-gnu)
    2012/06/24 23:37:01 0 s version=1.20-unstable_svn, build #7010, system=i486-linux-gnu, nice=0
    2012/06/24 23:37:01 0 s client max. idle=120 sec, debug level=0


    Kann man aus dem Log den Fehler erkennen, wieso watchdog oscam neugestartet hat?
    Kann bzw. sollte ich den Watchdog mal deaktivieren?
    Würde es etwas bringen auf eine andere Oscam Version zu wechseln?
    Ist es Zufall, dass oscam neugestartet wurde, weil user3 die Verbindung verloren hat oder könnte das der Verursacher sein?
     
    #1
  2. T1x
    Offline

    T1x VIP

    Registriert:
    11. Juni 2010
    Beiträge:
    3.951
    Zustimmungen:
    2.872
    Punkte für Erfolge:
    113
    AW: Oscam startet aus unerklärlichen Gründen neu

    Das ist eher ein Segfault.
    Wechsle mal die OScam Version.
     
    #2
  3. AnnaLu
    Offline

    AnnaLu Ist oft hier

    Registriert:
    19. April 2010
    Beiträge:
    116
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: Oscam startet aus unerklärlichen Gründen neu

    Nachdem ich zur Version 6069 gewechselt bin, läuft es nun seit 16 Stunden ohne Neustart durch.
     
    #3

Direkt Antworten

Überprüfung:
Der Entwurf wurde gespeichert Der Entwurf wurde gelöscht

Diese Seite empfehlen

OK Mehr information

Diese Seite verwendet Cookies. Mit Ihrem Klick auf OK stimmen Sie der Verwendung von Cookies zu. Andernfalls ist die Funktionalität dieser Website beschränkt.