Information ausblenden
Das Digital Eliteboard ist ein Kostenloses Forum. Wenn du alle Bereiche sehen möchtest oder Fragen hast, musst du dich zunächst Registrieren.

Jetzt Registrieren

Gelöst Kein Schreibzugriff auf Samba Ordner trotz User und Passwort

Dieses Thema im Forum "Debian" wurde erstellt von DocKugelfisch, 31. Dezember 2012.

  1. DocKugelfisch
    Offline

    DocKugelfisch Moderator Digital Eliteboard Team

    Registriert:
    9. Mai 2008
    Beiträge:
    3.242
    Zustimmungen:
    2.793
    Punkte für Erfolge:
    113
    Hallo zusammen!
    Habe heute einem bekannten einen Thin Client mit Debian eingerichtet und eine externe 1TB USB Platte drangehange, in der fstab gemountet und via CIFS freigegeben.
    Leider habe ich keine Schreibrechte, egal was ich mache wenn ich mit CIFS als Client darauf zugreife. NFS ist überhaupt kein Problem, da funktioniert alles bestens.
    Allerdings sollen aus dem Heimnetzwerk Linux und Windows Rechner darauf zugreifen können!

    Ich habe noch nie mit SAMBA gearbeitet, verwende hier NUR NFS weils halt super läuft und ich keine Windoof Rechner mehr habe...

    FRAGE: Wie kann ich es anstellen das JEDER IMMER SCHREIBZUGRIFF auf den bereitgestellten Ordner der 1TB USB hat?
    Ich kann via CIFS wunderbar browsen und auch alles sehen, aber KEIN Schreibzugriff via CIFS...

    Vorab schonmal ein Auszug der Share Definitions der smb.conf:
    Code:
    [
    
    
    NAS]	writeable = yes
    	public = yes
    	path = /media/NAS
    Der Benutzer User ist auch der Gruppe sambashare zugeordnet, oder hab ich hier was komplett falsch verstanden?
    Im Screenshot ist doch zu sehen das die Freigabe für jeden schreibbar ist, wieso kann ich nichts darauf schreiben?
    Wenn ich mich mit nautilus via SSH auf den Server mit diesem Benutzer und seinem Passwort verbinde klappt das ohne Probleme !!!

    Hab mich total verrannt und weiß imho nicht mehr woran es liegen könnte!

    Du mußt dich Registrieren um diesen Link sehen zu können. Hier klicken und kostenlos Registrieren
     
    Zuletzt bearbeitet: 31. Dezember 2012
    #1
  2. DocKugelfisch
    Offline

    DocKugelfisch Moderator Digital Eliteboard Team

    Registriert:
    9. Mai 2008
    Beiträge:
    3.242
    Zustimmungen:
    2.793
    Punkte für Erfolge:
    113
    AW: Kein Schreibzugriff auf Samba Ordner trotz User und Passwort

    Ich antworte mir mal :aha:
    Wir haben es nun anders gelöst! Die Linux Rechner greifen via nautilus und ssh auf den Server zu. Die Windows Clients via WinSCP.
    Ist alles in allem auch sicherer! Wer kein Kennwort hat kann halt nur lesen...

    Allerdings lässt mir das beschriebene Problem keine Ruhe :emoticon-0124-worri
     
    #2
  3. McMighty
    Offline

    McMighty Moderator Digital Eliteboard Team

    Registriert:
    2. März 2009
    Beiträge:
    9.622
    Zustimmungen:
    4.813
    Punkte für Erfolge:
    113
    Beruf:
    Inscheniör
    Ort:
    Bodensee
    AW: Kein Schreibzugriff auf Samba Ordner trotz User und Passwort

    Ich hab vor einigen Monaten nen Rasp mit ner externen Platte und Samba bestückt. Ich entsinne mich, dass man da mit der Freigabe ebenfalls Probleme hatte. Trotz Schreibrechte in der fstab bekam ich keine Schreibrechte für die Platte. Da besteht ein Problem mit dem Windows NTFS Filesystem. Letztendlich hat man einige Codezeilen in der Samba Config auskommentieren müssen, um das Problem zu umgehen.
    Ganz genau weiß ich nicht mehr wie das war, aber falls das Problem noch besteht, könnte ich mal meine gesicherten How-To's nochmal durchforsten. Eventuell liegt ja auch hier Dein Problem.
     
    #3
    Anderl gefällt das.
  4. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.242
    Punkte für Erfolge:
    113
    AW: Kein Schreibzugriff auf Samba Ordner trotz User und Passwort

    Gib mal dem Ordner /media/NAS die Rechte 777, dann sollte es funktionieren.

    Nicht vergessen den Samba Dienst neuzustarten.
     
    #4
  5. McMighty
    Offline

    McMighty Moderator Digital Eliteboard Team

    Registriert:
    2. März 2009
    Beiträge:
    9.622
    Zustimmungen:
    4.813
    Punkte für Erfolge:
    113
    Beruf:
    Inscheniör
    Ort:
    Bodensee
    Das half bei mir eben auch nix. Das war ein generelles Problem mit dem Filesystem NTFS...


    Sent from my iPhone using Tapatalk

    EDIT:

    Ich hab jetzt doch mal nachgeschaut: muss mich etwas korrigieren. Das Problem hatte Owncloud. Und man musste nen Teil Sourcecode in der Owncloud config ausblenden, der da die Rechte der User prüft. Lag aber an NTFS.

    Ich denke Du musst die Rechte eventuell noch in der fstab Datei anpassen (Stichwort Umask)
     
    Zuletzt bearbeitet: 10. Januar 2013
    #5

Direkt Antworten

Überprüfung:
Der Entwurf wurde gespeichert Der Entwurf wurde gelöscht

Diese Seite empfehlen

OK Mehr information

Diese Seite verwendet Cookies. Mit Ihrem Klick auf OK stimmen Sie der Verwendung von Cookies zu. Andernfalls ist die Funktionalität dieser Website beschränkt.