Information ausblenden
Das Digital Eliteboard ist ein Kostenloses Forum. Wenn du alle Bereiche sehen möchtest oder Fragen hast, musst du dich zunächst Registrieren.

Jetzt Registrieren

Anfänger Fragen zur Konfiguration von Oscam

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Liinus, 18. Februar 2014.

  1. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Guten Abend,

    ich habe heute meinen IGEL 564 LX (4 GB CF, 1GB RAM) bekommen und Debian installiert. Danach bin ich dieser Anleitung gefolgt: https://www.digital-eliteboard.com/...nt-564-LX-Premium-als-Oscam-Server-mit-Debian . Bis zu den Konfigurationsdateien war ich mir sicher, dass alles in Ordnung ist/war. Ich möchte lediglich Oscam als Server und Client nutzen. Hier kurz meine Geräte:

    IGEL 564 LX
    Smartmouse 2 Premium
    UM02 mit Sky Welt + Sport + Bundesliga

    Dazu habe ich mir folgende Dateien erstellt/abgeguckt.

    oscam.conf
    [global]
    logfile = /var/log/oscam.log
    cachedelay = 120
    nice = -1
    maxlogsize = 4069
    preferlocalcards = 1
    saveinithistory = 1

    [cccam]
    port = 17213
    version = 2.3.0

    [webif]
    httpport = 33333
    httphelplang = de
    httpuser = ++++
    httppwd = ++++
    httprefresh = 15
    httpallowed = 127.0.0.1,1.1.1.0-255.255.255.255

    oscam.server (rsakey und boxkey habe ich vom Oscam Config Creator)

    [ reader]
    label = UM02
    protocol = mouse
    device = /dev/ttyUSB0
    detect = CD
    cardmhz = 368
    caid = 1838
    rsakey = *****
    boxkey = ****
    group = 3
    emmcache = 1,1,2

    oscam.user
    [account]
    User = Vu
    Pwd = +++++
    AU = UM02
    Group = 3

    [account]
    User = Giga
    Pwd = ++++
    AU = UM02
    Group = 3

    Bitte zerstört mich nicht direkt, ich habe einige Seiten durchgeblättert und versucht die Einstellungen für mein System zu finden. Es gibt ja Dutzende Anleitungen und da ist es doch sehr schwer als Anfänger da durchzublicken.
    Hier mal mein Status falls es weiterhilft:

    2014/02/18 17:43:26 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r9540 (i486-linux-gnu)
    2014/02/18 17:43:26 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 2555
    2014/02/18 17:43:26 0 s userdb reloaded: 2 accounts loaded, 0 expired, 0 disabled
    2014/02/18 17:43:26 0 s signal handling initialized
    2014/02/18 17:43:26 0 s cccam: initialized (fd=5, port=17213)
    2014/02/18 17:43:26 0 s UM02 [mouse] creating thread for device /dev/ttyUSB0
    2014/02/18 17:43:26 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2014/02/18 17:43:26 0 s waiting for local card init
    2014/02/18 17:43:26 9454A48 h webif: decompressed 72089 bytes back into 200260 bytes
    2014/02/18 17:43:26 9454A48 h HTTP Server running. ip=0.0.0.0 port=33333
    2014/02/18 17:43:26 9452D50 r UM02 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=368)
    2014/02/18 17:43:27 9452D50 r UM02 [mouse] card detected
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] ATR: 3F FF 95 00 FF 91 81 71 FE 47 00 44 4E 41 53 50 31 34 32 20 52 65 76 47 30 36 12
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] Init card protocol T1, FI=9, F=512, D=16, N=255
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] Setting baudrate to 115200 bps
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] Calculated work ETU is 8.96 us reader mhz = 357
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] ATR Fsmax is 5 MHz, clocking card to wanted user cardspeed off 3.57 MHz (specified in reader->mhz)
    2014/02/18 17:43:28 9452D50 r UM02 [mouse] Card responded ok for ifsd request of 251
    2014/02/18 17:43:29 9452D50 r UM02 [mouse] detect native nagra card
    2014/02/18 17:43:30 9452D50 r UM02 [mouse] found card system nagra
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] THIS WAS A SUCCESFULL START ATTEMPT No 1 out of max alloted of 1
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] ROM: D N A S P 1 4 2
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] REV: R e v G 0 6
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] SER: ############
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] CAID: 1838
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] Prv.ID: 00 00 04 01 (sysid)
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] Prv.ID: 00 00 00 00
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] IRD ID: ############
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] active to: 2014/05/15 12:59
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] -----------------------------------------
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |id |tier |valid from |valid to |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] +----+--------+------------+------------+
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|05F1 |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|000F |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|7D23 |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|05DD |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|05DF |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|05DE |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|04CE |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|7D27 |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:30 9452D50 r UM02 [nagra] |1103|00F0 |2014/02/10 |2014/05/15 |
    2014/02/18 17:43:31 9452D50 r UM02 [nagra] -----------------------------------------
    2014/02/18 17:43:31 9452D50 r UM02 [nagra] ready for requests
    2014/02/18 17:43:31 0 s init for all local cards done
    2014/02/18 17:43:31 0 s anti cascading disabled

    Mein Gefühl sagt mir, dass es läuft. Stimmt das oder woran erkenne ich das genau?

    Sorry falls die Fragen dämlich sind, aber mehr ließ mein Intellekt nicht zu. Hoffe ihr könnt mir helfen.

    Gruß,
    Liinus
     
    #1
  2. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    AW: Anfänger Fragen zur Konfiguration von Oscam

    indem du eine box anschließt, so dieht man nur, dass die karte mit entitlements gelesen wird,
    clients mit cccam reichen völlig aus, ist einfacher als ocam auf den receivern, au für 1 user reicht auch
     
    #2
  3. 0p3r4t0r
    Offline

    0p3r4t0r Hacker

    Registriert:
    28. März 2012
    Beiträge:
    349
    Zustimmungen:
    112
    Punkte für Erfolge:
    43
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Also sieht wirklich gut aus. Laut deinem Log. Kann auf Anhieb keinen Fehler erkennen. Könntest theoretisch paar Verschönerungen vornehmen, sind allerdings nur zu optischen Zwecken, also nicht wirklich wichtig. Kannst in der conf vielleicht nur mal "version=2.3.0" entfernen, falls du keine Clients hast, die diese Version oder höher verwenden. Achte auch darauf, dass bei e2 Clients die cccam.cfg casesensitive ist. Muss also genau CCcam.cfg heißen. Sonst erkennen die Clients die Datei nicht und können nicht connecten.

    Gesendet von meinem HTC One S mit Tapatalk
     
    #3
  4. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Danke schon mal bis hier hin. Ehrlich gesagt habe ich bei den Howtos die CCam-Sachen umgangen, sodass ich nicht im Detail verstehe was da passiert. Muss ich noch etwas anderes anpassen als die CCcam.cfg ? Dafür gibt es ja schöne Howtos....
     
    #4
  5. 0p3r4t0r
    Offline

    0p3r4t0r Hacker

    Registriert:
    28. März 2012
    Beiträge:
    349
    Zustimmungen:
    112
    Punkte für Erfolge:
    43
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Nein, du schreibst einfach eine CCcam.cfg mit folgender Zeile: C: boxip 17213 Vu pwd - dann sollte Client schon laufen.

    Gesendet von meinem HTC One S mit Tapatalk
     
    #5
  6. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    #6
  7. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Habe die Datei erstellt in /usr/bin doch ich sehe im Webinterface nichts....
     
    #7
  8. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    AW: Anfänger Fragen zur Konfiguration von Oscam

    meinst du cccam.cfg, eher nicht in usr/bin, ist ja keine binär datei,
    bei enigma meist in /etc, müsste doch schon vorhanden sein zum bearbeiten,
    kann das zu vu und giga leider nicht sagen
     
    #8
  9. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Auch in dem Ordner und kompletten Neustart aller Geräte die VU+ als offline drin.
    \edit: Müsste ich nicht theoretisch auch eine F-Line am Server einrichten oder fällt dieses durch OScam weg?
     
    #9
  10. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    AW: Anfänger Fragen zur Konfiguration von Oscam

    f-line sind die user auf dem server, aber c-line muss ipc-ip also vom server haben, nicht boxip
    lies dir ruhg mal meine anleitung aus post #6 durch, da sind auch configs für ipc usw.
     
    Zuletzt bearbeitet: 18. Februar 2014
    #10
  11. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Dankeschööön!!!! Es ist hell... Ein paar Fragen habe ich noch. Bei meinen Clients muss ich so wie in deiner Anleitung den DynDNS eingeben, richtig? Warum musste ich dann bei meiner Vu+ UNO die Server-Adresse eingeben, nicht die des Routers. Warum hat er das nicht erkannt bzw. warum muss ich da n Port angeben. Dann noch zwei Sachen was Einstellungen betrifft.

    1.) Wie erlaube bzw. verbiete ich den Boxen EMM´s zu senden, das müsste doch im Reader zu finden sein.
    2.) Wenn das Ganze mal abkackt, welchen "Überwacher" sollte man sich installieren?

    Danke nochmal !!!!
    Gruß,
    Liinus
     
    #11
  12. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    AW: Anfänger Fragen zur Konfiguration von Oscam

    lokale box: serverip und cccam port (geht intern ohne port öffnen), internetbox: dyndns und cccam port auf server weitergeleitet, den server kann man ja nicht direkt ansprechen, hat lokale ip
    was hat der router damit zu tun, die karte wird am cardserver abgefragt (meine CCcam.cfg mal öffnen steht alles drin)
    ein bestimmter port wird immer für jede anwendung verwendet und ist genau dieser zugeordnet, bei cccam kann man einen port wählen, am besten zwischen 30000-60000
    1. man kann usern au erlauben, also nicht beim reader, hast du ja bei beiden schon gemacht, einer reicht allerdings
    2. mit ipc ist watchdog dafür vorgesehen, verwende aber kein ipc
    ich hoffe, dass du von UM kein IPv6 hast, wenn du übers inet sharen willst
     
    #12
  13. Liinus
    Offline

    Liinus Ist gelegentlich hier

    Registriert:
    16. Februar 2014
    Beiträge:
    58
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Ah okay, danke für die Erklärung! Nee ich hab auch kein IPC, deswegen fragte ich ja. Ich habe keinen UM Internetanschluss, habe IPv4.
     
    #13
  14. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    17.153
    Zustimmungen:
    4.705
    Punkte für Erfolge:
    113
    #14
  15. wafranyofl
    Offline

    wafranyofl Newbie

    Registriert:
    4. Juli 2013
    Beiträge:
    27
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    AW: Anfänger Fragen zur Konfiguration von Oscam

    Hallo. Ich kämpfe mich gerade durch die Anleitung https://www.digital-eliteboard.com/downloads.php?do=file&id=19497, bin als Anfänger aber noch ziemlich ratlos. Ich habe einen VU+ Ultimo mit VTi und eine I12-Karte. Meine Oscam-Version ist OSCAM 1.20-unstable_svn build r8972. Bisher habe ich die oscam.*-Dateien aus dem Link nach etc/tuxbox/config kopiert, die File Permissions auf 644 gesetzt und das Webinterface gestartet. Darin habe ich unter Reader alle Karten bis auf die I12 entfernt, als Device /dev/sci1 eingetragen (unterer Schacht) und MHz=2100 sowie Card MHz=700 eingestellt, wie in der Anleitung vorgeschlagen. Im Moment sind meine abonnierten UM-Kanäle dunkel, die freien natürlich zu sehen.

    Im Status des Oscam-WebIf finde ich zwei Einträge, die mir zu denken geben:
    "2014/02/19 12:32:47 52CDB0 c [DVBAPI] Demuxer #0 no suitable readers found that can be used for decoding!"
    sowie den Eintrag Crypted/OFF in der Zeile des Readers I12.

    Wie sollte ich weiter vorgehen?
     
    #15

Direkt Antworten

Überprüfung:
Der Entwurf wurde gespeichert Der Entwurf wurde gelöscht

Diese Seite empfehlen

OK Mehr information

Diese Seite verwendet Cookies. Mit Ihrem Klick auf OK stimmen Sie der Verwendung von Cookies zu. Andernfalls ist die Funktionalität dieser Website beschränkt.