Digital Eliteboard

Registriere dich noch heute kostenloses um Mitglied zu werden! Sobald du angemeldet bist, kannst du auf unserer Seite aktiv teilnehmen, indem du deine eigenen Themen und Beiträge erstellst und dich über deinen eigenen Posteingang mit anderen Mitgliedern unterhalten kannst! Zudem bekommst du Zutritt zu Bereiche, welche für Gäste verwert bleiben

Simplebuild (3/2.34/1.41)

telecomic

Spezialist
Mitglied seit
12. November 2008
Beiträge
518
Reaktion auf Beiträge
597
Punkte
143
Zur Log Ausgabe kommt es ja gar nicht mit diesen Versionen, wie soll ich da was posten. Egal ob ich manuell starte oder mit dem Cam Starter des GP4 Plugin und der entsprechend umbenannten oscam.
Im Log der oscam in /var/log auf der Box ist der letzte Eintrag der stop des servers. Danach kommt kein Eintrag mehr.. was ja auch passt.. da ja gar nichts passiert. Die Datei ist passenden Verzeichnis mit dem richtigen Namen und den passenden Rechten.

Kannst ja gerne mal probieren.. falls du eine dm920 hast.
 
Mitglied seit
31. Januar 2018
Beiträge
1.510
Reaktion auf Beiträge
1.489
Punkte
163
was soll das für eine Datei sein ?
startet nicht :angry:
 
Zuletzt bearbeitet:
Mitglied seit
18. Mai 2009
Beiträge
752
Reaktion auf Beiträge
1.308
Punkte
143
jo die ist nicht benutzbar
hast du einen smargo ? wenn nein wieso baust du mit libusb
gehe mal in den ordner configs und stelle
compiler_option -O1
 

telecomic

Spezialist
Mitglied seit
12. November 2008
Beiträge
518
Reaktion auf Beiträge
597
Punkte
143
Danke für deine Dateien,
aber mir geht es ja nicht darum dass du mir lauffähige Dateien zur Verfügung stellst.. ich will mir ja selbst welche bauen :blush: und meine oscam die ich bisher gebaut habe sind nicht gepackt sondern nennt sich eben oscam_1.20 und die wird in der Box mit dem Cam Starter aufgerufen. Das sollte doch auch so gehen... bzw. geht ja auch bisher.
Das sollte doch nicht daran scheitern..
 
Mitglied seit
31. Januar 2018
Beiträge
1.510
Reaktion auf Beiträge
1.489
Punkte
163
hast recht, gerade getestet, das Toolchain ist defekt , jedenfalls startet das Ergebnis nicht und das trotz des logs
Code:
   ___  ____   ___
   / _ \/ ___| / __|__ _ _ __ ___
  | | | \___ \| |  / _` | '_ ` _ \
  | |_| |___) | |_| (_| | | | | | |
   \___/|____/ \___\__,_|_| |_| |_|

+-------------------------------------------------------------------------------
| OSCam ver: 1.20_svn rev: 11494 target: arm-simplebuild3-linux-gnueabi-ssl-libusb
| Tools:
|  CROSS    = /opt/s3/support/toolchains/arm_s3_ssl102/bin/arm-simplebuild3-linux-gnueabi-
|  CC       = /opt/s3/support/toolchains/arm_s3_ssl102/bin/arm-simplebuild3-linux-gnueabi-gcc
| Settings:
|  CONF_DIR = /var/keys
|  CC_OPTS  = -Os -ggdb -pipe -ffunction-sections -fdata-sections
|  CC_WARN  = -W -Wall -Wshadow -Wredundant-decls -Wstrict-prototypes -Wold-style-definition
|  CFLAGS   = -fexpensive-optimizations -DWITH_SSL=1 -DWITH_LIBCRYPTO=1 -DWITH_LIBUSB=1 -DWITH_UTF8=1 -DWITH_UTF8
|  LDFLAGS  = -Wl,--gc-sections -DWITH_SSL=1 -DWITH_LIBCRYPTO=1 -DWITH_LIBUSB=1 -DWITH_UTF8=1 -DWITH_UTF8
|  LIBS     = -lssl -lcrypto -lusb-1.0 -lrt -lm -lpthread -ldl
|  UseFlags = USE_SSL=1 USE_LIBCRYPTO=1 USE_LIBUSB=1 USE_UTF8=1
| Config:
|  Addons   : WEBIF WEBIF_LIVELOG WEBIF_JQUERY TOUCH WITH_SSL HAVE_DVBAPI READ_SDT_CHARSETS IRDETO_GUESSING CS_ANTICASC WITH_DEBUG MODULE_MONITOR WITH_LB CS_CACHEEX CW_CYCLE_CHECK
|  Protocols: CAMD35 CAMD35_TCP NEWCAMD CCCAM CCCSHARE GBOX RADEGAST SCAM SERIAL CONSTCW PANDORA GHTTP
|  Readers  : NAGRA NAGRA_MERLIN IRDETO CONAX CRYPTOWORKS SECA VIACCESS VIDEOGUARD DRE TONGFANG BULCRYPT GRIFFIN DGCRYPT
|  CardRdrs : PHOENIX INTERNAL MP35 SMARGO STINGER SMART
|  Compiler : arm-simplebuild3-linux-gnueabi-gcc (crosstool-NG 1.23.0.595-e550d2c) 8.2.0
|  Config   : build/arm-simplebuild3-linux-gnueabi-ssl-libusb/config.mak
|  Binary   : /opt/s3/support/binaries/oscam-svn11494-arm_s3_ssl102-webif-dvbapi-ssl-libusb
+-------------------------------------------------------------------------------
HOSTCC    webif/pages_gen
GEN    webif/pages.c
GEN    Compressed 440360 template bytes into 178675 bytes. 261685 saved bytes (59.43%).
CC    cscrypt/i_ecb.c
CC    cscrypt/i_cbc.c
CC    cscrypt/i_skey.c
CC    cscrypt/des.c
CC    cscrypt/rc6.c
CC    cscrypt/md5.c
CC    cscrypt/mdc2.c
CC    cscrypt/fast_aes.c
CC    cscrypt/sha256.c
CC    csctapi/atr.c
CC    csctapi/icc_async.c
CC    csctapi/io_serial.c
CC    csctapi/protocol_t0.c
CC    csctapi/protocol_t1.c
CC    csctapi/ifd_mp35.c
CC    csctapi/ifd_phoenix.c
CC    csctapi/ifd_sci.c
CC    csctapi/ifd_smargo.c
CC    csctapi/ifd_smartreader.c
CC    csctapi/ifd_stinger.c
CC    minilzo/minilzo.c
CC    module-anticasc.c
CC    module-cacheex.c
CC    module-camd35-cacheex.c
CC    module-camd35.c
CC    module-cccam-cacheex.c
CC    module-cccam.c
CC    module-cccshare.c
CC    module-constcw.c
CC    module-csp.c
CC    module-cw-cycle-check.c
CC    module-dvbapi-chancache.c
CC    module-dvbapi.c
CC    module-gbox-helper.c
CC    module-gbox-sms.c
CC    module-gbox-remm.c
CC    module-gbox-cards.c
CC    module-gbox.c
CC    module-ird-guess.c
CC    module-monitor.c
CC    module-newcamd.c
CC    module-newcamd-des.c
CC    module-pandora.c
CC    module-ghttp.c
CC    module-radegast.c
CC    module-scam.c
CC    module-serial.c
CC    module-stat.c
CC    module-webif-lib.c
CC    module-webif-tpl.c
CC    reader-common.c
CC    webif/pages.c
CC    module-webif.c
CC    reader-bulcrypt.c
CC    reader-conax.c
CC    reader-cryptoworks.c
CC    reader-dgcrypt.c
CC    reader-dre.c
CC    reader-dre-cas.c
CC    reader-dre-common.c
CC    reader-griffin.c
CC    reader-dre-st20.c
CC    reader-irdeto.c
CC    reader-nagra-common.c
CC    reader-nagra.c
CC    reader-nagracak7.c
CC    reader-seca.c
CC    reader-tongfang.c
CC    reader-videoguard-common.c
CC    reader-viaccess.c
CC    reader-videoguard1.c
CC    reader-videoguard12.c
CC    reader-videoguard2.c
CC    oscam-aes.c
CC    oscam-array.c
CC    oscam-hashtable.c
CC    oscam-cache.c
CC    oscam-chk.c
CC    oscam-client.c
CC    oscam-conf.c
CC    oscam-conf-chk.c
CC    oscam-conf-mk.c
CC    oscam-config-account.c
CC    oscam-config-global.c
CC    oscam-config-reader.c
CC    oscam-config.c
CC    oscam-ecm.c
CC    oscam-emm.c
CC    oscam-emm-cache.c
CC    oscam-failban.c
CC    oscam-files.c
CC    oscam-garbage.c
CC    oscam-lock.c
CC    oscam-log.c
CC    oscam-log-reader.c
CC    oscam-net.c
CC    oscam-llist.c
CC    oscam-reader.c
CC    oscam-simples.c
CC    oscam-string.c
CC    oscam-time.c
CC    oscam-work.c
CC    oscam.c
CONF    build/arm-simplebuild3-linux-gnueabi-ssl-libusb/config.c
BUILD    Distribution/list_smargo-1.20_svn11494-arm-simplebuild3-linux-gnueabi-ssl-libusb
LINK    /opt/s3/support/binaries/oscam-svn11494-arm_s3_ssl102-webif-dvbapi-ssl-libusb.debug
STRIP    /opt/s3/support/binaries/oscam-svn11494-arm_s3_ssl102-webif-dvbapi-ssl-libusb

Code:
root@dm920:/tmp# mv oscam-svn11494-arm_s3_ssl102-webif-dvbapi-ssl-libusb oscam_1.20
root@dm920:/tmp# chmod 755 oscam_1.20
root@dm920:/tmp# ./oscam_1.20 -c /data/oscam/
-bash: ./oscam_1.20: No such file or directory
 
Zuletzt bearbeitet:

ghost0815

Power Elite User
Mitglied seit
17. Juni 2012
Beiträge
2.017
Reaktion auf Beiträge
2.050
Punkte
163
Wie bei der RC4 bekomme ich bei der RC5.1,
wenn ich auf Debian Jessi oder Stretch baue, bei osmio4k
Code:
oot@debian:/home/debian# bash <(wget -qO- https://s3.is-by.us/now.sh)
[3;J

  _________.__                  .__          ___.           .__ .__       .___
/   _____/|__|  _____  ______  |  |    ____ \_ |__   __ __ |__||  |    __| _/
\_____  \ |  | /     \ \____ \ |  |  _/ __ \ | __ \ |  |  \|  ||  |   / __ |
/        \|  ||  Y Y  \|  |_> >|  |__\  ___/ | \_\ \|  |  /|  ||  |__/ /_/ |
/_______  /|__||__|_|  /|   __/ |____/ \___  >|___  /|____/ |__||____/\____ |
        \/           \/ |__|               \/     \/                       \/
                                   ________
                                   \_____  \
                                     _(__  <
                                    /       \
                                   /______  /       2019 by Gorgone
                                          \/
        Install starts in 0 s. press ctrl + c to stop

Installdir LOCATION
===================

1 = default /opt/s3
2 = custom directory

? = 1 Default Installdir /opt/s3

please wait
download s3 rc5.1 100% done...
verify file s3_rc5.1.tar.gz: OK

  _    _ _______   __
| |  | |  __ \ \ / /
| |  | | |__) \ V /
| |  | |  ___/ > <
| |__| | |    / . \
  \____/|_|   /_/ \_\
====================
  SELECT Compression
====================

   (1) -1 fast
   (5) -5 normal
   (9) -9 strong
   (b) --best

   
perform now syscheck & checkout ?

1 = YES | 2 NO

? = 1 do syscheck & checkout
[3;J

    _________________
   /   _____/\_____  \   ===============
   \_____  \   _(__  <   Version 3.0 RC5
   /        \ /       \  ===============
  /_______  //______  /  by gorgone 2019
          \/        \/   ===============

  CHECK for binaries
  ==================

  need    dialog          (not found)
  have    grep            /bin/grep
  have    gawk            /usr/bin/gawk
  have    wget            /usr/bin/wget
  have    tar             /bin/tar
  have    bzip2           /bin/bzip2
  need    svn             (not found)
  have    xz              /usr/bin/xz
  need    upx             (not found)
  have    patch           /usr/bin/patch
  have    gcc             /usr/bin/gcc
  have    make            /usr/bin/make
  have    scp             /usr/bin/scp
  need    sshpass         (not found)
  have    openssl         /usr/bin/openssl
  need    dos2unix        (not found)

  CHECK for headers
  =================

  need    crypto.h        (not found)
  need    libusb.h        (not found)
  need    pcsclite.h      (not found)
  have    pthread.h       /usr/include/pthread.h

  CHECK for libraries
  ===================

  need    libccidtwin.so  (not found)

  CHECK for zlib32
  ================

  need    zlib32          (not found)

  Selected installer:    debian_os

  select dialog          from: dialog
  select svn             from: subversion
  select upx             from: upx
  select sshpass         from: sshpass
  select dos2unix        from: dos2unix
  select crypto.h        from: libssl-dev
  select libusb.h        from: libusb-1.0.0-dev
  select pcsclite.h      from: libpcsclite-dev
  select libccidtwin.so  from: libccid
  select zlib32          from: lib32z1

  INSTALLATION
  ============
  update package list...

OK   http://ftp.de.debian.org jessie-updates InRelease
OK   http://ftp.de.debian.org jessie Release.gpg
OK   http://ftp.de.debian.org jessie Release
OK   http://ftp.de.debian.org jessie-updates/main Sources
OK   http://ftp.de.debian.org jessie/main Sources
OK   http://ftp.de.debian.org jessie/main amd64 Packages
OK   http://ftp.de.debian.org jessie/main Translation-de_DE
OK   http://ftp.de.debian.org jessie/main Translation-de
OK   http://ftp.de.debian.org jessie/main Translation-en
Paketlisten werden gelesen...

  install packages bitte warten...

(Lese Datenbank ... 153443 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von libssl1.0.0:amd64 (1.0.1t-1+deb8u10) über (1.0.1t-1+deb8u6) ...
Entpacken von libpcsclite-dev (1.8.13-1+deb8u1) ...
Entpacken von libserf-1-1:amd64 (1.3.8-1) ...
Entpacken von libsvn1:amd64 (1.8.10-6+deb8u6) ...
Entpacken von libucl1:amd64 (1.03+repack-2) ...
Entpacken von dialog (1.2-20140911-1) ...
Entpacken von libc6-i386 (2.19-18+deb8u10) ...
Entpacken von lib32z1 (1:1.2.8.dfsg-2+b1) ...
Entpacken von zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
Entpacken von libssl-dev:amd64 (1.0.1t-1+deb8u10) ...
Entpacken von libssl-doc (1.0.1t-1+deb8u10) ...
Entpacken von libusb-1.0-0-dev:amd64 (2:1.0.19-1) ...
Entpacken von libusb-1.0-doc (2:1.0.19-1) ...
Entpacken von subversion (1.8.10-6+deb8u6) ...
Entpacken von upx-ucl (3.91-1) ...
Entpacken von dos2unix (6.0.4-1) ...
Entpacken von libccid (1.4.18-1) ...
Entpacken von sshpass (1.05-1) ...
Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
libssl1.0.0:amd64 (1.0.1t-1+deb8u10) wird eingerichtet ...
libpcsclite-dev (1.8.13-1+deb8u1) wird eingerichtet ...
libserf-1-1:amd64 (1.3.8-1) wird eingerichtet ...
libsvn1:amd64 (1.8.10-6+deb8u6) wird eingerichtet ...
libucl1:amd64 (1.03+repack-2) wird eingerichtet ...
dialog (1.2-20140911-1) wird eingerichtet ...
libc6-i386 (2.19-18+deb8u10) wird eingerichtet ...
lib32z1 (1:1.2.8.dfsg-2+b1) wird eingerichtet ...
zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) wird eingerichtet ...
libssl-dev:amd64 (1.0.1t-1+deb8u10) wird eingerichtet ...
libssl-doc (1.0.1t-1+deb8u10) wird eingerichtet ...
libusb-1.0-0-dev:amd64 (2:1.0.19-1) wird eingerichtet ...
libusb-1.0-doc (2:1.0.19-1) wird eingerichtet ...
subversion (1.8.10-6+deb8u6) wird eingerichtet ...
upx-ucl (3.91-1) wird eingerichtet ...
update-alternatives: /usr/bin/upx-ucl wird verwendet, um /usr/bin/upx (upx) im automatischen Modus bereitzustellen
dos2unix (6.0.4-1) wird eingerichtet ...
libccid (1.4.18-1) wird eingerichtet ...
sshpass (1.05-1) wird eingerichtet ...
Trigger für libc-bin (2.19-18+deb8u10) werden verarbeitet ...

[3;J
    ___  ____   ___
   / _ \/ ___| / __|__ _ _ __ ___
  | | | \___ \| |  / _` | '_ ` _ \
  | |_| |___) | |_| (_| | | | | | |
   \___/|____/ \___\__,_|_| |_| |_|
 

  keinen oscam-svn gefunden

  SVN TrunkURL  : http://www.streamboard.tv/svn/oscam/trunk
  SVN FileCount : gefunden 717
  SVN checkout  : 100%
  SVN Revision  : 11495
  SVN UserPath  : /opt/s3/oscam-svn
  SVN Backup    : done

  goto /opt/s3
  run -> ./s3
  for help

root@debian:/opt# cd /opt/s3
root@debian:/opt/s3# ./s3 osmio4k
[3;J


    ___  ____   ___
   / _ \/ ___| / __|__ _ _ __ ___
  | | | \___ \| |  / _` | '_ ` _ \
  | |_| |___) | |_| (_| | | | | | |
   \___/|____/ \___\__,_|_| |_| |_|
 

     toolchain : osmio4k  
        status : compiler nicht gefunden
   backupcheck : Toolchain-osmio4k.tar.xz nicht gefunden
          lade :      bitte warten... >       [12+1;17+1H100% done...                  

       entpacke : bitte warten... fertig![3;J


    ___  ____   ___
   / _ \/ ___| / __|__ _ _ __ ___
  | | | \___ \| |  / _` | '_ ` _ \
  | |_| |___) | |_| (_| | | | | | |
   \___/|____/ \___\__,_|_| |_| |_|
  
   toolchain : osmio4k     
     recheck : ok nun compiler gefunden
    compiler : aarch64-osmio4k-linux-gnu-gcc     

|       set : USE_UTF8=1
|       set : USE_LIBCRYPTO=1
|       set : USE_LIBUSB=1

|  MAX_CPUS : benutze 1 von 1 CPU(s)
|  CONF_DIR = /var/keys/
|  UseFlags = USE_LIBCRYPTO=1 USE_LIBUSB=1 USE_UTF8=1
|  Addons   : WEBIF LIVELOG JQUERY TOUCH DVBAPI READ_SDT IRDETO_GUESSING ANTICASC DEBUG MONITOR LB CACHEEX CWCC CLOCKFIX
|  Protocols: CAMD35 CAMD35_TCP NEWCAMD CCCAM CCCSHARE GBOX RADEGAST SCAM SERIAL CONSTCW PANDORA GHTTP
|  Readers  : NAGRA NAGRA_MERLIN IRDETO CONAX CRYPTOWORKS SECA VIACCESS VIDEOGUARD DRE TONGFANG BULCRYPT GRIFFIN DGCRYPT
|  CardRdrs : PHOENIX INTERNAL SC8IN1 MP35 SMARGO DB2COM STINGER DRECAS SMART
|  Binary   : /opt/s3/support/binaries/oscam-svn11495-osmio4k-webif-dvbapi-libusb
GEN -------->    webif/pages.c
GEN -------->    Compressed 440160 template bytes into 178708 bytes. 261452 saved bytes (59.40%).

TIME -------> [  0 min(s) 2 secs ]
baue ich übers menu --> .s3/ menu
kommt
Code:
+-------------------------------------------------------------------------------
| OSCam ver: 1.20_svn rev: 11495 target: -libusb
| Tools:
|  CROSS    = /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-
|  CC       = /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc
| Settings:
|  CONF_DIR = /var/keys/
|  CC_OPTS  = -O0 -ggdb -pipe -ffunction-sections -fdata-sections
|  CC_WARN  = -W -Wall -Wshadow -Wredundant-decls -Wstrict-prototypes -Wold-style-definition
|  CFLAGS   = -DWITH_LIBCRYPTO=1 -DWITH_LIBUSB=1 -DWITH_UTF8=1 -DWITH_UTF8
|  LDFLAGS  = -Wl,--gc-sections -DWITH_LIBCRYPTO=1 -DWITH_LIBUSB=1 -DWITH_UTF8=1 -DWITH_UTF8
|  LIBS     = -lcrypto -lusb-1.0 -lrt -lm -lpthread -ldl -lrt
|  UseFlags = USE_LIBCRYPTO=1 USE_LIBUSB=1 USE_UTF8=1
| Config:
|  Addons   : WEBIF WEBIF_LIVELOG WEBIF_JQUERY TOUCH HAVE_DVBAPI READ_SDT_CHARSETS IRDETO_GUESSING CS_ANTICASC WITH_DEBUG MODULE_MONITOR WITH_LB CS_CACHEEX CW_CYCLE_CHECK CLOCKFIX
|  Protocols: CAMD35 CAMD35_TCP NEWCAMD CCCAM CCCSHARE GBOX RADEGAST SCAM SERIAL CONSTCW PANDORA GHTTP
|  Readers  : NAGRA NAGRA_MERLIN IRDETO CONAX CRYPTOWORKS SECA VIACCESS VIDEOGUARD DRE TONGFANG BULCRYPT GRIFFIN DGCRYPT
|  CardRdrs : PHOENIX INTERNAL SC8IN1 MP35 SMARGO DB2COM STAPI STINGER DRECAS SMART
|  Compiler :
|  Config   : build/-libusb/config.mak
|  Binary   : /opt/s3/support/binaries/oscam-svn11495-osmio4k-webif-dvbapi-libusb
+-------------------------------------------------------------------------------
HOSTCC    webif/pages_gen
GEN    webif/pages.c
GEN    Compressed 442848 template bytes into 179271 bytes. 263577 saved bytes (59.52%).
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
Makefile:421: recipe for target 'build/-libusb/cscrypt/des.o' failed
make[1]: *** [build/-libusb/cscrypt/des.o] Error 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
Makefile:421: recipe for target 'build/-libusb/cscrypt/i_cbc.o' failed
make[1]: *** [build/-libusb/cscrypt/i_cbc.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/i_ecb.o' failed
make[1]: *** [build/-libusb/cscrypt/i_ecb.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/i_skey.o' failed
make[1]: *** [build/-libusb/cscrypt/i_skey.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/md5.o' failed
make[1]: *** [build/-libusb/cscrypt/md5.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/rc6.o' failed
make[1]: *** [build/-libusb/cscrypt/rc6.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/mdc2.o' failed
make[1]: *** [build/-libusb/cscrypt/mdc2.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/fast_aes.o' failed
make[1]: *** [build/-libusb/cscrypt/fast_aes.o] Error 1
Makefile:421: recipe for target 'build/-libusb/cscrypt/sha256.o' failed
make[1]: *** [build/-libusb/cscrypt/sha256.o] Error 1
Makefile:421: recipe for target 'build/-libusb/csctapi/atr.o' failed
make[1]: *** [build/-libusb/csctapi/atr.o] Error 1
Makefile:421: recipe for target 'build/-libusb/csctapi/icc_async.o' failed
make[1]: *** [build/-libusb/csctapi/icc_async.o] Error 1
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
Makefile:421: recipe for target 'build/-libusb/csctapi/io_serial.o' failed
make[1]: *** [build/-libusb/csctapi/io_serial.o] Error 1
Makefile:373: recipe for target 'all' failed
make: *** [all] Error 2

TIME    [  0 min(s) 2 secs ]
Baue ich auf Debian Buster baut er ohne Probleme.
 
Zuletzt bearbeitet:
Mitglied seit
18. Mai 2009
Beiträge
752
Reaktion auf Beiträge
1.308
Punkte
143
mach mal auf dem jessie
./s3 syscheck now

ich schaue mir die jessie sache nochmal extra an :-)
ich hab den installer jetzt user install tauglich gemacht genau wie simplebuild geht jetzt als user
 

ghost0815

Power Elite User
Mitglied seit
17. Juni 2012
Beiträge
2.017
Reaktion auf Beiträge
2.050
Punkte
163
Code:
root@debian:/opt/s3# ./s3 syscheck now
[3;J

    _________________
   /   _____/\_____  \   ===============
   \_____  \   _(__  <   Version 3.0 RC5
   /        \ /       \  ===============
  /_______  //______  /  by gorgone 2019
          \/        \/   ===============

  CHECK for binaries
  ==================

  have    dialog          /usr/bin/dialog
  have    grep            /bin/grep
  have    gawk            /usr/bin/gawk
  have    wget            /usr/bin/wget
  have    tar             /bin/tar
  have    bzip2           /bin/bzip2
  have    svn             /usr/bin/svn
  have    xz              /usr/bin/xz
  have    upx             /usr/bin/upx
  have    patch           /usr/bin/patch
  have    gcc             /usr/bin/gcc
  have    make            /usr/bin/make
  have    scp             /usr/bin/scp
  have    sshpass         /usr/bin/sshpass
  have    openssl         /usr/bin/openssl
  have    dos2unix        /usr/bin/dos2unix
  have  upx        Version 3.91 ok
 
  CHECK for headers
  =================

  have    crypto.h        /usr/include/openssl/crypto.h
  have    libusb.h        /usr/include/libusb-1.0/libusb.h
  have    pcsclite.h      /usr/include/PCSC/pcsclite.h
  have    pthread.h       /usr/include/pthread.h
 
  CHECK for libraries
  ===================

  have    libccidtwin.so  /usr/lib/pcsc/drivers/serial/libccidtwin.so
 
  CHECK for zlib32
  ================

  have    zlib32          /usr/lib32/libz.so.1

  Selected installer:    debian_os


root@debian:/opt/s3#
 

ghost0815

Power Elite User
Mitglied seit
17. Juni 2012
Beiträge
2.017
Reaktion auf Beiträge
2.050
Punkte
163
Nein geht nicht.
Code:
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
/opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/s3/support/toolchains/osmio4k/bin/aarch64-osmio4k-linux-gnu-gcc)
Edit:
Habe auch schon versucht das nachzuinstallieren.
Auf Ubuntu ist es mir gelungen, bei Debian nicht:
Code:
apt-get install software-properties-common
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.9 g++-4.9
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.9
 
Zuletzt bearbeitet:
Mitglied seit
18. Mai 2009
Beiträge
752
Reaktion auf Beiträge
1.308
Punkte
143
sudo apt-get install libstdc++6
?

das liegt aber an dem toolchain denn wieso sucht der toolchain eine system lib :-(
ih hab den nicht gebaut ...
aber ich hab selbst mit meinen probleme ... sch...
 
Zuletzt bearbeitet:
Oben Unten