Information ausblenden
Das Digital Eliteboard ist ein Kostenloses Forum. Wenn du alle Bereiche sehen möchtest oder Fragen hast, musst du dich zunächst Registrieren.

Jetzt Registrieren

Gelöst sendEmail - Probleme mit Sonderzeichen im Passwort ?

Dieses Thema im Forum "IPC" wurde erstellt von egon40, 13. Mai 2018.

  1. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Hallo auch,
    stehe gerade vor einem Problemchen.
    Erstmal hatte ich Probleme mit: apt-get install -y sendEmail >> "Paket nicht gefunden!"
    Habe dann sendmail installiert. Nun sagt er mir, das er die letzte Version von sendEmail (1.56) schon installiert hat. - komisch

    Egal, irgendwie geht die Mailfunktion trotzdem, jetzt habe ich aber wohl ein Problem mit meinem Password.
    Wenn ich den Teststring im Terminal eingebe:
    May 13 07:52:21 raspberrypi sendEmail[2608]: WARNING => The argument after -xp was not valid password!
    Password: mein Passord was auch im string oben stand- dann gehts:
    May 13 07:48:39 raspberrypi sendEmail[2371]: Email was sent successfully!
    Mail kommt dann auch an (gmail)

    Was kann das sein?
    Danke - für eine Antwort


    SMTPFROM="'versendername'@gmail.com"
    SMTPTO='empfänger@live.de'
    SMTPSERVER='smtp.gmail.com'
    SMTPUSER='versender@gmail.com'
    SMTPPASS='passwort mit raute'
    SMTPTLS='1'
     
    Zuletzt bearbeitet: 13. Mai 2018
    #1
  2. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    29.577
    Zustimmungen:
    24.130
    Punkte für Erfolge:
    113
    Auskommentieren: In Skripten und vielen Konfigurationsdateien besteht die Möglichkeit, Zeilen vom einlesenden Programm ignorieren zu lassen, indem das Zeichen # an den Anfang einer Zeile gesetzt wird. So markiert, können Sie Erklärungen in eine Datei einzufügen, ohne dass deren Funktion beeinträchtigt wird. Diese Zusatzinformationen bleiben weiterhin für den Menschen sichtbar, werden bei der "maschinellen" Auswertung der Datei aber ignoriert. Das Hinzufügen des Kommentarzeichens wird als Auskommentieren bezeichnet.

    würde mal das Passwort ändern in dem Fall
     
    #2
    Alex gefällt das.
  3. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    jupp liegt am Passwort.
    Wollte mir nun eine freemail bei mail.de anlegen, dort klappt das login via sendmail aber nicht.
    Bei web.de schon - na dann muss ich noch suchen.
     
    #3
  4. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Ja Danke - IPC tolle Sache :) !
    Ich habe mir schon ein Basis-Image vom Raspi (stretch lite 18.4.) gemacht, alle Updates, fester IP usw...
    Auf dieses Image setze ich nun bei meinen Tests auf.
    Hatte schon ein paar IPC-Versionen probiert und will jetzt "finalisieren" ;)

    Es hackt noch mit der sendmail-benachrichtigung.
    Mit dem Probestring funktioniert die Testmail. Wenn ich das gleiche via i cfg eintrage geht keine Mail raus (z.B. beim Backup) :confused:

    Danke fürs verschieben ... ;)

    macht es einen Unterschied wenn ich:

    apt-get install -y sendemail

    statt

    apt-get install -y sendEmail

    eingebe?
    Das Paket heißt sendemail:
    Du mußt dich Registrieren um diesen Link sehen zu können. Hier klicken und kostenlos Registrieren
     
    Zuletzt bearbeitet: 14. Mai 2018
    #4
  5. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Moin,
    also nicht das ich ein Verständnisproblem habe.
    Also habe meine sendemaildaten für web.de in der cfg eingetragen.
    Habe einen Test im Terminal mit genau diesen Daten abgesetzt - ist angekommen.
    Ich habe die oscam_mail_log.sh manuell gestartet - mail mit 3 Logfiles kam an.
    Also wenn ich im IPC ein Backup erzeuge sollte ich doch auch eine mail bekommen oder?
    So sollte es doch funktionieren?

    das nebenbei, das Paket heißt "sendemail" nicht "sendEmail"
     

    Anhänge:

    Zuletzt bearbeitet: 14. Mai 2018
    #5
  6. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Moin,
    ich schon wieder.
    Also ich habe mal in die Scripts geschaut. Z.B. im ipc_backup.sh stehen die Befehle alle mit "sendEmail" drin.
    Andererseits ist auch eine Verlinkung von sendEmail auf sendemail vorhanden.
    Haut bei Euch die sendemail-Funktion (z.B. Backup) noch hin??
    Grüße
     
    #6
  7. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Moin,
    hallooooo ich komm nicht weiter mit sendEmail. :sweat:
    Habe einen frischen Pi aufgesetzt.
    Dort dann vor der IPC-Install "sendemail" installiert. - Das läuft ohne Probleme durch!
    Auch die Tests via Consol mit untersschiedlichen Providern funtioniert immer (also mail wird gesendet-kommt an)
    Nur wenn ich die gleichen Einstellungen in der cfg eintrage bekomme ich nach einem Backup keine Mail.

    Mal eine Verstädnissfrage am Beispiel web.de

    Vorgabe:
    #Maileinstellung -> benoetigt [apt-get install sendEmail]
    SMTPFROM="`hostname`@fqdn.net"
    SMTPTO='admin@fqdn.net'
    SMTPSERVER='mail.fqdn.net'
    SMTPUSER=''
    SMTPPASS=''

    V1:
    SMTPFROM="`meinname`@web.de"
    SMTPTO='meinname@live.de'
    SMTPSERVER='smtp.web.de:587'
    SMTPUSER='meinname@web.de'
    SMTPPASS='meinpasswort'
    SMTPTLS='1'

    hier meckert IPC nach Abschluß die Zeile 50 an SMTPFROM=..... an.

    V2:
    SMTPFROM="meinname@web.de" - Fehler Zeile 50

    V3:
    SMTPFROM=`meinname@web.de`- Fehler Zeile 50

    V3:
    SMTPFROM='meinname@web.de' - keine Fehlermeldung - trotzdem keine Mail

    Wo kann ich sehen warum das nicht funktioniert - gibt doch bestimmt ein Logfile irgendwo??
    Wer hat eine momentan funktionierende Einstellung für WEB.de ??
    Kann doch nur mit der IPC-cfg zusammenhängen.

    Danke! ;)
     
    Zuletzt von einem Moderator bearbeitet: 18. Mai 2018
    #7
  8. Alex
    Offline

    Alex Administrator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    14.999
    Zustimmungen:
    15.316
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    so gerade mal getestet:

    Code:
    #Maileinstellung -> benoetigt [apt-get install sendEmail]
     SMTPFROM="bla@web.de"
     SMTPTO='bla@bla.de'
     SMTPSERVER='smtp.web.de'
     SMTPUSER='alex'
     SMTPPASS='passwort'
     SMTPTLS='1'
    
    #Mailnachricht bei Watchdog-Eingriff (0/1)
     CRASHMAIL='1'
    

    Danach hab ich mit folgendem Befehl Oscam abgemurkst und den den watchdog von hand gestartet:
    Code:
    killall oscam.x86_64 && bash /var/emu/script/oscam-watchdog.sh
    Die Ausgabe sah wie folgt aus:
    Code:
    root@Linuxserver ~ > bash /var/emu/script/oscam-watchdog.sh
    2018-05-18 12:25    Watchdog - apache2 Server laeuft
    Sende E-Mail...
    May 18 12:25:56 linuxserver sendEmail[11408]: Email was sent successfully!
    
    Die Mails kamen auch an
     
    Zuletzt bearbeitet: 18. Mai 2018
    #8
    axel gefällt das.
  9. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    OK, danke werds heut abend mal probieren! ;)
     
    #9
  10. Alex
    Offline

    Alex Administrator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    14.999
    Zustimmungen:
    15.316
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    Ganz vergessen:
    In meinem Passwort ist auch . als Sonderzeichen enthalten
     
    #10
  11. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    Nabend,
    danke Klasse ! E-mail bekommen: "OScam wurde auf #### vom Watchdog Ueberwachungsscript neu gestartet."
    musste bei mir aber: killall oscam.armel eingeben.
    ;)

    Nur nach einem Backup kommt nix.
     
    Zuletzt bearbeitet: 18. Mai 2018
    #11
    Alex gefällt das.
  12. Alex
    Offline

    Alex Administrator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    14.999
    Zustimmungen:
    15.316
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    Das hängt natürlich von der verwendeten Architektur ab
     
    #12
    axel gefällt das.
  13. egon40
    Offline

    egon40 Hacker

    Registriert:
    6. August 2008
    Beiträge:
    308
    Zustimmungen:
    78
    Punkte für Erfolge:
    28
    update von oben: nach einem Backup kommt aber keine Nachricht - ist aber nicht so schlimm crashmail war wichtiger
     
    #13
  14. Alex
    Offline

    Alex Administrator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    14.999
    Zustimmungen:
    15.316
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    Probier es gleich noch mit Backup
     
    #14
  15. axel
    Offline

    axel Moderator Digital Eliteboard Team

    Registriert:
    9. September 2011
    Beiträge:
    9.163
    Zustimmungen:
    25.508
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Informatiker
    Ort:
    Niederrhein
    Hi,

    danke an @Alex erstmal fürs "integrieren" der Funktion, genial.

    Mir persönlich würden die Emails auf den Zeiger gehen, obwohl Debian/IPC mir noch *nie* abgeschmiert ist.

    Was machst Du, wenn Du sone Mail bekommst und auf der Arbeit bist?

    Gruß

    Gesendet von meinem SM-G920F mit Tapatalk
     
    #15

Direkt Antworten

Überprüfung:
Der Entwurf wurde gespeichert Der Entwurf wurde gelöscht

Diese Seite empfehlen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden