1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Klienten verlieren Connection zum Server

Dieses Thema im Forum "CS CCcam" wurde erstellt von spider6367, 8. Dezember 2009.

  1. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    Hallo,

    seit einiger Zeit passiert auf meinem Server etwas ganz merkwürdiges.
    In unregelmässigen, aber kurzen Abständen verlieren einige aktive Klienten kurzzeitig die Verbindung zum Server.
    Habe es bei mir auf der Box beobachtet, das Bild bleibt dann kurz stehen und läuft nach paar Sekunden weiter.
    In der debug.txt steht dann folgendes:

    deleting client IP(username), read result -1

    Der entsprechende Klient verbindet sich dann sofort wieder neu, und das innerhalb von 5 min. 5-10x.

    Meine Konfiguration/System:

    Ubuntu 9.04 64bit
    CCcam 2.0.11 64bit (auch mit höheren Versionen passiert dasselbe)

    2x Smargo

    ca. 80 F-Lines

    ca. 70 C-Lines

    5 N-Lines

    1 L-Line

    SERVER LISTEN PORT : XXXXX
    ALLOW WEBINFO: yes
    WEBINFO USERNAME : xxx
    WEBINFO PASSWORD : xxx
    WEBINFO LISTEN PORT : xxx
    SERIAL READER : /dev/ttyUSB0 smartreader+
    SERIAL READER : /dev/ttyUSB1 smartreader+
    SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB0 5500000
    SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB1 8000000
    SHOW TIMING : yes
    TRY ALL CHIDS : /dev/ttyUSB0
    TRY ALL CHIDS : /dev/ttyUSB1
    CHANNELINFO FILE : /var/etc/CCcam.channelinfo
    DVB API: -1
    MINIMUM DOWNHOPS : 1

    Hat jemand ne Idee? Zumindest was dieses read result -1 bedeutet?
     
    Zuletzt bearbeitet: 8. Dezember 2009
    #1
  2. phantom

    Nervigen User Advertisement

  3. cobra112
    Offline

    cobra112 Ist gelegentlich hier

    Registriert:
    17. November 2009
    Beiträge:
    42
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Klienten verlieren Connection zum Server

    Hi

    Ich Tippe drauf das sich da 2 mit den selben usernamen anmelden.

    MFG
    Cobra
     
    #2
  4. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    wäre ne möglichkeit. würde das auch andere peers beeinflussen? weil es sind meist nie dieselben die rausfliegen.
    wie kann man bei 80 peers rausfinden wer das ist?
     
    #3
  5. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.335
    Zustimmungen:
    9.414
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: Klienten verlieren Connection zum Server

    schaue dir mal die ip adresen an , wenn du 2 mal die gleiche sichst dann hast du in .
    oder trage bei alen clienten die dyndns spere ein , dannwird er normale weise rot oder lila sein wenn er sich falsch anmeldet , wenn es dopelt wird dann kanst du es auch sehen

    du kenst bestimt info php ??
    wenn nicht dann einfach runterladn und instaliren , zu finden in der database.
     
    #4
  6. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    Sicher hab ich das WebinfoPHP installiert, nur lila wird da nix.
    Dyndns Sperren sind bei den F-Lines drin.
    Wenn sich jemand falsch anmeldet, also von einer anderen IP als die die hinter der F-Line steht, wird diese IP von meinem illegal user script gebannt.
    Diese Massnahme würde natürlich nicht greifen, wenn einer dieselbe Line auf zwei Receivern im selben Netzwerk zu laufen hat.
     
    Zuletzt bearbeitet: 9. Dezember 2009
    #5
  7. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.335
    Zustimmungen:
    9.414
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: Klienten verlieren Connection zum Server

    pasiert das nur bei den 1 client ? oder bei alen ?

    also wenn bei 1 und deselben client , dann werd ich mal tipen das er entweder 1 linie auf 2 reciviers hat , oder er wurde geheckt.
    wenn bei alen , kann sein das es einfach zu viele sind ?
     
    #6
  8. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    nicht nur bei einem, bei mehreren. es passiert wahllos sozusagen, auch auf meinen Boxen.
    Dort ist ebenfalls ein IP Schutz eingetragen (F: user pass 1 0 1 { 0:0:1 } { } { } 192.168.X.X)

    80 peers sind zuviel auf einem 64bit Rechner? hmmm...

    Bin echt langsam am verzweifeln.

    Es passiert auch nicht immer. Jetzt zB habe ich seit ca. 2h keinen Disconnect eines Klienten zu verzeichnen.
    Bestimmte Tageszeiten für dieses Problem gibt es nicht.
     
    #7
  9. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    eben ist es wieder passiert:

    08:30:52.785 CCcam: deleting client 192.168.2.X(XXXXX), read result -1
    08:30:52.786 CCcam: new tcp client from 192.168.2.X
    08:30:52.792 CCcam: user XXXXX login attempt from 192.168.2.X
    08:30:52.826 CCcam: client XXXX@XXXXXXXXX, running CCcam 2.1.3

    Bild hat natürlich gestanden.
     
    #8
  10. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.335
    Zustimmungen:
    9.414
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: Klienten verlieren Connection zum Server

    also das mit dem "zuviele pers " war nur ne sporadichsche frage , bei mir sind mehr und es pasiert so was nicht.

    ergend wo ist ein kleine fehler , und den musen wir jetzt herausfinden.

    den selben namen oder pasword hat du nicht zufelig 2 mal vergeben ??

    kan es sein das das ganze pasiert seit die pers auf die 2.1.3 umgestigen sind ??
     
    #9
  11. moench
    Offline

    moench Freak

    Registriert:
    22. Oktober 2009
    Beiträge:
    287
    Zustimmungen:
    45
    Punkte für Erfolge:
    28
    Beruf:
    EDV u. Telekommunikationstechniker
    AW: Klienten verlieren Connection zum Server

    hallo!
    das gleich problem habe ich auch...
    config: cccam 2.0.11 über vmware und clarkconnect
    hab ca. 20 clients
    gestern am abend hatte ich 5 leute dauerhaft online 4 sind immer neu gekommen und haben sich verbunden... bild bleibt kurz stehn und geht weiter... bei mir kommen diese aber nicht von einer anderen ip immer die selbe... ping von extern auf den server war immer super... 40-60 ms....
    ich kämpfe mit diesem problem schon seit 2 wochen... dann läuft es wieder am tag super... ich hab mir schon sorgen gemacht das ich zu viele clients habe darum der post mit meiner inet leitung under cs algemein!
    grüße
     
    #10
  12. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.335
    Zustimmungen:
    9.414
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: Klienten verlieren Connection zum Server

    pasiert das ganze auf versichidenen sender oder wenn die pers ein und den selben program schauen ??
    die lösung kann ganz simpel sein , karte überlastet und der cccam macht restart oder die leitung wird getrent ?
     
    #11
  13. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    naja dasselbe passwort schon, jedoch bei unterschiedlichen usernamen.

    Beispiel:

    F: wohnzimmer abcd
    F: schlafzimmer abcd

    das kann doch nicht das Problem sein oder?

    Ob es mit der 2.1.3 zu tun weiss ich nicht, aber vom Zeitpunkt her wäre es naheliegend.
    Kann es manchmal sein dass wenn sich ein Klient zweimal im selben Netzwerk einloggt, das schon die Ursache ist und andere Peers in Mitleidenschaft gezogen werden?
     
    #12
  14. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.335
    Zustimmungen:
    9.414
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: Klienten verlieren Connection zum Server

    endere zur sicherheit den pasword bei alen und wenn du mit dem cccam 2.1.3 arbeitest endere es auf zb. 2.0.11 und schaue was dann pasiert.
     
    #13
  15. spider6367
    Offline

    spider6367 Meister

    Registriert:
    16. Dezember 2008
    Beiträge:
    890
    Zustimmungen:
    189
    Punkte für Erfolge:
    0
    AW: Klienten verlieren Connection zum Server

    Wenn es passiert ist es egal auf welchem Sender man ist. CCcam macht da keinen Restart, erstens sehe ich das ja anhand der Runtime im WebInfoPHP und zweitens habe ich ja gepostet was im Log steht, also in der debug.txt
    Die ECM Time liegt meist unter 1000ms, also glaube ich nicht an eine Überlastung der Karte.
    Diverse Klienten verlieren einfach die Verbindung zum Server und verbinden sich sofort neu.
     
    #14
  16. darkmoslem
    Offline

    darkmoslem Ist oft hier

    Registriert:
    23. Januar 2008
    Beiträge:
    185
    Zustimmungen:
    30
    Punkte für Erfolge:
    28
    AW: Klienten verlieren Connection zum Server

    freunde das selbe problem hab ich schon seid monaten auch mit Debian , dm500 , 800 und 8000 sogar auf ubunu weis langsam auch net mehr weiter hier der treat damals von mir.




    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    würde mal gern wissen woran das liegt.

    40F-lines und 44 c-lines aber das passiert auch wenn ich nur 4 leute drin hab.........
     
    #15

Diese Seite empfehlen