1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Kein WebIF

Dieses Thema im Forum "OScam Archiv" wurde erstellt von Razor78, 25. November 2011.

  1. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    Oscam will net

    hi, brauch mal nen rat. und zwar geht bei mir das webif net. wenn ich meine ip:port eingebe steht da immer seite konnte net geladen werden. unten ist meine oscam.conf . verbinden will ich mich von 192.168.1.3 nach 192.168.1.8:8586 . leider geht das net. bin jetzt frisch von cccam auf oscam umgestiegen und hab meine oscam-dateien eigentlich soweit an meine bedürfnisse angeglichen. nur geht leider das webif net. :( Danke RaZor
    [global] serverip = 192.168.1.8 logfile = stdout fallbacktimeout = 2600 failbantime = 5 cachedelay = 120 nice = -1 maxlogsize = 512 preferlocalcards = 0 saveinithistory = 1 lb_mode = 1 lb_save = 100 lb_savepath = /tmp/.oscam/stat [newcamd] port = 36000@1702:000000;36001@1833:000000 serverip = 192.168.1.8 key = 0102030405060708091011121314 allowed = 127.0.0.1,192.168.1.0-192.168.1.254 keepalive = 1 mgclient = 0 [cccam] port = 12111 reshare = 0 ignorereshare = 1 version = 2.2.1 updateinterval = 240 minimizecards = 0 keepconnected = 1 stealth = 1 reshare_mode = 0 [dvbapi] enabled = 1 au = 1 boxtype = dreambox user = dvbapi pmt_mode = 0 [webif] httpport = 8586 httpuser = user httppwd = pass httprefresh = 0 httpallowed = 127.0.0.1,192.168.1.0-192.168.1.254 httphideidleclients = 0 httpreadonly = 0 httpsavefullcfg = 0 httpjsicons = 1
     
    Zuletzt bearbeitet: 25. November 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    Ist denn deine Oscam mit Webinterface kompiliert?
     
    #2
  4. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    leider keine ahnung. hab schon versucht auf verschiedenen wegen das webif an laufen zu bringen.
    hab zuerst mal das image neu gemacht. hab mich für

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    entschiden. zur ergänzung: nenn eine Dream 800SE clone mein eigen.

    dann hab ich mir über das onlineupdate der box zuerst oscam v 1.00 drauf gezogen. danach hab ich die config files online über die box gezogen.
    die box meldet das oscam aktiv bzw. gestartet ist. hab auch nen reboot der box gemacht. schon mehrmals. hab natürlich meine oscam.config dateien entsprechend bearbeitet.

    hatte sogar schon oscam-svn6034-mips-tuxbox-webif-Distribution sowie ne Oscam v1.10 stable hier aus dem forum gesaugt.

    aber ich komm mit keiner version auf die webif der box. das ganz normale webif der dream funktioniert hingegen (192.168.1.8) .


    wie oder woher bekomme ich denn eine oscam mit besagten webif kompiliert. oder wie kann ich testen ob ich sowas schon habe?

    Gruß RaZor
     
    #3
  5. helma59
    Offline

    helma59 Power Elite User

    Registriert:
    14. Mai 2008
    Beiträge:
    2.243
    Zustimmungen:
    1.129
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    bei oscam auch die rechte auf 775 gesetzt?? das war mein fehler beim oscam tausch.
    die box zeigte mir an oscam wurde gestartet.... dem war aber nicht so .wegen den rechten.:JC_hmmm:
     
    Zuletzt bearbeitet: 25. November 2011
    #4
    meister85 gefällt das.
  6. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    ja hab iich extra gemacht.
    nur nochmal zu meinen verständnis:

    - ich brauch nur die oscam.datei + die entsprechenden conf
    - also ich muss net cccam2.21/oscam installieren
    sondern kann doch oscam only nutzen, oder?

    die oscam.datei kopiere ich nach /usr/bin und vergeb die rechte 755

    die ganzen sogenannten config dateien von oscam (oscam.conf oscam.user oscam.server usw.) kopier ich nach /etc/tuxbox/config ,ODER?

    dann wähl ich oscam per bluepanel aus und aktivier das. dann mach ich noch sicherheitshalber nen reboot der box. dann geb ich in meinen mozilla firefox die ip 192.168.1.8:8586 ein die ich ja in der oscam.conf definiert habe.
    dann sollte es klappen. war jedenfalls bei cccam immer so. wollt aber jetzt endlich mal den einstieg in oscam schaffe. bloß wenn es schon am webif scheitert, dann gute nacht. :wacko1:

    Gruß RaZor
     
    #5
  7. helma59
    Offline

    helma59 Power Elite User

    Registriert:
    14. Mai 2008
    Beiträge:
    2.243
    Zustimmungen:
    1.129
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    genau du kannst oscam only nutzen. der rest so wie du geschrieben hast. aber nach jeder änderung der oscam datein emu bzw.box neu starten.

    und der pfad für die datein var/tuxbox->/etc/tuxbox/config.
     
    #6
  8. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    so... hab alles noch mal neu geflasht und jetzt geht schonmal das webif :)

    ABER es wird nur eine von meinen 3 lokalen karten erkannt. :(

    Wieso wird meine HD01 (HDPlus) weisse karte denn nicht von oscam erkannt und eingelesen? steht immer " NEEDINIT

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    " da.
    und wieso wird meine zweite S02 1702 Sky karte nicht von meinen Smargoreader+ den ich am usb der box betreibe erkannt. steht immer " ERROR

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    " da.
    weiterhin kann ich zu keinem freund conneczten. also von jemanden karten beziehen. steht immer "
    [TABLE="class: status, width: 100%"]
    [TR="class: p"]
    [TD="class: statuscol14"]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [TD="class: statuscol15"]00:01:24[/TD]
    [TD="class: statuscol16"]NEEDINIT

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [/TR]
    [/TABLE]
    bei dem sharepartnern. ????????????????

    bei cccam ging das ja auch?

    hier die configs:

    Oscam.conf
    ######################Hauptkonfig###
    ################################

    [global]
    serverip = 192.168.1.8
    logfile = stdout
    fallbacktimeout = 2600
    failbantime = 5
    cachedelay = 120
    nice = -1
    maxlogsize = 512
    preferlocalcards = 0
    saveinithistory = 1
    lb_mode = 1
    lb_save = 100
    lb_savepath = /tmp/.oscam/stat

    [cccam]
    port = 12111
    reshare = 0
    ignorereshare = 1
    version = 2.2.1
    updateinterval = 240
    minimizecards = 0
    keepconnected = 1
    stealth = 1
    reshare_mode = 0

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi
    pmt_mode = 0

    [webif]
    httpport = 8586
    httpuser = Razor78
    httppwd = zoll5301
    httprefresh = 0
    httpallowed = 127.0.0.1,192.168.1.0-192.168.1.254
    httphideidleclients = 0
    httpreadonly = 0
    httpsavefullcfg = 0
    httpjsicons = 1

    oscam.server
    ####################################################
    ############################# LOKALE KARTEN READER ####
    ####################################################
    [reader]
    label = SkyKarte01
    enable = 1
    protocol = internal
    device = /dev/sci0
    caid = 1702,1833
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2
    deprecated = 1
    lb_weight = 300

    [reader]
    label = HDPlus01
    enable = 1
    protocol = internal
    device = /dev/sci1
    caid = 1830
    rsakey = BF358xxxxxxx4DD5
    boxkey = A7xxxxx6D37C
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 2
    emmcache = 1,3,2
    deprecated = 1
    lb_weight = 300

    [reader]
    label = SkyKarte02
    enable = 1
    protocol = smargo
    device = /dev/ttyUSB0
    caid = 1702,1833
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 3
    emmcache = 1,3,2
    deprecated = 1
    lb_weight = 300

    #########################################################################################################################################################################################################
    ############################ C:Lines von Sharepartnern ##############################################################################################################################################
    #########################################################################################################################################################################################################

    [reader]
    label = C:LINE VON FREUND
    enable = 1
    protocol = cccam
    device = xxx.xxx.tv,12000
    account = rxxxxx
    password = xpxxxxxx
    caid = 1722,1834
    group = 4
    cccversion = 2.1.1
    cccmaxhops = 3
    cccmindown = 1
    ccckeepalive = 1
    lb_weight = 100

    oscam.user
    [account]
    user = dvbapi
    pwd =
    group = 1,2,3,4,5,6,7,8,9,10,11,12,13
    au = 1
    caid = 1702,1833,1722,1834,0100,0500,0604,09CD,0B01,1803,1880,0B00,1810,0608,0622,0648,0963,1801,0D05,0D95,0D02,1830
    betatunnel = 1833.FFFF:1702,1834.FFFF:1722
    suppresscmd08 = 1
    cccmaxhops = 5
    cccreshare = 1

    ################################################################
    ############################# Account - Karten Weitersharen an Sharepartner # ################################################################

    [account]
    user = user1
    pwd = pass1
    group = 1,2,3,4,5,6,7,8,9,10,11,12,13
    au = 0
    caid = 1702,1833,1722,1834,0100,0500,0604,09CD,0B01,1803,1880,0B00,1810,0608,0622,0648,0963,1801,0D05,0D95,0D02,1830
    betatunnel = 1833.FFFF:1702,1834.FFFF:1722
    suppresscmd08 = 1
    cccmaxhops = 5
    cccreshare = 0

    oscam.dvbapi
    P: 1702
    P: 1833
    P: 1722
    P: 1834
    P: 1830
    P: 0D95
    I: 1843
    I: 1861
    I: 09C4
    I: 09C7
    I: 09AF
     
    Zuletzt bearbeitet: 25. November 2011
    #7
  9. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    Wofür Newcamd? Lösch es raus, wenn du eh keine N-Lines vergibst.
     
    #8
  10. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    hab ich gemacht, hat aber auch net viel geholfen.
    hab den smartreader+ von maxdigital zum leben erweckt. schuld war das falsche protokoll. geändert von mouse zu smargo und schon ging dat. habs im vorherigen post korrigiert.

    aber die HD+ will noch net. :(
     
    #9
  11. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    Was sagt denn der LOG?
     
    #10
  12. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    wo find ich den die log.datei? sorry aber muss so dumm fragen.
     
    #11
  13. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Kein WebIF

    Da du die Ausgabe im stdout eingestellt hast, ist diese im Webinterface wieder zu finden.

    Ansonsten kannst du auch folgendes machen, stell folgenden Paramter mal um

    Code:
    logfile = var/log/oscam.log
    Oscam neustarten und dann sollte in var/log der oscam.log drin sein. Den postest du dann bitte (ohne serials und dyndns....)
     
    #12
    Razor78 gefällt das.
  14. Razor78
    Offline

    Razor78 Freak

    Registriert:
    17. April 2010
    Beiträge:
    262
    Zustimmungen:
    52
    Punkte für Erfolge:
    28
    AW: Kein WebIF

    hey...

    Danke aber hab es jetzt irgendwie selber hinbekommen.
    hab die einstellung

    deprecated = 1

    rausgeschmissen und irgendwann ging dat dan. keine ahnung obs daran lag.
     
    #13

Diese Seite empfehlen