1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gemini 4.7 CCcam2.2.1 + Oscam 1.0.0 Fehler Nline

Dieses Thema im Forum "CS CCcam" wurde erstellt von xenonbbc, 24. März 2011.

  1. xenonbbc
    Offline

    xenonbbc Newbie

    Registriert:
    12. Oktober 2010
    Beiträge:
    22
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Huhu,

    hab ein Problem.
    Ich hab auf meine DM500c Gemini 4.7 draufgespielt.

    Habe mir CCcam 2.2.1 und OScam 1.0.0 mit Configs draufgepackt.
    Wenn ich im BLueMenü CCcam + Oscam auswähle ist Sky *G02* Hell.

    Allerdings geht das Webinterface auf dem Port 16001 nicht.
    *Auch das Homesharing geht nicht*

    Wenn ich nur CCcam laufen lasse geht das Webinterface.
    Geh davon aus das irgendwas in den Configs falsch ist.
    Vielleicht kann mir da wer helfen.

    Oscam.config
    Code:
    # # main configuration #  
    [global] 
    nice          = -1 
    WaitForCards  = 1 
    pidfile          = /var/run/oscam.pid
    logfile          = /tmp/oscam.log 
    usrfile          = /tmp/oscamuser.log 
    cwlogdir      = /tmp/cw 
    
    [monitor] 
    port          = 988
    aulow          = 120 
    monlevel      = 4  
    
    [webif] 
    httpport      =  
    httpuser      =  
    httppwd       =   
    
    [newcamd] 
    key           = 0102030405060*************** 
    port          = 10000@****:000000  
    
    [dvbapi] 
    enabled          = 1
    Oscam.server
    Code:
    # # reader configuration #  
    [reader] 
    label    = KD 
    protocol = internal 
    detect   = CD 
    boxid    = 12345678 
    EMMCache = 1,3,2 
    device   = /dev/sci0 
    group    = 1
    caid     = 0**7,****,1834
    Oscam.user
    Code:
    # # user configuration #   
    [account]  
    user       = dummy  
    pwd        = dummy  
    monlevel   = 4  
    group      = 1  
    au         = 1  
    # 
    ident        = 0**7:000000  
    caid       = 0**7,***,1834
    cccam.cfg
    Code:
    N: 127.0.0.1 12000 dummy dummy 01 02 03 04 05 06 07 08 09 10 11 12 13 14
    Freu mich über jede Hilfe!
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. ydnaso
    Offline

    ydnaso Meister

    Registriert:
    7. Dezember 2010
    Beiträge:
    930
    Zustimmungen:
    405
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Bayern
    AW: Gemini 4.7 CCcam2.2.1 + Oscam 1.0.0 Fehler Nline

    Moin,
    mal ne ganz doofe Frage vornweg.
    Die Sternchen hast aber du (wieso auch immer) an den Stellen für den Post reingemacht?
    ... wenn ja hättest das nicht machen müssen, denn diese Stellen geben keine Auskunft über Daten
    die andere nicht sehen sollten...

    Was meinst du mit homesharing geht?

    Hast du mal versucht das Oscam WebIf zu verwenden?
    Code:
    [webif] 
    httpport      =  17001
    httpuser      =  oscam
    httppwd       = oscam 
     
    Hast du in der cccam.cfg nur die N-Line drin? Wenn nicht zeig mal die ganze config

    Die Aussage
    Kann ich auch nicht so ganz interpretieren? Welche Emus laufen denn? Und was davon geht (auch mit webif)
    und was davon geht nicht?

    Die N-Line ist auch falsch, wenn du hier den Port 10000 definierst
    Code:
    
    [newcamd] 
    key           = 0102030405060708091011121314 
    port          = 10000@****:000000
    
    musst du ihn auch in der N-Line verwenden und nicht den Standard ccccam Port 12000
    Code:
    N: 127.0.0.1 12000 dummy dummy 01 02 03 04 05 06 07 08 09 10 11 12 13 14
    Wenn das die ganze cccam.cfg ist, dann legst du hier ja auch kein webinterface fest...

    PS: Es wäre vielleicht besser deine Ausgangslage (Emu, welche Karten,...) genau zu beschreiben, deine Configs nochmals sauber zu posten und
    genau dazu zu schreiben was nicht funktioniert... Dabei ist es ausreichend wenn du user,pass,dyndns addys unkenntlich machst. Caids, ident, keys (auser boxkey und rsakey beii hd+)
    ports kannst du bedenkenlos zeigen
     
    Zuletzt bearbeitet: 24. März 2011
    #2
  4. xenonbbc
    Offline

    xenonbbc Newbie

    Registriert:
    12. Oktober 2010
    Beiträge:
    22
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Gemini 4.7 CCcam2.2.1 + Oscam 1.0.0 Fehler Nline

    Okay tut mir leid.
    Das ist alles neuland für mich ^^

    Also ich habe hier eine Dreambox 500c mit Gemini 4.7 die ich als "Server" nutzen möchte. Dort steckt meine SkyAbo Karte *G02* drin.

    Ich habe nur den CCcam 2.2.1 und Oscam 1.0.0 installiert.
    (+ die dazugehörigen config Files die wie folg aussehen)

    cccam.cfg
    Code:
    F: test1 test2
    N: **********.dyndns.org 12000 dummy dummy1 01 02 03 04 05 06 07 08 09 10 11 12 13 14 1
    SHOW TIMING : yes
    oscam.conf
    Code:
    #
    # main configuration
    #
    
    [global]
    nice          = -1
    WaitForCards  = 1
    
    [COLOR=Red]pidfile          = /var/run/oscam.pid
    logfile          = /tmp/oscam.log
    usrfile          = /tmp/oscamuser.log
    cwlogdir      = /tmp/cw[/COLOR]
    
    [COLOR=Red][monitor]
    port          = 12001
    aulow          = 120
    monlevel      = 4
    
    [webif]
    httpport      = 12002
    httpuser      = 
    httppwd       = [/COLOR]
    
    [newcamd]
    key           = 0102030405060708091011121314
    port          = 12000@09c7:000000
    
    [COLOR=Red][dvbapi]
    enabled          = 0[/COLOR]
    
    Kann ich die roten bereiche auch weglassen?

    oscam.server
    Code:
    #
    # reader configuration
    #
    
    [reader]
    label    = KD
    protocol = internal
    detect   = CD
    boxid    = 12345678
    EMMCache = 1,3,2
    device   = /dev/sci0
    group    = 1
    caid     = 09c7,1722,1834
    
    oscam.user
    Code:
    #
    # user configuration
    #
    
    [account]
    user       = dummy
    pwd        = dummy1
    monlevel   = 4
    group      = 1
    au         = 1
    #ident        = 09c7:000000
    caid       = 09c7,1722,1834
    
    Ich hatte im 1. Beitrag das Problem das ich Sky auf der Serverbox Hell
    bekomme. Aber wenn ich die serverip:16001 öffnen wollte. Kein Webinterface geladen werden konnte.

    Mit diesen Config Files habe ich es jetzt hinbekommen Sky auf der Serverbox Hell zubekommen. Und Das webinterface aufzurufen.

    Dort steht folgendes:

    Server
    Code:
    Server connections: 1 +----------------------+------------+-------+--------+----------------+-------+-------------------------------+
     | Host                 | Connected  | Type  | Version| NodeID         | Cards | 
    CAID/Idents                   | 
    +----------------------+------------+-------+--------+----------------+-------+-------------------------------+
     |127.0.0.1:12000       |00d 00:10:05|newcamd|        |                |     1 
    |local 09c7:000000 87(87)       | 
    +----------------------+------------+-------+--------+----------------+-------+-------------------------------+
    
    Share
    Code:
    Available shares: 1 
     +----------------------+--------+----+-------+----------+-------+-------+ | 
    Host                 | Type   |Caid| System| Providers|Uphops | Nodes | |  
                        |        |    |       |          |Maxdown|       | 
    +----------------------+--------+----+-------+----------+-------+-------+ 
    |127.0.0.1:12000       |newcamd | 9c7|nds    |0         |1   7  |       | 
    +----------------------+--------+----+-------+----------+-------+-------+
    
    Providers
    Code:
    Available providers:   
    +----+----------+--------------+-----+ 
    |Caid| Provider | Provider Name| System| 
    +----+----------+--------------+-----+
     | 9c7|          |Unknown       |nds  | 
    +----+----------+--------------+-----+
    Das Problem was ich jetzt habe ist, das ich kein Client auf die Box
    verbinden kann. dnydns ist eingerichtet und funktioniert. Im Router
    habe ich den Port 12000 auf die Serverbox IP weitergeleitet.

    Da komm ich nicht weiter. Ich hoffe jetzt versteht man es besser.
     
    #3
  5. ydnaso
    Offline

    ydnaso Meister

    Registriert:
    7. Dezember 2010
    Beiträge:
    930
    Zustimmungen:
    405
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Bayern
    AW: Gemini 4.7 CCcam2.2.1 + Oscam 1.0.0 Fehler Nline

    Vorab die roten Bereiche kannst du weglassen, sofern du kein oscam webif brauchst.
    [dvbpi] lass mal lieber drin...

    Du connectest mit deinem cccam über den port 12000 auf oscam.
    Da aber alles lokal ist, brauchst du nicht über dyndns zu connected.
    Den Port 12000 würde ich auch fast ändern, weil das ist der standard cccam port, was aber
    funktionell erstmal keinen unterschied macht.

    die N-Line müsste so aussehen:
    Code:
    N: 127.0.0.1 12000 dummy dummy1 01 02 03 04 05 06 07 08 09 10 11 12 13 14
    Jetzt wird der Server über die N-Line hell.

    Damit du aber über ccccam weiter an die clients sharen kannst. muss cccam nochmals einen port bereitstellen:


    Code:
    SERVER LISTEN PORT : 13000
    Nun können die Clients mit einer c-line und deinem dyndns namen auf cccam connecten:

    Code:
    C: **********.dyndns.org 13000 test1 test2
    Hoffe es ist halbwegsverständlich.
    Du brauchst quasi einen Port für die interene Übertragung Oscam zu Ccccam und
    einen zusätzlichen Port zum sharen. Hier jetzt 13000 weil du ja 12000 verwendet hast.

    Und mit der C-Line kann der Client auf die F-Fline des Servers connecten
    Die dyndns brauchst du nur an den clients... Du musst aber jetzt auch die Portweiterleitung für den Port 13000 machen,
    da die clients ja auf cccam verbinden.

    ... und jeder user eine eigene F Line...
     
    #4
    malimau99 gefällt das.
  6. xenonbbc
    Offline

    xenonbbc Newbie

    Registriert:
    12. Oktober 2010
    Beiträge:
    22
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Gemini 4.7 CCcam2.2.1 + Oscam 1.0.0 Fehler Nline

    Jup verstanden umgesetzt und es geht :D DANKE DIR !!!

    CLOSED :D
     
    #5

Diese Seite empfehlen