1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

Dieses Thema im Forum "Archiv" wurde erstellt von uter123, 13. Februar 2011.

  1. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    Hallo Leute,

    In den letzten 2 Tagen habe ich komischerweise immer ein Problem.
    Zur Situation: Ich lese eine Sky Karte und eine HD+ Karte mit Oscam und leite sie weiter an CCcam. Nachts um 4 lädt CCcam die neue CCcam.cfg und startet dann neu (glaube ich zumindest).
    In den letzten 2 Tagen passiert bei mir immer folgendes: Morgens bekomme ich Nachrichten von meinen Sharepartnern, dass Sky nicht geht, HD+ aber schon. Wenn ich dann ins CCcam Webinterface gehe sehe ich auch, dass alle ECM nok sind, die ECM von HD+ hingegen ok.
    Daraufhin gehe ich ins Oscam Webinterface und sehe bei der Sky Karte bei LB Value/Reader not found.
    Dies lässt sich erst beheben, wenn ich den Server mittels o restart && c restart zu einem Neustart beider Emus auffordere.

    Hat jemand eine Idee, woran das liegen könnte? Mehrere Monate lang ging das ganze ohne jedes Problem. Das Problem tritt auch auf, wenn ich gar keine neue CCcam.cfg (c cfgn) erstellt habe. An den Reader Einstellungen oder den UDEV Regeln habe ich auch nichts verstellt. Langsam bin ich mit meinem Latein am Ende...

    Viele Grüße,
    uter123
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Warum lässt du denn nachts um 4 die CCcam.cfg neu laden?
    CCcam restartet sich dadurch eigentlich nicht - nur selten schmiert es ab wenn man einstellungen an der CCcam.cfg verändert hat

    Und welche CCcam + OScam version benutzt du?

    Kann mir eigentlich nur vorstellen das OScam herruntergeschmissen wird und davon entweder nicht mitkriegt oder dein Build nen bug diesbezüglich hat - also vllt mal ne aktuelle OScam aufspieln


    ansonsten lass halt nachts um 4 nicht die cfg neu laden sondern starte erst CCcam neu und dann OScam, zb so: c restart; sleep 2; o restart
     
    #2
  4. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Ich nutze CCcam 2.1.1 (Die muss es auch bleiben) und dazu Oscam 0.99.4 Build #3035 Streamboard SVN. Bis vor einigen Tagen hat das ganze ja ohne Probleme funktioniert?!
    Werde heute mal eine neue Oscam Version testen.
    Ich starte CCcam nicht neu, ich dachte dass macht IPC alleine wenn ich eine cfgn anlege. Aber der Fehler tritt ja auch auf, wenn ich keine neue CFG angelegt habe.
     
    #3
  5. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Worüber hast du das denn eingestellt?

    Meinst du, wenn du "i jobs" eingibst und da dann die Zeile
    #30 4 * * * root /var/emu/script/cccam restart
    einkommentierst?

    Wenn du CCcam neu startest musst du glaub ich auch OScam neu starten, eben eine minute vorher, wie es auch vorgegeben ist:
    29 4 * * * root /var/emu/script/oscam restart

    Aber normalerweise brauch man das auch nicht - die Cams sollten eigentlich durchlaufen

    Hast du vllt irgendwelche Log's an die nach ner Zeit dein Flash voll machn?
     
    #4
  6. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Update:
    Der Fehler ist jetzt gerade erneut aufgetreten. Aber dieses Mal liegt es nicht an einem Neustart.
    Nun ist die HD+ Karte betroffen. Bis vor ca. 20min ging sie noch, doch jetzt sind bei CCcam alle ECM nok und Oscam sagt im Webinterface bei der Oscam sagt bei der Verbindung zu CCcam im Webinterface:
    LB Value/ Reader fake und Status Duplicate, während bei der Karte (mouse) CARDOK steht.
    Ich weiß so langsam nicht mehr weiter...
    Hier mal ein kleiner Logeintrag:
    Code:
    2011/02/14 0:21:11 XXXXX s client(3) connect from 127.0.0.1 (pid=24438, pipfd=16)
    2011/02/14 0:21:11 XXXXX c02 Connection closed to client
    2011/02/14 0:21:11 XXXXX c02 cccam disconnected from 127.0.0.1
    2011/02/14 0:21:11 XXXXX c03 Warning: clientdyndns disabled in config. Enable clientdyndns to use hostname restrictions
    2011/02/14 0:21:11 XXXXX c03 client(3) duplicate user 'cccam' from 127.0.0.1 set to fake (uniq=1)
    2011/02/14 0:21:11 XXXXX c03 encrypted newcamd:XXXXX-client 127.0.0.1 granted (cccam, au=0)
    2011/02/14 0:21:11 XXXXX c03 user cccam authenticated successfully (CCcam)
    2011/02/14 0:21:11 XXXXX c03 AU disabled for user cccam
     
    Zuletzt bearbeitet: 15. Februar 2011
    #5
  7. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Dann zeige doch mal die oscam.user, server und conf.

    Grüsse
    szonic
     
    #6
  8. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    @uter123: Zunächst kannste schonmal uniq = 0 für den jeweiligen benutzer setzen und du scheinst auch was bei hostname = eingetragen zu haben - das auch mal wieder rausnehmen (der oscam läuft doch eh hinter nem router und der oscam port ist nicht freigegeben, oder?)

    Und wenn es dann immernoch auftritt dann poste mal deine configs wie bereits verlangt :)
     
    #7
    uter123 gefällt das.
  9. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Danke erstmal für eure Antworten,
    Hatte in der oscam.user unique = 1 gesetzt. Das habe ich jetzt zu 0 geändert. Außerdem habe ich das Hostname entfernt. Die Ports sind natürlich dicht :)
    Ich hoffe es funktioniert jetzt wieder ohne Probleme, ich werde hier berichten.
    Aber warum tritt der Fehler erst jetzt auf, wo es doch seit Monaten mit der Config ging?

    Viele Grüße,
    uter123
     
    #8
  10. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Hm, schade hat wohl doch nichts gebracht...
    Heute morgen trat der selbe Fehler auf. Weder Sky noch HD+ gingen und die ECm lagen bei 3-6 sec mit nok Meldung. Ich war als einziger Client drauf.
    Dann mal die Configs...
    o.conf:
    Code:
    # OSCam Konfiguration IPC - oscam.conf
    
    [global]
    #logfile      = /var/log/ipc/OScam.log
    logfile      = stdout
    #serverip     = 127.0.0.1
    #maxlogsize   = 2480
    saveinithistory = 1
    
    [newcamd]
    key          = XXXXXXXXXXXXXXXXXXXXXXXXXXXX
    port         = XXXXX@1702:000000,000001; YYYYY@1830:003411; ZZZZZ@1833:000000
    
    [webif]
    httpport     = XXXXX
    httpuser     = XXXX
    httppwd      = XXXX
    httprefresh  = 15
    httpallowed  = 127.0.0.1,192.168.1.0-192.168.1.255
    httpdyndny   = none
    httphideidleclients = 0
    #httpreadonly = 1
    
    o.server:
    Code:
    # OSCam Konfiguration IPC - oscam.server
    
    [reader]
    label       = HD+
    protocol    = mouse
    detect      = CD
    smargopatch = 1
    group       = 1
    emmcache    = 1,3,2
    caid        = 1830
    device      = /dev/hdplus
    n3_rsakey   = *key*
    n3_boxkey   = *key*
      
    [reader]
    label       = sky
    protocol    = mouse
    detect      = CD
    smargopatch = 1
    group       = 1
    emmcache    = 1,3,2
    caid        = 1702,1833
    device      = /dev/sky
    
    o.user:
    Code:
    # OSCam Konfiguration IPC - oscam.user
    
    [account]
    user = hdplus
    pwd = password1
    caid = 1830
    ident = 1830:003411
    uniq = 0
    group = 1
    au = HD+
    
    [account]
    user = sky
    pwd = password2
    caid = 1702
    ident = 1702:000000,000001
    uniq = 0
    group = 1
    au = sky
    
    CCcam.cfg wg Verbindung:
    Code:
    N: 127.0.0.1 YYYYY hdplus password1 XX XX XX XX XX XX XX XX XX XX XX XX XX XX 256
    N: 127.0.0.1 XXXXX sky password2 XX XX XX XX XX XX XX XX XX XX XX XX XX XX 256
    
    Passt irgendwas in der Config nicht? Sie lief monatelang ohne jegliche Probleme und auch die Reader sind nicht das Problem, da Oscam meldet CARDOK. Es liegt definitiv an der Verbindung zu CCcam per N-Line. Die Versionen habe ich während den fast 2 Monaten ohne Probleme auch noch nicht geändert. Auf den CCcam 2.1.1 Server, der sich per N-Line verbindet geht auch noch eine Verbindung per C-Line zu einer DM800 mit CCcam 2.2.1 ein, kann es daran liegen?
    Ich bin mit meinem Latein am Ende...

    Vielen Dank euch.
     
    #9
  11. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    haste auch mal ne andere OScam version ausprobiert?

    Ich glaub nicht das CCcam schuld is wenn du die Karten mit OScam einliest
     
    #10
  12. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Teste gerade 1.0-unstable_svn build # 4711 und hoffe das es damit geht. Mich wundert nur nach wie vor, das es bis dato ohne Fehler lief...
     
    #11
  13. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Naja du schliest aber von vorneherrein einen defekt der Reader auch aus obwohl du das eigentlich auch nicht 100% wissen kannst...

    benutzt du vllt nen usb-hub? vllt is der ja auch schuld...
     
    #12
  14. uter123
    Offline

    uter123 Hacker

    Registriert:
    2. Februar 2009
    Beiträge:
    459
    Zustimmungen:
    67
    Punkte für Erfolge:
    0
    AW: [Debian IPC]nach Emu-Neustart nachts Oscam Fehlermeldung

    Naja, davon gehe ich erstmal nicht aus. Jetzt läuft das ganze auch schon seit 1,2 days ohne Probleme. Außerdem stand im Webinterface immer CARDOK. Außerdem: Warum sollte der Reader nach einem Neustart von Oscam wieder gehen?
    Ich habe mich auch noch ein wenig umgesehen und gelesen, dass einige Oscam Versionen das Problem haben bei einer Verbindung zu CCcam.
    Die 1.0 er Version die ich jetzt nutze erhält exakt alle 1:15 Minuten eine Anfrage von CCcam (Auch wenn keiner PayTV sieht), anscheinend, damit die Verbindung nicht gekillt wird. Anders kann ich mir die Anfrage alle exakt 1:15 (Also nachdem die Karte 1min 15sek ilde ist) nicht erklären. Außerdem wird die Abfrage nicht auf die ECM Gesamtanzahl aufgerechnet.
     
    #13
    feissmaik gefällt das.

Diese Seite empfehlen