Digital Eliteboard

Registriere dich noch heute kostenloses um Mitglied zu werden! Sobald du angemeldet bist, kannst du auf unserer Seite aktiv teilnehmen, indem du deine eigenen Themen und Beiträge erstellst und dich über deinen eigenen Posteingang mit anderen Mitgliedern unterhalten kannst! Zudem bekommst du Zutritt zu Bereiche, welche für Gäste verwehrt bleiben

HD+ und Sky Karte laufen nur einzeln, nicht zusammen

Daniel775

Ist gelegentlich hier
Registriert
24. Januar 2010
Beiträge
33
Punkte Reaktionen
4
Erfolgspunkte
8
Weiss jemand in dieser Situation weiter?
Irgendwie schaffe ich es nicht beide Karten mit den Readern einzubinden.

Geräte:
AzBox Premium HD
Synology DS207
Aktiver 7 Port USB-Hub
2x Smartreader von MaxDigital

Karten:
Sky S02
HD+ schwarz HD02

Client:
AzBox mit cccam Protokol Version 2.2.1

Server:
DS207 mit oscam version 1.00-unstable_svn, build #4100 und cccam 2.1.2
cccam hat über newcamd Port 34000 und 34001 verbindung zu oscam

Configs:
oscam.conf
[global]
logfile = /opt/var/etc/oscam.log
nice = -1
maxlogsize = 0

[newcamd]
port = 34000@1702:000000;34001@1843:000000
serverip = 127.0.0.1
key = 0102030405060708091011121314
allowed = 0.0.0.0-255.255.255.255
keepalive = 1
mgclient = 0

[webif]
httpport = 83
httpuser = oscam
httppwd = admin
httprefresh = 0
httpallowed = 127.0.0.1,192.168.170.0-192.168.170.255
httphideidleclients = 0
httpreadonly = 0
httpsavefullcfg = 0

oscam.server
[reader]
label = sky
enable = 1
protocol = mouse
device = /dev/ttyUSB0
services = sky
caid = 1702,1833
force_irdeto = 1
boxkey = 1122334455667788
detect = cd
mhz = 600
cardmhz = 600
ident = 1702:000000;1833:000000
group = 1
emmcache = 1,3,2
lb_weight = 100

[reader]
label = hdplus
enable = 1
protocol = mouse
device = /dev/ttyUSB1
services = hdplus
smargopatch = 1
caid = 1843
rsakey = BF***
boxkey = A7***
detect = cd
mhz = 357
cardmhz = 357
ident = 1843:000000,003411,008011
group = 2
emmcache = 1,3,2
lb_weight = 100

oscam.user
[account]
user = usersky
pwd = passsky
group = 1
monlevel = 2
au = sky
services = sky
caid = 1702
betatunnel = 1833.007A:1702,1833.007B:1702,1833.007C:1702,1833.007E:1702,1833.007F:1702,1833.0080:1702,1833.0081:1702,1833.0082:1702,1833.0083:1702,1833.0084:1702
ident = 1702:000000

[account]
user = userhd
pwd = passhd
group = 2
monlevel = 2
au = 1
services = hdplus
caid = 1843
ident = 1843:000000,003411,008011
cccmaxhops = 0
keepalive = 0

cccam.cfg
N: 127.0.0.1 34000 usersky passsky 01 02 03 04 05 06 07 08 09 10 11 12 13 14
N: 127.0.0.1 34001 userhd passhd 01 02 03 04 05 06 07 08 09 10 11 12 13 14
F: user pass

SERVER LISTEN PORT : 12000
#SERIAL READER : /dev/ttyUSB0 smartreader+
#SMARTCARD CLOCK FREQUENCY : /dev/ttyUSB0 6000000
DEBUG: No
DISABLE EMM : Yes
SOFTKEY FILE : /opt/bin/etc/SoftCam.Key
AUTOROLL FILE : /opt/bin/etc/AutoRoll.Key
CAID PRIO FILE : /opt/bin/etc/CCcam.prio
PROVIDERINFO FILE : /opt/bin/etc/CCcam.providers
CHANNELINFO FILE : /opt/bin/etc/CCcam.channelinfo
STATIC CW FILE : /opt/bin/etc/constant.cw
WEBINFO USERNAME :XXX
WEBINFO PASSWORD :XXX

oscam.log
Reader hdplus aktiviert
-------------------------------------------------------------------------------
>> OSCam << cardserver started at Tue Feb 8 18:56:57 2011
-------------------------------------------------------------------------------
2011/02/08 18:56:57 4000 s version=1.00-unstable_svn, build #4100, system=powerpc-tuxbox-linux, nice=-1
2011/02/08 18:56:57 4000 s client max. idle=120 sec, debug level=0
2011/02/08 18:56:57 4000 s max. logsize=10 Kb
2011/02/08 18:56:57 4000 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2011/02/08 18:56:57 4000 s client max. idle=120 sec, debug level=0
2011/02/08 18:56:57 4000 s max. logsize=10 Kb
2011/02/08 18:56:57 4000 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2011/02/08 18:56:57 4000 s auth size=4800
2011/02/08 18:56:57 4000 s services reloaded: 0 services freed, 11 services loaded
2011/02/08 18:56:57 4000 s userdb reloaded: 0 accounts freed, 2 accounts loaded, 0 expired, 0 disabled
2011/02/08 18:56:57 4000 s signal handling initialized (type=sysv)
2011/02/08 18:56:57 4000 s 8 service-id's loaded
2011/02/08 18:56:57 4000 s can't open file "/opt/var/etc/oscam.tiers" (err=2), no tier-id's loaded
2011/02/08 18:56:57 4000 s 3 provid's loaded
2011/02/08 18:56:57 4000 s can't open file "/opt/var/etc/oscam.ird" (errno=2) irdeto guessing not loaded
2011/02/08 18:56:57 4000 s monitor: disabled
2011/02/08 18:56:57 4000 s camd33: disabled
2011/02/08 18:56:57 4000 s camd35: disabled
2011/02/08 18:56:57 4000 s cs378x: disabled
2011/02/08 18:56:57 4000 s newcamd: initialized (fd=6, port=34000, ip=127.0.0.1, crypted)
2011/02/08 18:56:57 4000 s CAID: 1702
2011/02/08 18:56:57 4000 s provid #0: 000000
2011/02/08 18:56:57 4000 s newcamd: initialized (fd=7, port=34001, ip=127.0.0.1, crypted)
2011/02/08 18:56:57 4000 s CAID: 1843
2011/02/08 18:56:57 4000 s provid #0: 000000
2011/02/08 18:56:57 4000 s cccam: disabled
2011/02/08 18:56:57 4000 s radegast: disabled
2011/02/08 18:56:57 4000 s http thread started
2011/02/08 18:56:57 4000 s creating thread for device /dev/ttyUSB0 slot 0
2011/02/08 18:56:57 4000 s creating thread for device /dev/ttyUSB1 slot 0
2011/02/08 18:56:57 4002 h HTTP Server listening on port 83
2011/02/08 18:56:57 8003 r reader thread started (thread= 8003, label=sky, device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=600)
2011/02/08 18:56:57 4000 s waiting for local card init
2011/02/08 18:56:57 C004 r reader thread started (thread= C004, label=hdplus, device=/dev/ttyUSB1, detect=cd, mhz=357, cardmhz=357)
2011/02/08 18:56:57 C004 r ERROR in IO_Serial_Read errno=11
2011/02/08 18:56:58 C004 r hdplus card detected
2011/02/08 18:56:59 8003 r sky card detected
2011/02/08 18:57:03 C004 r ATR: ** ** ** **
2011/02/08 18:57:03 C004 r ERROR: Could not read reader->convention
2011/02/08 18:57:03 C004 r Error activating card.
2011/02/08 18:57:04 8003 r ATR: ** ** ** **
2011/02/08 18:57:04 8003 r ERROR: Could not read reader->convention
2011/02/08 18:57:04 8003 r Error activating card.
2011/02/08 18:57:09 C004 r ATR: ** ** ** **
2011/02/08 18:57:09 C004 r ERROR: Could not read reader->convention
2011/02/08 18:57:09 C004 r Error activating card.
2011/02/08 18:57:10 8003 r ATR: ** ** ** **
2011/02/08 18:57:10 8003 r ERROR: Could not read reader->convention
2011/02/08 18:57:10 8003 r Error activating card.
2011/02/08 18:57:14 C004 r ATR: ** ** ** **9
2011/02/08 18:57:14 C004 r ERROR: Could not read reader->convention
2011/02/08 18:57:14 C004 r Error activating card.
2011/02/08 18:57:16 8003 r ATR: ** ** ** **
2011/02/08 18:57:16 8003 r ERROR: Could not read reader->convention
2011/02/08 18:57:16 8003 r Error activating card.
2011/02/08 18:57:20 C004 r ATR: ** ** ** **
2011/02/08 18:57:20 C004 r ERROR: Could not read reader->convention
2011/02/08 18:57:20 C004 r Error activating card.
2011/02/08 18:57:21 8003 r ATR: ** ** ** **
2011/02/08 18:57:21 8003 r ERROR: Could not read reader->convention
2011/02/08 18:57:21 8003 r Error activating card.
2011/02/08 18:57:26 C004 r ATR: ** ** ** **
2011/02/08 18:57:26 C004 r ERROR: Could not read reader->convention
2011/02/08 18:57:26 C004 r Error activating card.
2011/02/08 18:57:26 C004 r card initializing error
2011/02/08 18:57:27 8003 r ATR: ** ** ** ** ** ** ** **
2011/02/08 18:57:27 8003 r ERROR: Could not read reader->convention
2011/02/08 18:57:27 8003 r Error activating card.
2011/02/08 18:57:27 8003 r card initializing error
2011/02/08 18:57:28 4000 s init for all local cards done
2011/02/08 18:57:28 4000 s anti cascading disabled

Reader hdplus deaktiviert
-------------------------------------------------------------------------------
>> OSCam << cardserver started at Tue Feb 8 19:00:24 2011
-------------------------------------------------------------------------------
2011/02/08 19:00:24 4000 s version=1.00-unstable_svn, build #4100, system=powerpc-tuxbox-linux, nice=-1
2011/02/08 19:00:24 4000 s client max. idle=120 sec, debug level=0
2011/02/08 19:00:24 4000 s max. logsize=10 Kb
2011/02/08 19:00:24 4000 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2011/02/08 19:00:24 4000 s auth size=4800
2011/02/08 19:00:24 4000 s services reloaded: 0 services freed, 11 services loaded
2011/02/08 19:00:24 4000 s userdb reloaded: 0 accounts freed, 2 accounts loaded, 0 expired, 0 disabled
2011/02/08 19:00:24 4000 s signal handling initialized (type=sysv)
2011/02/08 19:00:24 4000 s 8 service-id's loaded
2011/02/08 19:00:24 4000 s can't open file "/opt/var/etc/oscam.tiers" (err=2), no tier-id's loaded
2011/02/08 19:00:24 4000 s 3 provid's loaded
2011/02/08 19:00:24 4000 s can't open file "/opt/var/etc/oscam.ird" (errno=2) irdeto guessing not loaded
2011/02/08 19:00:24 4000 s monitor: disabled
2011/02/08 19:00:24 4000 s camd33: disabled
2011/02/08 19:00:24 4000 s camd35: disabled
2011/02/08 19:00:24 4000 s cs378x: disabled
2011/02/08 19:00:24 4000 s newcamd: initialized (fd=6, port=34000, ip=127.0.0.1, crypted)
2011/02/08 19:00:24 4000 s CAID: 1702
2011/02/08 19:00:24 4000 s provid #0: 000000
2011/02/08 19:00:24 4000 s newcamd: initialized (fd=7, port=34001, ip=127.0.0.1, crypted)
2011/02/08 19:00:24 4000 s CAID: 1843
2011/02/08 19:00:24 4000 s provid #0: 000000
2011/02/08 19:00:24 4000 s cccam: disabled
2011/02/08 19:00:24 4000 s radegast: disabled
2011/02/08 19:00:24 4000 s http thread started
2011/02/08 19:00:24 4000 s creating thread for device /dev/ttyUSB0 slot 0
2011/02/08 19:00:24 4000 s waiting for local card init
2011/02/08 19:00:24 4002 h HTTP Server listening on port 83
2011/02/08 19:00:24 8003 r reader thread started (thread= 8003, label=sky, device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=600)
2011/02/08 19:00:26 8003 r sky card detected
2011/02/08 19:00:37 8003 r version=1.00-unstable_svn, build #4100, system=powerpc-tuxbox-linux, nice=-1
2011/02/08 19:00:37 8003 r client max. idle=120 sec, debug level=0
2011/02/08 19:00:37 8003 r max. logsize=10 Kb
2011/02/08 19:00:37 8003 r client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2011/02/08 19:00:37 8003 r chid: 7D27, date: ****/**/** - ****/**/**
...
2011/02/08 19:00:39 8003 r [irdeto-reader] ready for requests
2011/02/08 19:00:40 4000 s init for all local cards done
2011/02/08 19:00:40 4000 s anti cascading disabled

Vorgehensweise nach Systemstart (DS207)
Login mit telnet:

mknod /dev/ttyUSB0 c 188 0
mknod /dev/ttyUSB1 c 188 0

insmod /opt/lib/modules/2.6.15/kernel/drivers/usb/serial/usbserial.ko
insmod /opt/lib/modules/2.6.15/kernel/drivers/usb/serial/ftdi_sio.ko

lsmod:

Module Size Used by Tainted: P
ftdi_sio 31848 1
usbserial 32848 4 ftdi_sio
...


dmesg:

usbcore: registered new driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
usbcore: registered new driver usbserial_generic
drivers/usb/serial/usb-serial.c: USB Serial Driver core
drivers/usb/serial/usb-serial.c: USB Serial support registered for FTDI USB Serial Device
usbcore: registered new driver ftdi_sio
drivers/usb/serial/ftdi_sio.c: v1.4.3:USB FTDI Serial Converters Driver
usb 1-2.5: new full speed USB device using ehci_hcd and address 19
ftdi_sio 1-2.5:1.0: FTDI USB Serial Device converter detected
drivers/usb/serial/ftdi_sio.c: Detected FT232BM
usb 1-2.5: FTDI USB Serial Device converter now attached to ttyUSB0
usb 1-2.4: new full speed USB device using ehci_hcd and address 20
ftdi_sio 1-2.4:1.0: FTDI USB Serial Device converter detected
drivers/usb/serial/ftdi_sio.c: Detected FT232BM
usb 1-2.4: FTDI USB Serial Device converter now attached to ttyUSB1


cat /proc/bus/usb/devices:

...
T: Bus=01 Lev=02 Prnt=02 Port=99 Cnt=01 Dev#= 20 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0403 ProdID=6001 Rev= 4.00
S: Product=USBDevice
S: SerialNumber=Reader 77
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=ftdi_sio
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

T: Bus=01 Lev=02 Prnt=02 Port=99 Cnt=02 Dev#= 19 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0403 ProdID=6001 Rev= 4.00
S: Product=USBDevice
S: SerialNumber=Reader 59
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=ftdi_sio
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

Smartreader Settings:
Reader 1:
Mode = Autoswitch
Kernel = Normal
T-Mode = T=0
EGT = 0

Reader 2:
Mode = Autoswitch
Kernel = Normal
T-Mode = T=0
EGT = 0

Smartreader Firmware:
Reader 1: 1.4
Reader 2: 1.4

cccam Server:
Shares:
HTML:
Bitte, Anmelden oder Registrieren Code-Inhalt anzeigen!
HTML:
Bitte, Anmelden oder Registrieren Code-Inhalt anzeigen!
 
OP
D

Daniel775

Ist gelegentlich hier
Registriert
24. Januar 2010
Beiträge
33
Punkte Reaktionen
4
Erfolgspunkte
8
AW: HD+ und Sky Karte laufen nur einzeln, nicht zusammen

Hat keiner eine Idee?
Ich habe irgendwie das Gefühl, das das Setting /dev/ttyUSB0 oder 1 garnix bringt. Er kann die Devices nicht auseinanderhalten. Weil wenn ich zum Beispiel für die HD+ Karte Device = /dev/ttyUSB1 zuweise, die Sky Karte als erstes in den USB-Hub einstecke und anschließend die HD+ Karte einstecke, danach die Sky Karte wieder entferne, dann müsste diese Hardwarezuweisung passen. Jedenfalls sagt mir dmesg das so.
Code:
Bitte, Anmelden oder Registrieren Code-Inhalt anzeigen!
Und komischerweise sagt mir die Log von oscam das er beide Karten gefunden hat. Obwohl nur eine drinsteckt!?

Code:
Bitte, Anmelden oder Registrieren Code-Inhalt anzeigen!
 

zotte007

Ist gelegentlich hier
Registriert
11. Februar 2010
Beiträge
90
Punkte Reaktionen
8
Erfolgspunkte
8
AW: HD+ und Sky Karte laufen nur einzeln, nicht zusammen

@Daniel775

Folgendes: Ich besitze neuerdings eine Synology DS111 worauf ich Oscam + Smargo zum laufen gebracht habe.
Nun will ich eine HD+ Card (weiss) im Smargo betreiben. Leider klappt das nicht.
Egal welche Einstellungen ich im Smargo oder in der oscam.server (mhz,cardmhz,smargopatch) wähle, ich bekomme immer diese Fehlermeldung:

2011/06/17 23:46:09 401A1BA0 r hdplus card detected
2011/06/17 23:46:17 401A1BA0 r ATR: XX XX 95 XX FF 91 81 71 FE 47 00 XX 4E 41 XX
50 31 34 32 20 52 65 76 47 43 34 63
2011/06/17 23:46:18 401A1BA0 r Maximum frequency for this card is formally 5 Mhz
, clocking it to 3.57 Mhz
2011/06/17 23:46:20 401A1BA0 r detect native nagra card
2011/06/17 23:46:28 401A1BA0 r card system not supported
2011/06/17 23:46:28 401A1BA0 r Normal mode failed, reverting to Deprecated Mode
2011/06/17 23:46:36 401A1BA0 r ATR: XX XX 95 XX FF 91 81 71 FE 47 00 XX 4E 41 XX


Da du ein ähnliches System am laufen hast wollte ich fragen ob du mir deine Smargo HWConfig und den Server-Eintrag mitteilen kannst womit deine HD+ Card mittels Smargo/Oscam auf deiner Syno läuft.
 
Oben