1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam & Smargo

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von speww, 31. Januar 2013.

  1. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Hallo !

    Ich versuche nun schon seit längerem einen HTPC mit Oscam und Smargo zu betreiben, bis jetzt leider ohne Erfolg. Ich habe schon gefühlt das halbe Internet durchsucht, bin aber in Sachen configs immer noch nicht schlauer. Mit meinen jetztigen configs wird die Smartcard zwar erkannt und initialisiert, allerdings funktionieren außer den öffentlich keine anderen Sender. Ich habe eine G09 Karte und ein Premium HD Abo von KD.

    oscam.config

    [global]
    nice = -1
    WaitForCards = 1
    preferlocalcards = 1
    logfile = /var/log/oscam/oscam.log
    maxlogsize = 256

    [webif]
    HttpPort = 3xxx
    HttpUser = admin
    HttpPWD = xxxx
    HttpRefresh = 10
    HttpAllowed = 192.168.0.1-192.168.255.255
    Httpdyndns = 192.168.178.28 leermachen, ist für Zugriff von außen
    HttpReadOnly = 0

    [cccam]
    Port = 52xxx
    Reshare = 2
    Ignorereshare = 1
    Version = 2.1.1
    Stealth = 0

    [dvbapi]
    Enabled = 1
    Boxtype = pc
    User = vdr
    decodeforever = 1
    AU = 1

    oscam.server

    [reader]
    label = KD
    protocol = mouse
    enable = 1
    device = /dev/ttyUSB0
    detect = CD
    caid = 09C7
    boxid = 12345678
    cool_timeout_after_init = 15
    cool_timeout_init = 30
    die beiden erstmal default stellen
    group = 3
    emmcache = 1,1,2

    oscam.user

    [account]
    User = DVBApi
    AU = 1
    Group = 3
    CAID = 09c7

    [account]
    user = vdr
    pwd = xxxx
    au = 1
    group = 3
    caid = 09C7
    ident = 09C7:000000 leerlassen
    cccmaxhops = 1

    Auszug aus den oscam logs...

    2013/01/31 02:01:32 263C200 r KD [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=500)
    2013/01/31 02:01:33 263C200 r KD [mouse] card detected
    2013/01/31 02:01:35 263C200 r KD [mouse] ATR: 3F XX
    2013/01/31 02:01:35 263C200 r KD [mouse] Init card protocol T0, FI=1, F=372, D=1, N=2
    2013/01/31 02:01:35 263C200 r KD [mouse] Setting baudrate to 13440 bps
    2013/01/31 02:01:35 263C200 r KD [mouse] Calculated work ETU is 104.20 us
    2013/01/31 02:01:35 263C200 r KD [mouse] ATR Fsmax is: 5 Mhz, clocking card to wanted user cardspeed of 3.57 Mhz (specified in reader->mhz)
    2013/01/31 02:01:36 263C200 r KD [mouse] Card type: KLPV
    2013/01/31 02:01:36 263C200 r KD [mouse] Rom version: 10LM
    2013/01/31 02:01:37 263C200 r KD [mouse] parental lock setting: FF FF FF FF
    2013/01/31 02:01:37 263C200 r KD [mouse] type: VideoGuard Kabel Deutschland G02/G09 (09C7), caid: 09C7
    2013/01/31 02:01:37 263C200 r KD [mouse] serial: ########, BoxID: ########, baseyear: 2004
    2013/01/31 02:01:37 263C200 r KD [mouse] ready for requests
    2013/01/31 02:01:37 263C200 r KD [mouse] found card system videoguard2
    2013/01/31 02:01:37 263C200 r KD [videoguard2] card detected
    2013/01/31 02:01:37 263C200 r KD [videoguard2] type: VideoGuard Kabel Deutschland G02/G09 (09C7)
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 00f3, expiry date: 2013/04/10-01:00:00
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 00f4, expiry date: 2013/04/10-01:00:00
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 00fa, expiry date: 2013/04/10-01:00:00
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 00fe, expiry date: 2013/04/10-01:00:00
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 0133, expiry date: 2013/04/10-01:00:00
    2013/01/31 02:01:37 263C200 r KD [videoguard2] tier: 0137, expiry date: 2013/04/10-01:00:00

    Wenn ich jetzt allerdings auf Sender wie zum Beispiel RTL HD, ProSieben HD oder AXN schalte kommen im Webinterface immer folgende Meldungen:

    2013/01/31 01:53:41 266F380 c dvbapi: Start descrambling PID #2 (CAID: 09C7) 1
    2013/01/31 01:53:41 266F380 c vdr (09C7&000000/0000/C47F/5F:434A1A1D4EDCDBFE9D50CCA0C85DA464): not found (0 ms) by KD
    2013/01/31 01:53:41 0 --- Skipped 1 duplicated log lines ---
    2013/01/31 01:53:41 0 >> OSCam << cardserver log switched, version 1.20-unstable_svn, build #8192 (x86_64-linux-gnu)
    2013/01/31 01:53:41 0 version=1.20-unstable_svn, build #8192, system=x86_64-linux-gnu, nice=-1
    2013/01/31 01:53:41 0 client max. idle=120 sec, debug level=0, filter_sensitive=1
    2013/01/31 01:53:41 0 max. logsize=256 Kb, loghistorysize=4096 bytes
    2013/01/31 01:53:41 0 client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
    2013/01/31 01:53:41 266F380 c dvbapi: Start descrambling PID #0 (CAID: 1861) 1
    2013/01/31 01:53:41 266F380 c vdr (09C7&000000/0000/C47F/5F:434A1A1D4EDCDBFE9D50CCA0C85DA464): not found (0 ms) by KD
    2013/01/31 01:53:41 266F380 c dvbapi: Start descrambling PID #2 (CAID: 09C7) 1
    2013/01/31 01:53:41 266F380 c vdr (09C7&000000/0000/C47F/5F:434A1A1D4EDCDBFE9D50CCA0C85DA464): not found (0 ms) by KD
    2013/01/31 01:53:42 0 --- Skipped 1 duplicated log lines ---

    So langsam weiß ich auch nicht mehr weiter. Bin schon auf sovielen Seiten umhergeirrt und habe um Rat gefragt, nach Infos gesucht doch bis jetzt leider ohne Erfolg. Wo könnte hier der Fehler liegen ? Über Hilfe würde ich mich sehr freuen, greetz
     
    Zuletzt von einem Moderator bearbeitet: 31. Januar 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.879
    Zustimmungen:
    6.210
    Punkte für Erfolge:
    113
    AW: Oscam & Smargo

    Schau Dir jetzt mal die Änderungen/ Vorschläge in Deinem Post an.
    "not found" ist klar, es wird ja gar kein Sender angefragt.
     
    #2
  4. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam & Smargo

    Ich habe das mal so geändert, wie du es mir vorgeschlagen hast. Alelrdings leider ohne Erfolg.
    Das was sich jetzt geändert hat, ist diese Ausgabe in der Log.

    oscam.log

    2013/01/31 16:06:47 B8FC70 c dvbapi: [ADD PID 0] CAID: 1834 ECM_PID: 1AF2 PROVID: 000000
    2013/01/31 16:06:47 B8FC70 c dvbapi: [ADD PID 1] CAID: 09C7 ECM_PID: 1AF3 PROVID: 000000
    2013/01/31 16:06:47 B8FC70 c dvbapi: [ADD PID 2] CAID: 1861 ECM_PID: 1AEF PROVID: 000000
    2013/01/31 16:06:47 B8FC70 c dvbapi: Found 3 ECMpids and 2 STREAMpids in PMT
    2013/01/31 16:06:47 B8FC70 c dvbapi: New program number: C362 (1834:C362 unknown) [pmt_list_management 3]
    2013/01/31 16:06:47 B8FC70 c dvbapi: Start descrambling PID #1 (CAID: 09C7) 1
    2013/01/31 16:06:47 B8FC70 c vdr (09C7&000000/0000/C362/5D:2C42FD3C6C077FFC129B3AB5FDC4F790): found (321 ms) by G09
    2013/01/31 16:06:49 B8E160 r G09 [videoguard2] vdr emmtype=global, len=155, idx=1, cnt=1: written (269 ms)
    2013/01/31 16:06:49 B8E160 r G09 [videoguard2] vdr emmtype=global, len=36, idx=2, cnt=1: written (56 ms)
    2013/01/31 16:06:58 B8FC70 c vdr (09C7&000000/0000/C362/5D:C0EA0B1EEE5232A6881EB4A52EE2A0A9): found (320 ms) by G09
    2013/01/31 16:06:59 B8E160 r G09 [videoguard2] vdr emmtype=global, len=36, idx=3, cnt=1: written (56 ms)
    2013/01/31 16:07:08 B8FC70 c vdr (09C7&000000/0000/C362/5D:9FC2D797F56944CE29D74C8C6511E5F2): found (320 ms) by G09
    2013/01/31 16:07:10 B8E160 r G09 [videoguard2] vdr emmtype=global, len=36, idx=4, cnt=1: written (56 ms)

    Ich bin noch recht neu auf diesem Gebiet, deswegen weiß ich jetzt nicht ob das so eine grandiose Verbesserung ist zur vorherigen Ausgabe. Aber zumindest steht da jetzt was von "foun" und nicht mehr "not found". Allerdings gibt's trotzdem kein Bild...
     
    #3
  5. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.879
    Zustimmungen:
    6.210
    Punkte für Erfolge:
    113
    AW: Oscam & Smargo

    Richtig, es kommt found. Ist ein Anfang.
    Nun noch bitte die oscam-Files vom Client posten.
     
    #4
    Pilot gefällt das.
  6. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Anfang, das klingt schonmal gut. Ist jetzt wahrscheinlich eine recht blöde Frage, aber ich weiß gar nicht ob ich da files für habe. Das ganze soll ja alles auf einem PC laufen, also Server / Client. Ist da das Problem, das ich das nicht angelegt habe ? Wie sollten diese Configs für den Clienten denn aussehen und wo gehören sie hin ?

    Die configs des Clienten sehen so aus:

    oscam.conf
    [global]
    nice = -1
    WaitForCards = 1
    preferlocalcards = 1
    logfile = /var/log/oscam/oscam.log
    usrfile = /var/log/oscam/oscam.log
    maxlogsize = 256

    [webif]
    HttpPort = 3xxx
    HttpUser = admin
    HttpPWD = xxx
    HttpRefresh = 10
    HttpAllowed = 192.168.0.1-192.168.255.255
    Httpdyndns =
    HttpReadOnly = 0

    [cccam]
    Port = 52000
    Reshare = 2
    Ignorereshare = 1
    Version = 2.1.1
    Stealth = 0

    [dvbapi]
    Enabled = 1
    Boxtype = pc
    User = vdr
    decodeforever = 1
    AU = 1

    oscam.server

    [reader]
    label = server
    enable = 1
    protocol = cccam
    device = 192.168.178.28,5xxx
    account = vdr,xxxx
    group = 3

    oscam.user

    [account]
    User = DVBApi
    AU = 1
    Group = 3
    caid = 09c7

    [account]
    user = vdr
    pwd = xxx
    au = 1
    group = 3

    ...und das sagt mir die Log bei verschlüsselten Sendern:

    2013/02/01 10:04:35 FF3330 c dvbapi: Start descrambling PID #0 (CAID: 1861) 1
    2013/02/01 10:04:35 FF3330 c vdr (09C7&000000/0000/C3BA/5F:6A182BAEE855D686C80D73EAFAE701AA): rejected group (0 ms) (0/0/0/0) (no matching reader)
    2013/02/01 10:04:35 FF3330 c dvbapi: Start descrambling PID #3 (CAID: 09C7) 1
    2013/02/01 10:04:35 FF3330 c vdr (09C7&000000/0000/C3BA/5F:6A182BAEE855D686C80D73EAFAE701AA): rejected group (0 ms) (0/0/0/0) (no matching reader)
     
    Zuletzt von einem Moderator bearbeitet: 1. Februar 2013
    #5
  7. Stehlampe
    Offline

    Stehlampe Ist gelegentlich hier

    Registriert:
    24. Januar 2012
    Beiträge:
    36
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Oscam & Smargo

    Ein Bekannter von mir hatte das selbe Problem. Er hat die CAID felder (oscam.server und oscam.user) und den IDENT leer gelassen und dann klappte es.
     
    #6
  8. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam & Smargo

    Habe ich versucht, bringt leider auch rein gar nichts. Habe erstmal alles wieder so zurückgestellt. Habe nach wie vor diese Meldung, wenn ich verschlüsselte Sender aufrufen will:

    2013/02/01 14:02:39 1C0C7D0 c dvbapi: New program number: C35C (1861:C35C unknown) [pmt_list_management 3]
    2013/02/01 14:02:39 1C0C7D0 c dvbapi: Start descrambling PID #1 (CAID: 09C7) 1
    2013/02/01 14:02:39 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:042EAC7A0AF48E2D5DF7ACA11F2A4EB8): found (328 ms) by KD
    2013/02/01 14:02:47 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:DE2A70173ECDBCE258ACDFD3D433845E): found (320 ms) by KD
    2013/02/01 14:02:57 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:7AC0E15D2C20E50B780CF3B60EC57E52): found (319 ms) by KD
    2013/02/01 14:03:07 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:710C3D9330DBCCF3E5A8ACDA87F8F2FB): found (320 ms) by KD
    2013/02/01 14:03:17 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:AAFB8784D73B59FC9F9909A6E2032A13): found (321 ms) by KD
    2013/02/01 14:03:27 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:99756220CA4C7E26350D694FFB884C52): found (320 ms) by KD
    2013/02/01 14:03:37 1C0C7D0 c anonymous (09C7&000000/0000/C35C/5D:FF0E3612DA61AFAAAE8E3917C602623C): found (321 ms) by KD

    Dazu sagt mir dann immer mein VDR "No Signal". Wenn ich da oben jetzt lese, dass was gefunden wurde, ist's dann einfach das Problem, dass es nicht entschlüsselt werden kann ?
     
    #7
  9. nsane
    Offline

    nsane Hacker

    Registriert:
    2. Februar 2012
    Beiträge:
    413
    Zustimmungen:
    122
    Punkte für Erfolge:
    43
    AW: Oscam & Smargo

    Gefunden beudetet, dass du den passenden Key bekommen hast!

    verwendest du das vdr dvbapi plugin von manio?
     
    #8
  10. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam & Smargo

    Wenn ich die Keys passenden Keys bekomme, dann sollte ich doch auch ein Bild bekommen - oder ? Sorry, wenn ich mich hier zeitweise recht doof anstelle, aber ich bin in dem Thema noch recht neu. Hab' die letzten Tage damit verbracht zu versuchen, etwas mehr zu lernen und das ganze zum Laufen zu bringen - ohne Erfolg bis jetzt.
    Das weiß ich gar nicht um ehrlich zu sein. Wenn ich:

    root@ubuntu:/usr/src/vdr# /etc/init.d/vdr start
    Starting Linux Video Disk Recorder: vdr
    root@ubuntu:/usr/src/vdr# Searching for plugins (VDR 1.7.28/1.7.28) (cache hit): dvbapi vnsiserver femon.Searching for plugins (VDR 1.7.28/1.7.28) (cache hit): dvbapi vnsiserver femon.

    Dann sagt er mir halt das hier > dvbapi vnsiserver femon
     
    #9
  11. Stehlampe
    Offline

    Stehlampe Ist gelegentlich hier

    Registriert:
    24. Januar 2012
    Beiträge:
    36
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Oscam & Smargo

    Die Karte findet den Key, aber der User wird nicht genommen. Konfiguriert hast Du einen User namens "vdr". Angefragt werden die Keys aber von einem "anonymous".
    Entferne bitte mal das Kennwort des Users "vdr" aus Deiner oscam.user. Lass das Feld einfach leer.

    oscam.user:
    oscam.conf:
     
    Zuletzt von einem Moderator bearbeitet: 2. Februar 2013
    #10
  12. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam & Smargo

    Okay, hab's jetzt wie beschrieben eingestellt.

    2013/02/01 20:42:54 1AE6B70 c dvbapi: Found 3 ECMpids and 2 STREAMpids in PMT
    2013/02/01 20:42:54 1AE6B70 c dvbapi: New program number: C362 (1834:C362 unknown) [pmt_list_management 3]
    2013/02/01 20:42:55 1AE6B70 c dvbapi: Start descrambling PID #1 (CAID: 09C7) 1
    2013/02/01 20:42:55 1AE6B70 c vdr (09C7&000000/0000/C362/5D:40232B3A0F37ABDCB3D8A61C68C37D9C): found (328 ms) by KD
    2013/02/01 20:42:56 1AE6B70 c vdr (09C7&000000/0000/C362/5D:CF456BEB1AABE481C7B4F9B70672A563): found (319 ms) by KD
    2013/02/01 20:43:00 1AE5030 r KD [videoguard2] vdr emmtype=global, len=36, idx=0, cnt=1: written (56 ms)

    Jetzt sieht's so aus. Und wie bekommt man mit den gefundenen Keys nun ein Bild zustande ?
     
    #11
  13. nsane
    Offline

    nsane Hacker

    Registriert:
    2. Februar 2012
    Beiträge:
    413
    Zustimmungen:
    122
    Punkte für Erfolge:
    43
    AW: Oscam &amp;amp; Smargo

    Ich erinnere mich das selbe Problem bei meinem xbmc pvr gehabt zu haben.
    Problem war damals die dvbapi. Zu diesem Zeitpunkt wurde noch viel am dvbapi plugin für vdr gebastelt, das gab es da nämlich erst 1 Woche :)

    Habe mein Problem damals auf oscam.to gepostet und der dev, manio hatte mir geholfen die dvbapi settings anzupassen bis es lief.
    Leider ist die Site down und ich kann mich auch nicht mehr genau erinnern was der Fehler war :/

    Eventuell hilft dir das ja weiter und du weißt wo du suchen musst ^^

    - - - Aktualisiert - - -

    UPDATE:

    Im github ist die readme zum dvbapi plugin, darin steht:

    Code:
    [COLOR=#333333][FONT=Consolas]3) In the oscam.conf file add following options[/FONT][/COLOR]
            [dvbapi]
            enabled = 1
            au = 1
            boxtype = pc
            user = vdr
            pmt_mode = 4
            request_mode = 1
    
    
       boxtype to "pc" will allow oscam to take adapter/demux information from CAPMT frame.
       pmt_mode to "4" will allow oscam to use camd.socket in /tmp/ dir
    - - - Aktualisiert - - -

    https://github.com/manio/vdr-plugin-dvbapi/
     
    #12
  14. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam &amp;amp; Smargo

    Danke ! Das sieht ja schonmal nach einem Plan aus, dann werde ich mich auf der Seite mal umsehen und ggf. mal alles installieren - vielleicht klappts dann ja. Wäre irgendwie schon ganz praktisch :) Oder ich melde mich nachher wieder, weil ich alles zerschossen habe ^^
     
    #13
  15. Stehlampe
    Offline

    Stehlampe Ist gelegentlich hier

    Registriert:
    24. Januar 2012
    Beiträge:
    36
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Oscam & Smargo

    Soweit schon mal klasse. Die Karte wird aufgemacht. Jetzt kanns nur noch an der DVBAPI liegen.
     
    #14
  16. speww
    Offline

    speww Newbie

    Registriert:
    22. November 2012
    Beiträge:
    16
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Oscam & Smargo

    Da bin ich beruight ;-) Dann sollte der Rest hoffentlich nicht mehr ganz so schwierig sein. Ich habe mal nachgeschaut und eigentlich habe ich das schon so, wie nsane das oben gepostet hat. Aber trotzdem gibt's da kein Bild. Was könnte denn an der DVBAPI hapern ?
     
    #15

Diese Seite empfehlen