1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCAM: Rejected ECM

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von speckthehut, 28. November 2012.

  1. speckthehut
    Offline

    speckthehut Hacker

    Registriert:
    2. April 2012
    Beiträge:
    363
    Zustimmungen:
    113
    Punkte für Erfolge:
    43
    Beruf:
    Rebbe
    Ort:
    Beim Metzger
    Hallo!

    Derzeit habe ein bis zweimal am Tag eine Meldung im LOG mit einem NOK wie dem hier:

    Habt ihr eine Ahnung was da los ist? Es kommt dabei auch immer zu Freezern.

    Meine config für den Reader ist:

    [reader]
    label = sky_satellit_v13
    description = Sky SAT V13
    protocol = mouse
    device = /dev/EASYMOUSE2-1
    services = "vorhanden"
    caid = 09C4
    boxid = 12345678
    ins7e11 = 15
    detect = cd
    mhz = 600
    cardmhz = 357
    group = 4
    emmcache = 1,2,2
    blockemm-unknown = 1
    blockemm-g = 1
    lb_weight = 300
    dropbadcws = 1
    ndsversion = 2

    Für den User:

    [account]
    user = F "gekürzt"
    pwd = xxx
    description = xxx
    caid = 09C4,0D05,0D95,1830,0500
    keepalive = 1
    group = 4,5
    services = "vorhanden" Negativ und Positiv
    cccmaxhops = 2
    cccreshare = 2
    cccignorereshare = 0

    OSCAM.conf

    # oscam.conf generated automatically by Streamboard
    OSCAM 1.20-unstable_svn SVN r7937
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    loghistorysize = 8100
    logfile = /var/log/ipc/OScam.log
    clienttimeout = 4700
    fallbacktimeout = 2600
    clientmaxidle = 300
    nice = 0
    maxlogsize = 8100
    cacheexwaittime = 300
    lb_save = 5000
    lb_savepath = /mnt/usb-stick/stat
    failbantime = 10080
    failbancount = 8

    [cs357x]
    port = xxx

    [cs378x]
    port = xxx

    [cccam]
    port = xxx
    nodeid = xxx
    version = 2.3.0
    reshare = 2

    [webif]
    httpport = xxx
    httpuser = xxx
    httppwd = xxx
    httpcss = /var/etc/maerklin_DEB_style.css
    httphelplang = de
    httprefresh = 15
    httpallowed = 192.168.0.0-192.168.255.255
    appendchaninfo = 1


    Das ganze kommt so weit bei allen Usern vor, eher selten aber Nervig!

    Die Karte hat noch dies Nacht Updates auf den Sack bekommen. Fast 5000 Global und 60 Unique EMM´s. Gültig bis März. Die OSCAM ist die Build: OSCAM 1.20-unstable_svn SVN r7937

    Habt ihr das selbe?

    Liebe Grüße!



    #############################

    Falls der Thread mal jemanden helfen sollte, hier die "wahrscheinliche" Lösung des Problems

    Einfach auf die Version 7943 Updaten, und schon läuft alles wieder wie es soll. Zumindest jetzt nach 24 Stunden! Obwohl ich in der Timeline nichts erkennen kann das da an diesem Fehler gearbeitet wurde. Nur ist für mich zu erkennen das die ECM´s jetzt gaaaanz lang angezeigt werden im LOG.

     
    Zuletzt bearbeitet: 30. November 2012
    #1
    hwmmc gefällt das.
  2. phantom

    Nervigen User Advertisement

  3. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.495
    Zustimmungen:
    3.034
    Punkte für Erfolge:
    113
    AW: OSCAM: Rejected ECM

    Der ECM Header ist falsch abgefragt wurden.
     
    #2
    speckthehut gefällt das.
  4. speckthehut
    Offline

    speckthehut Hacker

    Registriert:
    2. April 2012
    Beiträge:
    363
    Zustimmungen:
    113
    Punkte für Erfolge:
    43
    Beruf:
    Rebbe
    Ort:
    Beim Metzger
    AW: OSCAM: Rejected ECM

    Hallo!

    Jetzt habe ich leider gesehen das die neuere OSCAM Version den Fehler nicht behoben hat. Würde mich auch wundern.

    Meinst du das es vielleicht mit einem Eintrag im Reader des Servers im ECM Header getan ist? Würde dann das hier eintragen:

    807098000001,817098000001,807060000001,817060000001,80709D000001,81709D000001,80704E000001,81704E000001,807066000001,817066000001,8070B0000001,8170B0000001

    Habs noch nicht ausprobiert. Werde aber mal hoffen das damit das Problem vielleicht der vergangenheit angehören wird...
    Die verursachenden Clienten sind mit OSCAM Version 7805 und die 1.10 stable bei mir Online, alle machen den selben Fehler, wenn auch höchstens einmal am Tag.
     
    #3
  5. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.495
    Zustimmungen:
    3.034
    Punkte für Erfolge:
    113
    AW: OSCAM: Rejected ECM

    Es kommen Abfragen von einen Receiver, der den ECM Header verbiegt, aber nicht korrekt abfragt.
    Lässt du den ECM Header im Reader weg, bekommst du da timeout, jedoch kein found!
     
    #4
    speckthehut gefällt das.
  6. speckthehut
    Offline

    speckthehut Hacker

    Registriert:
    2. April 2012
    Beiträge:
    363
    Zustimmungen:
    113
    Punkte für Erfolge:
    43
    Beruf:
    Rebbe
    Ort:
    Beim Metzger
    AW: OSCAM: Rejected ECM

    Hallo!

    Da muss ich das Thema nochmal aus dem Dreck ziehen...

    Leider ist der Fehler noch immer vorhanden. Er tritt bei verschiedensten Receivern auf! Egal ob mit OSCAM oder CCCAM only. Eben erst noch bei meiner Dreambox mit OSCAM 7855. Im WebIF vom OSCAM Server steht dann beim Reader ein NOK. Im User Interface vom Server steht dagegen kein NOK oder Timeout!
    Der Fehler tritt noch immer rund einmal am Tag auf, an machen Tagen sogar bis zu 3 mal! Und das immer von Unterschiedlichen Receivern... (Habe meine Dreambox eine DBox2 und Goldemedia 990 im Share)

    Ob es sich hier um einen Bug handelt?

    Also wurde die das ganze scheinbar Entschlüsselt und verworfen...

    Würde das ganze gerne mal im Log sehen können was genau da passiert, doch mit dem LOG auf 0 steht da nichts ausser rejected. Wisst ihr welchen Log Level ich einstellen muss um da an weitere Infos zu kommen?

    ################# EDIT ####################

    Falls jemand sowas ähnliches hat, hier hab ich was schönes Gefunden:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Behebt die ganze Sache noch immer nicht, aber man kommt dem was näher. Wie es aussieht wenn ich richtig gelesen habe; Das da Fake ECM´s verschickt werden und der Receiver den einfach nur weiterleitet und eine Antwort erwartet. Doch warum man dann Umschalten muss um wieder ein Bild zu bekommen ist mir Rätselhaft. Wenn mal was ganz schief läuft verschicken manche Receiver ja auch 8 ECM Anfragen in einer Sekunde :)


    #################### EDIT 2 #####################

    Hier bin ich nochmal! LEider hatte das ganze doch nicht geholfen. Der Fehler mit dem Rejected kam doch noch bis zu 3 mal am Tag vor.

    Es war so -> User1 fragt nach der Entschlüsselung 10
    Antwort -> Rejected
    zweite Anfrage
    Antwort -> Not found (Mit gleicher ECM)
    User2 fragt die selbe ECM ab weil er den selben Sender sieht
    Antwort -> Not found

    Doch jetzt habe ich ev. doch eine einfache Lösung!
    Im WebIF für den Reader gibt es seit einigen Monaten den Parameter "

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    " da steht Standartmäßig ein Haken, für Enabled. Den Parameter auszuschalten hilft bisher, seit ca. 30 Stunden kein Not Found oder Rejected mehr! Aber auch keine Freezer!
    Wie sieht der Parameter denn bei Euch aus?
     
    Zuletzt bearbeitet: 7. Mai 2013
    #5
    hwmmc gefällt das.

Diese Seite empfehlen