1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

N*va Karte funktioniert mit PC-Server nicht einwandfrei

Dieses Thema im Forum "CS CCcam" wurde erstellt von grepane, 2. Januar 2010.

  1. grepane
    Offline

    grepane Newbie

    Registriert:
    2. Januar 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    erstmal grüße an alle, bin neu hier.

    Ich habe auf meinem Ubuntu 9.04 Server 50 F-Lines die 3 Karten von mir sharen, 2 unterschiedliche S*y Karten mit Load Balancer und Sid Assign, eine N*va (griechisch, Irdeto) Karte mit Vollpaket.

    Alle 3 Karten habe ich mit Hilfe eines aktiven D-Link D7 Hubs über Smargo+ am laufen.

    Es ist aber so, dass manchmal alle Shares die No*a gucken plötzlich nicht mehr gucken können.(das passiert so alle 1-3 Stunden)

    In der Client List steht dann:


    |Username |12.345.678.901 |00d 01:13:46|00d 00:00:03|430 (405)|0 (0) |2.1.3 |0604:000000:017a (nok)

    S*y funktioniert aber immernoch.

    Die Nov* Karte wird unter Entitlements immernoch angezeigt, aber liefert keine ECMs zurück.

    Wenn ich die Nov* Karte aber in meiner Dm500 share und die Dm500 über eine F-Line mit dem Server verbinde, habe ich das Problem nicht. Dann läuft es absolut stabil, über Tage.

    Die Config, betreffend der Nov* Karte ist sowohl in der Dm500 als auch auf Ubuntu absolut gleich, also normaler Camkey und keine Übertaktung.

    Dass die Karte überlastet ist denke ich auch nicht, da die ja mit dem Dm500 problemlos funktioniert.

    Die Smargos habe ich auch getauscht, bringt keine Hilfe.
    Den Slot wo die N*va Karte steckt habe ich auch geändert.
    Ich weiß nicht mehr weiter, habt ihr vielleicht eine idee?

    Hier meine Config:

    SERIAL READER : /dev/ttyUSB2 smartreader+
    CAMKEY: /dev/ttyUSB2 00 00 00 00 00 00 00 00

    WEBINFO USERNAME : .....
    WEBINFO PASSWORD : .
    WEBINFO LISTEN PORT : .....
    SERVER LISTEN PORT : .....
    GLOBAL LIMITS: { 1834:000000 }
    #CAID PRIO FILE: /var/etc/CCcam.prio
    DISABLE EMM : yes
    #EXTRA EMM LEVEL : yes
    #EMM THREADS : 1


    So sieht eine F-Line aus von einem, der mir EMM's senden darf:

    F: xxxxx xxxxx 1 0 1 { 0:0:1 }


    Passwörter und Logins tauchen nie doppelt auf, das kann ich auschließen.

    Grüße,

    Dimi
     
    Zuletzt bearbeitet: 2. Januar 2010
    #1
  2. phantom

    Nervigen User Advertisement

  3. robocop
    Offline

    robocop Freak

    Registriert:
    5. März 2008
    Beiträge:
    280
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    hi
    probiere das mal so:
    #DISABLE EMM : yes
    B: /dev/ttyUSB2 04

    so kommem nur die wichtigsten daten durch, ansonsten wird die karte mit emm`s bombadiert.

    robo
     
    #2
    grepane gefällt das.
  4. hchfhfghxhxfd
    Offline

    hchfhfghxhxfd Newbie

    Registriert:
    2. November 2008
    Beiträge:
    12
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    Oder

    DISABLE EMM : yes
    B: /dev/ttyUSB2 04 ?
     
    #3
  5. robocop
    Offline

    robocop Freak

    Registriert:
    5. März 2008
    Beiträge:
    280
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    es bring ja wohl nichts die emm´s komplett zu blocken und dann eine regel zu erstellen was durch darf.
    so wie ich es im ersten beitrag geschrieben habe ist es schon in ordnung!

    robo
     
    #4
  6. roli1968
    Offline

    roli1968 Spezialist

    Registriert:
    12. August 2008
    Beiträge:
    681
    Zustimmungen:
    107
    Punkte für Erfolge:
    43
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    also die Irdeto Karten sind eigentlich nicht so anfählig was EMM anbelangt hast du mal versucht die Karte in einem anderen Smargo mal laufen zu lassen , also Tausche mal die SKY mit der Nova Karte aus und schaue mal ob es immer noch so ist oder stecke sie mal in einen anderen port auf dem HUB
     
    #5
  7. grepane
    Offline

    grepane Newbie

    Registriert:
    2. Januar 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei


    Habe ich bereits gemacht, siehe erster Post.

    @robocop.

    Wieso Disable EMM: yes ausklammern?

    Die Karten stecken in einem PC Server also können sie von sich aus sowieso keine EMMs empfangen und sind auf die Clients angewiesen?

    Wie soll die karte geupdated werden, wenn die EMMs gesperrt sind?
     
    #6
  8. robocop
    Offline

    robocop Freak

    Registriert:
    5. März 2008
    Beiträge:
    280
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    wenn du emm´s nicht erlaubst, kommen die von den clienten auch nicht an.
    ich habe bei einem freund eine nova karte seit einem jahr im smargo laufen, ohne sie im reciever updaten zu müssen.

    robo
     
    #7
  9. grepane
    Offline

    grepane Newbie

    Registriert:
    2. Januar 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    also bei mir ist es so, dass wenn die karte 3 tage keine EMMs bekommt die dunkel ist... bist du dir absolut sicher dass EMMs bei dir inaktiv sind?

    Jedenfalls habe ich die B-Linie drin.

    Kannst du mir mal erklären wieso DISABLE EMM: yes deaktiviert werden soll?
    In der CCCam.cfg steht ja drin:

    # Mit dieser Einstellung lässt sich das lokale EMM-lesen ganz abschalten.
    # Das spart eine Menge CPU-Last, allerdings wird die Karte nun nicht mehr
    # geupdated, oder nur noch von Clients, denen man in der F: Line die Erlaubnis
    # dazu erteilt hat.
    # Es ist auf jeden Fall sehr sinnvoll dies in einem reinem Server, welcher eh nicht
    # über einen Sat/Kabelanschluss verfügt, zu setzen.
    #
    # Standard: no
    #
    #DISABLE EMM : yes

    _______________________


    Hier mal 2 Fehlermeldungen im Log:

    02:32:15.747 CCcam: local ecm -> card /dev/ttyUSB2 0x604(0x000) sid 0x1bd1
    02:32:15.747 CCcam: local ecm <- card /dev/ttyUSB2 error
    02:32:15.747 CCcam: client blabla ecm request for handler 0x78 0x604(0x0) sid 0x142 ok: 1
    02:32:15.748 CCcam: client xyzxyz ecm request for handler 0x78 0x604(0x0) sid 0x142 ok: 1
    02:32:15.748 CCcam: client zyxzyx ecm request for handler 0x78 0x604(0x0) sid 0x13f ok: 0


    oder hier mal anders:


    18:37:03.049 CCcam: local ecm -> card /dev/ttyUSB2 0x604(0x000) sid 0x142
    18:37:03.049 CCcam: local ecm <- card /dev/ttyUSB2 error <- *
    18:37:03.049 CCcam: client
    xyzxyz ecm request for handler 0x78 0x604(0x0) sid 0x142 ok: 0

    *Diesen Error verstehe ich nicht, wieso habe ich ab und zu solch einen Error? Welche Gründe kann es alles haben?
    USB Port überlastet?(hab einen aktiven Hub!?)
    Karte überlastet?


    Die Kanäle 0142 und 013F habe ich natürlich im Paket.


    Was ich aber garnicht verstehe ist folgendes:


    Ich habe eine SID Assign Liste für die Nova Karte mittlerweile:
    SMARTCARD SID ASSIGN : /dev/ttyUSB2 { 0070, 013C, 013D, 013E, 013F, 0140, 0141, 0142, 0145, 015F, 0161, 0162, 0163, 0168, 0169, 016A, 016B, 0170, 0178, 0179, 017A, 1BC2, 1BC3, 1BC4, 1BC5, 1BC7, 1C85, 1D4D, 1D4E, 1D4F, 1D51, 1D52, 1D53, 1D54, 1D57, 1D97, 1D99 }

    Trotzdem werden Anfragen für irgendwelche Kanäle gestellt (Beispielsweise 35C6), die ich garnicht in der Liste habe... dann ist es normal dass die Karte ok: 0 ausspuckt...

    Warum ist das so?

    Und außerdem habe ich bemerkt, dass ich mit aktivierter Sid Liste CCcam 2-3x neustarten muss, bis die Clients endlich gucken können ...




     
    Zuletzt bearbeitet: 3. Januar 2010
    #8
  10. robocop
    Offline

    robocop Freak

    Registriert:
    5. März 2008
    Beiträge:
    280
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    hi
    hier mal ein auszug aus der config:

    # SERIAL READER : <Pfad zum Reader> <Readertyp>
    #
    # Beispiel:
    #
    ##SERIAL READER : /dev/tts/0
    SERIAL READER : /dev/ttyUSB0 smartreader+
    #
    # Schreibverzögerungseinstellung für die Smartcards.
    # Hier lässt sich die Schreibgeschwindigkeit der Smartcards feintunen. Die optimale Einstellung ist abhängig
    # von der Rechenleistung des Systems und der Rechenleistung der Smartcards.
    # Der Standardwert wird berechnet, kann aber mit dieser Einstellung aufgehoben werden.
    # Verzögerung in Millisekunden zischen den Bytes, 0 = keine Verzögerung, -1 = Standard berechnen
    # Bemerkung: Es gibt einen großen Unterschied zwischen den Werten 0 und 1, wegen des tabellarischen Mehraufwandes.
    #
    # SMARTCARD CLOCK FREQUENCY : <device> <freq in Hz>

    SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB0 6000000
    #
    # Anzeige der ECM-Zeiten im OSD und der Debug-Ausgabe
    # Standard ist no (ausgeschaltet)
    #
    SHOW TIMING : yes

    # Hier kann man einstellen welchen EMM-Blocker man möchte. Dies lässt sich für jeden angeschlossenen
    # internen und externen Kartenleser separat setzen.
    # Standardmäßig werden keine EMM geblockt.
    #
    # B: /dev/sci0 01
    # 00 - nothing
    # 01 - SA EMM werden geblockt
    # 02 - UA EMM werden geblockt
    # 04 - GA EMM werden geblockt
    # Werte werden addiert, um verschieden EMM zu blocken. z.B. 01 + 02 = 03
    # blockt SA und UA EMM.
    #
    # Beispiele:
    #
    B: /dev/ttyUSB0 04

    # Mit dieser Einstellung lässt sich das lokale EMM-lesen ganz abschalten.
    # Das spart eine Menge CPU-Last, allerdings wird die Karte nun nicht mehr
    # geupdated, oder nur noch von Clients, denen man in der F: Line die Erlaubnis
    # dazu erteilt hat.
    # Es ist auf jeden Fall sehr sinnvoll dies in einem reinem Server, welcher eh nicht
    # über einen Sat/Kabelanschluss verfügt, zu setzen.
    #
    # Standard: no
    #
    #DISABLE EMM : yes

    #
    # CAMKEY: <Pfad> <Byte1> <Byte2> <Byte3> <Byte4> <Byte5> <Byte6> <Byte7> <Byte8>
    #
    # Beispiel:
    #
    CAMKEY: /dev/ttyUSB0 00 00 00 00 00 00 00 00
    CAMKEY: /dev/tts/0 00 00 00 00 00 00 00 00

    # Ersetzen der Irdeto Camdata (64 Byte Hex)
    # Null-Bytes am Ende können weggelassen werden.
    # Standard für unbekannte ASCs ist 11 22 33 44 55 66 77 88 00 00 .. 00, bekannte ASCs haben andere Standards.
    #
    # CAMDATA: <Pfad> <Byte1> <Byte2> <Byte3> <Byte4> <Byte5> <Byte6> ... <Byte64>
    #
    # Beispiel, wenn nur die ersten 15 Bytes der Camdata aus nicht nuller Blöcken bestehen:
    #
    CAMDATA: /dev/ttyUSB0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    CAMDATA: /dev/ttyS0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    #
    #TRY ALL CHIDS : <Pfad>
    #
    #Beispiel: Die Karte in /dev/ttyUSB0 bekommt ECM für alle möglichen CHIDs, nicht
    #nur die CHIDs die sie offiziell unterstützt.
    #
    TRY ALL CHIDS : /dev/ttyUSB0
    TRY ALL CHIDS : /dev/ttyS0

    # Beispiel für das Abschalten nicht laufender DVB-Hardware:
    DVB API: -1


    und damit rennt die karte schon ewig!

    robo

    ps: du musst natürlich noch einem clienten erlauben emm`s zu senden!
     
    Zuletzt bearbeitet: 3. Januar 2010
    #9
  11. grepane
    Offline

    grepane Newbie

    Registriert:
    2. Januar 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    Ok, ich habs mal so eingefügt, danke erstmal.
    Mal schauen wie sich der Server macht.
     
    #10
  12. grepane
    Offline

    grepane Newbie

    Registriert:
    2. Januar 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: N*va Karte funktioniert mit PC-Server nicht einwandfrei

    Lohnt es sich die EMMs für S*y auch zu sperren mit Hilfe dieser B-Linie?
     
    #11

Diese Seite empfehlen