1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst ECM Zeiten sehr schlecht seit LB aktiv ist mit 2x S02 und HD01

Dieses Thema im Forum "OScam Archiv" wurde erstellt von hartharry, 2. Mai 2012.

  1. hartharry
    Offline

    hartharry Newbie

    Registriert:
    27. Januar 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    leider komme ich bei meiner Konstellation nicht weiter und bräuchte mal Hilfe.

    Meine Konfiguration wäre Freetzbox 7270V3 ,3 Smargos am 7 Port König Hub, seriell angesprochen mit Loadbalance über OSCAM. Die Freetz Version wäre 74.04.88freetz-devel-6576M, die Oscamversion ist die 1.10 5990. Leider sind nach Aktivierung vom LB die ECM Zeiten steil nach oben gegangen, wobei die S02 mit ca. 1s noch recht gut laufen, die HD01 selbst bei einem Clienten schon bei 1,2 - 1,5s liegen.

    Vor Aktivierung des LB mit einer S02 habe ich die S02 über cccam 2.1.1 laufen lassen und hatte eigentlich immer sehr gute ECM Zeiten um die 0.600 - 0.800. Die HD01 Karte hatte ich per OSCAM laufen und lief bei ~ 0.400s, selbst bei allen 6 Clients war es kaum über 1.000s. Da LB bei mir Probleme mit dem Mouse Protokoll machten und die Reader ständig abstürzten, bin ich auf das smartreader Protokoll ausgewichen. Abbrüche oder Fehler in den Client-Statistiken habe ich seitdem keine mehr, die Karten werden sofort erkannt, also alles schön. Leider sind damit nur die Zeiten sehr hoch gegangen..shit...Die Clients laufen bis jetzt übrigens alle über CCCam.

    Die HD01 sollte bei aktivem LB eigentlich ja ohne Ident auskommen. Das haut bei dem Opticum Receiver leider nicht hin, da die Anfragen mit 1830:003411 reinkommen. Daher hab ich's wieder aufgenmmen.

    Vielleicht hat jemand einen Tipp für mich. Anbei mal die Configs.

    Vielen Dank schon mal im voraus.

    jetzt noch Spoiler... :ja

    oscam.server
    [reader]
    label = sky1
    protocol = smartreader
    device = Serial:Reader 1234567
    services = sky,!skyselect
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 1702:93
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    lb_weight = 200

    [reader]
    label = sky2
    protocol = smartreader
    device = Serial:Reader 1234567
    services = sky,!skyselect
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 1702:93
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    lb_weight = 200

    [reader]
    label = HD01
    Protocol = smartreader
    detect = CD
    device =Serial:Reader 1234567
    services = hdplus
    group = 2
    emmcache = 1,3,2
    rsakey= BFxxx5
    boxkey = AxxxxxC
    CAID = 1830
    IDENT = 1830:003411;1830:008011;1830:000000
    #mhz = 368
    cardmhz = 368
    blockemm-unknown = 1
    lb_weight = 200
    ecmwhitelist = 1830:92

    oscam.conf
    # GLOBALs --------------------------------------------------
    [monitor]
    port = 85
    aulow = 120
    monlevel = 2
    #NoCrypt = 192.xxx.xxx.0-192.xxx.xxx.255
    httphideidleclients = 0
    httpport = 83
    httpuser =
    httppwd =
    httpcss =
    httprefresh = 20
    httptpl =
    Httpcss =

    [global]
    serverip = 192.xxx.xxx.x
    nice = -1
    WaitForCards = 1
    ClientTimeout = 11000
    clientmaxidle = 60
    failbantime = 3600
    failbancount = 20
    usrfile = /var/media/ftp/uStor01/cs/oscam/oscamuser.log
    #logfile = /var/media/ftp/uStor01/cs/oscam/oscam.log
    maxlogsize = 5000 #max. 5 MB
    saveinithistory = 1
    Level = 15
    CacheDelay = 20
    bindwait = 120
    netprio = 1
    lb_mode = 1
    lb_save = 200
    lb_savepath = /var/media/ftp/uStor01/cs/oscam/lb_stat
    fallbacktimeout = 2600
    preferlocalcards = 0

    # WEBIF ----------------------------------------------------
    [webif]
    httpport=xxxxx
    httpallowed=127.0.0.1,192.168.0.0-192.xxx.xxx.255
    httprefresh = 20
    httphideidleclients = 0
    httpreadonly = 0

    [cccam]
    port = xxxxx
    keepconnected = 0
    reshare = 1
    stealth = 1

    [cs357x]
    port = xxxxx

    oscam.services

    [sky]
    caid = 1702
    provid = 000000
    srvid = 0008,0009,000A,000B,000C,000D,000E,0010,0011,0012,0013,0014,0015,0016,0017,0018,0019,001A,001B,001C,001D,0021,0022,0023,0024,0025,0026,0027,0029,002A,002B,0032,0034,0035,0037,0038,0039,003A,003C,003D,003E,003F,0040,0041,0042,0043,0044,007D,0096,0097,0098,0099,009A,009B,009C,00A8,00DD,00DE,00DF,00FC,00FD,0106,0107,0110,0111,011A,011B,0124,0125,012E,012F,0138,0139,0142,0143,014C,014D,0156,0160,016B,0175,0201,0203,0204,0206,07FF,2EFE,3331,4461,4462,7001,700A,0077,0072,006A,006B,006F,0070,0071,0081,0082,0083,0084,0075,00FC,00DF,0106,0110,011A,0124,012E,0138,0142,014C,0156,0160,0069,3335,0201,000F,006C,0076,0074,007C,6FB8,6FB9
    [skyselect]
    caid = 1702,1833
    provid = 000000
    srvid = 0012,0078,0079,007A,00FB,00FE,0105,0108,010F,0119,0123,012D,0137,0141,014B,0159,0163,016D,0096,0097,0098,0099,009A,009B,009C,0045,0046,003B
    [hdplus]
    caid = 1830
    provid = 000000,003411,008011
    srvid = 277E,EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77,5273,5274,1519

    # oscam.user ***********************************************
    [account]
    user=user
    pwd=pwd
    group = 1,2,
    uniq=0
    au=sky1,sky2,hdplus
    services = sky,hdplus,!skyselect
    caid = 1830,1702,1833
    ccmaxhops = 0
    cccreshare = 0
    enable= 1
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.949
    Zustimmungen:
    5.873
    Punkte für Erfolge:
    113
    Ich würde mal den Ident-Eintrag im HD+Reader entfernen.

    laut oscam-wiki
    ident

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Parameter ist optional

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Achtung: Wenn in oscam.conf [global] unter lb_mode loadbalancing aktiviert ist, dann dürfen hier keine Einträge stehen!
    Edit: hab ich zu spät gesehen
    Aber kannst du das nicht in den user packen?

    Gruß
    janni1
     
    #2
  4. hartharry
    Offline

    hartharry Newbie

    Registriert:
    27. Januar 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    keine Ahnung, ob dann HD+ aufgeht. Auf jeden Fall sind die Zeiten unverändert, da ich den Ident Eintrag vorher draußen hatte.

    Gruß
    Harry
     
    #3
  5. hartharry
    Offline

    hartharry Newbie

    Registriert:
    27. Januar 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hat keiner eine Idee??

    Kann es Sinn machen, die Fritzbox mit einem Recoveryimage zurückzusetzen und dann die Smargos wieder mit Mouse protokoll anzusteuern?
    Damit waren die Zeiten ja sehr gut (bis auf die Abbrüche der Reader). Oder sollten die Smargos anders eingestellt werden??

    Wie läuft es bei euch, wenn Loadbalance aktiv? Mit Mouse oder Smartreader Protokoll?? Hab leider keine andere Beispielkonfig gefunden.

    Gruß
     
    #4
  6. razorback
    Offline

    razorback Power Elite User

    Registriert:
    21. Mai 2008
    Beiträge:
    2.012
    Zustimmungen:
    1.308
    Punkte für Erfolge:
    113
    Beruf:
    IT
    Ort:
    Wien-Süd
    zum Thema Ident, die den LB unwirksam macht aber deine Optis finster läßt:

    da du ja in den readern ecmwhitlist = benutzt, kannst das ganze in die datei oscam.whitelist (den genauen aufbau schaust dir bitte in der Wiki an, )

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    reinpacken und dort kannst auch die ident mappen
    also:
    M: 1830 1830:000000
    damit werden alle Zugriffe auf die 1830 mit was für einer ident auch immer auf 1830:000000 umgebogen und deine optis sollten was sehen können und du kannst die Ident aus dem reader rausnehmen.

    zu den langen ecms:
    du hast in der oscam.conf im Abschnitt [cccam] einen keepconnected = 0 drin.
    das kann heißen, daß bei jeder anfrage des clients die verbindung neu aufgebaut wird. sollte zwar nicht sein, kann aber - änder das mal auf 1.

    weiteres:
    in deiner oscam.conf gibts noch einige ungereimtheiten:
    im abschnitt [monitor] hast auch noch die ganzen settings fürs webinterface drin (alles was mit http.. anfängt)
    hau die dort mal raus, die hast ja im abschnitt [webif] und die machen dort nur unsinn....

    in der [global]
    brauchst die serverip nicht, wäre nur erforderlich, wenn der server mehr als einen Netzwerkport hätte, also raus.
    ebenfalls raus die folgenden 4 Zeilen: (wo hast denn DAS her ?)
    Level = 15
    CacheDelay = 20
    bindwait = 120
    netprio = 1

    Und grundsätzlich würde ich empfehlen, auf eine aktuelle OSCam Version zu gehen.
    Und obwohl angeblich "unstable" würd ich zu einer solchen raten - sie ist in der mehrzahl der fälle mindestens so stabil wie die "stable".
    ich hab - allerdings nicht auf einer fritte - momentan die 1.20 rev 6652 im einsatz und das ding geht ab wie sau.
    und mit smartreader protokoll DEUTLICH besser als mit mouse.

    R
     
    #5
  7. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.391
    Zustimmungen:
    23.804
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    Danke dir razorback,

    stand vor einem Phänomen. Ich teste seit einenigen Tagen die neusten oscam Versionen. Mit cccam Protokoll super. diese version: Version: 1.20-unstable_svn Rev. 6665
    Beim Newcamd Protokoll für meine Newcamd Clienten meldete sich ein user anonymus auf die IP meines Servers und die Newcamd clienten konnten sich nicht einmal einloggen.

    Erfolg brachte diese Aussage von dir. Bei mir aber im Umkehrschluß.
    in der [global]
    brauchst die serverip nicht, wäre nur erforderlich, wenn der server mehr als einen Netzwerkport hätte, also raus

    Hate nie eine IP in der oscam.conf bei global. Jetzt habe ich eine IP eingtragen, da ich einige Ports im Newcamd Protokoll drin hatte, den port im cccam Protokoll und den Port im Cs 357.
    Der user anonymus verscwand. die Newcamd Clienten können sich einloggen und werden hell.

    Meine Vermutung jetzt: Die neusten oscam Versionen verlangen eine IP im oscam.conf global, wenn mehrere Ports angesprochen werden müssen.

    Mlg piloten
     
    #6
  8. hartharry
    Offline

    hartharry Newbie

    Registriert:
    27. Januar 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ok, danke razorback. Ich teste das morgen mal aus.

    VG
    Harry
     
    #7
  9. razorback
    Offline

    razorback Power Elite User

    Registriert:
    21. Mai 2008
    Beiträge:
    2.012
    Zustimmungen:
    1.308
    Punkte für Erfolge:
    113
    Beruf:
    IT
    Ort:
    Wien-Süd
    @piloten

    intessant zu hören.

    ich habe sowohl cccam als auch cs357x als auch cs378x aktiv, KEINE Serverip und keinerlei Probleme mit "anonymous" Geschichten.
    allerding eben auch kein newcamd im einsatz.
    (OSCam 1.20 rev 6652)

    R
     
    #8
  10. hartharry
    Offline

    hartharry Newbie

    Registriert:
    27. Januar 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi zusammen,

    das Problem scheint sich gelöst zu haben. Die Einstellungen alleine waren nicht der volle Erfolg. Ich hab ein Recovery gemacht und danach das DEB Devel 8888 installiert. Dannach wars okay. Jetzt jabe ich Zeiten von 500- 700ms. Damit kann ich sehr gut leben :)

    Vielen Dank nochmal!!

    Leider haut der AU auf die HD01noch nicht hin. Dieser soll ausschliesslich über ein Receiver laufen. Weder über CCCam noch Oscam (per camd35) hauts hin. Die S02 wird upgedated. AU steht auf beide Labels. Vielleicht habt ihr da noch einen Tipp für mich.

    VG

    AU auf die HD+ Karte hat sich auch erl. Shit Tippfehler.....
     
    Zuletzt von einem Moderator bearbeitet: 7. Mai 2012
    #9

Diese Seite empfehlen