1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

CCcam Client bekommt keine Verbindung zum OScam Server

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von heugabel, 4. April 2013.

  1. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    Hänge mich mal dran.
    Mein Client bekommt von mir auch keine Verbindung.
    oscam.cfg

    [cccam]
    port = 12000
    reshare = 1
    forward_origin_card = 0
    ignorereshare = 0
    version = 2.1.4
    minimizecards = 0
    keepconnected = 1
    stealth = 0
    reshare_mode = 0
    updateinterval = 240
    [global]
    Nice = -1
    ClientTimeout = 7
    FallbackTimeout = 3
    ClientMaxIdle = 120
    CacheDelay = 120
    BindWait = 5
    WaitForCards = 1
    PreferLocalCards = 1
    LogFile = stdout
    saveinithistory = 1
    readerrestartseconds = 5
    LogFile = /var/swap/keys/oscam.log
    #usrfile = /var/keys/oscam_usr.log
    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1
    [webif]
    httpport = 8888
    httpuser = root
    httppwd = oscam
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    oscam.user
    [account]
    user = hans
    pwd = wurst
    group = 1
    au = 1
    caid = 0D05

    Auf Clienten die CCcam.cfg
    C: meine.dyndns.org 12000 hans wurst

    CCcam läuft auf Clienten.

    Router Portweiterleitung aktiviert.

    Router Clienten keine Portfreigabe/Weiterleitung aktiviert.

    Intern mit IP eingetragen, läuft ein Client.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.388
    Zustimmungen:
    23.804
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Hallo Heugalel,

    da wir hier dieses ranhängen nicht mögen, hab ich die dein eigenes Thema verpasst.

    Mlg piloten
     
    #2
  4. Honza
    Offline

    Honza Ist oft hier

    Registriert:
    10. September 2012
    Beiträge:
    117
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Schon Deine aktuelle IP mit Dyndns abgegleichen?

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #3
  5. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Ja stimmt überein.
     
    #4
  6. Honza
    Offline

    Honza Ist oft hier

    Registriert:
    10. September 2012
    Beiträge:
    117
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    ... den Client Resi "hans - wurst" versuchst Du jetzt auch nicht im Home-CS über DynDns zu verbinden? Das geht nämlich nicht. Im Home-CS nur über IP!
     
    #5
  7. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Nein, war nur zum Testen. Hans Wurst versucht über DynDns sich zu verbinden.
     
    #6
  8. w33dburner
    Offline

    w33dburner Ist gelegentlich hier

    Registriert:
    16. April 2009
    Beiträge:
    34
    Zustimmungen:
    15
    Punkte für Erfolge:
    8
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    OScam läuft? Start-Log mal anhängen, um auszuschließen, dass zB das Portbinding nicht klappt, da der Port evtl schon belegt ist.

    Wenn es intern läuft, liegt der Verdacht nahe das es evtl an der Portweiterleitung liegt? Teste es mal =>

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #7
  9. Honza
    Offline

    Honza Ist oft hier

    Registriert:
    10. September 2012
    Beiträge:
    117
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Deine Antwort kann ich ich beide Richtungen verstehen.
    Also hans-wurst ist NICHT in Home-CS, sondern steht ausserhalb (Inet-CS) und versucht über Dyndns sich zu verbinden.
     
    #8
  10. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Ja, hatte den Namen und PW zum testen im Home ausprobiert und jetzt meinem Clienten gegeben.


    "Your ISP is not blocking port 12000"
     
    Zuletzt von einem Moderator bearbeitet: 4. April 2013
    #9
  11. w33dburner
    Offline

    w33dburner Ist gelegentlich hier

    Registriert:
    16. April 2009
    Beiträge:
    34
    Zustimmungen:
    15
    Punkte für Erfolge:
    8
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Dann hast du wohl einen anderen Test genutzt, denn die Ausgaben sehen wie folgt aus(wobei A.B.C.D natürlich für deine IPv4-Addy steht):

    Port nicht erreichbar:

    Code:
    A.B.C.D isn't responding on port 12000
    Port erreichbar:

    Code:
    [COLOR=#ff0000]A.B.C.D is responding on port 12000 (entextxid).[/COLOR]
    Da es lokal läuft, kannste das mit dem Portbinding-Problem ignorieren(hast du ja bereits gemacht, da kein Start-Log geliefert)

    Also zum testen kannste auch einen lokalen Client per Dyn-Addy anbinden, wenn das nicht geht, ist das Problem ja erkannt.
     
    #10
  12. Honza
    Offline

    Honza Ist oft hier

    Registriert:
    10. September 2012
    Beiträge:
    117
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Bitte noch im OScam WebIf unter Configuration - WebIf - Http save full config: NO setzen (fast ganz unten zu finden).
    Hiermit werden nur die gesetzen Confs in die Conf eingetragen und nicht alle. oscam.conf wird dann übersichtlicher.
    Wenn Du das umgestellt hast, Neustart und erneut logs, und alle confs (.conf / .user / .server).
     
    #11
  13. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Hier dein Link.
    isn't responding on port 12000 (entextxid).

    "Lokalen Client per Dyn-Addy anbinden"? verstehe ich nicht ganz, kannst du es mir bitte mal erklären (Beispiel).
     
    #12
  14. w33dburner
    Offline

    w33dburner Ist gelegentlich hier

    Registriert:
    16. April 2009
    Beiträge:
    34
    Zustimmungen:
    15
    Punkte für Erfolge:
    8
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Das ist die Erklärung, die Portweiterleitung ist nicht aktiv/korrekt.

    Einen Receiver von dir im LAN nicht per IP an deinen Server verbinden, sondern deine Dyn-Adresse verwenden.
    Das ganze wird aber erst funktionieren, wenn du das Portforwarding an deinem Router richtig eingestellt hast.
     
    #13
  15. heugabel
    Offline

    heugabel Ist oft hier

    Registriert:
    5. Dezember 2008
    Beiträge:
    179
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    log webif
    1970/12/12 20:00:19 0 s starting thread log_list_thread
    1970/12/12 20:00:19 0 s log_list_thread thread started
    1970/12/12 20:00:19 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #7965 (sh4-linux)
    1970/12/12 20:00:19 0 s version=1.20-unstable_svn, build #7965, system=sh4-linux, nice=-1
    1970/12/12 20:00:19 0 s client max. idle=120 sec, debug level=0, filter_sensitive=1
    1970/12/12 20:00:19 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    1970/12/12 20:00:19 0 s client timeout=7000 ms, fallback timeout=3000 ms, cache delay=120 ms
    1970/12/12 20:00:19 0 s The current system time is smaller than the build date (Dec 15 2012). Waiting up to 60 seconds for time to correct
    2013/04/04 20:29:41 0 s services reloaded: 0 services freed, 19 services loaded, rejected 0
    2013/04/04 20:29:41 0 s userdb reloaded: 4 accounts loaded, 0 expired, 0 disabled
    2013/04/04 20:29:41 0 s signal handling initialized (type=sysv)
    2013/04/04 20:29:41 0 s 1485 service-id's loaded in 102ms
    2013/04/04 20:29:41 0 s ERROR: Cannot open file "/var/swap/keys/oscam.tiers" (errno=2 No such file or directory)
    2013/04/04 20:29:41 0 s 912 provid's loaded
    2013/04/04 20:29:41 0 s ERROR: Cannot open file "/var/swap/keys/oscam.guess" (errno=2 No such file or directory)
    2013/04/04 20:29:41 0 s ERROR: Cannot open file "/var/swap/keys/oscam.whitelist" (errno=2 No such file or directory)
    2013/04/04 20:29:41 0 s ERROR: Cannot open file "/var/swap/keys/oscam.cacheex" (errno=2 No such file or directory)
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s monitor: disabled
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s camd33: disabled
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s camd35: disabled
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s cs378x: disabled
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s newcamd: disabled
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s cccam: initialized (fd=4, port=12000, crypted)
    2013/04/04 20:29:41 0 s Starting listener 0
    2013/04/04 20:29:41 0 s csp: disabled
    2013/04/04 20:29:41 0 s starting thread http
    2013/04/04 20:29:41 0 s http thread started
    2013/04/04 20:29:41 0 s starting thread reader check
    2013/04/04 20:29:41 0 s reader check thread started
    2013/04/04 20:29:41 0 s starting thread check
    2013/04/04 20:29:41 0 s check thread started
    2013/04/04 20:29:41 0 s orf [mouse] creating thread for device /dev/ttyUSB0
    2013/04/04 20:29:41 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/04/04 20:29:41 0 s waiting for local card init
    2013/04/04 20:29:41 56F0C8 h HTTP Server listening on port 8888
    oscam.user
    [account]
    user = hans
    pwd = wurst
    group = 1
    au = 1
    caid = 0D05
    uniq = 0
    oscam.server
    [reader]
    enable = 1
    label = ORF
    protocol = mouse
    device = /dev/ttyUSB0
    emmcache = 1,1,2
    detect = CD
    group = 1
    caid = 0D05
    mhz = 368
    cardmhz = 368
    smargopatch = 1
    ins7e11 = 15
    ndsversion = 2

    Wuste ich nicht, dass ich mich mit meiner eigenen DynDns mit eigenen Clienten verbinden kann.


    Router:
    Bei PortMapping Eintrag: IP Box 12000 12000 TCP und aktiviert.
     
    Zuletzt von einem Moderator bearbeitet: 5. April 2013
    #14
  16. w33dburner
    Offline

    w33dburner Ist gelegentlich hier

    Registriert:
    16. April 2009
    Beiträge:
    34
    Zustimmungen:
    15
    Punkte für Erfolge:
    8
    AW: CCcam Client bekommt keine Verbindung zum OScam Server

    Der Eintrag scheint ja, wenn die IP stimmt, richtig zu sein. Evtl braucht dein Router einen Neustart, damit er die Regel annimmt?!

    Da der Test ja nicht erfolgreich war, ist das definitiv die(eine) Ursache. Starte den Router mal neu, ist einen Versuch wert.
     
    #15
    heugabel gefällt das.

Diese Seite empfehlen