Digital Eliteboard

Registrieren dich noch heute kostenloses um Mitglied zu werden! Sobald du angemeldet bist, kannst du auf unserer Seite teilnehmen, indem du deine eigenen Themen und Beiträge erstellst und dich über deinen eigenen Posteingang mit anderen Mitgliedern unterhalten kannst! Zudem bekommst du Zutritt zu Bereiche, welche für Gäste verwert bleiben

Office 2016 Suche Excel Formel

Phantom

Administrator
Mitarbeiter
Mitglied seit
5. Juli 2007
Beiträge
39.310
Gefällt mir
20.581
Punkte
163
#1
Moin. Ich suche eine Excel Formel die folgendes für mich macht.

Ich habe 2 Blätter. Auf Blatt 1 sind B2 bis B1000 habe ich Zahlen. Gleich daneben steht ein Status. Ich habe in Blatt 2 die selben Zahlen nur durcheinander und weit aus mehr wie auf Blatt 1. Dazu ist auf Blatt 2 der Status immer aktuell.

Ich möchte jetzt den Status von Blatt 2 in Blatt 1 übertragen.

Dazu soll auf Blatt 1 nur die Zelle B2 mit Blatt 2 B:B verglichen werden. WENN eine Zelle gleich ist, soll von Blatt 2 D:D der wert ausgegeben werden. Dieser muss dann aber auch aus der reihe kommen, wo der treffer war.
 
Thread Starter
OP
Phantom

Phantom

Administrator
Mitarbeiter
Mitglied seit
5. Juli 2007
Beiträge
39.310
Gefällt mir
20.581
Punkte
163
#3
Das habe ich schon versucht. Keine ahnung warum es nicht will aber als ausgabe komm NV Nicht vorhanden.

=SVERWEIS(B2;'Status Import'!1:1048576;7;FALSCH)
 

szonic

MFC
Mitarbeiter
Mitglied seit
4. März 2009
Beiträge
10.536
Gefällt mir
8.680
Punkte
163
#5
Habe es gerade erst gelesen, aber Du hast es ja gelöst.
Die Matrix war Dein Problem, bzw. die fehlende Matrix.
Gleich merken für das nächste Mal. :-)
 
Thread Starter
OP
Phantom

Phantom

Administrator
Mitarbeiter
Mitglied seit
5. Juli 2007
Beiträge
39.310
Gefällt mir
20.581
Punkte
163
#6
Keine sorge, ich bin zwar damit fertig, aber jetzt kommt das nächste.Ich will eine Suche in einer neuen Tabelle erstellen mit ein Suchfeld. Das klappt zwar, aber ich kann immer nur ein Ergebnis listen lassen.

Im moment habe ich es so
=SVERWEIS($C$7;Aufträge;SPALTE(A9);0)

C7 ist hierbei das suchfeld. Das ganze habe ich über mehrere zeilen. Was aber wenn ich mehr mehr als ein Treffer vorhanden ist
 
Thread Starter
OP
Phantom

Phantom

Administrator
Mitarbeiter
Mitglied seit
5. Juli 2007
Beiträge
39.310
Gefällt mir
20.581
Punkte
163
#8
Den spass hatte ich schon ganz vergessen :) Deine vorlage ist sehr gut, etwas Bearbeitung und dann sollte das ganze passen.
 
Mitglied seit
5. November 2012
Beiträge
795
Gefällt mir
1.660
Punkte
143
#9
Aufpassen: Formel in D2 ist die erste Fundstelle, D3 bezieht sich dann auf D2; D4 auf D3 usw. Formeln sind also unterschiedlich. Ab D3 kannste aber runterkopieren.
 

axel

Moderator
Mitarbeiter
Mitglied seit
9. September 2011
Beiträge
9.762
Gefällt mir
28.734
Punkte
163
#10
Hi,

je nachdem wieviel das wird - Datenbank mit Access. ;)

Gruß

Gesendet von meinem SM-G920F mit Tapatalk
 

Oben