Digital Eliteboard - Das große Technik Forum

Registriere dich noch heute kostenloses um Mitglied zu werden! Sobald du angemeldet bist, kannst du auf unserer Seite aktiv teilnehmen, indem du deine eigenen Themen und Beiträge erstellst und dich über deinen eigenen Posteingang mit anderen Mitgliedern unterhalten kannst! Zudem bekommst du Zutritt zu Bereiche, welche für Gäste verwehrt bleiben

  • Derzeit stellt SKY die Verschlüsselung um, wonach alle V13 Karten nicht mehr hell werden. Dies nutzen derzeit vermehrt Betrüger aus, welche euch überzeugend mitteilen, dass es eine Lösung gibt. Diese Lösung kostet Geld, welches Ihr am besten mit Bitcoin überweisen möchtet. Von dem Betrüger werdet Ihr im Anschluss nix mehr hören. Wenn es eine Lösung gibt, werden wir euch darüber informieren!!!!!

Newcamd-Client mit Oscam funktioniert nicht

wecker123

Newbie
Registriert
3. September 2012
Beiträge
24
Punkte Reaktionen
2
Erfolgspunkte
3
Hallo,

Ich habe eine Nline (von einem Nicht-Linux Receiver als Newcamd-Server) die in meinem Client mit CCcam hell ist
(Alles beispielhafte, abgeänderte persönliche Daten wie IP, Port, User, Passwort)
N: 192.168.1.20 12000 client pass 01 02 03 04 05 06 07 08 09 10 11 12 13 14

Aber in der OSCam will es nicht klappen. Dabei habe ich alles genauso übertragen. Da würde ich gerne wissen, warum/ob die OSCam damit nicht zurecht kommt. Der Receiver und die Softcams selber laufen einwandfrei.

im Webif steht unter dem erstellten Reader "newcamdproxy" Status: CONNECTED und bei dem dvbapi-User in der gleichen Spalte: OK und davor not found 0ms (LB Value)

falls es eigentlich gehen sollte, dazu meine (minimalen) Configs und der log
oscam.conf:
[global]
logfile = /usr/keys/oscam.log
nice = -1

[dvbapi]
enabled = 1
au = 1
user = api
boxtype = dreambox

[webif]
httpport = 81
httphelplang = de
httprefresh = 30
httpallowed = 192.168.0.0-192.168.254.254
oscam.server:
[reader]
label = newcamdproxy
protocol = newcamd
device = 192.168.1.20,12000
key = 0102030405060708091011121314
user = client
password = pass
keepalive = 1
group = 1
oscam.user:
[account]
user = api
au = 1
group = 1
oscam.dvbapi
P: 098C
I: 0
oscam.log:
(reader) newcamdproxy [newcamd] connecting to 192.168.1.20:12000
(newcamd) Newcamd Server: 192.168.1.20:12000 - UserID: 1
(newcamd) CAID: 098C - UA: 0000000000000000 - Provider # 1
(newcamd) Provider ID: 656667 - SA: 30627637
(ecm) api (098C@000000/0B5E/007B/98:9305D24B056CD0315C162DA6F81FEBBA): not found (179 ms) by newcamdproxy
(dvbapi) Demuxer 0 restarting decodingrequests after 0 ms with 1 enabled and 2 disabled ecmpids!
(dvbapi) Demuxer 0 trying to descramble PID 2 CAID 098C PROVID 000000 ECMPID 1A17 ANY CHID PMTPID 0060 VPID 00FF
(ecm) api (098C@000000/0B5E/007B/98:9305D24B056CD0315C162DA6F81FEBBA): not found (1 ms) by newcamdproxy
(dvbapi) Demuxer 0 restarting decodingrequests after 0 ms with 1 enabled and 2 disabled ecmpids!
(dvbapi) Demuxer 0 trying to descramble PID 2 CAID 098C PROVID 000000 ECMPID 1A17 ANY CHID PMTPID 0060 VPID 00FF
(ecm) api (098C@000000/0B5E/007B/98:9305D24B056CD0315C162DA6F81FEBBA): not found (1 ms) by newcamdproxy
(dvbapi) Demuxer 0 restarting decodingrequests after 0 ms with 1 enabled and 2 disabled ecmpids!
(dvbapi) Demuxer 0 trying to descramble PID 2 CAID 098C PROVID 000000 ECMPID 1A17 ANY CHID PMTPID 0060 VPID 00FF
(ecm) api (098C@000000/0B5E/007B/98:283A6E7AE5ECAB83395C9515A5FA8994): not found (1 ms) by newcamdproxy
Danke schon mal.
 

janni1

Moderator
Teammitglied
Registriert
3. Mai 2010
Beiträge
6.214
Punkte Reaktionen
8.543
Erfolgspunkte
383
AW: Newcamd-Client mit Oscam funktioniert nicht

Hi,
an den Configs ist erstmal kein Fehler zu entdecken.
Sieht aus als ob diese Sid am Server nicht verfügbar wäre.
Geht denn diese Sid in CCcam?

Gruß
janni1
 
OP
W

wecker123

Newbie
Registriert
3. September 2012
Beiträge
24
Punkte Reaktionen
2
Erfolgspunkte
3
AW: Newcamd-Client mit Oscam funktioniert nicht

Hi,
habe es gerade unter CCcam versucht (in der cfg steht nur die line, sonst nichts). Funktioniert auf dem gleichen Sender wie zuvor unter Oscam problemlos.
(auch unter einem anderen Client -PC mit Acamd als newcamd eingetragen - kann ich die SID erhellen).

Nur mit Oscam geht es komischerweise nicht. Ist vielleicht unter Oscam nicht nutzbar?

Gruß
 
Zuletzt bearbeitet:

Pilot

MFC
Teammitglied
Registriert
29. Mai 2008
Beiträge
31.776
Lösungen
2
Punkte Reaktionen
28.965
Erfolgspunkte
1.103
Ort
Deutschland
AW: Newcamd-Client mit Oscam funktioniert nicht

Hast du unter oscam irgendwelche filter eingebaute: services, whitelist?
Wenn ja zum Testen: loschen. oscam neu starten.

Klick mal beim Newcamd reader rechts auf das kleine i.
Dort müssten die Caids aufgelistet sein, die geliefert werden
 
OP
W

wecker123

Newbie
Registriert
3. September 2012
Beiträge
24
Punkte Reaktionen
2
Erfolgspunkte
3
AW: Newcamd-Client mit Oscam funktioniert nicht

Hi, habe eigentlich nur die gepostetenen Dateien im Oscam Ordner dringelassen. Beim Neustart wird dann noch oscam.ccache und oscam.srvid2 (leer) erstellt.

Zum auslesen der Caids habe ich eine Frage. Wenn ich das richtig verstehe, dann ist das i in Webif im "Reiter" Readers (wo z.B. jetzt auch ECM 100%NOK steht) unter Actions, wo dann auch expire date für Karten steht? Das i fehlt bei mir im Newcamd-Reader. (dort sind von 6 Symbolen 4 angezeigt - edit, write EMM, Show Lb, delete)
 
Zuletzt bearbeitet:

janni1

Moderator
Teammitglied
Registriert
3. Mai 2010
Beiträge
6.214
Punkte Reaktionen
8.543
Erfolgspunkte
383
AW: Newcamd-Client mit Oscam funktioniert nicht

Hi,
das ist bei newcamd normal so.
Hab das bei mir mal mit deinen Configs soweit nachgestellt und es funktioniert bei mir.

Poste bitte mal die Einträge, die du im WebIf unter Files -> oscam.version findest.

Gruß
janni1
 
OP
W

wecker123

Newbie
Registriert
3. September 2012
Beiträge
24
Punkte Reaktionen
2
Erfolgspunkte
3
AW: Newcamd-Client mit Oscam funktioniert nicht

ok Danke für das ausprobieren. Wenn du mit den geposteten Configs erfolg hattest, liegts es nicht an den (geschriebenen) Configs, sondern eher an meiner Oscam. (oder am Server der kein Oscam verträgt?)

desweiteren

oscam.version ist:
Unix starttime: 1454077809
Starttime: 29.01.2016 15:30:09
Version: oscam-1.20-unstable_svn-r10998
Compiler: mipsel-openpli40-linux-gnu-libusb
Box type: osmini (generic)
TempDir: /tmp/.oscam
ConfigDir: /usr/keys/oscam_atv/
WebifPort: 81

Web interface support: yes
LiveLog support: yes
jQuery support intern: yes
Touch interface support: yes
SSL support: no
DVB API support: yes
DVB API with AZBOX support: no
DVB API with MCA support: no
DVB API with COOLAPI support: no
DVB API with STAPI support: no
DVB API with STAPI5 support: no
DVB API read-sdt charsets: no
Irdeto guessing: yes
Anti-cascading support: yes
Debug mode: yes
Monitor: yes
Loadbalancing support: yes
Cache exchange support: yes
CW Cycle Check support: yes
LCD support: no
LED support: no
Clockfix with realtime clock: yes
IPv6 support: no

camd 3.3x: no
camd 3.5 UDP: yes
camd 3.5 TCP: yes
newcamd: yes
CCcam: yes
CCcam share: yes
gbox: yes
radegast: yes
scam: yes
serial: yes
constant CW: yes
Pandora: yes
ghttp: yes

Reader support: yes

Nagra: yes
Irdeto: yes
Conax: yes
Cryptoworks: yes
Seca: yes
Viaccess: yes
NDS Videoguard: yes
DRE Crypt: yes
TONGFANG: yes
Bulcrypt: yes
Griffin: yes
DGCrypt: yes

cardreader_phoenix: yes
cardreader_internal_azbox: no
cardreader_internal_coolapi: no
cardreader_internal_sci: yes
cardreader_sc8in1: yes
cardreader_mp35: yes
cardreader_smargo: yes
cardreader_pcsc: no
cardreader_smartreader: yes
cardreader_db2com: yes
cardreader_stapi: no
cardreader_stapi5: no
cardreader_stinger: yes
ist vielleicht nicht ganz aktuell.

zudem habe ich mal in der Oscam einen 2 User (arbeitszimmer) erstellt und in der conf das newcamd-Protokoll angeschaltet, um die line weiterzugeben. (falls das irgendwas aussagt)
wenn ich mit dem besagten weiteren Client via Acamd verbinden will, klappt es nicht: "not found (1 ms) by newcamdproxy" bzw. "not able to decode" (Direkt von Acamd zum Server klappt.)

Oscam Anzeige
2016/01/29 15:22:35 140455B2 c (newcamd) client connected to 13000 port
2016/01/29 15:22:35 140455B2 c (client) encrypted newcamd:13000-client 192.168.1.21 granted (arbeitszimmer, au=auto (1 reader))
2016/01/29 15:22:35 140455B2 c (newcamd) user arbeitszimmer authenticated successfully (ACamd)
2016/01/29 15:22:35 140455B2 c (newcamd) AU disabled for user arbeitszimmer
2016/01/29 15:23:13 240AB9D2 c (newcamd) client connected to 13000 port
2016/01/29 15:24:18 240AB9D2 c (client) anonymous disconnected from 192.168.1.21
2016/01/29 15:24:28 17BC503A c (newcamd) client connected to 13000 port
2016/01/29 15:24:41 17BC503A c (client) encrypted newcamd:13000-client 192.168.1.21 granted (arbeitszimmer, au=auto (1 reader))
2016/01/29 15:24:41 17BC503A c (newcamd) user arbeitszimmer authenticated successfully (ACamd)
2016/01/29 15:24:41 17BC503A c (newcamd) AU disabled for user arbeitszimmer
2016/01/29 15:24:41 1E02B5BA p (reader) 192.168.1.20: resolved ip=192.168.1.20
2016/01/29 15:24:41 1E02B5BA p (reader) newcamdproxy [newcamd] connecting to 192.168.1.20:12000
2016/01/29 15:24:41 1E02B5BA p (newcamd) Newcamd Server: 192.168.1.20:12000 - UserID: 1
2016/01/29 15:24:41 1E02B5BA p (newcamd) CAID: 098C - UA: 0000000000000000 - Provider # 1
2016/01/29 15:24:41 1E02B5BA p (newcamd) Provider ID: 656667 - SA: 30627637
2016/01/29 15:24:41 17BC503A c (ecm) arbeitszimmer (098C@000000/0CEB/0025/98:46EB445BAE5ABEFF1E5DD4FE8F888E3A): not found (176 ms) by newcamdproxy - AXN
2016/01/29 15:24:41 17BC503A c (ecm) arbeitszimmer (098C@000000/0CEB/0025/98:46EB445BAE5ABEFF1E5DD4FE8F888E3A): not found (1 ms) by newcamdproxy - AXN
2016/01/29 15:24:41 17BC503A c (ecm) arbeitszimmer (098C@000000/0CEB/0025/98:AEFD4C7EAE5D411D6DCA61BE3E478F35): not found (1 ms) by newcamdproxy - AXN
Acamd Anzeige
15:23:47.424: Ch: 98 - AXN Action (deu)
15:23:47.424: Programm crc: DBFED19B
15:23:47.599: Incomming PackageSize [188]
15:23:47.759: PMT: ACamd_PMT.txt, search, not found PMT=0062 (AND SID=0025)
15:23:47.760: 0x0062 0x0025 0x098C 0x00000000 0x1A25 0x1008 11111110
15:23:47.806: Login attemp (1)
15:23:47.807: connecting to 192.168.1.22:13000/tcp (192.168.1.22)
15:24:00.443: Newcamd 0: CaID=098c admin=0 srvUA=0000000000000000 provider 000000/0000000000000000
15:24:00.443: Newcamd: EMM disabled from config
15:24:00.634: Newcamd 0: ECM [1A25][098C/00000000] Pro (0.190)
15:24:00.634: Newcamd 0: ECM [1A25][098C/00000000] not able to decode
15:24:00.673: Newcamd 0: ECM [1A25][098C/00000000] Pro (0.016)
15:24:00.673: Newcamd 0: ECM [1A25][098C/00000000] not able to decode
15:24:00.696: Newcamd 0: ECM [1A25][098C/00000000] Pro (0.015)
15:24:00.696: Newcamd 0: ECM [1A25][098C/00000000] not able to decode
15:24:00.718: Newcamd 0: ECM [1A25][098C/00000000] Pro (0.016)
15:24:00.718: Newcamd 0: ECM [1A25][098C/00000000] not able to decode
 
Zuletzt bearbeitet:
Oben