1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Zum Ende der Seite springen [Problem] NewCS / Windows / Smargo Smardreader

Dieses Thema im Forum "CS Newcs" wurde erstellt von sev0n, 15. Januar 2009.

  1. sev0n
    Offline

    sev0n Ist gelegentlich hier

    Registriert:
    8. Januar 2009
    Beiträge:
    41
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Hallo,

    ich habe mit den Smargo USB-Reader besorgt, wie mir hier im Board geraten wurde und hab mich gleich ans Werk gemacht.

    Hab natürlich gleich Version 1.63 versucht und wurde leider enttäuscht. Da er irgendwie nich an die Schnittstelle kommt.

    Code:
    This is NewCS 1.63 - the New CardServer by the Butter-team..
    Compiled on Jan 14 2009 at 19:51:56
    Reading Config file from newcs.xml
    TCP-log password is enabled, set to: NewCSpwd
    TCP-log set to simple mode
    level: normal
    type: init
    output: console,tcp
    logger config: level 1 type 3 output 5
    Console log options: level 1 type 3
    TCP log options: level 1 type 3
    [ 17:40:04 ] [ Box detect ] Windows XP Build 2600
    [ 17:40:04 ] [ Config ] Option <blockc0> for device 0 (Phoenix Interface) not present, defaulting to
     NO
    [ 17:40:04 ] [ Config ] Option <crypto-special> for device 0 (Phoenix Interface) not present, defaul
    ting to NO
    [ 17:40:04 ] [ Config ] Pincode for device 0 (Phoenix Interface): 0000
    [ 17:40:04 ] [ Config ] COM1 ECM priority: round
    [ 17:40:04 ] [ httpd ] httpd-user: newcs, password: newcs, accesslevel: admin
    [ 17:40:04 ] [ EMM Cache ] Initialising dynamic Cache
    [ 17:40:04 ] [ ECM Cache ] Initialising dynamic Cache
    [ 17:40:04 ] [ Loader ] Starting Telnet on port 1001
    [ 17:40:04 ] [ Loader ] Started HTTP-server on port: 8080
    [ 17:40:04 ] [ Loader ] Reader type 2 on node COM1
    [ 17:40:04 ] [ Phoenix ] Opening device COM1
    [ 17:40:04 ] [ Phoenix ] Setting parity to ODD on node COM1
    [ 17:40:04 ] [ Phoenix ] Setting 1 Stop bit on node COM1
    [ 17:40:04 ] [ Phoenix ] Setting baud to 16457
    [ 17:40:05 ] [ ATR ] T=14  1etu=104.17us  Guardtime:17etu  WWT:9600etu
    [ 17:40:05 ] [ ATR ] Historical bytes: I R D E T O   A C S [03] [84] U [FF] [80]
    [ 17:40:05 ] [ Loader ] Init Irdeto card
    [ 17:40:05 ] [ Phoenix ] Setting parity to NONE on node COM1
    [ 17:40:05 ] [ Phoenix ] Setting 2 Stop bits on node COM1
    [ 17:40:05 ] [ Phoenix ] Setting baud to 9600
    [ 17:40:06 ] [ KeymaN ] Adding key 831921 type 0 on Provider 000000 for caid 1702 ID=0
    [ 17:40:06 ] [ KeymaN ] Adding key FFFFFF type 1 on Provider 000000 for caid 1702 ID=0
    [ 17:40:06 ] [ KeymaN ] Adding key FFFFFF type 1 on Provider 000001 for caid 1702 ID=1
    [ 17:40:06 ] [ KeymaN ] Skipping duplicate irdeto
    [ 17:40:06 ] [ KeymaN ] Adding key FFFFFF type 1 on Provider 000002 for caid 1702 ID=2
    [ 17:40:06 ] [ KeymaN ] Skipping duplicate irdeto
    [ 17:40:06 ] [ KeymaN ] Adding key FFFFFF type 1 on Provider 000003 for caid 1702 ID=3
    [ 17:40:06 ] [ KeymaN ] Skipping duplicate irdeto
    [ 17:40:07 ] [ Loader ] Card 1702 on port COM1 failed
    [ 17:40:07 ] [ Loader ] Starting Newcamd Server on port 34000
    [ 17:40:07 ] [ Newcamd ] Newcamd thread Server started on port 34000
    newcamd: main loop
    [ 17:40:12 ] [ Newcamd:34000 ] User dummy logged in, client: CCcam
    [ 17:40:12 ] [ Newcamd:34000 ] Connection from dummy to not-ready server!
    
    Die Version 1.18 funzt jedoch wunderbar.
    Das ganze mit der selben Config.
    Ich benutze diese hier

    Code:
    <?xml version="1.0"?>
    
    <newCSconfig>
    	<readers name="Phoenix">
    		<device>
    			<name>Phoenix Interface</name>
    			<type>phoenix</type>
    			<mhz>600</mhz>
    			<node>COM1</node>
    			<parity>odd</parity>
    			<reset>normal</reset>
    			<export>Yes</export>
    			<enabled>Yes</enabled>
    			<blocksa>No</blocksa>
    			<blockua>No</blockua>
    			<blockga>No</blockga>
    			<!-- <boxkey>0000000000</boxkey>  -->
    			<!-- <rsa>0000000000</rsa> -->
    			<PTShandshake>No</PTShandshake>
    			<carddetect>yes</carddetect>
    			<newcamd_port>34000</newcamd_port>
    			<autosid>Yes</autosid>
    			<Seca-PPV>no</Seca-PPV>
    			<pincode>0000</pincode>
    			<priority>round</priority>
    		</device>
    	</readers>
    	<radegastserver>
    			<enabled>No</enabled>
    			<port>16000</port>
    			<allow>
    				<hostname>localhost</hostname>
    			</allow>
    	</radegastserver>
    	<cache>
    			<emm>20</emm>
    			<ecm>-1</ecm>
    	</cache>
            <httpd>
    		<server> 
    			<port>8080</port>
    			<enabled>yes</enabled>
    		</server>
    		<user>
    			<name>newcs</name>
    			<password>newcs</password>
    			<accesslevel>admin</accesslevel>
    		</user>
    	</httpd>	
    	<debug>
    			<password>NewCSpwd</password>	
    			<level>normal</level>
    			<type>init</type>
    			<output>console,tcp</output>
    			<console_options>normal,init</console_options>
    			<tcp_port>1001</tcp_port>
    			<tcp_options>normal,init</tcp_options>
    	</debug>
    	<newcamdserver>
    			<enabled>Yes</enabled>
    			<name>newcs</name>
    			<deskey>01 02 03 04 05 06 07 08 09 10 11 12 13 14</deskey>
    			<user>
    			        <name>dummy</name>
    				<password>dummy</password>
    				<hostname>localhost</hostname>
    				<port>12000</port>
    				<au>on</au>
    				<sidoverride>off</sidoverride>
    				<spider>No</spider>
                                    <rate>2</rate>
    			</user>
    	</newcamdserver>
    </newCSconfig>
    

    Diese Version würde mir reichen, obwohl ich da das Webif doch vermisse, jedoch gibt die Version auf meinem Windows Server 2003 nach einigen Minuten immer einen kompletten Systemfreez. Ebenso auf einem Vista-Rechner.

    Hat jemand Erfahrung damit, und kann mir sagen, wie ich den NewCS auf meinem Server mit Windows Server 2003 zum laufen bringe?

    danke schonmal

    gruß
    sev0n
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. sev0n
    Offline

    sev0n Ist gelegentlich hier

    Registriert:
    8. Januar 2009
    Beiträge:
    41
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Zum Ende der Seite springen [Problem] NewCS / Windows / Smargo Smardreader

    Habe das ganze nun über ne VMWare laufen lassen, und dort Debian gestartet.
    Funktioniert wunderbar...

    siehe XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

    nur für den fall, das irgendwer eine ähnliche Konstruktion zuhause hat



    Keine Links zu anderen Foren Posten.
     
    #2
  4. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Zum Ende der Seite springen [Problem] NewCS / Windows / Smargo Smardreader

    Das ist auch klar das die Smargos nicht unter Windows laufen :). Diese sind nur für Linux gedacht und Dreambox.
     
    #3
  5. sev0n
    Offline

    sev0n Ist gelegentlich hier

    Registriert:
    8. Januar 2009
    Beiträge:
    41
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: Zum Ende der Seite springen [Problem] NewCS / Windows / Smargo Smardreader

    läuft aber mit winxp und newcs 1.13
    ohne probs...

    und bei anderen mit gepatchter newcs 1.62 sogar unter win server 2003

    ach ja, und der smargo wurde mir hier sogar empfohlen für windows zu nehmen

    siehe

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #4
  6. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Zum Ende der Seite springen [Problem] NewCS / Windows / Smargo Smardreader

    Meine Aussage bezog sich darauf was damit läuft. Unter Vista habe ich die Smargos nicht zum laufen bekommen. Wenn du dein PC ausschließlich als Server nutzen tust, dann sollte das ganze kein Thema sein.
     
    #5

Diese Seite empfehlen