1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst winSrv2008-NFS-Freigabe -> dm800se mount

Dieses Thema im Forum "DM 800se HD Clones" wurde erstellt von maether, 12. Juni 2013.

  1. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Liebe liebenden,

    es gibt zwar schon einige Einträge zum Thema NFS-Mount von Box zu Box oder von eingebauten Festplatten, die man auf einer anderen Box mounten will, aber zu meinem Problem habe ich noch kein Thema gefunden, deswegen dieses neue hier.

    Meine Hardware:

    Windows 2008 Server R2
    IP: 192.168.0.2
    NFS-Freigaben:
    192.168.0.2:/savings (für Aufnahmen)
    192.168.0.2:/tmp (für Timeshift)

    DM800se Clone (Wohnzimmer)
    IP: 192.168.0.8
    Image: newnigma2-dm800se-v3-3-2-ramiMAHER.nfi

    DM800se Clone (Schlafzimmer)
    IP: 192.168.0.9
    Image: newnigma2-dm800se-v3-3-2-ramiMAHER.nfi

    Was ich will klar:
    Beide Receiver sollen den 24/7 laufenden Windows-Server als HDD-Ersatz nutzen um dort Aufnahmen abzulegen. (Auch mit der Idee, dass Receiver1 aufnimmt und später auf Receiver2 geschaut wird)

    Die NFS-Freigaben auf dem Windowsserver laufen.
    Auf der DM800se habe ich es nun auf zwei Varianten probiert:
    Variante1: Einstellungen->System->Netzwerk->LAN->Freigabe-Manager->Freigabe-hinzufügen:

    (savings für Aufnahmen)
    [TABLE="width: 98%, align: center"]

    [TABLE="class: tableinborder, width: 100%"]
    [TR="class: smallfont"]
    [TD="class: tablecat, colspan: 2"]php:
    [TR="class: smallfont"]
    [TD="class: inposttable, align: right"]1: 2: 3: 4: 5: 6: 7:[/TD]
    [TD="class: inposttable, align: left"]Aktiv = aktivieren
    Lokaler Freigabename
    = savings
    Freigabetyp
    = NFS Freigabe
    Server IP
    = 192.168.0.2
    Server Freigabe
    = media/hdd/savings
    als HDD
    -Ersatz = ja
    Freigabeoptionen
    = rw,nolock,tcp

    [/TD]
    [/TR]
    [/TABLE]
    [/TD]
    [/TR]
    [/TABLE]

    und

    (tmp für timeshift)
    [TABLE="width: 98%, align: center"]

    [TABLE="class: tableinborder, width: 100%"]
    [TR="class: smallfont"]
    [TD="class: tablecat, colspan: 2"]php:
    [TR="class: smallfont"]
    [TD="class: inposttable, align: right"]1: 2: 3: 4: 5: 6: 7:[/TD]
    [TD="class: inposttable, align: left"]Aktiv = aktivieren
    Lokaler Freigabename
    = tmp
    Freigabetyp
    = NFS
    Freigabe Server IP
    = 192.168.0.2
    Server Freigabe
    = media/hdd/tmp
    als HDD
    -Ersatz = ja
    Freigabeoptionen
    = rw,nolock,tcp

    [/TD]
    [/TR]
    [/TABLE]
    [/TD]
    [/TR]
    [/TABLE]


    leider werden diese Freigaben weder als 'Festplatten' erkannt, noch kann ich unter Aufnahmepfaden irgendwas ändern um die Freigabe als Aufnahmepfad zu verwenden.

    Variante2:
    Mit Telnet auf die box verbunden, als root angemeldet und folgenden Befehl abgesetzt:

    [TABLE="width: 98%, align: center"]

    [TABLE="class: tableinborder, width: 100%"]
    [TR="class: smallfont"]
    [TD="class: tablecat, colspan: 2"]code:
    [TR="class: smallfont"]
    [TD="class: inposttable, align: right"]1: 2: 3:[/TD]
    [TD="class: inposttable, align: left"]mount -t nfs 192.168.0.2:/savings /media/hdd/savings/[/TD]
    [/TR]
    [/TABLE]
    [/TD]
    [/TR]
    [/TABLE]

    [TABLE="width: 98%, align: center"]

    [TABLE="class: tableinborder, width: 100%"]
    [TR="class: smallfont"]
    [TD="class: tablecat, colspan: 2"]code:
    [TR="class: smallfont"]
    [TD="class: inposttable, align: right"]1: 2: 3:[/TD]
    [TD="class: inposttable, align: left"]mount -t nfs 192.168.0.2:/tmp /media/hdd/tmp/[/TD]
    [/TR]
    [/TABLE]
    [/TD]
    [/TR]
    [/TABLE]

    Das mounten an sich hat funktioniert mit diesen zwei Befehlen, da ich per FTP auf der Box Dateien in den Ordnern gefunden habe, die ich zum Test auf dem Server in die Freigabeordner gelegt habe. Allerdings konnte ich in den Box-Settings wieder keine Pfade einstellen. Noch dazu weiß ich nicht, wie ich diese zwei Befehle quasi als automount absetzen kann, da sie nach jedem Box-Restart verloren gehen.

    Ich wäre Euch sehr verbunden, wenn Ihr mir helfen könntet, da ich nun schon einige Tage an diesem Thema sitze und langsam nicht mehr weiß, nach was ich googeln soll. Ich denke mein Problem ist irgendwas banales, an was ich gerade nicht denke.

    Vielen Dank im vorraus!
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Karl-Hein
    Offline

    Karl-Hein Elite Lord

    Registriert:
    1. Februar 2010
    Beiträge:
    14.037
    Zustimmungen:
    3.734
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Findet der Netzwerk/Netzwerkbrowser deinen freigegebenen PC Ordner !
     
    #2
  4. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Der netzwerkbrowser findet meinen winSrv2008, ja. Allerdings will er, wenn ich diesen markiere und auf OK klicke einen Benutzernamen incl. Passwort. Da geht es dann eher um eine normale Windows-Freigabe, oder?

    Was ich ja will ist eine NFS-Freigabe.
    Diese habe ich auch schon eingerichtet.

    Wenn ich auf den festgelegten Timeshiftpfad "/media/hdd/" (welchen ich btw nie ändern kann) diesen Telnet-Befehl:
    mount -t nfs 192.168.0.2:/tmp /media/hdd/
    absetze, kann ich die Timeshift-Funktion auch verwenden. Allerdings gehen diese Settings nach einem Receiver-Neustart wieder verloren.

    Das sagt mir zumindest, dass die NFS-Freigabe am Windows-Server richtig eingestellt ist.
    Nur auf der Dreambox komm ich nicht ganz klar damit.

    Ich will eine NFS-Freigabe automounten und die Dreambox diese als Festplatte erkennen lassen, damit ich auch meine Standard-Aufnahmepfade auf diese umstellen kann.

    Nur wie!?

    etc/enigma2/settings wird bei jedem Neustart quasi auf werkseinstellung zurück gesetzt.
    und die automount.xml ignoriert meine settings auch. :/
     
    #3
  5. Karl-Hein
    Offline

    Karl-Hein Elite Lord

    Registriert:
    1. Februar 2010
    Beiträge:
    14.037
    Zustimmungen:
    3.734
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Musst du nicht setzen, kannst du auch frei lassen !
     
    #4
  6. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Habe ich auch schon versucht. Egal ob ich Benutzername/passwort angebe oder nicht, der Server klappt nicht auf.
     
    #5
  7. Karl-Hein
    Offline

    Karl-Hein Elite Lord

    Registriert:
    1. Februar 2010
    Beiträge:
    14.037
    Zustimmungen:
    3.734
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Versuch mal den Freigabe Server/Ordner umzubenennen in "dreambox" !
     
    #6
  8. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    [​IMG]
    [​IMG]
    [​IMG]

    done...
    wie auf den Screenshots zu sehen, habe ich einen Ordner 'dreambox' sowohl als nfs- als auch als CIFs-Freigabe erstellt.
    im Netzwerkbrowser dann den Server ausgewählt, keine Benutzerdaten angegeben und trotzdem klappt sich nichts auf.

    - - - - - - - - - -

    Das hier ist dann der Netzwerkbrowser:
    [​IMG]

    - - - - - - - - - -

    Natürlich hatte ich den SVR2008 vorher mit OK aufklappen wollen, trotzdem bleibt das Bild so
     
    Zuletzt von einem Moderator bearbeitet: 13. Juni 2013
    #7
  9. Karl-Hein
    Offline

    Karl-Hein Elite Lord

    Registriert:
    1. Februar 2010
    Beiträge:
    14.037
    Zustimmungen:
    3.734
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Starte mal die Box neu !
    -----------------
    edit. Die Firewall sollte noch separat konfiguriert werden !
     
    Zuletzt bearbeitet: 13. Juni 2013
    #8
  10. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    ach, die starte ich quasi nach jedem minimalen setting komplett neu :)
    Hab sie gestern Abend sogar mal kurz neu geflasht um auszuschließen, dass ich irgendwas kaputt gesettet habe...

    Leider auch nach dem Neustart kein neues Bild :/
     
    #9
  11. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Am Image kann es auch nicht liegen, habe jetzt zwei andere ausprobiert und bei beiden das gleiche Problem.

    Es wird irgendein sau dummer Anwendungsfehler sein, aber fragt mich nicht welcher.
    Ich kenne mich normal mit Netzwerk gut aus, ein DAU-Fehler kann es also nicht sein... :/
     
    #10
  12. Karl-Hein
    Offline

    Karl-Hein Elite Lord

    Registriert:
    1. Februar 2010
    Beiträge:
    14.037
    Zustimmungen:
    3.734
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    AW: winSrv2008-NFS-Freigabe -> dm800se mount

    Naja ich sag mal auf Deinem 2008er Rechner einen Benutzer anlegen und ein Passwort zuweisen für die Dreambox !
    Und dann nochmal mit CIFS Mount versuchen !
     
    #11
  13. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    auch das habe ich schon probiert.
    einen Benutzer 'dreambox' angelegt und einen ordner für diesen benutzer mit schreib- und leserechten freigegeben.

    Wenn ich von meinem Notebook aus auf meinen Server zugreife mit \\srv2008, werde ich nach Benutzername/Passwort gefragt wo ich dann diesen angelegten Benutzer angebe. Dann sehe ich den freigegebenen Ordner.

    Wenn ich jedoch im Networkbrowser diese Benutzerinformationen angebe, klappt wieder nichts auf. :///

    was könnte ich denn noch vergessen haben?

    Hat denn keiner von Euch eine funktionierende NFS-Verbindung zwischen einer Dreambox und einem Windows-Server (oder ähnlichem), die er mit mir mal kurz durchkauen könnte?
     
    Zuletzt bearbeitet: 13. Juni 2013
    #12
  14. maether
    Offline

    maether Newbie

    Registriert:
    6. April 2013
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sodala, habe jetzt einfach mal ein Debian aufgesetzt und auf diesem einen NFS-Server installiert.
    Nun komme ich mit meinen Dreamboxen drauf.

    D.h. irgendwas im Windows 2008 blockiert den Netzwerkbrowser.
    Per Telnet kann ich zwar mounten, aber der Netzwerkbrowser kanns nicht.

    What ever, ich habe ja jetzt das Debian mit NFS-Server.

    Ich habe per FTP einen Film in die NFS-Freigabe gelegt und konnte ihn problemlos mit der DM800se öffnen.
    Komischerweise funktioniert aber das aufnehmen noch nicht.
    meine nfs-freigabe hat allerdings alle rechte auf der linux-kiste:

    mit einem ls -lisa command auf den ordner, in dem mein 'nfs' ordner liegt bekomme ich:
    Code:
    393351 4 drwxrwxrwx 2 nobody nogroup ... nfs
    was doch bedeutet, dass jeder vollen zugriff hat.

    Was könnte ich gerade vergessen haben?

    Ok, ich habe den Fehler gefunden:

    in der /etc/exports müssen folgende Zeilen stehen:

    Code:
    /var/www/nfs-verzeichnis IP-DER-BOX(rw,sync) IP-DER-ZWEITEN-BOX(ro,sync)
    
     
    Zuletzt von einem Moderator bearbeitet: 14. Juni 2013
    #13

Diese Seite empfehlen