1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Rasperry Boot und ttyUSB0

Dieses Thema im Forum "Raspberry Pi" wurde erstellt von FabTwo, 31. Juli 2013.

  1. FabTwo
    Offline

    FabTwo Ist gelegentlich hier

    Registriert:
    18. Juli 2013
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo ich habe ein Problem mit dem erkennen des Easymouse Cardreader nach dem Bootvorgang.
    Wenn ich den Rasperry starte und den Cardreader schon angeschlossen habe, dann ist unter /dev keine ttyUSB0 device hinterlegt. Aber wenn ich den Cardreader erst anschliesse wenn der Server schon läuft dann wird das device erstellt.

    Mein Problem ist, dass Oscam ja startet sobald der Raspberry bootet und so keinen Cardreader findet.
    Leider kenn ich mich auch kaum mit Linux aus und so kann ich nicht den Bootvorgang richtig kontrollieren.

    Im Oscam bekomme ich dann immer den folgenden Log:
    2013/07/31 12:27:05 0 s skyv13 [mouse] creating thread for device /dev/ttyUSB0
    2013/07/31 12:27:05 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/07/31 12:27:05 0 s waiting for local card init
    2013/07/31 12:27:05 1661318 h webif: decompressed 51323 bytes back into 152244 bytes
    2013/07/31 12:27:05 165F750 r skyv13 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2013/07/31 12:27:05 165F750 r skyv13 [mouse] Cannot open device: /dev/ttyUSB0

    Kann mir jemand irgendeinen Tip geben???
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. maxblank
    Offline

    maxblank Elite User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.658
    Zustimmungen:
    555
    Punkte für Erfolge:
    113
    Ort:
    @home
    AW: Rasperry Boot und ttyUSB0

    Hast du die Easymouse bereits an der Himbeere gehabt als du dein System installiert hast?

    Gib mal Folgendes in die Konsole ein:

    apt-get purge brltty
     
    #2
  4. FabTwo
    Offline

    FabTwo Ist gelegentlich hier

    Registriert:
    18. Juli 2013
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Rasperry Boot und ttyUSB0

    Ne ich hatte vorher ein Smargo an ihm dran.
    Habe ich eingegeben
    root@raspberrypi:~# apt-get purge brltty
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paket »brltty« ist nicht installiert, wird also auch nicht entfernt.
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 40 nicht aktualisiert.

    Glaube aber das es nichts gebracht hat
     
    #3
  5. iZz0s
    Offline

    iZz0s Freak

    Registriert:
    15. Juli 2009
    Beiträge:
    222
    Zustimmungen:
    3.053
    Punkte für Erfolge:
    93
    Beruf:
    IT-Systemelektroniker
    Ort:
    Köln
    AW: Rasperry Boot und ttyUSB0

    Ich hab momentan ein ähnliches Problem mit dem aktuellen Kernel, kannst du das reproduzieren?

    Hier mein Post:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #4
  6. FabTwo
    Offline

    FabTwo Ist gelegentlich hier

    Registriert:
    18. Juli 2013
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Rasperry Boot und ttyUSB0

    Also ich hab wohl mal zwischendurch auch die raspi-config aufgerufen, aber ich habe nichts geupdatet.
    Das kam bei mir jetzt gestern eigentlich relativ plötzlich.
    Vorher beim einrichten des Servers hat er immer den Reader erkannt und da muss man den Server ja mehrmals neustarten.

    Das Problem ist auch, dass ich rebooten kann aber das hilft bei mir nichts. Ich muss immer das USB Kabel rausziehen und wieder reinstecken nach dem Boot. Nur so erkennt er den Reader.
    Und der Server steht nicht neben mir und daher ist das rausziehen also auch keine Alternative.
     
    #5
  7. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.423
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Rasperry Boot und ttyUSB0

    @maxblank: Wenn britty installiert geweseb wäre, hätte es gar nicht funktioniert.
    Egal ob beim Booten angesteckt oder nicht.
     
    #6
    maxblank gefällt das.
  8. maxblank
    Offline

    maxblank Elite User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.658
    Zustimmungen:
    555
    Punkte für Erfolge:
    113
    Ort:
    @home
    AW: Rasperry Boot und ttyUSB0

    Da hast du leider Recht. War der Smargo bei der Installation angeschlossen?
     
    #7
  9. FabTwo
    Offline

    FabTwo Ist gelegentlich hier

    Registriert:
    18. Juli 2013
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Rasperry Boot und ttyUSB0

    Achso habe den Reader auch nicht irgendwie wissentlich in die udev oder per Serial verlinkt oder so (was immer das auch genau heisst ...)

    Weiß ich nicht mehr, war bisschen Havanna im Spiel
     
    #8
  10. maxblank
    Offline

    maxblank Elite User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.658
    Zustimmungen:
    555
    Punkte für Erfolge:
    113
    Ort:
    @home
    AW: Rasperry Boot und ttyUSB0

    Dann mache das mal. Du kannst Oscam auch so einstellen, dass es eine gewisse Zeit x auf den Reader wartet. Aber bei einem System-Reboot bringt es das ja auch nicht wirklich.
     
    #9
  11. FabTwo
    Offline

    FabTwo Ist gelegentlich hier

    Registriert:
    18. Juli 2013
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Rasperry Boot und ttyUSB0

    Ich weiß nicht ob ich daran schon scheiter.
    Hab das nach der Anleitung

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    probiert und das hat nichts geholfen
     
    #10
  12. iZz0s
    Offline

    iZz0s Freak

    Registriert:
    15. Juli 2009
    Beiträge:
    222
    Zustimmungen:
    3.053
    Punkte für Erfolge:
    93
    Beruf:
    IT-Systemelektroniker
    Ort:
    Köln
    AW: Rasperry Boot und ttyUSB0

    Wenn der Reader angeschlossen ist (nach dem Boot), du ihn jedoch über ttyUSB nicht ansprechen kannst ... bekommst du dann trotzdem mit " lsusb -v | grep iSerial" in der Konsole eine Serial angezeigt?
     
    #11
  13. maxblank
    Offline

    maxblank Elite User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.658
    Zustimmungen:
    555
    Punkte für Erfolge:
    113
    Ort:
    @home
    AW: Rasperry Boot und ttyUSB0

    Hast du IPC drauf?
     
    #12
  14. 0800555333
    Offline

    0800555333 Hacker

    Registriert:
    9. Juli 2013
    Beiträge:
    327
    Zustimmungen:
    367
    Punkte für Erfolge:
    0
    AW: Rasperry Boot und ttyUSB0

    das ist eigentlich egal da OScam immer wieder versucht den Reader anzusprechen


    FabTwo: Mach mal bitte folgendes:

    1) Fahr den Rpi herrunter und zieh Strom ab
    2) Schliess die eine Easymouse2 inkl. Karte direkt an einen der 2 USB Ports des Rpi's an
    3) Schliess den Rpi wieder an Strom an damit er hochfährt
    4) Melde dich auf der Konsole als root an und poste dann bitte die Ausgabe (Bitte in
    Code:
     ![/COLOR]) der folgenden Befehle:
    
    [B]more /var/log/dmesg[/B]
    (mit der leertaste (space) blättert er eine seite weiter, mit der q-Taste wird more beendet. wenn more nicht geht dann nimm less)
    
    [B]ls -la /dev | grep ttyUSB*[/B]
    [B]
    lsusb -v | grep iSerial [/B]
     
    #13
  15. maxblank
    Offline

    maxblank Elite User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.658
    Zustimmungen:
    555
    Punkte für Erfolge:
    113
    Ort:
    @home
    AW: Rasperry Boot und ttyUSB0

    Wenn du mich zitierst, dann bitte auch komplett und reiße es nicht aus dem Zusammenhang. Ich habe direkt drunter geschrieben, dass es wohl nix bringt, weil es das Problem bei einem Reboot gibt. Danke.
     
    #14
  16. 0800555333
    Offline

    0800555333 Hacker

    Registriert:
    9. Juli 2013
    Beiträge:
    327
    Zustimmungen:
    367
    Punkte für Erfolge:
    0
    AW: Rasperry Boot und ttyUSB0

    eh?
    kommentare zu deinen posts sind nicht erlaubt oder was wird das jetzt?

    wieso schreibst du dann überhaupt das sowas ginge wenn es denn aber gar nix bringt :emoticon-0112-wonde :emoticon-0179-headb

    könnten wir ja auch gleich dazu übergehen ihm zu raten dass er sich eine neue easymouse2 kaufen müsse, obwohl das schwachsinn is... :wacko1::wacko1:


    und wieso sollte ich dein kompletten post zitieren wenn ich aber nur auf den einen satz bezug nehmen wollte um zu verdeutlichen dass das in dem zusammenhang mit dem hier beabsichtigten vorhaben keine rolle spielt?
    oder muss man das neuerdings machen? ich wette dann kommt ein mod daher und entfernt das komplettzitat lol

    welchen unterschied würde es zudem machen ob man "waitforcards" einstellt oder oscam bereits von alleine ca. alle 5 sekunden versucht auf das device zu zugreifen? völlig egal ob systemstart oder reboot usw (na fällt dir auf wieso ich nicht alles gequotet hab?)



    naja, auf solche reaktionen, weil man auf aussagen anderer nicht antworten darf, kann ich auch verzichten - viel glück noch bei der lösungssuche
     
    #15
    hismastersvoice und jensebub gefällt das.

Diese Seite empfehlen