1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam startet, erkennt aber Reader nicht

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von hollis, 18. März 2013.

  1. hollis
    Offline

    hollis Ist gelegentlich hier

    Registriert:
    1. Januar 2008
    Beiträge:
    66
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    Moin Leute,

    habe ne s02 bisher per cccam lesen lassen, will aber auf oscam umsteigen. Leider folgender Fehler. Habe am smargo nichts geändert

    lt log:
    2013/03/18 19:44:16 944A1B8 r sky [smartreader] Wrong device format (/dev/ttyUSB0), it should be Device=bus:dev
    2013/03/18 19:44:16 944A1B8 r sky [smartreader] Cannot open device: /dev/ttyUSB0


    oscam server sieht folgendermaßen aus:
    [reader]
    label = Sky
    enable = 1
    protocol = smartreader
    device = dev/ttyUSB0
    services = Sky
    caid = 1702
    detect = cd
    mhz = 600
    cardmhz = 600
    ident = 1702:000000
    group = 1
    emmcache = 1,3,2
    ecmcache = 1
    #lb_weight = 100
    Kann jemand helfen?
     
    Zuletzt von einem Moderator bearbeitet: 19. März 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.897
    Zustimmungen:
    6.216
    Punkte für Erfolge:
    113
    AW: Oscam startet, erkennt aber Reader nicht

    Klar kann jemand helfen :dance3:
    Du hast im Log doch den Fehler stehen:
    ...it should be Device=bus:dev
    Geh mal per Telnet auf den Server und gib dann ein: cat /proc/bus/usb/devices
    In der Ausgabe ist weiter unten ein Block, wo was mit Vendor Argolis oder Maxdigital drinsteht.
    Oben in diesem Block steht Bus : 00x und Device : 00x.
    Diese beiden Werte überträgst Du in der oscam.server da hin -> device = 00x:00x
     
    #2
  4. dadonali
    Offline

    dadonali Spezialist

    Registriert:
    6. Oktober 2012
    Beiträge:
    525
    Zustimmungen:
    163
    Punkte für Erfolge:
    43
    AW: Oscam startet, erkennt aber Reader nicht

    hast du schonmal versucht die boxkey = 1122334455667788 noch mit einzufügen in deine oscam.server?
     
    #3
  5. hollis
    Offline

    hollis Ist gelegentlich hier

    Registriert:
    1. Januar 2008
    Beiträge:
    66
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam startet, erkennt aber Reader nicht

    Genauso steht es im log, aber der Pfad /proc/bus/usb/ ist leer, kein Ordner devices drin, deshalb zeigt er auch nichts an.
    Wie komme ich nun an die Infos bus und device?
     
    Zuletzt von einem Moderator bearbeitet: 18. März 2013
    #4
  6. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam startet, erkennt aber Reader nicht

    Hi,

    bei dem Device Eintrag sollte das Protocol Mouse sein.
    Code:
    protocol                      = mouse
    device                        = dev/ttyUSB0
    
    Gruß
    Bombadil
     
    #5
  7. hollis
    Offline

    hollis Ist gelegentlich hier

    Registriert:
    1. Januar 2008
    Beiträge:
    66
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam startet, erkennt aber Reader nicht

    ich habe doch aber einen smargo dran...
     
    #6
  8. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.897
    Zustimmungen:
    6.216
    Punkte für Erfolge:
    113
    AW: Oscam startet, erkennt aber Reader nicht

    Versuche es mal damit im Telnet:
    lsusb -v
    Da bekommst Du mehrere Möglichkeiten.
    Müßte der 4. Eintrag sein.
    Die beiden Einträge mal testen, ob der Smargo darauf anspringt.

    Übrigens: wenn Du im o.g. Pfad nix findest, ist schon das ein Fehler.
    Was hast Du als Server?
     
    #7
  9. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam startet, erkennt aber Reader nicht

    Hi,

    den Smargo kannst du sehr wohl über das mouse protocol ansprechen. Dann eben so wie du es im Device angegeben hast. Im Smartreader Protocol würde der eintrag dann so ausehen.
    Code:
    protocol                      = smartreader
    device                        = Serial:Reader A4908D0
    
    oder so
    Code:
    protocol                      = smartreader
    device                        = Serial:12345678
    
    oder so gehts auch (glaube ich zumindest)
    Code:
    protocol                      = smartreader
    device                        = 002:003
    
    Gruß
    Bombadil
     
    #8
  10. hollis
    Offline

    hollis Ist gelegentlich hier

    Registriert:
    1. Januar 2008
    Beiträge:
    66
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam startet, erkennt aber Reader nicht

    jo, kommt ein ellenlanger Text, aber wo steht da ein bus oder device?
    Ich habe einen Igel mit IPC 11.5. CCcam läuft ja auch super mit den folgenden Einstellungen:
    SERIAL READER : /dev/ttyUSB0 smartreader+
    SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB0 6000000

    hollis
     
    #9
  11. krane
    Offline

    krane Ist oft hier

    Registriert:
    25. November 2008
    Beiträge:
    169
    Zustimmungen:
    7
    Punkte für Erfolge:
    18
    AW: Oscam startet, erkennt aber Reader nicht

    Hallo Hollis,versuche mal den Smartreader fest zuverlinken( geht auch über den Gerätemanager um die Nummer raus zu kriegen)und es gibt auch viele Beiträge hier im Forum,wenn nicht mal Googel.Den Reader ist bei mir so eingestellt :
    [reader]
    label = skyde
    protocol = smartreader
    device = Serial:Reader xxxxxxx
    services = hdplus,skyfullhd,skyselect,orfcw,austriasat
    smargopatch = 1
    caid = 1702,1833
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    Bei mier läüft alles über die Fritzbox 7270v3...................Gruss Krane:emoticon-0111-blush
     
    Zuletzt von einem Moderator bearbeitet: 19. März 2013
    #10
  12. skywalkera
    Offline

    skywalkera Stamm User

    Registriert:
    13. Februar 2010
    Beiträge:
    1.093
    Zustimmungen:
    224
    Punkte für Erfolge:
    63
    Ort:
    Sachsen
    AW: Oscam startet, erkennt aber Reader nicht

    dann richte doch erstmal eine udev regel (unter system und dort bei manager auf der seite die dann kommt ganz nach unten dort steht dein smargo und dem gibst du einfach nen namen) ein und beim reader unter device gibst du dann nur noch den udev namen an.
     
    #11
  13. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.897
    Zustimmungen:
    6.216
    Punkte für Erfolge:
    113
    AW: Oscam startet, erkennt aber Reader nicht

    Dazu braucht er aber zuerst die Serial des Readers.
    Er hat aber nix unter /proc/bus/usb/devices zu stehen.
     
    #12
  14. hollis
    Offline

    hollis Ist gelegentlich hier

    Registriert:
    1. Januar 2008
    Beiträge:
    66
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam startet, erkennt aber Reader nicht

    für heute danke ich euch erstmal, ich mache morgen weiter
     
    #13
  15. Kermit
    Offline

    Kermit Guest

    AW: Oscam startet, erkennt aber Reader nicht

    Hi,

    wenn OScam auf einem Igel läuft, dann kann er auch über das WebIf von OScam die passende iSerial3 heraus finden.
    Hierzu den Reiter READERS anklicken und dann gibt es Button "Scan USB". Wenn nur ein Reader angeschlossen ist, dann kann man recht einfach die entsprechende Nummer finden. Dies setzt aber einen Smargo mit Firmware 1.04 oder 1.05 voraus. Bei der Firmware 1.07 wird die iSerial3 über das Konfigtool des Smargo gesetzt.

    Grüße

    Kermit
     
    #14
  16. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.924
    Zustimmungen:
    16.213
    Punkte für Erfolge:
    113
    AW: Oscam startet, erkennt aber Reader nicht

    wenn er einen Igel mit IPC hat gehts auch über das IPC WebIf, unter System ---> Manager, ganz unten IPC UDEV, steht die Serial und kann man einen UDEV namen vergeben
     
    #15

Diese Seite empfehlen