1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam - Mehr als ein Reader - Clienten weg!

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Jar Jar Bings, 14. September 2013.

  1. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    Hallo Leute

    Ich bin am Ende mit meinen Nerven und ich blicke nicht mehr durch....
    In den letzten Tagen habe ich auf meinem Debian Server mit eurer Hilfe meine 4 Reader eingerichtet.
    Einen nach dem anderen.

    Ich hab einen Reader konfiguriert, lief der, habe ich ihn dann mit einem # in der oscam.server ausgekreutzt.
    Nun, als alle 4 liefen, dachte ich, ich nehm mal die # weg.

    Jetzt ist es so... Wenn mehr als ein Reader in der config stehen, können sich keine Clienten mehr verbinden.
    Das heißt, sie werden im WebIF gar nicht mehr angezeigt.

    Lösche ich alle Reader bis auf einen aus der config Datei heraus, starte Oscam neu, tauchen die Clienten wieder auf..
    Ich weiß mir nicht mehr zu helfen und ja... keine Ahnung...

    oscam.config

    Code:
    [global]
    logfile                       = /var/log/oscam.log
    maxlogsize                    = 200
    nice                          = -1
    preferlocalcards              = 1
    fallbacktimeout               = 2500
    
    
    [cccam]
    port                          = 19740
    version                       = 2.3.0
    reshare                       = 2
    # ignorereshare                 = 0
    
    
    [webif]
    httpport                      = 16002
    httpuser                      = jarjar
    httppwd                       = testPW
    httphelplang                  = de
    httprefresh                   = 10
    httpallowed                   = 0.0.0.0-192.168.255.255
    aulow                         = 120
    
    
    oscam.server
    Code:
    [reader]
    label = ORFIrdeto
    enable = 1
    protocol = mouse
    detect = cd
    device = /dev/orf
    group = 1
    caid = 0648
    mhz = 600
    cardmhz = 600
    force_irdeto = 1
    rsakey = DF********************D
    boxkey = 1**********************8
    blockemm-unknown = 1
    blockemm-u = 1
    deprecated = 1
    emmcache = 1,3,2
    
    
    [reader]
    label                         = hdplus
    enable                        = 1
    protocol                      = mouse
    device                        = /dev/hdplus
    #services                      =
    smargopatch                   = 1
    caid                          = 1830
    rsakey = BF*************************D5
    boxkey = A******************C
    detect                        = cd
    #mhz                           = 357
    #cardmhz                       = 368
    ident                         =
    group                         = 1
    emmcache                      = 1,3,2
    ecmcache                      = 1
    lb_weight
    
    
    [reader]
    label                         = Sky2
    protocol                      = mouse
    device                        = /dev/sky2
    caid                          = 1702,1833
    boxid                         = 12345678
    detect                        = cd
    mhz                           = 600
    cardmhz                       = 600
    ident                         = 1702:000000;1833:000000
    group                         = 2
    emmcache                      = 1,3,2
    
    
    [reader]
    label                         = Sky
    protocol                      = mouse
    device                        = /dev/sky
    caid                          = 1702,1833
    boxid                         = 12345678
    detect                        = cd
    mhz                           = 600
    cardmhz                       = 600
    ident                         = 1702:000000;1833:000000
    group                         = 1
    emmcache                      = 1,3,2
    
    oscam.user
    Code:
    [account]
    user                          = jarjar
    pwd                           = jarartestpw
    group                         = 1
    au                              = 1
    

    Ich kann oder darf wie gesagt nur mehr einen einzigen Reader in der Config angeben, sonst ist mein Test Client weg :(
    Habe alles schon mehrmals neu gestartet, also richtig neu gestartet, sprich Server herunter gefahren und wieder gestartet.
    Ebenfalls die Dreambox, das Netzwerk usw....

    Bitte um Hilfe
    Vielen vielen Dank!
     
    Zuletzt bearbeitet: 15. September 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. slasch
    Offline

    slasch Ist gelegentlich hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    39
    Zustimmungen:
    13
    Punkte für Erfolge:
    8
    Geschlecht:
    männlich
    Ort:
    Pfälzer Bub
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Hi jar jar bings

    schau mal bei group,du hast 3 mal die 1
     
    #2
  4. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Hi,

    poste doch bitte ein Log mit dem Erkennen der Reader.

    Ist dieses Problem gelöst?

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    oder gehört es noch dazu. Wenn ja, dann lege ich die beiden Threads zusammen. Zwei Threads mit dem gleichen Problem ist kontraproduktiv

    Grüße
    Bombadil
     
    #3
  5. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Nein, das ist ein anderes Problem, auf das ich noch zurück kommen werde.

    slash, unabhängig davon, besteht das selbe Problem.
    Das waren meine einzelnen Configs, die ich angepasst habe, bzw. als ich immer nur einen Reader dran hatte.
    In der jetzigen config stehen sie von 1 bis 4, aber mein Client ist trotzdem weg :(

    Sobald ich mehr als einen Reader hinzufüge, wird mein Test Client im WebIF als offline angezeigt.

    Log:
    Code:
    2013/09/14 17:43:06  A0428E0 r Sky2 [mouse] Cannot open device: /dev/sky2         
            2013/09/14 17:43:06        0 s Sky [mouse] creating thread for device /dev/sky         
            2013/09/14 17:43:06  A044A68 r Sky [mouse] ERROR: Opening device /dev/sky (errno=2 No such file or directory)         
            2013/09/14 17:43:06  A044A68 r Sky [mouse] Cannot open device: /dev/sky         
            2013/09/14 17:43:06        0 s loadbalancer: can't read from file /tmp/.oscam/stat         
            2013/09/14 17:43:06        0 s waiting for local card init         
            2013/09/14 17:43:06  A03E5D0 r ORFIrdeto [mouse] Reader initialized (device=/dev/orf, detect=cd, mhz=600, cardmhz=600)         
            2013/09/14 17:43:07  A03E5D0 r ORFIrdeto [mouse] card detected         
            2013/09/14 17:43:08  A03E5D0 r ORFIrdeto [mouse] ATR: 3B          
            2013/09/14 17:43:08  A03E5D0 r ORFIrdeto [mouse] Init card protocol T0, FI=1, F=372, D=2, N=0         
            2013/09/14 17:43:08  A03E5D0 r ORFIrdeto [mouse] Calculated work ETU is 62.00 us         
            2013/09/14 17:43:08  A03E5D0 r ORFIrdeto  [mouse] ATR Fsmax is: 5 MHz, clocking card to wanted user cardspeed of  6.00 MHz (specified in reader->mhz)         
            2013/09/14 17:43:09  A03E5D0 r ORFIrdeto [mouse] Hist. Bytes: TÄ         
            2013/09/14 17:43:09  A03E5D0 r ORFIrdeto [mouse] detect irdeto card         
            2013/09/14 17:43:09  A03E5D0 r ORFIrdeto [mouse] caid: 0648, acs: 0.05, country code: AUT         
            2013/09/14 17:43:09  A03E5D0 r ORFIrdeto [mouse] providers: 4, ascii serial: ##########, hex serial: ######, hex base: ##         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [mouse] active providers: 4 (b5abff,b5abff,002600,b5abff)         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [mouse] found card system irdeto         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [irdeto] entitlements for provider: 1, id: B5ABFF         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [irdeto] chid: 000D, date: 2013/09/12 - 2013/10/12         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [irdeto] chid: 0002, date: 2013/09/14 - 2014/05/22         
            2013/09/14 17:43:10  A03E5D0 r ORFIrdeto [irdeto] chid: 7FF7, date: 2013/09/13 - 2013/09/23         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] entitlements for provider: 2, id: B5ABFF         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 001D, date: 2013/09/12 - 2013/12/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: FFE1, date: 2013/09/13 - 2013/10/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 7FFA, date: 2013/09/13 - 2013/10/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 7FF6, date: 2013/09/13 - 2013/09/23         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: FFD9, date: 2013/09/12 - 2013/10/12         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 0015, date: 2013/09/14 - 2013/11/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] entitlements for provider: 4, id: B5ABFF         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: FFE3, date: 2013/09/12 - 2013/10/12         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 002A, date: 2013/09/12 - 2013/11/11         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 002B, date: 2013/09/12 - 2013/11/11         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 002C, date: 2013/09/12 - 2013/11/11         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 002D, date: 2013/09/12 - 2013/11/11         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 7FF8, date: 2013/09/13 - 2013/10/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: 7FF4, date: 2013/09/13 - 2013/09/23         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] chid: FFDB, date: 2013/09/13 - 2013/10/13         
            2013/09/14 17:43:11  A03E5D0 r ORFIrdeto [irdeto] ready for requests         
    

    Ich hab jetzt nur den einen ORF Reader dran, hatte aber auch schon alle 4 dran, keine Änderung...
    Bei mehr als einem Reader sind die Clienten weg bzw. werden als Offline angezeigt.

    Ein Reader und alles ist okay
    Ich versteh das nicht
     
    #4
  6. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Hi,

    das Logfile hättest du eben mit beifügen können.

    Grüße
    Bombadil
     
    #5
  7. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Hab ich ja, bzw. schnell editiert :)
     
    #6
  8. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Hi,

    es scheitert schon an der Erkennung des Readers (Easymouse, Smargo, Apollo, was auch immer du nutzt.) Die devices sind offensichtlich nicht richtig konfiguriert. Was ist mit der HDplus Karte, die erscheint im Log nirgendwo.

    Nutzt du die IPC Scripte?

    Grüße
    Bombadil
     
    #7
  9. Galliano99
    Offline

    Galliano99 Ist oft hier

    Registriert:
    10. März 2013
    Beiträge:
    142
    Zustimmungen:
    29
    Punkte für Erfolge:
    28
    Ort:
    Cologne
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Also was mir aufgefallen ist:

    Nur bei einem der 4 (identischen?) Reader steht:

    smargopatch = 1

    Nimm das mal raus, oder bei allen dazu - je nachdem wie Deine Konstallation aussieht.

    Und lösche doch - nur zum testen - einmal alle Zeilen mit dem Ident-Eintrag bei oscam.server.

    Und bei oscam.user noch

    caid = 1830,1702,1833,0648

    rein

    EDIT: Stimmt, liegt wohl an der falschen Config der Reader - hatte den Log nicht gesehen...
     
    #8
  10. DarkStarXxX
    Offline

    DarkStarXxX Best Member

    Registriert:
    30. Dezember 2009
    Beiträge:
    5.045
    Zustimmungen:
    2.585
    Punkte für Erfolge:
    113
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Wegen deinen Client Problem:

    waitforcards = 1 <--- Zufällig gesetzt? Dann wäre es kein Wunder das sich die Clients nicht verbinden solange nicht alle Reader Online sind.
     
    #9
    Jar Jar Bings und Skyrider79 gefällt das.
  11. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Genau dieser waitforcards lässt clienten erst connecten wenn alle "aktivierten" Reader "CardOK" anzeigen.
    Tun sie das nicht wird das verbinden der Clients geblockt.
     
    #10
  12. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Guten Abend!

    Habe ich aber nicht angegeben bzw. so konfiguriert :/
    Bzw. wo würde das stehen?

    Habe nichts dergleichen gefunden.
     
    Zuletzt bearbeitet: 14. September 2013
    #11
  13. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Ja das kann schon sein.
    Denn dieser Wert ist standardmässig schon auf = 1 wenn man nichts einträgt.
    Wenn du willst das Clients auch connecten obwohl nicht alle Reader fertig sind mit Karteneinlesen dann musst du das
    explizit erlauben indem du den wert in der oscam.conf auf = 0 setzt.
    So
    waitforcards = 0
    oder eben über das Webinterface ändern unter Configuration wait for cards = 0 (enable Client logins while init)
     
    #12
    Jar Jar Bings gefällt das.
  14. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    Ich werde es probieren, aber klingt mal nicht nach meinem Problem

    Habe zwei Reader dran hängen gehabt, beide Reader wurden ordnungsgemäß eingelesen, aber Clienten kamen keine.
    Werde testen und berichten!
     
    #13
  15. Jar Jar Bings
    Offline

    Jar Jar Bings Meister

    Registriert:
    13. März 2010
    Beiträge:
    923
    Zustimmungen:
    50
    Punkte für Erfolge:
    28
    Ort:
    Internet
    AW: Oscam - Mehr als ein Reader - Clienten weg!

    So Leute!

    Alle, die mir das waitforcards = 0 empfohlen haben........
    VIELEN VIELEN DANK!!!

    Das hat wirklich geklappt!!!
    Danke :)
     
    #14
    Skyrider79 gefällt das.
  16. misko1234
    Offline

    misko1234 Meister

    Registriert:
    6. September 2010
    Beiträge:
    917
    Zustimmungen:
    156
    Punkte für Erfolge:
    43
    AW: Oscam - Mehr als ein Reader - Clienten weg!



    Hatte das gleiche Problem nach dem ich meine Oscam upgedatet habe.
     
    Zuletzt von einem Moderator bearbeitet: 15. September 2013
    #15
    Jar Jar Bings gefällt das.

Diese Seite empfehlen