1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Newcs Server mit Nagra3+Smargo unter XP?

Dieses Thema im Forum "CS Newcs" wurde erstellt von wurli, 28. November 2008.

  1. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    Moin Gemeinde,
    ich versuche verzweifelt einen newcs Server unter XP ans laufen zu bringen. Ich hatte diese Kombo an einer FB 7170 zu laufen, da wurde die Karte nur einmal erkannt (CAID/Mhz/Resets/ECMs/Node/Reader
    1702/600/0/0/dev/ttyUSB0/0 (USB). Dann nie wieder.
    Um das Problem einzugrenzen, will ich zum Testen den newcs erstmal unter Windows ans Laufen bringen. Die Karte selber ist aktiviert und funktioniert auch (Nagra3). Der Smargo wird als COM1 erkannt.
    Die Weboberfläche kann ich starten, der Reader wird aber nicht erkannt.
    Hier erstmal meine newcs.xml:

    <?xml version="1.0"?>
    <newCSconfig>
    <readers name="Phoenix">
    <device>
    <name>Phoenix Interface</name>
    <type>phoenix</type>
    <mhz>600</mhz>
    <node>COM1</node>
    <parity>odd</parity>
    <reset>normal</reset>
    <export>Yes</export>
    <enabled>Yes</enabled>
    <blocksa>No</blocksa>
    <blockua>No</blockua>
    <blockga>No</blockga>
    <!-- <boxkey>0000000000</boxkey> -->
    <!-- <rsa>0000000000</rsa> -->
    <PTShandshake>No</PTShandshake>
    <carddetect>yes</carddetect>
    <newcamd_port>15000</newcamd_port>
    <autosid>Yes</autosid>
    <Seca-PPV>no</Seca-PPV>
    <pincode>0000</pincode>
    <priority>round</priority>
    </device>
    </readers>
    <httpd>
    <server>
    <port>8080</port>
    <enabled>yes</enabled>
    </server>
    <user>
    <name>newcs</name>
    <password>newcs</password>
    <accesslevel>admin</accesslevel>
    </user>
    </httpd>
    <radegastserver>
    <enabled>No</enabled>
    <port>16000</port>
    <allow>
    <hostname>localhost</hostname>
    </allow>
    </radegastserver>
    <cache>
    <emm>20</emm>
    <ecm>-1</ecm>
    </cache>
    <debug>
    <password>NewCSpwd</password>
    <level>normal</level>
    <type>init</type>
    <output>all</output>
    <logfile>logfile.txt</logfile>
    <console_options>normal,init</console_options>
    <tcp_port>1001</tcp_port>
    <tcp_options>normal,init</tcp_options>
    </debug>
    <newcamdserver>
    <enabled>Yes</enabled>
    <name>newcs</name>
    <deskey>01 02 03 04 05 06 07 08 09 10 11 12 13 14</deskey>
    <user>
    <name>dummy</name>
    <password>dummy</password>
    <hostname>192.168.0.254</hostname>
    <port>12000</port>
    <au>on</au>
    <sidoverride>off</sidoverride>
    <spider>No</spider>
    <rate>2</rate>
    </user>
    <user>
    <name>little</name>
    <password>little</password>
    <hostname>192.168.0.254</hostname>
    <port>12000</port>
    <au>on</au>
    <sidoverride>off</sidoverride>
    <spider>No</spider>
    <rate>2</rate>
    </user>
    <user>
    <name>dream</name>
    <password>dream</password>
    <hostname>192.168.0.254</hostname>
    <port>12000</port>
    <au>on</au>
    <sidoverride>off</sidoverride>
    <spider>No</spider>
    <rate>2</rate>
    </user>
    <user>
    <name>reel</name>
    <password>reel</password>
    <hostname>192.168.0.254</hostname>
    <port>12000</port>
    <au>on</au>
    <sidoverride>off</sidoverride>
    <spider>No</spider>
    <rate>2</rate>
    </user>
    </newcamdserver>
    </newCSconfig>

    Logdatei:

    [ 10:10:41 ] [ Box detect ] Windows XP Build 2600
    [ 10:10:41 ] [ Config ] Option <blockc0> for device 0 (Phoenix Interface) not present, defaulting to NO
    [ 10:10:41 ] [ Config ] Option <crypto-special> for device 0 (Phoenix Interface) not present, defaulting to NO
    [ 10:10:41 ] [ Config ] Pincode for device 0 (Phoenix Interface): 0000
    [ 10:10:41 ] [ Config ] COM1 ECM priority: round
    [ 10:10:41 ] [ httpd ] httpd-user: newcs, password: newcs, accesslevel: admin
    [ 10:10:41 ] [ EMM Cache ] Initialising dynamic Cache
    [ 10:10:41 ] [ ECM Cache ] Initialising dynamic Cache
    [ 10:10:41 ] [ Loader ] Starting Telnet on port 1001
    [ 10:10:41 ] [ Loader ] Started HTTP-server on port: 8080
    [ 10:10:41 ] [ Loader ] Reader type 2 on node COM1
    [ 10:10:41 ] [ Phoenix ] Opening device COM1
    [ 10:10:41 ] [ Phoenix ] Setting parity to ODD on node COM1
    [ 10:10:41 ] [ Phoenix ] Setting 1 Stop bit on node COM1
    [ 10:10:41 ] [ Phoenix ] Setting baud to 16457
    [ 10:10:43 ] [ Loader ] Reset failed ...
    [ 10:10:43 ] [ Loader ] Starting Newcamd Server on port 15000
    [ 10:10:43 ] [ Newcamd ] Newcamd thread Server started on port 15000


    Bitte helft mir, ich hab keinen Plan mehr.....:20:
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Ich werde morgen mal mein Smargo testen. Mit MasterCRD läuft deine Config jedenfalls bestens. Ist ja auch meine :D.
     
    #2
    Pilot gefällt das.
  4. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Hab oben die Dateien nochmal angepasst. Hab nun auch ein Logfile.
     
    #3
  5. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Dein newcs ist bereit. Es kommt nur kein Client!!!!!!!
     
    #4
  6. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    In der Web Oberfläche ist aber kein Reader erkannt! Wenn der Resi drauf will, kommt sinn gemäß die Meldung, dass der Server nicht fertig ist. Poste das Log gleich.
     
    #5
  7. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Ich teste es jetzt mal selbst mit den Smargo. Mal schauen was bei raus kommt.
     
    #6
  8. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Der Reader will bei mir ebenso nicht laufen. Die alte und neue Nagra wird erkannt. Später kommt die Meldung das die Initialisierung fehl schlägt. Wenn sich der User einloggt, bekommen ich die Meldung das der Server nicht bereit ist. Ich habe auch versucht den Reader manuell auf 6 Mhz zu stellen. Das ergebniss war das selbe. Selbst mit die Windows Treiber möchte das newcs der Smargo nicht laufen. Ich habe das ganze mit den MasterCRD am laufen und dort shart das newcs tadellos.
     
    #7
  9. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    So ist es bei mir auch. Was meinst Du mit neuer Nagra? Die aktuelle, die PR. verschickt?
     
    #8
  10. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Mit den Satz "aber NewCS ist noch nicht hundert Prozent angepasst!" denke ich mal das er das selbe Problem hat.

    Desweiteren denke ich auch das der User sich wichtig macht. Schau mal ganz genau auf die XML

    <readers name="Smargo-PW">
    <device>
    <name>Smargo</name>
    <type>phoenix</type>
    <mhz>600</mhz>
    <node>/dev/usb/tts/0</node>
    <parity>none</parity>
    <reset>normal</reset>
    <export>Yes</export>
    <enabled>Yes</enabled>
    <blocksa>No</blocksa>
    <blockua>No</blockua>
    <blockga>No</blockga>

    Es ist nicht möglich mit ein Linux Pfad den Reader unter Windows anzusprechen.
     
    #9
  11. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Das hatte ich auch in com1 geändert.
    Ist die "neue" Narga die s02?
     
    #10
  12. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Ist das jetzt ein S02->Smargo oder newcs->Smargo Problem?
     
    #11
  13. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Der Smargo ist eigentlich für Linux gedacht. Mit neu meine ich die neue S02. Ich habe aber auch noch die alte S02 hier zum testen. Wie gesagt, beide laufen nicht.
     
    #12
  14. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Die FB konnte ihn auch nur einmal ansprechen, und da läuft ja Linux. Mal ´ne andere Frage. Zu welchem Server gehört das Newcamd 5.25 Protokoll? Newcs oder Mpcs?
     
    #13
  15. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Mit Newcamd und MPCS habe ich mich noch nicht beschäftigt. Das Problem bei der FB ist vermutlich der Kernel. Darin wird der Treiber nicht mit geladen.
     
    #14
  16. wurli
    Offline

    wurli Ist oft hier

    Registriert:
    16. März 2008
    Beiträge:
    131
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Newcs Server mit Nagra3+Smargo unter XP?

    Aber warum hat er den Reader ein mal angezeigt? Er wird ja aucher kannt:

    usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB0

    Hast Du dieses Image geflasht?

    7170_04.59freetz-devel-2741M.de.image

    Wegen dem Protokoll. Mein Octagon kann nur Newcamd 5.0 und 5.25. Nicht das nachher der newcs garnicht der Richtige ist. :(
     
    #15

Diese Seite empfehlen