1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Internet-Client disconnected alle paar Stunden

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von DarkIdea, 7. Juni 2013.

  1. DarkIdea
    Offline

    DarkIdea Ist gelegentlich hier

    Registriert:
    20. Juni 2011
    Beiträge:
    74
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    Hallo ihr Lieben,
    ich habe bei mir folgendes Problem und benötige dafür Hilfe.

    Ich habe bei mir zum testen ein kleines Cardsharing Netzwerk aufgebaut, damit ich meine Smartcard nicht immer durch die Gegend tragen muss.

    Verwendete Karte: Sky V13

    Ich besitze folgende Geräte:
    ET 4000 (Server) mit OPENPli - OSCAM 1.20-unstable_svn build r8678
    ET 9000 (Lan-Client) mit OPENPli - OSCAM 1.20-unstable_svn build #7365
    Pingulux (Internet Client in meiner Zweitwohnung) mit Spark - OSCAM 1.20-unstable_svn build7924

    Nun zum Problem: Im Lan funktioniert das Cardsharing einwandfrei, ohne Probleme. Aber in meiner Zweiwohnung habe ich alle immer wieder kurze Disconnects, die dafür sorgen, dass ich immer wieder einen Bildhänger für 10-15 Sekunden habe. Die Disconnects treten dabei unregelmäßig auf. Manchmal alle 20-30 Minuten und manchmal hält der Client auch 8 Stunden am Stück durch um sich dann wieder 2x in einer Stunde zu verabschieden.
    Wenn ich den Client zu mir nach Hause hole und ihn im Lan anschließe, dann treten diese Probleme nicht auf.
    Meine Logs im Router habe ich überprüft, es liegt nicht an Trennungen der Internetleitung. Außerdem habe ich noch probiert, ob es an dem dyndns liegen könnte, aber auch ne direkte IP Verbindung ist nicht die Problemlösung. Oscam Version wurde auch variiert.
    Des weiteren habe ich mal den ET 4000 als Client genommen in der Zweitwohnung, da gabs dann das gleiche Problem.

    Hier die Logs vom Server
    2013/06/01 23:55:24 5F3AF8 c zweitwohnung (09C4&000000/0000/6FB9/B3:3A7A): found (121 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:55:34 5F3AF8 c zweitwohnung (09C4&000000/0000/6FB9/B3:9095): found (118 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:55:44 5F3AF8 c zweitwohnung (09C4&000000/0000/6FB9/B3:E0B3): found (122 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:55:54 5F3AF8 c zweitwohnung (09C4&000000/0000/6FB9/B3:AD0A): found (124 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:56:36 5F3AF8 c zweitwohnung disconnected from **********
    2013/06/01 23:56:43 6325B0 c encrypted cccam-client ********** granted (zweitwohnung, au=off)
    2013/06/01 23:56:55 6325B0 c zweitwohnung (09C4&000000/0000/6FB9/B3:E0D4): found (121 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:57:05 6325B0 c zweitwohnung (09C4&000000/0000/6FB9/B3:33ED): found (120 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:57:14 6325B0 c zweitwohnung (09C4&000000/0000/6FB9/B3:349E): found (120 ms) by sky_v13_unterer_schacht - MTV Live HD
    2013/06/01 23:57:24 6325B0 c zweitwohnung (09C4&000000/0000/6FB9/B3:7836): found (120 ms) by sky_v13_unterer_schacht - MTV Live HD

    Neuer Log:
    2013/06/04 23:37:24 545E50 c zweitwohnung (09C4&000000/0000/007B/B3:D2BECFA527D5D7FB3D3E787C8182AC54): found (122 ms) by sky_v13_unterer_schacht - TNT Serie HD
    2013/06/04 23:37:38 545E50 c zweitwohnung disconnected from **********
    2013/06/04 23:37:39 548C40 c encrypted cccam-client ******** granted (zweitwohnung, au=off)
    2013/06/04 23:37:45 548C40 c zweitwohnung (09C4&000000/0000/007B/B3:0031FE070B31541252A1BCC0E3122D95): found (122 ms) by sky_v13_unterer_schacht - TNT Serie HD

    Logs vom Clienten
    2013/06/03 15:35:56 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:B8F4): found (154 ms) by cardserver
    2013/06/03 15:36:03 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:2674): found (163 ms) by cardserver
    2013/06/03 15:36:09 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:5370): found (148 ms) by cardserver
    2013/06/03 15:36:17 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:F911): found (143 ms) by cardserver
    2013/06/03 15:36:24 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:D69B): found (142 ms) by cardserver
    2013/06/03 15:36:31 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:6B75): found (161 ms) by cardserver
    2013/06/03 15:36:37 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:ED6D): found (155 ms) by cardserver
    2013/06/03 15:36:38 0 >> OSCam << cardserver log switched, version 1.20-unstable_svn, build #7924 (sh4-linux)
    2013/06/03 15:36:38 0 version=1.20-unstable_svn, build #7924, system=sh4-linux, nice=-1
    2013/06/03 15:36:38 0 client max. idle=120 sec, debug level=0, filter_sensitive=1
    2013/06/03 15:36:38 0 max. logsize=10 Kb, loghistorysize=4096 bytes
    2013/06/03 15:36:38 0 client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
    2013/06/03 15:36:49 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:EA38): timeout (5002 ms) by cardserver
    2013/06/03 15:36:56 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:A364): timeout (5001 ms) by cardserver
    2013/06/03 15:37:03 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:0698): timeout (5002 ms) by cardserver
    2013/06/03 15:37:16 5A1810 p can't resolve cardserver, error: Name or service not known
    2013/06/03 15:37:16 5A1810 p cardserver: resolved ip=0.0.0.0
    2013/06/03 15:37:16 5A1810 p dropping client data for cardserver time 18s
    2013/06/03 15:37:26 5A1810 p cardserver: resolved ip=*********
    2013/06/03 15:37:26 5A1810 p cardserver [cccam] connecting to cardserver:*port*
    2013/06/03 15:37:33 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:004C): found (139 ms) by cardserver
    2013/06/03 15:37:41 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:30D9): found (151 ms) by cardserver
    2013/06/03 15:37:47 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:545A): found (160 ms) by cardserver


    Neuer Log:

    2013/06/03 15:41:25 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:DAAB): found (152 ms) by cardserver
    2013/06/03 15:41:32 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:81A2): found (141 ms) by cardserver
    2013/06/03 15:41:43 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:BDAE): timeout (5002 ms) by cardserver
    2013/06/03 15:41:50 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:3C75): timeout (5001 ms) by cardserver
    2013/06/03 15:41:57 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:2A88): timeout (5001 ms) by cardserver
    2013/06/03 15:42:06 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:476C): rejected group (2 ms) (0/0/0/0) (no matching reader)
    2013/06/03 15:42:08 5A1810 p can't resolve cardserver, error: Name or service not known
    2013/06/03 15:42:08 5A1810 p cardserver: resolved ip=0.0.0.0
    2013/06/03 15:42:08 5A1810 p dropping client data for cardserver time 13s
    2013/06/03 15:42:10 5A1810 p cardserver: resolved ip=*******
    2013/06/03 15:42:10 5A1810 p cardserver [cccam] connecting to cardserver:*port*
    2013/06/03 15:42:14 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:DF1F): found (140 ms) by cardserver
    2013/06/03 15:42:21 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:8896): found (160 ms) by cardserver
    2013/06/03 15:42:28 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:CCC1): found (153 ms) by cardserver
    2013/06/03 15:42:35 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:A802): found (142 ms) by cardserver
    2013/06/03 15:42:42 5BBAE8 c dvbapi (09C4&000000/0000/EF10/B3:624E): found (160 ms) by cardserver

    Nun die relevanten Configen:
    Server - oscam.conf
    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r7425
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    logfile = /var/volatile/tmp/.oscam/oscam.log
    unlockparental = 1
    nice = -1
    maxlogsize = 2048
    preferlocalcards = 1
    netprio = 1
    cachedelay = 120
    dropdups = 1


    [cccam]
    port = *****
    reshare = 1
    version = 2.3.0
    keepconnected = 1
    stealth = 1


    [monitor]
    appendchaninfo = 1


    [dvbapi]
    au = 1
    enabled = 1
    user = local-hdfreak
    boxtype = dreambox


    [webif]
    httpport = ******
    httphelplang = de
    httprefresh = 3
    httpallowed = **********************

    Server - oscam.user
    [account]
    user = local-hdfreak
    pwd =
    group = 1
    au = 1
    uniq = 3


    [account]
    disabled = 0
    user = zweitwohnung
    pwd = *****
    group = 1
    cccmaxhops = 0


    [account]
    disabled = 0
    user = et_9000
    pwd = ******
    group = 1
    uniq = 3
    cccmaxhops = 0

    Server - oscam.server
    [reader]
    label = sky_v13_unterer_schacht
    enable = 1
    protocol = internal
    device = /dev/sci1
    caid = 09C4
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,1,2
    ndsversion = 2
    ins7e11 = 15

    User Pingulux - oscam.conf
    [global]
    unlockparental = 1
    nice = -1
    waitforcards_extra_delay = 3000
    dropdups = 1
    lb_retrylimit = 1600
    lb_savepath =
    lb_reopen_mode = 1
    WaitForCards = 0
    saveinithistory = 1
    pidfile = /var/run/oscam.pid
    logfile = /var/log/oscam/oscam.log
    usrfile = /var/log/oscam/oscamuser.log
    cwlogdir = /var/log/oscam/cw
    maxlogsize = 1024

    [dvbapi]
    enabled = 1
    au = 0
    user = dvbapi


    [webif]
    httpport = *****
    httphelplang = de
    httprefresh = 3
    httpallowed = *******

    User - Pingulux oscam.server
    [reader]
    label = cardserver
    enable = 1
    protocol = cccam
    device = *cardserver*,*port*
    user = zweitwohnung
    password = *******
    inactivitytimeout = 1
    reconnecttimeout = 2
    caid = 09C4
    group = 1
    cccversion = 2.3.0
    ccckeepalive = 1

    Ich freue mich über Hilfe und bin für Fragen jederzeit bereit!
    LG
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. wylly31
    Offline

    wylly31 Elite Lord Supporter

    Registriert:
    11. Juli 2009
    Beiträge:
    3.326
    Zustimmungen:
    1.862
    Punkte für Erfolge:
    113
    Ort:
    Hell
    AW: Internet-Client disconnected alle paar Stunden

    Wenn Du in Deiner Zweitwohnung Wlan nutzt dann liegt es zu 99% daran.
     
    #2
    bombadil gefällt das.
  4. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Internet-Client disconnected alle paar Stunden

    Hi,

    auf dem Client brauchst du das rote erst mal nicht
    Code:
    [COLOR=#ff0000]unlockparental                = 1[/COLOR]
    nice                          = -1
    [COLOR=#ff0000] waitforcards_extra_delay      = 3000[/COLOR]
    [COLOR=#ff0000] dropdups                      = 1[/COLOR]
    [COLOR=#ff0000]lb_retrylimit                 = 1600
    lb_savepath                   = 
    lb_reopen_mode                = 1
    WaitForCards  = 0[/COLOR]
    [COLOR=#ff0000] saveinithistory = 1[/COLOR]
    [COLOR=#ff0000]pidfile          = /var/run/oscam.pid[/COLOR]
    logfile          = /var/log/oscam/oscam.log
    [COLOR=#ff0000] usrfile = /var/log/oscam/oscamuser.log[/COLOR]
    [COLOR=#ff0000] cwlogdir = /var/log/oscam/cw[/COLOR]
    maxlogsize                    = 1024
    


    Um einen Fehler in der Netzwerkverbindung auszuschließen. Wie schließt du den Reveiver in deiner Zweitwohnung an? Lan, Wlan, Dlan?

    Grüße
    Bombadil
     
    #3
    DarkIdea und Pilot gefällt das.
  5. DarkIdea
    Offline

    DarkIdea Ist gelegentlich hier

    Registriert:
    20. Juni 2011
    Beiträge:
    74
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    AW: Internet-Client disconnected alle paar Stunden

    Danke, ich nehme die roten Einträge mal raus!
    Ich hab überall nur LAN Verbindungen, kein Wlan. Jedes Kabel kommt direkt vom Router und geht zum Reciever. Mit meinen anderen Geräten im Netzwerk habe ich keine Probleme.
     
    #4
  6. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Internet-Client disconnected alle paar Stunden

    Hi,

    nimm bei Proxyreader (Client) diese beiden Parameter raus.
    Code:
    inactivitytimeout             = 1
    reconnecttimeout              = 2
    
    da dürften die Default Werte besser sein.

    Grüße
    Bombadil
     
    #5
    Pilot und DarkIdea gefällt das.
  7. DarkIdea
    Offline

    DarkIdea Ist gelegentlich hier

    Registriert:
    20. Juni 2011
    Beiträge:
    74
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    AW: Internet-Client disconnected alle paar Stunden

    Okay prima,
    also ich habe nun jeweils die Einstellungen in der .conf und .server entsprechend geändert und beobachte nun, ob das Problem weiterhin auftritt.
    Vielen Dank!
     
    #6
  8. DarkIdea
    Offline

    DarkIdea Ist gelegentlich hier

    Registriert:
    20. Juni 2011
    Beiträge:
    74
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    AW: Internet-Client disconnected alle paar Stunden

    So ihr Lieben,
    nun sind ein paar Tage verstrichen und ich hab die Änderungen mal getestet.
    Leider konnte das Problem nicht behoben werden, mein Lanclient ist mittlerweile seit über 5 Tagen verbunden, der Internet Client jedoch hat immernoch unregelmäßige Disconnects. Längste verbundene Zeit war mal bei 9 Stunden. Der Schnitt liegt aber bei 0-2 Stunden.

    Kann es am Server liegen? Meint ihr, dass mir ein anderer Server evtl. das Problem beheben könnte? Thema externer Client mit Smargo / EasyBox?

    Oder liegts am Clienten?
     
    #7
  9. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.882
    Zustimmungen:
    6.211
    Punkte für Erfolge:
    113
    AW: Internet-Client disconnected alle paar Stunden

    Was sagt die Verbindung ins Internet beim Client?
    Kommt es dort zu Abbrüchen, ist natürlich auch der Server "weg".
     
    #8
  10. DarkIdea
    Offline

    DarkIdea Ist gelegentlich hier

    Registriert:
    20. Juni 2011
    Beiträge:
    74
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    AW: Internet-Client disconnected alle paar Stunden

    Ich hab die Logs in der Fritz Box kontrolliert. Weder beim Server, noch in meiner Wohnung beim Clienten gabs in dem besagten Zeitraum nen disconnect.

    Also war die Internetverbindung wohl vermutlich "konstant".
     
    #9
  11. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.882
    Zustimmungen:
    6.211
    Punkte für Erfolge:
    113
    AW: Internet-Client disconnected alle paar Stunden

    Ok.
    Trage mal im Server bei dem Client die CAID mit ein.
     
    #10

Diese Seite empfehlen