1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Debian IPC mit Oscam HD02 im Smargo "Error activating card"

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von tomekkk, 10. März 2013.

  1. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    Hallo,
    Habe ein "kleines" Problem an meinem Igel 564 mit einer HD+ (HD02) Karte. Erstmal zu meiner Konfiguration:

    Igel 564 lx
    2x Smartmouse 2 (V13 und HD02)
    1x Smargo Argolis v1.5 (HD02)
    [SIZE=-1]Debian 6.0.7[/SIZE] + IPC 11.5
    OSCAM 1.20-unstable_svn build r8500
    camd3 als emu

    Die Reader werden mit der udev Regel "bestimmt"

    #Smartmouse2 mit HD02
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="A400fBIr", SYMLINK+="HD+"
    #Smartmouse2 mit V13
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="A700ffkq", SYMLINK+="V13"
    #Smargo mit HD02
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="Reader 303F4FD", SYMLINK+="smargo"

    Beide Smartmäuse laufen einwandfrei. Jedoch bekomme ich den Smargo mit der HD02 nicht zum laufen. Mal wird mir ATR angezeigt (ist dann aber viel zu kurz) aber meistens gar nicht.

    Ich bekomme immer folgenden Fehler:

    2013/03/10 17:26:50 8EAA1B8 h smargo_hd+ [mouse] creating thread for device /dev/smargo
    2013/03/10 17:26:50 8EB2160 r smargo_hd+ [mouse] Reader initialized (device=/dev/smargo, detect=cd, mhz=357, cardmhz=357)
    2013/03/10 17:26:50 8EB2160 r smargo_hd+ [mouse] card detected
    2013/03/10 17:26:54 8EB2160 r smargo_hd+ [mouse] Error activating card.

    Meine oscam.server sieht folgendermaßen aus:

    [reader]
    label = hd+
    protocol = mouse
    device = /dev/HD+
    caid = 1843
    boxkey = AxxxxxxxxxxxC
    rsakey = Bxxxxxxxxxxxxxxxxxxxxxxx5
    detect = cd
    mhz = 600
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1

    [reader]
    label = camd3emu
    protocol = camd35
    device = 127.0.0.1,20248
    user = emu
    password = emu123
    caid = 0D05
    ident = 0D05:000000,000004,000008,000010
    group = 3

    [reader]
    label = v13
    protocol = mouse
    device = /dev/V13
    caid = 09C4
    boxid = 12345678
    boxkey = 1122334455667788
    ins7e11 = 15
    detect = cd
    mhz = 600
    ident = 09C4:000000
    group = 2
    emmcache = 1,3,2
    ndsversion = 2

    [reader]
    label = smargo_hd+
    protocol = mouse
    device = /dev/smargo
    smargopatch = 1
    caid = 1843
    boxkey = AxxxxxxxxxxxxxxC
    rsakey = Bxxxxxxxxxxxxxxxxxxxxxxxxxxxx5
    detect = cd
    mhz = 369
    group = 4
    emmcache = 1,3,2

    Der Smargo ist so eingestellt:

    Mode = fixed
    Frequency = 3,69
    Kernel = Normal
    T-mode = T=0
    EGT = 0

    Ich finde einfach keinen Weg die HD+ Karte im smargo zum laufen zu bekommen. Habe schon zig oscam configs ausprobiert (357mhz, 368mhz, 369mhz, 600mhz) bzw auch mal komplett ausgeklammert (# davorgesetzt) Doch kein einziges mal wurde die Karte richtig erkannt. Stecke ich sie in die smartmouse, wird sie sofort erkannt und funktioniert...

    Auch die smargo Einstellungen habe ich mehrfach geändert. Mal auf auto gestellt, mal mit den Kernel rumgespielt und jedes mal das gleiche... Meiner Meinung nach bin ich alle Möglichkeiten schon durchgegangen. Aber vielleicht ist es nur eine Kleinigkeit bzw ich übersehe etwas. Bin für jeden Tipp dankbar
     
    Zuletzt bearbeitet: 10. März 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    16.769
    Zustimmungen:
    4.584
    Punkte für Erfolge:
    113
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    im webif unter configuration - webif unten http savefullcfg auf NO stellen und configs oben ändern,
    sind viel zu lang
     
    #2
  4. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Habs geändert. Sieht jetzt viel übersichtlicher aus
     
    #3
  5. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi,

    ich glaube, die UDEV Regel zieht nicht beim Smargo. Lies den mit dem protokoll Smartreader.
    Code:
    protocol                      = smartreader
    device                        = Serial:Reader A4908D0
    
    Grüße
    Bombadil
     
    #4
    tomekkk gefällt das.
  6. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Keine Besserung siehe log:

    2013/03/10 18:49:31 93EAA20 h smargooo [smartreader] creating thread for device Serial:Reader 303F4FD
    2013/03/10 18:49:31 94051F8 r smargooo [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    2013/03/10 18:49:31 94051F8 r Found reader with serial Reader 303F4FD at 004:002
    2013/03/10 18:49:31 94051F8 r Found smartreader device Serial:Reader 303F4FD
    2013/03/10 18:49:31 94051F8 r smargooo [smartreader] Reader initialized (device=Serial:Reader 303F4FD, detect=cd, mhz=357, cardmhz=357)
    2013/03/10 18:49:32 94051F8 r smargooo [smartreader] card detected
    2013/03/10 18:49:37 94051F8 r smargooo [smartreader] Error activating card.
    2013/03/10 18:49:50 94051F8 r smargooo [smartreader] card initializing error
     
    #5
  7. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi,

    teste im Reader
    Code:
    mhz = 368
    cardmhz = 368
    
    Gruß
    Bombadil
     
    #6
    tomekkk gefällt das.
  8. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    2013/03/10 19:01:37 94051F8 r smargooo [smartreader] card detected
    2013/03/10 19:01:42 94051F8 r smargooo [smartreader] Error activating card.
     
    #7
  9. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi,

    denke, dass der Smargo nicht richtig eingestellt ist. Versuch da mal zu schrauben, autoswitch oder Ähnliches. Stehe mit denen auf dem Kriegsfuss.

    Lieben Gruß
    Bombadil
     
    #8
    al-x83 gefällt das.
  10. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Bin ich schon alles durchgegangen. Immer das selbe...

    Aber mal ganz ehrlich. Die Dinger sind doch der letzte Dreck, oder ? Ständig lese ich nur von Problemen mit Smargos. Dann kosten die Dinger auch noch doppelt so viel wie die easymouse... Hatte letztens erst ne Fritzbox für ein Bekannten eingerichtet. Der hatte auch die smargo reader. Stundenlang probiert und nur probleme gehabt. Auch etliche oscam versionen durchprobiert und immer die selben Fehler gehabt. Irgendwann ging es dann, aber auch nur nach dem Zufallsprinzip. Mal ja mal nein. Smartmouse drann = geht SOFORT

    Ich verstehs einfach nicht, warum die Dinger von einigen usern so gelobt werden. ICH hatte bis jetzt NUR Probleme damit. Naja, wenn ich nichtmal ein Fehler in den configs habe o.ä. dann heißt das wohl das der smargo entweder defekt oder einfach nur schlecht ist... Ich mache jetzt noch ein Versuch mit dem smargo und einer V13. Sollte das nicht klappen = Mülltonne !
     
    #9
  11. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi tomekkk,

    man sollte die Smargos nicht einfach verteufeln. Ich habe auch einen und der lief auf Anhieb mit der HD01 an einer DM800se, danach ohne Probleme an der Fritte 7390 und jetzt auch sofort am Futro mit Debian.

    Bin mit dem Ding als Cardreader zufrieden, vielleicht habe ich auch nur Glück gehabt. (oder einfach nur mehr gelesen).

    Ich hab dann mal ne Easymouse getestet mit meiner D02 und bin für die weiteren Karten einfach dann bei den Mäusen geblieben. Sind eben einfacher einzustellen und billiger.
    Bei den Möglichkeiten der Einstellungen sind die Mäuse aber etwas limitiert, für meine Karten passt das aber.

    Fazit:
    Ich kann schon verstehen, dass einige User, die keine Schwierigkeiten mit dem Smargo haben, auch bei dem bleiben wollen.

    Lieben Gruß
    Bombadil
     
    #10
    tomekkk und laila-no1 gefällt das.
  12. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Soll ich den smargo mal auf 1.7 updaten ? Oder verschlimmert das das ganze nur noch ? Obwohl, schlimmer kanns ja nicht sein...
     
    #11
  13. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi,

    wie gesagt. Unabhängig vom meinem Post über die Smargos, stehe ich mit denen auf dem Kriegsfuß. Das gilt fürs Supporten, nicht für den Smargo. Meiner, Maxdigital, hat die Firmware 1.05.
    Viele haben aber Probleme mit dem Downgrade, wenn es dann nicht geht.

    Gruß
    Bombadil
     
    #12
  14. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    So, hab jetzt ein Ergebnis. Smargo auf 1.07 upgedatet ----> geht !
    Gegenprobe
    Smargo von 1.07 zurück auf 1.05 ----> GEHT !

    Warum ?! Das wird hier wohl niemand sagen können...

    Jedenfalls läuft jetzt alles perfekt. Karte wird sofort erkannt
     
    #13
    bombadil gefällt das.
  15. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Hi,

    das ist der Grund, warum ich die Smargos nicht gerne supporte. Aber ich freue mich für dich, dass alles funktioniert.

    Lieben Gruß
    Bombadil
     
    #14
    tomekkk gefällt das.
  16. tomekkk
    Offline

    tomekkk Ist oft hier

    Registriert:
    20. Januar 2012
    Beiträge:
    132
    Zustimmungen:
    61
    Punkte für Erfolge:
    28
    AW: Debian IPC mit Oscam HD02 im Smargo "Error activating card"

    Ich Danke dir auf jeden Fall für die Hilfe.

    Eine Frage hätte ich aber noch. Und zwar sind die Zeiten bei dem smargo schlechter als bei der Smartmouse.

    Smartmouse:
    2013/03/10 20:40:49 9BA36E0 c test (1843&000000/0000/EF74/89:BE99E9A1D9F7BF6795A86C9C1B985BF4): found (369 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:40:56 9BA36E0 c test (1843&000000/0000/EF74/89:6C0FF5A6C50DA8447EC54F962E11EEE1): found (369 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:03 9BA36E0 c test (1843&000000/0000/EF74/89:1EFB6D9C6F0F552E1D76467707BA2A81): found (373 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:10 9BA36E0 c test (1843&000000/0000/EF74/89:BF30ABC1F9F331D7743832DB7AF81F23): found (371 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:17 9BA36E0 c test (1843&000000/0000/EF74/89:9BB0458493065AD282F581F706E740F2): found (374 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:24 9BA36E0 c test (1843&000000/0000/EF74/89:34C3349539932E28722E83CC02A96B03): found (373 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:31 9BA36E0 c test (1843&000000/0000/EF74/89:FA1243F4802FCDB3D0527475C67AD627): found (373 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:38 9BA36E0 c test (1843&000000/0000/EF74/89:622999DB478D842C8F3D0A12FD1956E2): found (370 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:45 9BA36E0 c test (1843&000000/0000/EF74/89:F885ADB8767024DD334D127F8B296734): found (371 ms) by Smartmouse_hd+ (P/2/2/2)
    2013/03/10 20:41:52 9BA36E0 c test (1843&000000/0000/EF74/89:8DD167E7296386DC5C432EC8DC159E26): found (367 ms) by Smartmouse_hd+ (P/2/2/2)

    Smargo:
    2013/03/10 20:42:28 9BA36E0 c test (1843&000000/0000/EF74/89:482545EFC4F7E85FBFA0B4DA846DC384): found (463 ms) by smargo
    2013/03/10 20:42:35 9BA36E0 c test (1843&000000/0000/EF74/89:67C8F56F71052979BD95C01955763048): found (459 ms) by smargo
    2013/03/10 20:42:42 9BA36E0 c test (1843&000000/0000/EF74/89:F189D6F6149E4963E15EF9AA9DE6FDCD): found (461 ms) by smargo
    2013/03/10 20:42:49 9BA36E0 c test (1843&000000/0000/EF74/89:B9CA1EFE00288148049C5159BE523FF4): found (461 ms) by smargo
    2013/03/10 20:42:56 9BA36E0 c test (1843&000000/0000/EF74/89:9D63A7A72EBF8988098B8CAFF1C17542): found (459 ms) by smargo
    2013/03/10 20:43:03 9BA36E0 c test (1843&000000/0000/EF74/89:636A157E12F743D71000BE09414CA441): found (458 ms) by smargo
    2013/03/10 20:43:10 9BA36E0 c test (1843&000000/0000/EF74/89:564B55A0C2056211B48C3EE2CB2B9B3F): found (465 ms) by smargo
    2013/03/10 20:43:17 9BA36E0 c test (1843&000000/0000/EF74/89:EA81944D91109A93772A3BFEE02C553F): found (457 ms) by smargo
    2013/03/10 20:43:24 9BA36E0 c test (1843&000000/0000/EF74/89:6D9631AC95DDCDF6D6AF1DE2ED4DA001): found (464 ms) by smargo
    2013/03/10 20:43:31 9BA36E0 c test (1843&000000/0000/EF74/89:A7C6B67A6D05CDBA1FBC782F184EA127): found (460 ms) by smargo
    2013/03/10 20:43:38 9BA36E0 c test (1843&000000/0000/EF74/89:ED5BC6C86BB1F64B36BC64BA8FF415CF): found (464 ms) by smargo
    2013/03/10 20:43:45 9BA36E0 c test (1843&000000/0000/EF74/89:97FEB865F00928D9138A790F75F790F8): found (464 ms) by smargo
    2013/03/10 20:43:52 9BA36E0 c test (1843&000000/0000/EF74/89:77F5293E6DEC692EA90B933F5703BBC5): found (464 ms) by smargo
    2013/03/10 20:43:59 9BA36E0 c test (1843&000000/0000/EF74/89:2DE156720A777009567A10CFB9F0EF12): found (465 ms) by smargo

    Bei beiden ist die Karte mit 600mhz getaktet. 90-100 ms sind ja nicht gerade wenig...
     
    #15

Diese Seite empfehlen