1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Was ist hier genau defekt ?

Dieses Thema im Forum "Debug Modus" wurde erstellt von N1con, 30. April 2008.

  1. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    Hallo liebe DBOX Experten,

    habe eine Nokia Box welche beim Starten auf dem Betaresearch Bildschirm (im Display) hängenbleibt, es sieht so aus als sie in einer Art Loop, das Bild wird ca. alle 4sek dunkler udn dann wieder Hell und es tut sich nix weiteres. Die Box ist im Debug.

    Ich tippe auf einen Defekt im Flash ... ?!?!?

    Beim flashen der BOX gab das Log folgende Meldung aus:

    Code:
    +debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: BMon V1.0  mID 01
    debug: feID 7a    gtxID 0b
    debug: fpID 5a     dsID http://Hallenberg.com  
    debug: HWrev X5  SWrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    debug: autoboot aborted from terminal
    dbox2:root>  boot net net net net net net net net net net
    debug: 
    BOOTP/TFTP bootstrap loader (v0.3)
    debug: 
    debug: Transmitting BOOTP request via broadcast
    debug: Got BOOTP reply from Server IP 192.168.0.1, My IP 192.168.0.202
    debug: Sending TFTP-request for file u-boot
    will verify ELF image, start= 0x800000, size= 140064
    verify sig: 262
    boot net: boot file has no valid signature
    Branching to 0x40000
    
    
    U-Boot 1.3.1 (Tuxbox - Hallenberg.com) (Dec 23 2007 - 22:22:21)
    
    CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
             *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
    Board: DBOX2, Nokia, BMon V1.0
           Watchdog enabled
    I2C:   ready
    DRAM:  32 MB
    FLASH:  8 MB
    FB:    ready
    LCD:   ready
    In:    serial
    Out:   serial
    Err:   serial
    Net:   SCC ETHERNET
    BOOTP broadcast 1
    Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'u-boot'.
    Load address: 0x100000
    Loading: Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'logo-lcd'.
    Load address: 0x100000
    Loading: ##
    done
    Bytes transferred = 7680 (1e00 hex)
    BOOTP broadcast 1
    Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'u-boot'.
    Load address: 0x100000
    Loading: Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'logo-fb'.
    Load address: 0x100000
    Loading: ####################################
    done
    Bytes transferred = 179877 (2bea5 hex)
    
    Options:
      1: Console on null
      2: Console on ttyS0
      3: Console on framebuffer
    Select option (1-3), other keys to stop autoboot:  0 
    Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'kernel-cdk'.
    Load address: 0x100000
    Loading: #################################################################
         ##########################################################
    done
    Bytes transferred = 626108 (98dbc hex)
    Using SCC ETHERNET device
    TFTP from server 192.168.0.1; our IP address is 192.168.0.202
    Filename 'u-initrd'.
    Load address: 0x400000
    Loading: #################################################################
         #################################################
    done
    Bytes transferred = 579075 (8d603 hex)
    ............................................................... done
    Un-Protected 63 sectors
    ## Booting image at 00100000 ...
       Image Name:   dbox2
       Image Type:   PowerPC Linux Kernel Image (gzip compressed)
       Data Size:    626044 Bytes = 611.4 kB
       Load Address: 00000000
       Entry Point:  00000000
       Verifying Checksum ... OK
       Uncompressing Kernel Image ... OK
    ## Loading RAMDisk Image at 00400000 ...
       Image Name:   Ramdisk Image
       Image Type:   PowerPC Linux RAMDisk Image (gzip compressed)
       Data Size:    579011 Bytes = 565.4 kB
       Load Address: 00000000
       Entry Point:  00000000
       Verifying Checksum ... OK
       Loading Ramdisk to 01f21000, end 01fae5c3 ... OK
    Linux version 2.4.36-dbox2 (Hallenberg.com)  (gcc version 3.4.6) #2 So 6. Jan 18:22:41 CET 2008
    On node 0 totalpages: 8192
    zone(0): 8192 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: console=ttyS0 root=/dev/ram rw ip=192.168.0.202:192.168.0.1:::::off
    Decrementer Frequency = 252000000/60
    m8xx_wdt: active wdt found (SWTC: 0xFFFF, SWP: 0x1)
    m8xx_wdt: keep-alive trigger installed (PITC: 0x1000)
    Console: colour dummy device 80x25
    Calibrating delay loop... 66.96 BogoMIPS
    Memory: 30356k available (1048k kernel code, 324k data, 72k init, 0k highmem)
    Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
    Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x1
    i2c-core.o: i2c core module version 2.6.1 (20010830)
    i2c-dev.o: i2c /dev entries driver module version 2.6.1 (20010830)
    CPM UART driver version 0.04
    ttyS0 at 0x0280 is on SMC1 using BRGÿttyS1 at 0x0380 is on SMC2 using BRG2
    pty: 256 Unix98 ptys configured
    eth0: CPM ENET Version 0.2.dbox2 on SCC2, 00:50:9c:1d:26:59
    RAMDISK driver initialized: 16 RAM disks of 3333K size 1024 blocksize
    D-Box 2 flash driver (size->0x800000 mem->0x10000000)
    D-Box 2 flash memory: Found 2 x16 devices at 0x0 in 32-bit bank
     Intel/Sharp Extended Query Table at 0x0035
    cfi_cmdset_0001: Erase suspend on write enabled
    Creating 6 MTD partitions on "D-Box 2 flash memory":
    0x00000000-0x00020000 : "BR bootloader"
    0x00020000-0x00040000 : "FLFS (U-Boot)"
    0x00040000-0x006a0000 : "root (rootfs)"
    0x006a0000-0x00800000 : "var (jffs2)"
    0x00020000-0x00800000 : "Flash without bootloader"
    0x00000000-0x00800000 : "Complete Flash"
    Linux video capture interface: v1.00
    mice: PS/2 mouse device common for all mice
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 2048 bind 4096)
    IP-Config: Guessing netmask 255.255.255.0
    IP-Config: Complete:
          device=eth0, addr=192.168.0.202, mask=255.255.255.0, gw=255.255.255.255,
         host=192.168.0.202, domain=, nis-domain=(none),
         bootserver=192.168.0.1, rootserver=192.168.0.1, rootpath=
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    RAMDISK: Compressed image found at block 0
    Freeing initrd memory: 565k freed
    EXT2-fs warning: checktime reached, running e2fsck is recommended
    VFS: Mounted root (ext2 filesystem).
    Mounted devfs on /dev
    Freeing unused kernel memory: 72k init
    init started: BusyBox v1.9.0 (2008-01-05 13:28:28 CET)
    lcd.o: init lcd driver module
    lcd.o: found KS0713/SED153X lcd interface
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    dbox2 - ImageFlashingAssistent 3.0
    
     - Hallenberg.com - 
    
    
    
    Schreibe Backup: 8064k von 8064k (100%)
    Lade Flashimage...
    done.
    Sende Backup...
    Lösche Sektoren: 28 von 63 (44%)Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Lösche Sektoren: 44 von 63 (69%)Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Lösche Sektoren: 63 von 63 (100%)
    Schreibe Daten: 8064k von 8064k (100%)
    Verifziere Daten: 8064k von 8064k (100%)
    
    Sie koennen die dbox jetzt ausschalten.
    
    -------------------------------------------------------------
    BootP: Request von 00509C1D2659 erhalten
    Error DeleteIpNetEntry: Falscher Parameter.
    
    BootP: ARP-Eintrag mit IP: 192.168.0.202 und Mac: 00509C1D2659 gesetzt
    BootP: Antwort an 00509C1D2659 gesendet
    TFTP: Sende C:\Programme\DBOX_IFA\tftp\u-boot
    TFTP: Transfer erfolgreich beendet
    BootP: Request von 00509C1D2659 erhalten
    BootP: ARP-Eintrag mit IP: 192.168.0.202 und Mac: 00509C1D2659 gesetzt
    BootP: Antwort an 00509C1D2659 gesendet
    TFTP: Sende C:\Programme\DBOX_IFA\tftp\logo-lcd
    TFTP: Transfer erfolgreich beendet
    BootP: Request von 00509C1D2659 erhalten
    BootP: ARP-Eintrag mit IP: 192.168.0.202 und Mac: 00509C1D2659 gesetzt
    BootP: Antwort an 00509C1D2659 gesendet
    TFTP: Sende C:\Programme\DBOX_IFA\tftp\logo-fb
    TFTP: Transfer erfolgreich beendet
    TFTP: Sende C:\Programme\DBOX_IFA\tftp\kernel-cdk
    TFTP: Transfer erfolgreich beendet
    TFTP: Sende C:\Programme\DBOX_IFA\tftp\u-initrd
    TFTP: Transfer erfolgreich beendet
    TFTP: Sende C:\Dokumente und Einstellungen\AdminUser\Desktop\Receiver & co\dbox2\kw image kabel2xi incl.scam and mg1.27.img
    TFTP: Transfer erfolgreich beendet
    TFTP: Schreibe Backup nach C:\Programme\DBOX_IFA\Backups\2008-04-28 16-34-31_545.img
    TFTP: Transfer erfolgreich beendet
    
    ------ Zusatzinformationen ------
    Gewählter Netzwerkadapter: ADMtek AN983-basierter Ethernetadapter - Paketplaner-Miniport (0)
    IP-Adresse des Netzwerkadapters: 192.168.0.1
    IP-Adresse die die dbox bekommt: 192.168.0.202
    Betriebssystem: Microsoft Windows XP Professional Service Pack 2 (Build 2600)
    CPU 1: AMD Athlon(tm) 64 Processor 3000+ @ 2000 MHz
    Dateiname des Images: kw image kabel2xi incl.scam and mg1.27.img
    Imagetyp: Zwei Flashs
    DBOX-IFA Version: 3.1
    ------ Powered by http://www.dboxservice-hallenberg.de ------
    
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Der log sieht völlig in Ordnung aus. Das es am Flash liegen tut glaube ich nicht denn das Image wird ja erfolgreich geschrieben. Aber was ich nicht verstehe ist das bei dir Betaresearch im Display steht wenn du Linux drauf hast.
     
    #2
  4. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    ich suche mal ne digicam hier in meiner bude und mach dann mal ne aufname bild oder video um das mit dem hell dunkel näher zu bringen!
     
    #3
  5. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Wenn möglich, denn lade das Video in wmv Format hoch. Die idee ist gut :)
     
    #4
  6. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    leider waren die schwankungen auf dem video nicht zu erkennen :( ist halt nur meine eyetoy cam ... deshalb hier einfach mal das foto vom display, von welchem das LOG stammt.

    [​IMG]
     
    #5
  7. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Das passt mit den Log gar nicht zusammen da im Log steht dass das Backup geschrieben wurde bzw geschrieben wird. Im Display sollte dann das Hallenberg logo stehen.
     
    #6
  8. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    hmm, kann es sein das die möhre irgendwie nen schreibschutz hat ? also das es so aussieht als würde er das image druffspielen, aber im enteffekt tut er das garnicht weil schreibgeschützt ?
     
    #7
  9. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    ok, ich versuche grade erneut zu flashen! das problem ist, wenn er jetzt bei löschen sektoren ist, braucht er unglaublich lange dafür. ca. 20-30 min pro sektor :(
     
    #8
  10. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Vielleicht ist der Bootloader im Eimer. Wird dir der Dbox beim Start angezeigt. Das erkennst du daran wenn viele Zahlen und Buchstaben im Display stehen. Es ist normal nicht möglich dass das Image geschrieben wird wenn der Schreibschutz on ist. Was passiert wenn du die Dbox ganz normal startest. Bleibt sie dann ebenfalls beim Bootloader stehen ?
     
    #9
  11. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    wenn ich die ganz normal starte kommt NUR das bild was auch auf dem foto oben ist!

    wie kann man denn den bootloader wieder fixen ? oder ist die box dann im eimer ?
     
    #10
  12. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    also ich denke mal die ganze misere hängt hiermit zusammen:

    Code:
    Lösche Sektoren: 11 von 63 (17%)Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Lösche Sektoren: 23 von 63 (36%)Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Lösche Sektoren: 55 von 63 (87%)Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    
    oder irre ich mich da? denn SO sah das bei meiner sagem box nicht aus die ich geflashed habe!
     
    #11
  13. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Wurde die Dbox vor kurzen im Debug Modus gesetzt oder hat sich schon mal funktioniert. Die Vermutung liegt nah das der Bootloader zerstört ist. Dieser wird ausgelötet und dann muss ein neuer wieder drauf. Im Netz gibt es ein paar Seiten die diesen Service anbieten.
     
    #12
  14. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    ich hab die in dem zustand bekommen! :(

    ich sehe auch, wenn ich die resette mit ausschalltknopf und pfeil anhc oben udn dann loslassen usw. da kommen keine zahlen im display! würde evtl. nen kompletter neuversuch den in debug zubringen helfen ?
     
    #13
  15. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.636
    Zustimmungen:
    17.914
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Was ist hier genau defekt ?

    Ich vermute mal das du beim Dbug einschalten den Bootloader zerstört hast. Wenn du den Schreibschutz aufheben tust, denn ist die Box sehr anfällig und dabei kann ganz leicht der Bootloader zerstört werden. Du kannst es ja noch mal versuchen den Debug einzuschalten. Eventuell hilft es ja was und du kannst ein neues Image flashen.
     
    #14
  16. N1con
    Offline

    N1con <img src="http://www.digital-eliteboard.com/images

    Registriert:
    18. Februar 2008
    Beiträge:
    411
    Zustimmungen:
    14
    Punkte für Erfolge:
    0
    Homepage:
    AW: Was ist hier genau defekt ?

    Wie gesagt ich hab die so bekommen, d.h. das Problem bestand von anfang an Sprich: N1con nix schuld, N1con anderes Baustelle

    das ist mein nächster Plan, danke dir soweit mal für die Infos! ich werde berichten, wie es läuft/gelaufen ist!
     
    #15

Diese Seite empfehlen