1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 USB

Dieses Thema im Forum "TP-Link Talk" wurde erstellt von nappi, 7. August 2012.

  1. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    TP Link 1043nd Openwrt, OSCAM mit Easymouse2 USB installation

    1. Installtion von OSCAM
    2. Installation von NFS und Samba
    3. Installtion USB Festplatte
    4. Firewall Configuration

    Dies Anleitung ist aus vielen Anleitungen aus dem Internet zusammen geschustert, auch fliesen hier einiges an Erfahrungen mit ein.

    Für alles was hier beschrieben ist braucht man eine Installation von Openwrt 10.03.1

    1. OSCAM
    Installation:Als erstes habe ich folgende Pakete über das OpenWRT Webinterface installiert:
    CCID
    libusb
    libopenssl
    ibpcsclite
    openssl-util
    pcscd
    kmod-usb-serial-ftdi
    Dann hab ich OScam aus diesem Link hier runtergeladen und nach /usr/bin kopiert und in oscam umbenannt:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Hier gibt es die Aktuelle Oscam für unseren Router

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Die Config Dateien welche nach /etc/config/oscam kopiert werden müssen wenn der Ordner nicht vorhanden ist dann einen machen.
    Nun den Reader anstecken und den Router neustarten
    Dann über putty Oscam starten.
    Startparameter für oscam
    oscam -b -c /etc/config/oscam/

    2. NFS und Samba
    Installation:
    Folgende Pakete werden benötigt
    Am besten über putty installieren
    nfs-kernel-server
    libwrap
    libuuid
    kmod-fs-nfsd
    kmod-fs-exportfs
    kmod-fs-nfs
    portmap
    kmod-fs-nfs-common
    nfs-kernel-server-utils
    nfs-server
    nfs-utils
    libevent
    unfs3
    Falls ein Paket nicht zu installieren geht dann macht es über Luci, aber nur wenn unbedingt nötig.

    opkg update
    opkg install nfs-kernel-server
    vi /etc/exports
    . /etc/init.d/portmap start
    . /etc/init.d/portmap enable
    . /etc/init.d/nfsd start
    . /etc/init.d/nfsd enable
    netstat –a
    hier ein Konfiguration Beispiel,
    /mnt/sda2 192.168.1.2,192.168.1.3,192.168.1.4(ro,sync,no_subtree_check) /mnt/sda3 192.168.1.2(rw,sync,no_subtree_check) /mnt/sda4 192.168.1.3(rw,sync,no_subtree_check)

    Wenn er fertig seid mit der Bearbeitung der /etc/exports dann einfach :
    exportfs –ar
    damit er alles übernimmt

    Das er beim Boot Vorgang alles ladet gibt folgendes ein
    [FONT=&quot] /etc/init.d/portmap start[/FONT]
    [FONT=&quot] /etc/init.d/nfsd start[/FONT]
    [FONT=&quot] /etc/init.d/portmap enable[/FONT]
    [FONT=&quot] /etc/init.d/nfsd enable[/FONT]
    [FONT=&quot] [/FONT]
    Nach dem start kann man über top oder ps nachschauen ob die Services laufen
    Es sollte folgende ausgabe haben in den Prozessen
    /usr/sbin/rpc.mountd -p 32780
    /usr/sbin/rpc.statd -p 32778 -o 32779
    /usr/sbin/portmap

    Nun zu Samba,
    folgende Pakete werden benötigt
    samba3
    kmod-fs-???? Die Fragezeichen stehen für das Filesysteme was ihr nutzen wollt, meine Festplatte hat EXT4 somit lade ich nur die
    kmod-fs-ext4 runter
    luci-app-samba, braucht man nicht aber wer über Weboberfläche machen will kann es runterladen.

    Wir installieren die 2 oder 3 Pakete über Putty.
    Nun editieren wir die
    /etc/init.d/samba
    Nach belieben ab.
















    Hier eine Beispiel Config:
    config samba
    option 'name' 'openwrt'
    option 'workgroup' 'openwrt'
    option 'description' 'openwrt'
    option 'homes' '1'

    config sambashare
    option 'name' 'usb'
    option 'path' '/mnt/usb/'
    option 'read_only' 'no'
    option 'guest_ok' 'no'
    option 'create_mask' '0700'
    option 'dir_mask' '0700'
    #option 'users' 'abc'
    Nun restarten wir Samba mit,
    /etc/init.d/samba restart

    Was hier genau passiert habe ich nicht richtig verstanden aber hab es trotzdem duchgeführt.

    /etc/init.d/samba disable smbd -D
    nmbd –D
    Start on Boot
    /etc/init.d/samba enable
    /etc/init.d/samba start

    Nun installieren wir über Putty:
    shadow-useradd

    Nun geben wir in putty
    useradd Deinuser
    passwd deinuser
    smbpasswd deinuser hierDasPAsswort









    3. Installtion von der USB Festplatte
    Zuerst erstellen wir einen neuen ordner in /mnt/
    mkdir /mnt/sda1

    Folgende Pakete werden benötigt, wir installieren über Putty
    kmod-usb-storage
    kmod-fs-ext4 ß ihr müsst die version laden vom filesystem eurer festplatte

    wir verbinden die usb platte mit dem router
    Nun geben wir über putty ein
    Blkid

    Nun sollte eine ausgabe erscheinen die in etwa so aussieht
    /dev/sda1: UUID="e3e38a66-7d58-4ffc-b7c3-e75e4ed0d71e"

    Das die Festplatte Automtisch gemountet wird installieren wir über Putty noch
    block-mount
    block-hotplug

    Nun wird der automount gemacht mit :
    [FONT=&quot]/etc/init.d# ./fstab enable[/FONT]
    [FONT=&quot] [/FONT]
    [FONT=&quot]Nun müssen wir noch die [/FONT]
    [FONT=&quot]/etc/config/fstab [/FONT]
    [FONT=&quot]Bearbeiten nach belieben[/FONT]
    [FONT=&quot] [/FONT]
    config global automount
    option from_fstab 1
    option anon_mount 0

    config global autoswap
    option from_fstab 1
    option anon_swap 0

    config mount
    option target /mnt/sda1
    option device /dev/sda1
    option fstype ext4
    option options rw,sync
    option enabled 1
    option enabled_fsck 0

    config swap
    option device /dev/sda2
    option enabled 0



    4.Firewall Konfiguration
    Der einfachste weg ist dieser, man geht auf die Weboberfläche von Luci und stellt bei Wan folgendes ein.
    Reject.

    Somit sind alle ports zu.
    Da wir ja mindestens einen offenen Port haben müssen der von aussen erreichbar sein soll machen wir folgendes über putty.

    root@OpenWrt:~# uci add firewall rule
    root@OpenWrt:~# uci set firewall.@rule[-1].src=wan
    root@OpenWrt:~# uci set firewall.@rule[-1].target=ACCEPT oder Reject
    root@OpenWrt:~# uci set firewall.@rule[-1].proto=tcp
    root@OpenWrt:~# uci set firewall.@rule[-1].dest_port= OscamPort
    root@OpenWrt:~# uci commit firewall
    root@OpenWrt:~# /etc/init.d/firewall restart

    Das klappt, vorher habe ich über Luci gemacht aber der hat nie den port geöffent, oder habe die Firewall.user bearbeitet mit der Rule aber selbes ergebnis port blieb dicht.
    Aber mit UCI hat es sofort geklappt.

    Wer Fehler findet in der Rechschreibung darf sie behalten, wer aber Fehler findet oder verbesserungen vorschlägt darf sich gerne am tutorial auslasssen.

    Dieses Tutorial darf nur im DEB weiterverbreitet werden, ich wünsche nicht das es in allen foren auftaucht.
    Big Thx an Viper ohne dessen grossartige Vorarbeit dieses hier nicht möglich gewesen würde


    Falls der Router keine Wan IP vom Modem bekommt ist das hier die Lösung,
    Zum Router und Internet problem das habe so gelöst

    #### WAN configuration
    config interface wan
    option ifname "eth0.1"
    option proto dhcp

    macht es über Luci das geht am einfachsten
    Dann hat er eine IP direkt bekomme


    Falls der Router keine Wan IP vom Modem bekommt ist das hier die Lösung,

    #### WAN configuration
    config interface wan
    option ifname "eth0.1"
    option proto dhcp

    macht es über Luci das geht am einfachsten
    Dann hat er eine IP direkt bekomme
     
    Zuletzt bearbeitet: 7. August 2012
    #1
    Pretender666 gefällt das.
  2. phantom

    Nervigen User Advertisement

  3. Pretender666
    Offline

    Pretender666 Elite Lord

    Registriert:
    28. Juli 2008
    Beiträge:
    3.207
    Zustimmungen:
    708
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Hallo,

    bei mir sind die angegebenen Packete im Webinterface unter Software nicht vorhanden. Habe frisch geflasht von der STOCK Firmware aus. Der Router läuft bei mir bislang nur als AP im gleichen Netz.
    Also am WAN habe ich nichts angeschlossen.
     
    #2
  4. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.552
    Zustimmungen:
    938
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Hast du die Paketquellen aktualisiert?
    mittels putty : opkg update
    Odda im Webinterface in der Paketverwaltung ganz oben, so ein grüner knopp!
     
    #3
  5. Pretender666
    Offline

    Pretender666 Elite Lord

    Registriert:
    28. Juli 2008
    Beiträge:
    3.207
    Zustimmungen:
    708
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Ah danke,

    hat super geklappt.

    Oscam rennt schon :)

    Problem:

    wollte jetzt USB nutzen aber krieg fstab nicht zum laufen.

    root@OpenWrt:/# /etc/init.d/fstab start
    /etc/rc.common: .: line 33: can't open '/lib/functions/fsck/*.sh'
    root@OpenWrt:/#

    weiß jemand wo das Problem ist? Der fsck Ordner ist leer.
     
    Zuletzt bearbeitet: 15. September 2012
    #4
  6. SymbolB
    Offline

    SymbolB Ist gelegentlich hier

    Registriert:
    27. November 2009
    Beiträge:
    66
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Hallo, wollte das grade auf meinen WDR4900 anwenden, aber bekomme im Systemstartprotokoll:
    Sun Oct 20 07:05:12 2013 kern.emerg /bin/oscam: line 1: syntax error: unexpected "("

    Hilfe...
    PS: hatte die .tar.gz Oscam entpackt und nur die oscam nach /bin kopiert und auf 777 gesetzt... fehler?
     
    #5
  7. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.552
    Zustimmungen:
    938
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    weil du die falsche architektur verwendest.
    Ich bau dir ebn ein Image warte.
     
    #6
  8. SymbolB
    Offline

    SymbolB Ist gelegentlich hier

    Registriert:
    27. November 2009
    Beiträge:
    66
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Man da bist Du ja wieder ;) Hoffe geht allen Gut, " Nachwuchs " ;)
     
    Zuletzt von einem Moderator bearbeitet: 20. Oktober 2013
    #7
  9. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.552
    Zustimmungen:
    938
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Joar nachwuchs bestimmt den tagesablauf. ;)

    Dieses Imaga hier funktioniert nur mit dem Tplink WDR 4900:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #8
  10. busbauen
    Offline

    busbauen Ist gelegentlich hier

    Registriert:
    17. März 2013
    Beiträge:
    71
    Zustimmungen:
    6
    Punkte für Erfolge:
    0
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Wie viele Clients hast du dran hängen? Wie viele kann man da maximal dranhängen? Ist da der Router der Flaschenhals oder wo liegt der?
     
    #9
  11. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.552
    Zustimmungen:
    938
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Tp link 1043nd mit Openwrt, OSCAM, Firewall, Festplatte, NFS Samba, Easymouse2 US

    Ich hab einen dran. Theoretisch bekommst du da 1000 clienten dran. Es kommt drauf an welche karte(n) du hast.

    Gesendet von meinem HTC One XL mit Tapatalk
     
    #10

Diese Seite empfehlen