1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo Smargo V2 zum laufen bringen

Dieses Thema im Forum "Cardreader/Cardwriter" wurde erstellt von 21a, 21. Dezember 2013.

  1. 21a
    Offline

    21a Newbie

    Registriert:
    17. Dezember 2013
    Beiträge:
    19
    Zustimmungen:
    20
    Punkte für Erfolge:
    3
    Hallo Community !

    Da ich mit meinem SmargoV2 (nachfolger des SmargoPlus) anfangs Probleme hatte die Serial auszulesen (es wurden mit Debian 8xLeerzeichen angezeigt, unter Win garkein erfolg), hier ne kleine Beschreibung wie ich vorgegangen bin um das Teil zum Laufen zu bringen.
    Die kurze Anleitung bezieht sich nur auf Linux.


    1. Verbindet euch mit eurem SSH Client auf euren Server, bzw startet die Konsole wenn ihr schon am Linux System sitzt.

    2. Ladet nun die beiden Tools "Smargo V2 Firmware Update" und "Smargo V2 Settingstool" runter..

    Code:
    wget http://www.argolis.com/files/smartreader2update_v10_linux_x86.zip
    Code:
    wget http://www.argolis.com/files/smartreader2tool_v10_linux_x86.zip
    .. und entpackt sie.

    Code:
    unzip smartreader2update_v10_linux_x86.zip
    Code:
    unzip smartreader2tool_v10_linux_x86.zip

    3. Jetzt machen wir die beiden Dateien Ausführbar.

    Code:
    chmod a+rx smartreader2update
    Code:
    chmod a+rx smartreader2tool
    4. Als erstes wird nun der SmargoV2 geupdatet mit

    Code:
    sudo ./smartreader2update
    5. Nun können wir mit follgendem Befehl dem SmargoV2 eine eigene Serial verpassen.
    Wobei die "XXXXXXXX" mit eurer gewünschten Buchstaben\Zahlen Kombination zu ersetzten ist.

    Code:
    sudo ./smartreader2tool -n XXXXXXXX
    Beispiel
    Code:
    sudo ./smartreader2tool -n DEBSMRV2
    6. Das Tool sollte den Befehl bestätigen was wir wiederum mit follgendem Befehl überprüfen.

    Code:
    lsusb -v | grep Serial
    Ausgabe :
    ....
    ....
    ....
    Bus 001 Device 008: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
    idProduct 0x6001 FT232 USB-Serial (UART) IC
    iSerial 3 DEBSMRV2


    7. In der oscam.server könnt ihr nun den Smargo hinzufügen, in diesem Beispiel für die v14


    Code:
    [reader]
    label                         = v14
    enable                        = 0
    protocol                      = smartreader
    device                        = SRv2;Serial:DEBSMRV2
    caid                          = 098C
    boxid                         = 12345678
    detect                        = cd
    mhz                           = 369
    cardmhz                       = 369
    group                         = 1
    emmcache                      = 1,3,2


    Das wars auch schon, hoffe es hilft euch, wie es mir geholfen hat!

    So far #Copy&Paste friendly# 21a

    Schöne Feiertage !
     
    #1
    stewic66, masterjoda, madro17 und 6 anderen gefällt das.
  2. phantom

    Nervigen User Advertisement

  3. Nappy08
    Offline

    Nappy08 Chef Mod Digital Eliteboard Team

    Registriert:
    19. Oktober 2008
    Beiträge:
    6.894
    Zustimmungen:
    4.529
    Punkte für Erfolge:
    113
    Ort:
    DEB
    AW: Smargo V2 zum laufen bringen

    Vielen Dank für die Anleitung. Ich habe mir mal erlaubt die oben anzupinnen.
     
    #2
  4. harryhallers
    Offline

    harryhallers Newbie

    Registriert:
    6. November 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Smargo V2 zum laufen bringen

    Hallo,

    leider bekomme ich beim Ausführen einen Fehler:
    Evtl. ein Fehler mit der Executable vor? Hat jmd. eine Idee?

    Grüße.
     
    #3
  5. 21a
    Offline

    21a Newbie

    Registriert:
    17. Dezember 2013
    Beiträge:
    19
    Zustimmungen:
    20
    Punkte für Erfolge:
    3
    AW: Smargo V2 zum laufen bringen

    Den Fehler bekam ich auch als ich probierte das ganze über mein Raspberry mit Raspbian auszuführen. Habe dann mein Notebook mit Ubuntu genommen, vllt installierste dir rasch ne kleine vmware.
     
    #4
  6. harryhallers
    Offline

    harryhallers Newbie

    Registriert:
    6. November 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Smargo V2 zum laufen bringen

    Danke, so gehts!
     
    Zuletzt von einem Moderator bearbeitet: 16. Januar 2014
    #5
  7. Lattenjup
    Offline

    Lattenjup Hacker

    Registriert:
    5. März 2011
    Beiträge:
    452
    Zustimmungen:
    7
    Punkte für Erfolge:
    18
    AW: Smargo V2 zum laufen bringen

    bekomme auch die fehlermeldung sudo nicht gefunden
    was kann ich da machen gibt es noch eine andere möglichkeit für smartreader einzustellen für oscam
    windows7 64b mit telnet
     
    #6
  8. ridla
    Offline

    ridla Newbie

    Registriert:
    27. Januar 2008
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Smargo V2 zum laufen bringen

    bin leider nicht sehr erfahren und mal nach Anleitung gearbeitet...bis 3. alles gut aber...
    [~] # sudo ./smartreader2update
    sudo: unknown user: root
    sudo: unable to initialize policy plugin
    sollte dazu sagen das ich ein QNAP TS 251 als server nutzen möchtw, hab etwas gegoogelt scheint grundlegend ein root admin prob zu sein...
    wenn ich ohne "sudo" ausführe weil ich als admin root rechte habe erscheint das...

    /smartreader2update: /lib/libc.so.6: version `GLIBC_2.15' not found (required by ./smartreader2update)


    was muss ich machen----?
     
    Zuletzt bearbeitet: 12. Februar 2015
    #7
  9. ridla
    Offline

    ridla Newbie

    Registriert:
    27. Januar 2008
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Smargo V2 zum laufen bringen

    bin leider nicht sehr erfahren und mal nach Anleitung gearbeitet...bis 3. alles gut aber...
    [~] # sudo ./smartreader2update
    sudo: unknown user: root
    sudo: unable to initialize policy plugin

    was muss ich machen----?

    - - - - - - - - - -

    bin leider nicht sehr erfahren und mal nach Anleitung gearbeitet...bis 3. alles gut aber...
    [~] # sudo ./smartreader2update
    sudo: unknown user: root
    sudo: unable to initialize policy plugin

    hab etwas gegoogelt..
    scheint bei Qnap zu liegen da ich ein TS 251 nutze...admin = root...habe ohne "sudo" versucht auszuführen dann kommt das...

    ./smartreader2update: /lib/libc.so.6: version `GLIBC_2.15' not found (required b y ./smartreader2update)
    ./smartreader2tool: /lib/libc.so.6: version `GLIBC_2.7' not found (required by . /smartreader2tool)



    was muss ich machen----?
     
    #8

Diese Seite empfehlen