1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Problem bei Einbindung von camd3 keyserver in oscam

Dieses Thema im Forum "CS Allgemein" wurde erstellt von towly, 9. August 2012.

  1. towly
    Offline

    towly Newbie

    Registriert:
    9. August 2012
    Beiträge:
    3
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    Hallo,


    nachdem ich mich nun (nach langer Zeit) mal wieder mit dem Thema CS und Oscam beschäftigt habe, bin ich nun mit meinem Latein am Ende. Oscam (OSCAM 1.20-unstable_svn build #5789) läuft hier auf einem Alix Board mit S02 und HD02 - neu installiert - alles O.K. Nun habe ich nach dieser Anleitung (

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    ) versucht, Camd3 als Keyserver für ORF einzubinden (camd3.x86 aus dem link). Camd3 Webinterface ist erreichbar (user&keyfile sind da, Pfade stimmen also), allerdings meldet sich der in Oscam eingerichtete Reader einfach nicht an. Auch ein im Netz auf einem E2 Receiver (SH4 / Camd3.902) installierter client mit entsprechender config ist im Webinterface nicht sichtbar/logt sich nicht ein. Mit Sicherheit habe ich etwas übersehen bzw. nicht verstanden, hier meine Config-files:

    camd3.conf:

    UDP_PORT=33455
    HTTP_PORT=9090
    HTTP_ADMIN=++++++
    HTTP_PASSWORD=++++++
    LOG=1
    BOX_TYPE=9
    DNS_CACHE=600
    LOG_FILE=/camd3.log
    #BOX2_AU=1
    USERS=/var/etc/camd3/camd3.users
    SERVERS=/var/etc/camd3/camd3.servers
    KEYS=/var/etc/camd3/camd3.keys
    SOCKET=/var/tmp/camd.socket
    oscam.server:
    [reader]
    label = austriasat
    protocol = camd35
    device = localhost,33455
    user = server
    password = server
    services = austriasat
    caid = 0D95
    group = 2

    [user noch wie im Beispiel, wird sobald es funzt geändert]

    oscam.services:
    [austriasat]
    caid = 0D05
    provid = 000000,000004,000010
    srvid = 003E,0045,0046,07FA,07FD,07FF,2EFE,4461,4462,6FEE,6FEF,6FF0,6FF3,6FFF,003B,132F,1330,32C9,32CA,32CB,32CC,32CD,32CE,32CF,32D0,32D1,32D2,32D3,32D4,3332,4E27,6FEE,6FEF,6FF0,6FF1,6FF3,6FFF,6FFA
    Ausgabe im Oscam Debug:
    2012/08/09 16:43:31 8785FF0 h restarting reader austriasat
    2012/08/09 16:43:31 8785FF0 h creating thread for device localhost
    2012/08/09 16:43:31 878F748 p camd35 proxy localhost:33455
    2012/08/09 16:43:31 878F748 p proxy austriasat initialized (server=localhost:33455)
    2012/08/09 16:43:42 878F748 p client killed
    2012/08/09 16:43:42 878F748 p tcp_conn_close(): fd=0, cl->typ == 'p' is_udp 0
    Normalerweise versuche ich meine Probleme selbst zu lösen, also seid mir nicht böse wenn die Lösung offensichtlich ist (sitze vielleicht einfach schon zu lange vor der Kiste). Hoffe ihr könnt mir helfen, towly.
     
    Zuletzt von einem Moderator bearbeitet: 9. August 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. chris2910
    Offline

    chris2910 Freak

    Registriert:
    22. Oktober 2010
    Beiträge:
    241
    Zustimmungen:
    241
    Punkte für Erfolge:
    43
    Ort:
    Na Hier
    AW: Problem bei Einbindung von camd3 keyserver in oscam

    ich würde beide caid´s zuweisen (0D05,0D95) :DDD
     
    #2
    towly gefällt das.
  4. towly
    Offline

    towly Newbie

    Registriert:
    9. August 2012
    Beiträge:
    3
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    AW: Problem bei Einbindung von camd3 keyserver in oscam

    Danke für die Antwort,

    mache ich gleich. Allerdings ist mein Problem, daß einfach keine Anmeldung am Camd3 erfolgt, sowohl bei Oscam als reader als auch bei einem "Testclient" (s.o.). Die Line im Camd3 Webinterface (users) hinter dem user "server" ist unter das "last seen" schlicht und einfach leer...

    habe gerade den Laberthread zum Thema "entdeckt", lese ich mir mal durch... für heute reichts mir aber...
     
    Zuletzt bearbeitet: 9. August 2012
    #3
  5. chris2910
    Offline

    chris2910 Freak

    Registriert:
    22. Oktober 2010
    Beiträge:
    241
    Zustimmungen:
    241
    Punkte für Erfolge:
    43
    Ort:
    Na Hier
    AW: Problem bei Einbindung von camd3 keyserver in oscam

    meine config sieht so aus

    camd config:
    BOXTYPE=1
    UDP_PORT=24110
    LOG=1
    DNS_CACHE=600
    LOG_FILE=/camd3.log
    LOG_HOST=192.168.178.15
    HTTP_HOST=192.168.178.15
    HTTP_PORT=20104
    HTTP_ADMIN=camd
    HTTP_PASSWORD=camd
    DBOX2_AU=1
    USERS=/camd3.users
    SERVERS=/camd3.servers
    KEYS=/camd3.keys
    SOCKET=/var/tmp/camd.socket
    SLOT=/dev/tts/1:1:1:1:1:997:com1:CAR
    server:

    cs357x://chris:12345@192.168.178.15:24110

    user:

    chris:12345

    hast du ein user und server in camd 3 angelegt?
     
    Zuletzt von einem Moderator bearbeitet: 9. August 2012
    #4
    towly gefällt das.
  6. towly
    Offline

    towly Newbie

    Registriert:
    9. August 2012
    Beiträge:
    3
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    AW: Problem bei Einbindung von camd3 keyserver in oscam

    Danke für die Hilfe, Problem gelöst: hatte als localhost 127.0.0.1 und localhost eingegeben, mit der IP des Oscam funzt es... oh mann!
     
    #5
    szonic und Pilot gefällt das.

Diese Seite empfehlen