1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk [OScam Supportanfrage] OSCam 2 OSCam timeout/hohe ecms

Dieses Thema im Forum "OScam Archiv" wurde erstellt von cirtaP, 3. April 2012.

  1. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [gelöst] OSCam 2 OSCam timeout/hohe ecms

    Ich habe BoxA mit Oscam only und BoxB mit Oscam only. Diese sind mit cccam ext verbunden. BoxA ist eine Dreambox und BoxB ist ein Ubuntu System. Am PC habe ich im Smargo eine V13. (ich bekomm auf der Dream zum verrecken kein smargosupport) In der Dream ist eine HD01 somit sind die slots voll. HD01 läuft einwandfrei aber die v13 zickt rum. In der Serverbox wird die Karte gelesen und auch die Anfragen bearbeitet. ECM zeiten liegen bei ca 150ms allerdings zeigt mir die Dream timeout >5000ms an. Das ganze läuft nur intern, da sollte maximal 1ms bis 5ms für die Übertragung dazukommen. Zeitweise wird mir auch was von "invalid" angezeigt. Die Probleme sehe ich nur auf der Dream. Leider komm ich grad gar nicht weiter, ich suche schon seit 1 Woche nach einer Lösung bzw. probiere unterschiedliche Settings aus. Camd35 und Newcamd habe ich auch schon probiert, da habe ich das gleiche Problem. Anbei sind die Configs und logs (nur Dream):

    config
    Code:
    [global]
    max_cache_time                = 7
    cacheexwaittime               = 150
    logfile                       = /var/tuxbox/logs/oscam.log;stdout
    maxlogsize                    = 500
    loghistorysize                = 8192
    usrfile                       = /var/tuxbox/logs/oscamuser.log
    usrfileflag                   = 1
    clienttimeout                 = 5000
    failbantime                   = 15
    dropdups                      = 0
    unlockparental                = 1
    nice                          = -10
    readerrestartseconds          = 10
    saveinithistory               = 1
    lb_mode                       = 0
    preferlocalcard               = 0
    waitforcards                  = 0
    
    [cccam]
    port                          = xxxxx
    ignorereshare                 = 0
    forward_origin_card           = 1
    version                       = 2.3.0
    keepconnected                 = 1
    stealth                       = 0
    reshare_mode                  = 0
    
    [dvbapi]
    enabled                       = 1
    au                            = 1
    boxtype                       = dreambox
    user                          = dvbapi
    pmt_mode                      = 0
    request_mode                  = 0
    
    [webif]
    httpport                      = +xxxxx
    httphelplang                  = de
    httpuser                      = xxxxxxxx
    httppwd                       = xxxxxxxx
    httpcert                      =
    httpjscript                   =   
    httprefresh                   = 7
    httpallowed                   = xxxxxxxxxxxx
    httpdyndns                    = 
    httpreadonly                  = 0
    httpsavefullcfg               = 1

    dvbapi
    Code:
    P: 09C4
    P: 1830
    
    M: 1843 1830
    
    I: 1834
    I: 09C7
    I: 1702

    server
    Code:
    [reader]
    label                         = srv
    enable                        = 1
    protocol                      = cccam
    device                        = xxx.xxx.xxx.xxx,xxxxx
    user                          = xxx
    password                      = xxx
    services                      = skyv13,hdplus
    inactivitytimeout             = 30
    reconnecttimeout              = 30
    caid                          = 09C4,1830
    showcls                       = 10
    group                         = 4
    emmcache                      = 1,3,2
    blockemm-unknown              = 1
    blockemm-g                    = 1
    cccversion                    = 2.3.0
    cccmaxhops                    = 2
    ccckeepalive                  = 1
    cccreshare                    = 1
    audisabled                    = 0
    auprovid                      = 

    services
    Code:
    [skyv13]
    caid   = 09C4
    srvid  = 0008,0009,000A,000B,000C,000D,000E,0010,0011,0013,0014,0015,0016,0017,0018,0019,001A,001B,001C,001D,0021,0022,0023,0024,0025,0026,0027,0029,002A,002B,0032,0034,0035,0037,0038,0039,003A,003C,003D,003E,003F,0040,0041,0042,0043,0044,0069,006A,006B,006C,006C,006F,0070,0071,0072,0074,0076,0077,007A,007B,007C,007D,007E,007F,0080,0081,0082,0083,0084,00A8,00DD,00DE,00DF,00FC,00FD,0106,0107,0110,0111,011A,011B,0124,0125,012E,012F,0138,0139,0142,0143,014C,014D,0156,0160,016B,0175,0201,0203,0204,0206,07FF,2EFE,3331,4461,4462,6FF1,7001,7009,700A
    
    [hdplus]
    caid   = 1830,1843
    srvid  = 1519,277E,5273,5274,EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77

    user
    Code:
    [account]
    user                   = dvbapi
    pwd                    = 
    uniq                   = 1
    caid                   = 09C4,1830
    au                     = hdplus_hd01,sky_v13
    group                  = 1,2,4
    services               = hdplus,skyv13
    monlevel               = 4
    cccmaxhops             = 3
    cccreshare             = 1
    cccstealth             = 0

    log
    Code:
    dvbapi (09C4&000000/0008/90:411E): timeout (0 ms) (2 of 2)
    dvbapi (09C4&000000/0008/90:411E): timeout (4001 ms) (2 of 2)
    

    Im WebIF steht häufig auch folgendes:
    [TABLE="class: status, width: 100%"]
    [TR="class: c"]
    [TD="class: statuscol12"]09C4:0008[/TD]
    [TD="class: statuscol13"]Sky: Sky Comedy[/TD]
    [TD="class: statuscol14"]by invalid (0ms)[/TD]
    [/TR]
    [/TABLE]
    In der Serverbox kommt die ECM Anfrage trotzdem an und wird mit ca 150ms beantwortet... ich kann mir solangsam kein reim mehr darauf machen. Wenn die Configs des Servers benötigt werden, bitte melden ich habe diese weggelassen weil ich die auf dem Lappi nicht zur Verfügung habe (copy&paste) Ich hab debug auf 255.

    Schonmal Vielen Dank für Hilfe, Lösungen und Denkanstöße im voraus.
     
    Zuletzt bearbeitet: 15. April 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. Timmes123
    Offline

    Timmes123 Newbie

    Registriert:
    16. August 2011
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    nur fürs verständnis, hast du jetzt die hd01 in der dream und die v13 im server?
    oder beides im server? weil bei deiner config so wie se ist, ist ja in der dream gar keine karte vorhanden
     
    #2
  4. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja weil die hd01 läuft (in der dream) hab ich die aus dem post weg gelassen.
     
    #3
  5. Timmes123
    Offline

    Timmes123 Newbie

    Registriert:
    16. August 2011
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    ich bin mir nicht sicher, da ich nicht mit dvbapi arbeite
    aber muss nicht für jeden user ein passwort hinterlegt werden?
    vielleicht hat er deswegen keine rechte die reader zu verwenden?!
    [account]
    user = dvbapi
    pwd = dvbapi


    was mir aufgefallen ist, was mit dem problem aber nix zu tun hat ist
    au = hdplus_hd01,sky_v13

    da muss dein reader "srv" rein sonst schickste keine updates auf den server
     
    #4
  6. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    damn sorry etwas wesentliches vergessen reine cccam clients laufen, die dvbapi läuft teilweise auch weil ab und zu (bei 30 mal zappen) kurz eine Anfrage innerhalb der von mir gesetzten zeit zurückkommt. (5000ms) au werde ich hinzufügen das passwort bei der dvbapi hab ich noch nie gesetzt gehabt und es hat bislang immer funktioniert.

    kann leider heute nicht mehr weiter testen den rest muss ich morgen ausprobieren. und danke für deine wertvolle zeit.
     
    #5
  7. Timmes123
    Offline

    Timmes123 Newbie

    Registriert:
    16. August 2011
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    hmm das einzige was ich noch versuchen würde wäre bei dvbapi

    request_mode = 1 # versuche alle CAIDs simultan

    aber wie gesagt.. bis jetzt nie damit gearbeitet :>
     
    #6
  8. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habs nun getestet request_mode=1 bringt leider nicht den gewünschten erfolg.
    Mir ist aufgefallen das bei den ECM Anfragen der oscam noch eine weitere zeile auftaucht, die bei den cccam clienten nicht auftaucht. ich weiss aber nicht was dies zu bedeuten hat:
    request_cw stage=3 to reader srv ecm=111A (Den wert hab ich mir jetzt ausgedacht)

    Ich kann einfach nicht nachvollziehen warum oscam -> cccam die daten innerhalb der vom server stehenden Zeit ankommen und bei oscam -> oscam das ganze über 5 sek steigt.


    EDIT:
    Ich kann jetzt nicht ganz nachvollziehen wo der fehler liegt aber "cccam ext" ausgeschaltet und auf cccam umgestellt läuft es komischerweise. Könnte das vielleicht etwas mit "numusers" zu tun haben? Denn wenn ich es richtig verstanden habe, werden ja simultan anfragen gestellt wenn "ext" verwendet wird. Wie dem auch sei ich wert das ganze mal testen und nochmal alle logs durchforsten. Vielleicht finde ich den Fehler noch dann werd ich mich hier noch einmal melden.
     
    Zuletzt bearbeitet: 4. April 2012
    #7
  9. handyman1983
    Offline

    handyman1983 Hacker

    Registriert:
    14. März 2010
    Beiträge:
    450
    Zustimmungen:
    39
    Punkte für Erfolge:
    28
    Kann dir nur empfehlen zum server eine camd3 Verbindung zu machen dann hast auch keine Probleme mit AU auf verschiede karten !
     
    #8
  10. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    eine camd verbindung bringt mir aber die gleichen fehler also beim umschalten ab und zu kurz bild und dann wieder timeout oder invalid. das war die erste variante die ich ausprobiert habe. bis die verbindung stand also der login klappte (wurde nur srrverseitig angezeigt) habe ich schon ne halbe ewigkeit gebraucht. wenn ich den fehler dort wegbekommen würde wäre mir das genauso recht. hätte ich denn in dem fall auch die cache funktion?
     
    #9
  11. handyman1983
    Offline

    handyman1983 Hacker

    Registriert:
    14. März 2010
    Beiträge:
    450
    Zustimmungen:
    39
    Punkte für Erfolge:
    28
    für caches braucht man einen separaten user !

    Aber wozu !

    Teste mal so

    Oscam.conf

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapiau


    oscam.server
    [reader]
    label = server-home
    protocol = camd35
    device = 192.168.0.XXXXX,20250
    user = User
    password = User
    inactivitytimeout = 0
    group = 3
    lb_weight = 200



    Auf dem Server

    oscam.conf
    [cs357x]
    port = 20250


    oscam.user
    [account]
    user = user
    pwd = user
    description = Wohnzimmer
    group = 1,2,3,4,5,6,7
    au = skysat,skysat2,hdplus,hdplus2,orfsat,pent
    services = hdplus,skyfullhd,!skyselect,!bluemovie,sportdigital,!nosky,orf,camd3emu,pent,srgswiss
    cccmaxhops = 2
    cccreshare = 0
    cccignorereshare = 1
     
    #10
  12. cirtaP
    Offline

    cirtaP Newbie

    Registriert:
    23. Juli 2011
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mit camd35 hab ich jetzt erstmal wieder das problem das sich die beidem oscams nicht miteinander verbinden -.- werd da noch ein bischen rumtüffteln

    Edit:
    Ich habs jetzt über cccam am laufen. Camd35 hat bei mir nicht hingehauen, ich weiss allerdings nicht warum. Der Login hat einfach nicht funktioniert. Der Fehler lag bei den "cacheex" Einstellungen. Ich weiss nicht genau warum, da ich es jetzt erstmal deaktiviert habe.

    Fazit: Falsche cacheex Einstellungen können die ECM Anfragen/Antworten blockieren.
     
    Zuletzt bearbeitet: 7. April 2012
    #11

Diese Seite empfehlen