1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam/CCcam user offline

Dieses Thema im Forum "OScam Archiv" wurde erstellt von janheigener, 20. Juni 2010.

  1. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Zunächst meine Konfiguration:

    Ubuntu-Server mit Easymouse2 und D09.

    In meinem Receiver steckt ein Diablo Wifi mit der Underworld 2.00.


    Auf dem Server laufen Ocam und CCcam:

    Oscam als Cardreader. Karte wird auch gelesen.

    CCcam verbindet sich als Client.

    Das Diablo Wifi verbindet sich als als Client am CCcam-Server.


    Nun zu meinen Problemchen:

    Das Diablo verbindet sich korrekt zum CCcam-Server. Dies wird mir sowohl im Webinterface von CCcam als auch im Diablo-Menü bestätigt. Allerdings verschwindet der Diablo-User nach 20 Sekunden aus der Liste "Active Clients", befindet sich aber weiterhin unter "connected clients".

    Der CCcam-User wird im Webinterface von Oscam unter "Status" als online angezeigt, aber unter "Users" steht er als offline.

    Fazit: im Moment wird nichts helle...

    CCcam.cfg
    Code:
    N: 127.0.0.1 15000 1337 1337 01 02 03 04 05 06 07 08 09 10 11 12 13 14 1
    
    F: XXX XXX
    
    DISABLE EMM : yes
    
    oscam.conf
    Code:
    [global]
    Nice = -1
    WaitForCards = 1
    ClientTimeout = 30
    LogFile = stdout
    Level = 15
    CacheDelay = 10
    PreferLocalCards = 1
    
    [newcamd]
    Key = 0102030405060708091011121314
    Port = 15000@1834:000401
    
    [webif]
    httpport = 16002
    httpuser = XXX
    httppwd = XXX
    httprefresh = 7
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    
    oscam.server
    Code:
    [reader]
    label = KD
    protocol = mouse
    #smargopatch = 1
    detect = CD
    device = /dev/ttyUSB0
    group = 1
    emmcache = 1,3,2
    N3_rsakey = XXX
    N3_boxkey = XXX
    mhz = 600
    cardmhz = 600
    caid = 1702,1722,1833,1834
    #caid = 1834
    
    oscam.user
    Code:
    [account]
    user                  = 1337
    pwd                   = 1337
    disabled              = 0
    expdate               =
    group                 = 1
    hostname              =
    uniq                  = 0
    sleep                 = 0
    monlevel              = 2
    au                    = kd
    services              = kdfull,!kdfull,skyfullhd,!skyfullhd
    caid                  = 1834&FFFF, 1833&FFFF, 1702&FFFF, 1722&FFFF
    betatunnel            =
    ident                 = 1834:000401
    keepalive             = 1
    
    oscam.provid
    Code:
    1834:000401|KD|N3|German
    1833:000401|Sky|N3|German
    1702:000000|Sky|N3|German
    1722:000000|Sky|N3|German
    
    oscam.services
    Code:
    [kdfull]
    caid=1722,1834
    srvid=d161,d163,d17a,d175,d176,d164,cf0a,d168,d162,cf77,cf0e,d171,d169,cf0d,d172,cf76,d10a,d17e,d170,c3be,d173,d174,d16c,d16f$
    
    [skyfullhd]
    caid=1702,1833
    srvid=0084,0081,007e,007f,0080,0083,0082,000a,000b,002b,0009,0029,001b,002a,000e,0044,003e,000d,000c,0034,0017,0008,0204,0014$
    
     
    Zuletzt von einem Moderator bearbeitet: 22. Juni 2010
    #1
  2. phantom

    Nervigen User Advertisement

  3. j__k
    Offline

    j__k Hacker

    Registriert:
    13. März 2009
    Beiträge:
    324
    Zustimmungen:
    194
    Punkte für Erfolge:
    43
    AW: Oscam/CCcam user offline

    Warum denn so Kompliziert? Das Wifi kann per CCcam oder newcamd Protocol direkt mit oscam kommunizieren! Noch ein zwischengeschaltener CCcam verbessert das wohl kaum.


    Zum user account: Warum gibst du denn die services frei und verbietest sie gleichzeitig wieder? Mach die Zeile erst mal ganz raus, mit den services kannst du später noch optimieren.
    Und zur caid Zeile:
    Die 1722 wird doch wohl bei einer Kabelkarte reichen? 1702 ist Sat und die 1833 u. 1834 jeweils für die HD
    ident zeile weg
    allerdings fehlt wieder der betatunnel:
    betatunnel = 1833.007E:1702,1833.007F:1702,1833.0080:1702,1833.0081:1702,1833.0082:1702,1833.0083:1702,1833.0084:1702

     
    #2
  4. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam/CCcam user offline

    Erstmal danke für die schnelle Antwort!

    Das löschen des RSA- und Boxkey bewirkt lediglich, dass meine Karte nicht mehr gelesen werden kann:
    Code:
    2010/06/20 20:04:54  20853 r02 card system not supported
    2010/06/20 20:04:54  20853 r02 card initializing error
    
    Und als CAID wird mir von Oscam 1834 ausgeworfen. Also wird der oben gepostet Betatunnel ja auch nicht mehr passen, oder?


    Hab nun übrigens die Wifi per CCcam direkt an den Oscam-Server connected. Wird auch hier als verbundener Client angezeigt, allerdings im Userfenster als "offline".
     
    Zuletzt bearbeitet: 20. Juni 2010
    #3
  5. massendaten
    Offline

    massendaten Spezialist

    Registriert:
    23. April 2009
    Beiträge:
    542
    Zustimmungen:
    85
    Punkte für Erfolge:
    28
    AW: Oscam/CCcam user offline

    Hi,

    Da ich im moment auch bei OSCAM ein wenig rumprobiere, hätte ich gerne eine FAQ die beinhaltet was es für Befehle bzw. Möglichkeiten gibt die Configs zu gestallten.

    Schaffe es nicht ganz durchzusteigen da die Configs dich bisher gesehen habe sich sehr oft im Inhalt stark unterscheiden.

    Wäre Dankbar für einen Link oder PDF.
     
    #4
  6. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam/CCcam user offline

    Ich hab jetzt mal die o.g. Veränderungen vorgenommen, mit Außnahme der Keys, weil meine Karte sonst nicht mehr gelesen werden kann.

    CAID 1722 sowie der Betatunnel ändern leider nichts.

    Aber meiner Meinung kann das auch nicht klappen, weil mir der Cardreader CAID 1834 ausspuckt. Das muss also schon das richtige für meine Karte sein.

    Wie müsste da der Betatunnel aussehen?
     
    #5
  7. goetzy200
    Offline

    goetzy200 Guest

    AW: Oscam/CCcam user offline

    :JC_hmmm:So Boxkey und RSAKey brauchst du auf jedenfall, aber mit Ubunte kenn ich mich garnicht aus aber vielleicht hilft Dir das

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    :dance3:
     
    #6
  8. Mogelhieb
    Offline

    Mogelhieb Administrator Digital Eliteboard Team

    Registriert:
    29. November 2008
    Beiträge:
    12.055
    Zustimmungen:
    16.483
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Counselor
    Ort:
    Bayern
    AW: Oscam/CCcam user offline

    Du solltest es vermeiden für den Benutzernamen und das Passwort identische Zeichen zu verwenden.
    Probiere mal anstatt der 127.0.0.1 mal die richtige IP des Servers.
     
    #7
  9. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Okay, das habe ich auch mal versucht. Ohne Erfolg.

    Mittlerweile nutze ich aber den integrierten CCcam von Oscam, wie es mir in der ersten Antwort geraten wurde. Somit muss der Fehler woanders liegen.

    Auch mit newcamd als Protokoll funktioniert es nicht.

    Das Wifi verbindet sich und wird als Client angezeigt, aber an der Helligkeit ändert sich nichts.


    Meine Karte müsste doch eigentlich richtig erkannt worden sein. Der Cardreader von Oscam spuckt hier folgendes aus:

    detect Irdeto tunneled NAGRA card
    using NAGRA mode
    ROM: D N A S P 1 8 1
    REV: D V R L 0 0
    SER: XX XX XX XX
    CAID: 1834
    Prv.ID: 00 00 04 01 (sysid)
    Prv.ID: 00 00 00 00

    Mir scheint es so, als stelle meine Wifi überhaupt keine Anfragen.

    Der einzige Traffic ist unter Debuglevel 8 sichtbar:
    Code:
    2010/06/22 14:03:45 3704 c01 cccam: decrypted header: 
    2010/06/22 14:03:45 00 06 00 00 
    2010/06/22 14:03:45 3704 c01 cccam: full decrypted msg, len=4: 
    2010/06/22 14:03:45 00 06 00 00 
    2010/06/22 14:03:45 3704 c01 cccam: received 4 bytes from client 
    2010/06/22 14:03:45 00 06 00 00 
    2010/06/22 14:03:45 3704 c01 cccam(s) jan: parse_msg=6 
    2010/06/22 14:03:45 3704 c01 cccam: keepalive ack
    
    Dieser Part wird ständig wiederholt.


    Unter Debuglevel 16:
    Code:
    2010/06/22 14:07:38 3698 r02 IFD: Status = card 
    
    Meldung wird ebenfalls laufend wiederholt.


    Ansonsten sieht mein StartLog so aus:
    Code:
    2010/06/22 14:08:46   3771 s   >> OSCam <<  cardserver started version 0.99.4svn, build #2379 (i686-pc-linux)
    2010/06/22 14:08:46   3771 s   version=0.99.4svn, build #2379, system=i686-pc-linux, nice=-1
    2010/06/22 14:08:46   3771 s   max. clients=509, client max. idle=120 sec
    2010/06/22 14:08:46   3771 s   max. logsize=unlimited
    2010/06/22 14:08:46   3771 s   client timeout=30000 ms, fallback timeout=2500 ms, cache delay=10 ms
    2010/06/22 14:08:46   3771 s   shared memory initialized (size=4300150, id=3964928)
    2010/06/22 14:08:46   3771 s   auth size=4756
    2010/06/22 14:08:46   3771 s   Cannot open file "/usr/local/etc/oscam.services" (errno=2)
    2010/06/22 14:08:46   3771 s   userdb reloaded: 0 accounts freed, 1 accounts loaded, 0 expired, 0 disabled
    2010/06/22 14:08:46   3771 s   signal handling initialized (type=sysv)
    2010/06/22 14:08:46   3771 s   can't open file "/usr/local/etc/oscam.srvid" (err=2), no service-id's loaded
    2010/06/22 14:08:46   3771 s   can't open file "/usr/local/etc/oscam.provid" (err=2), no provids's loaded
    2010/06/22 14:08:46   3771 s   monitor: disabled
    2010/06/22 14:08:46   3771 s   camd 3.3x: disabled
    2010/06/22 14:08:46   3771 s   camd 3.5x: disabled
    2010/06/22 14:08:46   3771 s   cs378x: disabled
    2010/06/22 14:08:46   3771 s   newcamd: disabled
    2010/06/22 14:08:46   3771 s   cccam: initialized (fd=5, port=12000, crypted)
    2010/06/22 14:08:46   3771 s   radegast: disabled
    2010/06/22 14:08:46   3771 s   logger started (pid=3772)
    2010/06/22 14:08:46   3771 s   resolver thread started
    2010/06/22 14:08:46   3771 s   http started (pid=3774)
    2010/06/22 14:08:46   3771 s   reader started (pid=3775, device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=600)
    2010/06/22 14:08:46   3771 s   waiting for local card init
    2010/06/22 14:08:46   3774 h   HTTP Server listening on port 16002
    2010/06/22 14:08:49   3775 r02 card detected
    2010/06/22 14:08:54   3775 r02 ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 03 84 55 FF 80 6D 
    2010/06/22 14:08:55   3775 r02 Maximum frequency for this card is formally 6 Mhz, clocking it to 6.00 Mhz
    2010/06/22 14:08:56   3775 r02 detect Irdeto tunneled NAGRA card
    2010/06/22 14:08:56   3775 r02 using NAGRA mode
    2010/06/22 14:08:59   3775 r02 ROM:    D N A S P 1 8 1
    2010/06/22 14:08:59   3775 r02 REV:    D V R L 0 0
    2010/06/22 14:08:59   3775 r02 SER:    XX XX XX XX
    2010/06/22 14:08:59   3775 r02 CAID:   1834
    2010/06/22 14:08:59   3775 r02 Prv.ID: 00 00 04 01 (sysid)
    2010/06/22 14:08:59   3775 r02 Prv.ID: 00 00 00 00 
    2010/06/22 14:08:59   3775 r02 [nagra-reader] ready for requests
    2010/06/22 14:08:59   3771 s   init for all local cards done
    2010/06/22 14:08:59   3771 s   anti cascading disabled
    2010/06/22 14:08:59   3771 s   client(1) connect from 192.168.0.14 (pid=3777, pipfd=11)
    2010/06/22 14:08:59   3777 c01 encrypted cccam-client 192.168.0.14 granted (jan, au=auto)
    2010/06/22 14:09:00   3777 c01 cccam(s) jan:          client 'jan' (C19790EE5FDEC042) running v ()
    2010/06/22 14:09:00   3777 c01 cccam(s) jan:          version: 2.1.1, build: 2971 nodeid: C19790EE5FDEC042
    
     
    Zuletzt bearbeitet: 2. Mai 2011
    #8
  10. goetzy200
    Offline

    goetzy200 Guest

    AW: Oscam/CCcam user offline

    In deinem Log ist nichts von AU drinne, richte das mal ein!!!:emoticon-0141-whew:
     
    #9
  11. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam/CCcam user offline

    Und jetzt die blöde Frage zum AU:

    Muss ich lediglich in der oscam.user den Eintrag au = 1 vornehmen oder was genau war damit gemeint?
     
    #10
  12. Mogelhieb
    Offline

    Mogelhieb Administrator Digital Eliteboard Team

    Registriert:
    29. November 2008
    Beiträge:
    12.055
    Zustimmungen:
    16.483
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Counselor
    Ort:
    Bayern
    AW: Oscam/CCcam user offline

    Nein, bei AU = kommt das Label rein auf welchem Reader AU gemacht werden soll. Wenn Du als Label Sky gewählt hast dann kommt da AU = Sky rein.
     
    #11
  13. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam/CCcam user offline

    Macht leider auch keinen Unterschied. Jetzt zeigt mir mein Log folgendes an:

    23869 c01 encrypted cccam-client 192.168.0.14 granted (jan, au=kd)

    kd ist selbstverständlich mein Reader. Vorher stand dort au=auto, was ja durch die 1 bewirkt wurde.
     
    #12
  14. kirkage
    Offline

    kirkage Hacker

    Registriert:
    23. März 2010
    Beiträge:
    375
    Zustimmungen:
    38
    Punkte für Erfolge:
    28
    AW: Oscam/CCcam user offline

    hast du eine Lösung für das Problem gefunden?
     
    #13
  15. janheigener
    Offline

    janheigener Newbie

    Registriert:
    26. Mai 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam/CCcam user offline

    Hab mittlerweile den Reader gewechselt und nun läuft alles wunderbar!
     
    #14

Diese Seite empfehlen