1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

oscam blockiert ecm time 5005 ms

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von sky pirate, 23. Dezember 2013.

  1. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    hallo zusammen
    hoffentlich kann jemand was dazu sagen.

    das problem hatte ich schon frueher.

    aus irgend einem grund kommen die clients auf ein timeout und schluss.
    muss oscam neu starten und ok.
    das kommt so 1 x taeglich vor, ohne jegliche zeit ordnung. nachts-morgens, wann auch immer.

    im log steht

    client.xxx timeout 5004 ms by cardreader sosoxx
    connection closed by client.
    und das ist bei allen clients die an diesem card reader dran sind,
    ich habe mehrere card reader am debian (omnikey)
    ich weiss dass oscam lauft, denn die anderen karten laufen ok.
    sind ja an der gleichen oscam dran.

    das timeout in der configurierung ist auf 5000 eingestellt, hab ich mal auf 7000 umgestellt.
    ich habe kein load balancing activiert.
    ja es sind viele clients an der karte dran.

    bevor ich weiter schreibe, mal sehen ob jemand eine einfache loesung dafuer hat.
    ausserdem meine oscam ist nicht die neueste so um die 6050 vers. rum.
    aber lauft ok sonst.ç
    danke fuer jedes info oder rad
    el pirate
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    Musst mal dazu schreiben,um welche es sich dreht!
     
    #2
    sky pirate gefällt das.
  4. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    hi
    du meinst um welche karte es sich dreht?
    nds s*y uk
    normal ecm ist so um 100ms
    jetz hatte ich den timeout auf 7000 eingestellt, und heute morgen war der omnikey card reader auf off.
    oscam restart und ok
    was kann das sein.
    zu viele user?
    hab aber keine freezer noemalerweise.
    cardreader 1 - group 1 sind so 25 clients dran. immer ok.
    cardreader 2 - group 2 sind so 50 clients dran. schaltet ab wegen timeout oder cardreader off.

    das waere einfach zu sagen zu viele clients dran.
    ich hab die alle auf einer vu+solo als server am laufen gehabt an einer karte! ohne probleme.

    somit glaub ich dass da vielleicht bei oscam was mehr eingestellt werden sollte.
    ich kann die configs mal zeigen.
    gruss
    el pirate

    oder load balancing?


    hier meine cfg

    # o
    scam.conf generated automatically by Streamboard OSCAM 1.10rc-svn build #6089

    [global]
    logfile = /var/log/ipc/OScam.log
    clienttimeout = 7000
    nice = 0
    maxlogsize = 2480
    saveinithistory = 1

    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [cccam]
    port = port-group1,port-group2
    reshare = 1
    ignorereshare = 1
    version = 2.1.1
    minimizecards = 1
    stealth = 1

    [webif]
    httpport = xxxxx
    httpuser = oscam
    httppwd = oscam
    httprefresh = 15
    httpallowed =



    [reader]
    label = manchester1
    protocol = pcsc
    device = 0
    caid = 0963
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 0963:000000
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    blockemm-g = 1


    [reader]
    label = manchester2
    protocol = pcsc
    device = 1
    caid = 0963
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 0963:000000
    group = 2
    emmcache = 1,3,2
    blockemm-unknown = 1
    blockemm-g = 1


    sorry muss mal auf frischen das thema, denn immer wieder schalten die card reader ab = off.
    oscam lauft....
    kann das vielleicht am nicht so sauberen spanischen strom liegen.
    immer wieder kleine und groessere stromausfaelle.
    hab mir bisher noch keine backup batterie geleistet.
    kann das meine reader ausschalten.
    danke fuer kommentare
     
    Zuletzt von einem Moderator bearbeitet: 3. Januar 2014
    #3
    hwmmc gefällt das.
  5. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    Wenn du nur SkyUK Karten im Share hast, dann machst du entweder
    Code:
    clienttimeout                  = 580
    fallbacktimeout                = 580
    und setzt einen Reader als Fallback.

    Oder aktiviere den Loadbalancer und mache folgendes:
    Code:
    lb_mode                        = 1
    lb_save                        = 2000
    lb_nbest_readers               = 1
    lb_nfb_readers                 = 2
    lb_reopen_mode                 = 1
    lb_reopen_seconds              = 30
    lb_nbest_percaid               = 
    lb_min_ecmcount                = 2
    lb_max_ecmcount                = 500
    lb_retrylimit                  = 2800
    lb_retrylimits                 = 09:480,17:5500
    lb_savepath                    = /var/etc/stat
    lb_stat_cleanup                = 336
    lb_max_readers                 = 1
    
    
     
    #4
    sky pirate gefällt das.
  6. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    hi
    vielen dank, dass du dir die muehe machst, auf das zu antworten.:ja
    aber super, das werde ich heute spaeter noch einbauen.
    mittlerweile hab ich loadbalancer activiert aber half auch nix, da waren beide cardreader am morgen off.
    mein loadbalancer ist sehr basic, eigentlich nur
    lb_mode = 1

    mit deiner finetuning, vielleicht ist das die loesung.:ja
    ich verstehe gerne was ich tue, somit eine frage.
    was bedeuted

    lb_retrylimits = 09:480,17:5500

    kann das nicht finden.

    und dieses hier

    lb_max_ecmcount = 500 meinst du nicht ein bisschen viel, da sind eigentlich schon freezer??


    egal ich versuchs mal so wie du es sagst.:emoticon-0117-talki
    bist ja nicht irgend jemand.
    danke nochmal, fuer die muehe.
    ich werde hier das resultat posten.

    eins kann ich jetzt schon sagen, oscam hat viele viele moeglichkeiten.
    man muss nur sich damit befassen. zb load balancing mit seinen moeglichkeiten
    danke
    el pirate
    :smoke:
     
    #5
    hwmmc gefällt das.
  7. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    Bedeutet, wenn lb_retrylimit per Default auf 800 ms eingestellt ist (bei ist auf 2800 ms eingestellt), dass
    lb_retrylimits = 09:480,17:5500
    bei alle NDS CAIDs 09XX nur bis 480 ms ECM Zeit der Reader abgefragt wird,
    wird die Zeit überschritten, dann wird zu einen anderen Reader der die CAID hat gewechselt.
    ... genauso ist es bei den CAIDs 17XX, aber eben andere ECM Zeit wie angegeben.
    Der Default Wert von 800 ms ist wirklich nur Default. Mit lb_retrylimits = ... ,
    kann man das für jede beliebige CAID genauer einstellen.
    (eine 0963 macht bei ab ca. 600 ms Freezer/Aussetzer, darum setze ich das Limit auf 480 ms, damit noch Reserve ist bis zu deinen Clienten)

    lb_max_ecmcount = 500
    ... sagt nur: nach 500 ECM Anfragen auf einen Reader,
    sollen mal wieder andere Reader (wenn vorhanden) angefragt werden,
    eventuell wegen besser ECM Zeiten ...
     
    #6
    sky pirate gefällt das.
  8. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    danke fuer die klare antwort.
    die lb configs hab ich schon am laufen und es sieht gut aus, mal sehen auf ein paar tagen.
    eine frage noch, ich lese immer wieder netprio option

    [h=4]netprio[/h]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    parameter is optional

    network priority - This sets the value of SO_PRIORITY on network connections. Basically this leads to setting the TOS fields of the sent IP packages so that QoS can be better used.
    Beispiel:
    netprio = 1 # Priority 1
    Default:
    netprio = 0 # system given

    versteh nicht genau was es meint, aber es soll die internet verbindung solider machen.?
    bringt das was oder stoert es eher?
    ich mag auch wenig ist mehr.
    gruss und danke
     
    #7
    hwmmc gefällt das.
  9. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    Wenn du 2 oder mehr Server in einen Netzwerk hast,
    bestimmst du hiermit welcher der Hauptserver oder Nebenserver ist.
    ... z.B. 3 Server in einen Netzwerk
    Server1 Hauptserver mit allen externen Clienten (netprio = 1)
    Server2 Nebenserver ... (netprio = 0)
    Server3 Nebenserver ... (netprio = 0)
     
    #8
    sky pirate gefällt das.
  10. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    hi:emoticon-0184-tmi::kez_03:
    danke bisher aber das problem besteht noch, nicht mehr wie frueher aber doch noch.
    cardreader waren wieder auf aus. (liefen 2 tage ohne probleme)
    werde versuchen ein oscam log file zu kriegen.
    obwohl oscam lauft weiter es sind nur die card reader off. omnikeys.
    anscheinend gibt es neue driver fuer onmikey, so werde ich das mal machen.
    vielleicht auch meine oscam updaten 6059 ist ja nicht die neueste.
    fuer info das ist das problem::wacko1:

    aus irgend einem grund kommen die clients auf ein timeout und schluss.
    muss oscam neu starten und ok.
    das kommt so 1 x taeglich vor, ohne jegliche zeit ordnung. nachts-morgens, wann auch immer.

    im log steht
    :emoticon-0183-swear

    client.xxx timeout 5004 ms by cardreader sosoxx
    connection closed by client.
    und das ist bei allen clients die an diesem card reader dran sind,
    ich habe mehrere card reader am debian (omnikey)
    ich weiss dass oscam lauft, denn die anderen karten laufen ok.
    sind ja an der gleichen oscam dran.

    das timeout in der configurierung ist auf 5000 eingestellt, hab ich mal auf 7000 umgestellt.

    mittlerweile ist lb am laufen und alles lauft bis auf reader off ab und zu.
    hat sonst jemand dieses problem mit omnikey readern?

    hast du noch eine idee HWMMMC?
    :whistle2:
    danke auf alle faelle
    el pirate
    :emoticon-0150-hands
     
    #9
  11. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    ... mit oscam.whitelist arbeiten.
    Wie verbinden sich deine Clienten zu dir und/bzw. mit welchen Boxen und Camd?
    Als welche CCcam Version gibst du dich aus?
    Welche Clienten verursachen dieses "timeout..."? (Box/Camd/Version)
     
    #10
    sky pirate gefällt das.
  12. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    hi
    naja das problem ist leider noch nicht weg.
    die omnikey cardreader schalten immer noch ab und zu einfach ab = off
    wegen irgendwelchen timeout by client.
    das kann auch mitten in der nacht passieren wenn fast niemand am server haengt.

    @hmmwc du meinst whitelist?
    fuer s*y uk wurde das frueher viel genommen aber nach sovielen aenderungen ist das ins aus gekommen.
    anscheinend war das um killer emms abzuhalten. da war nie was bei nds 963 s*yuk.
    ich finde auch keine neue whitelist, und mir selbst eine zu machen, das kostet mich ein halben tag.
    glaubst du wirklich?? sag bitte wenn es wirklich wichtig ist.

    meine clients verbinden sich mit allen moeglichen boxen und cccam versionen.
    mein server lauft mit oscam als server und cardreader, und clients verbinden mit cccam.
    meine cccam ist 2.1.1. das hab ich bei oscam eingefuegt. (hab selber gar keine cccam am server)

    mein verdacht ist das wackelige internet hier. da sind immer welche aussetzer.
    koennte das abschalten von card readern verursachen?

    hoffentlich finded sich eine loesung fuer das, ist ja wirklich aergerlich.
    danke fuer alle kommentare
    el pirate

    das ist im syslog
    Jan 13 15:21:28 debian pcscd: commands.c:1393:CCID_Receive Card absent or mute
    Jan 13 15:21:28 debian pcscd: ifdwrapper.c:527:IFDTransmit() Card not transacted: 612
    Jan 13 15:21:28 debian pcscd: winscard.c:1532:SCardTransmit() Card not transacted:
    oscam log
    2014/01/13 17:33:28 0 >> OSCam << cardserver log switched, version 1.20-unstable_svn, build #7048 (x86_64-linux-gnu)
    2014/01/13 17:33:28 0 version=1.20-unstable_svn, build #7048, system=x86_64-linux-gnu, nice=0
    2014/01/13 17:33:28 0 client max. idle=120 sec, debug level=0
    2014/01/13 17:33:28 0 max. logsize=2480 Kb, loghistorysize=4096 bytes
    2014/01/13 17:33:28 0 client timeout=7000 ms, fallback timeout=2500 ms, cache delay=0 ms


    2014/01/13 17:33:29 1766770 r [videoguard2-reader] classD0 ins40: (-2) status not ok 00 00
    2014/01/13 17:33:29 1766770 r dropping client data for manchester1 time 9s
    2014/01/13 17:33:29 1766770 r dropping client data for manchester1 time 9s
    2014/01/13 17:33:29 1768120 r [videoguard2-reader] classD0 ins40: (-2) status not ok 00 00


    2014/01/13 17:33:29 2C0B6140 c cccam(s) clientxxx: connection closed by client, n=-1.
    2014/01/13 17:33:29 2C0B6140 c clientxxx disconnected from xxxx ip
    2014/01/13 17:33:29 2C0B6140 c thread 7F7431815700 ended!
    2014/01/13 17:33:30 2C0C7D80 c cccam(s) manu10: connection closed by client, n=-1.
    2014/01/13 17:33:30 2C0C7D80 c manu10 disconnected from xxxxxx ip
    2014/01/13 17:33:30 2C0C7D80 c thread 7F7431941700 ended!
    2014/01/13 17:33:30 2C0B9690 c encrypted cccam-client xxxxx ip granted (manu10, au=on (2 reader))
    2014/01/13 17:33:30 1766770 r [videoguard2-reader] classD0 ins40: (-2) status not ok 00 00
    2014/01/13 17:33:30 1768120 r [videoguard2-reader] classD0 ins40: (-2) status not ok 00 00
    2014/01/13 17:33:30 2C01A300 c cccam(s) manu: connection closed by client, n=-1.
    kann jemand hier was sehn, linux nix verstehen andere baustelle hehe
    ja das die oder der reader nicht lauft, oscam restart und ok fuer 1-2 tage
     
    Zuletzt von einem Moderator bearbeitet: 14. Januar 2014
    #11
    hwmmc gefällt das.
  13. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    AW: oscam blockiert ecm time 5005 ms

    Und wie sieht die komplette oscam.conf aus?
    ... dann solltest mal eine OScam Version benutzen die mit 9XXX beginnt.
    Bei CCcam auf 2.3.0 stellen und deinen Clienten sagen,
    nur Zugriff mit CCcam Version ab 2.2.X, alles darunter ist Müll.
     
    #12
    sky pirate gefällt das.
  14. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    hi sorry war mit arbeit beschaeftigt.
    anyway warum schalten sich die omnikeys ab und zu ab.
    danke hwmmmmc fuer deine hilfe
    mal sehen ob wir das problem finden.
    deine lb fine einstellung hat es auf alle faelle stabiler gemacht.
    die oscam werde ich morgen updaten auf 90++
    meine freunde share clients, benutzen fast alle skyboxen f3-f5 die haben cccam 2.1.4 fix drin.
    das wird schwer sein.
    wie kann ich meine cccam version updatebn in oscam cfg?
    ich hab ja keine cccam.bin file
    einfach in oscam.cfg aendern?
    lass mich wissen bitte
    hier meine cfgs oscam
    # oscam.conf generated automatically by Streamboard OSCAM 1.10rc-svn build #6089

    [global]
    logfile = /var/log/ipc/OScam.log
    clienttimeout = 7000
    nice = 0
    maxlogsize = 2480
    saveinithistory = 1
    lb_save = 2000
    lb_nbest_readers = 1
    lb_nfb_readers = 2
    lb_reopen_mode = 1
    lb_reopen_seconds = 30
    lb_nbest_percaid =
    lb_min_ecmcount = 2
    lb_max_ecmcount = 500
    lb_retrylimit = 2800
    lb_retrylimits = 09:480,17:5500
    lb_savepath = /var/etc/stat
    lb_stat_cleanup = 336
    lb_max_readers = 1


    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [cccam]
    port = port-group1,port-group2
    reshare = 1
    ignorereshare = 1
    version = 2.1.1
    minimizecards = 1
    stealth = 1

    [webif]
    httpport = xxxxx
    httpuser = oscam
    httppwd = oscam
    httprefresh = 15
    httpallowed =
    [reader]
    label = manchester1
    protocol = pcsc
    device = 0
    caid = 0963
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 0963:000000
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    blockemm-g = 1


    [reader]
    label = manchester2
    protocol = pcsc
    device = 1
    caid = 0963
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 0963:000000
    group = 2
    emmcache = 1,3,2
    blockemm-unknown = 1
    blockemm-g = 1
    [account]
    user = user
    pwd = pass
    group = 1,2
    au = manchester1,manchester2
    kann man da ein problem sehen?
    ich benutze keine service files weil es so auch gut lief, ist das wichtig?
    wie man sieht hab ich 2 groups mit 2 verschiedenen ports. das kommt weil ich 2 eigene server auf dem debian zusammen gefuehrt habe.
    also 2 ips, die ich uebermn router weiter route und 2 server listen ports.
    aber das sollte doch gehen.
    oder kann das meine reader in stress bringen?
    so das sie abschalten.
    ich habe das gefuehl, das hat was mit timeout einstellungen zu tun.
    aber was meint ihr?
    danke fuer alle faelle.
    el pirate

    ps: ich kriege keine emms mit dieser einstellung? kann jemand sagen warum?
     
    Zuletzt von einem Moderator bearbeitet: 15. Januar 2014
    #13
  15. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: oscam blockiert ecm time 5005 ms

    Moin,

    hier sehe ich, dass du auf diesem Server zwei lokale Karten hast und offensichtlich diese an zwei Server verteilen willst. Da brauchst du doch nur einen Port nehmen.

    Vielleicht habe ich deine Konstruktion auch nicht ganz verstanden.

    Grüße
    Bombadil
     
    #14
    sky pirate gefällt das.
  16. sky pirate
    Offline

    sky pirate Meister

    Registriert:
    2. Dezember 2009
    Beiträge:
    801
    Zustimmungen:
    49
    Punkte für Erfolge:
    28
    Beruf:
    papa und channelhunter
    Ort:
    andalucia
    Homepage:
    AW: oscam blockiert ecm time 5005 ms

    das problem ist leider complizierter
    kann mal post 13 durchschauen bitte
    was meinst du hwmmmc da sind auch die configs
    danke
     
    #15
    hwmmc gefällt das.

Diese Seite empfehlen