1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

Dieses Thema im Forum "IPC" wurde erstellt von Pilot, 19. August 2012.

  1. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.375
    Zustimmungen:
    23.797
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    o compile ist mir richtig gut und lieb geworden.
    Hat alles bisher bestens geklappt bis oscam Version 7266.
    Alle oscam Versionen danach liefern Fehlermeldungen bei mir. Oscam läßt sich dann nicht starten.

    Auf was muß ich achten bei den oscam Versionen ab 7267. Eben gerade die Version 7271 versucht mit o compile zu laden. Weiß nicht mehr genau was da stand: irgendwas von .64 macht Probleme.
    Werd versuchen die Fehlermeldungen nach zu liefern.


    Mlg piloten
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Hallo piloten,

    Problem ist bekannt und bei pebkac schon gelöst.

    tausche dein vorhandenes o compile script gegen das aktuelle onlinescript:
    Gruß
    jensebub
     
    #2
    pegas, meister85, Pilot und 2 anderen gefällt das.
  4. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.375
    Zustimmungen:
    23.797
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Habe das im Putty eingegeben:
    wget -O/var/emu/script/oscam-compile.sh ipc.pebkac.at/ipc/scripts/oscam-compile.sh chmod 755 /var/emu/script/oscam-compile.sh

    Hat in einem Igel wunderbar geklappt. Es läuft jetzt oscam 7274

    Beim 2. Igel(ersatz Igel) hat es nicht geklappt. Es kommt diese Fehlermeldung:
    shell-init: kann das nicht aktuelle Verzeichnis wiederfinden: getwd: kann nicht auf das übergeornete Verzeichnis zugreifen. Datei oder Verzeichnis nicht gefunden.
    oscam : reastart
    oscam : beendet.
    /var/emu/oscam/oscam.x86:: Error while loading shared libraries: libusb-1.0.so.0: cannot open shared objekt file: no such file or diretory
    Fehler beim starten von oscam


    Mlg piloten
     
    #3
  5. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.421
    Zustimmungen:
    12.684
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Sind beim Ersatz-Igel alle Pakete auf dem neusten Stand? Ich Tippe drauf, das libusb-1.0 fehlt.
     
    Zuletzt bearbeitet: 23. August 2012
    #4
  6. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.375
    Zustimmungen:
    23.797
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Komischer Weise wird oscam Version 7266 beim Ersatz Igel richtig mit o compile geladen.
    Ab 7267 macht der Ersatzigel Probleme, obwohl der Script ergänzt wurde.

    wie kann ich libusb-1.0 beim Ersatzigel nachladen?


    Mlg piloten
     
    #5
  7. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.421
    Zustimmungen:
    12.684
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Mit apt-get install libusb-1.0 wird das Paket installiert
     
    #6
    starturk, pegas, Pilot und 2 anderen gefällt das.
  8. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Hi Piloten, lies mal hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Grüsse
    szonic
     
    #7
    Pilot, jensebub und al-x83 gefällt das.
  9. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.375
    Zustimmungen:
    23.797
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    Damit: apt-get install libusb-1.0 l läuft o compile mit der neusten oscam Version 7276 auch perfekt: oscam ist gestartet. Danke für diesen Befehl al-x83

    Im Nach hinein wundert mich nur, das der 1. Igel ohne diesen Befehl klar kam. Script Anderungen nach Beitrag 2 von jensebub-Danke dafür- bei beiden Igeln durchgeführt.
    Der 1. Igel hat o compile danach perfekt durchgeführt. Der 2. brauchte den Befehl apt-get install libusb-1.0 von al-x83.

    Mein alter EDV Lehrer hat folgenden Spruch getätigt: was ist EDV auf volks deutsch übersetzt: Ende der Vernunft bei bestimmten Problemen.

    In diesem Sinne: danke euch allen. Es läuft perfekt. Nicht länge über vergangene Probleme nachdenken und genießen.


    Mlg piloten
     
    #8
    pegas, szonic und al-x83 gefällt das.
  10. aragorn
    Online

    aragorn Guest

    AW: o compile mit Fehlermedungen ab oscam 7267-ipc 11.4

    das "o compile" script überprüft nur ein mal ob die zum kompilieren benötigten files installiert sind. danach wird ein file " /var/emu/conf/.oscam_compile_check.OK " erstellt und solange das existiert überprüft das script die zum kompilieren benötigten pakete nicht erneut..
    die zum kompilieren benötigen pakete sind in dem script in der mitte hinterlegt:
    Code:
    NP1="build-essential autoconf automake cmake make patch gcc g++ pkg-config subversion"
    NP2="libccid libtool libglib2.0-dev libssl-dev libpcsclite1 libpcsclite-dev libusb-dev"
    NP3="gettext tar bzip2 gzip ncurses-bin flex bison wget libpng3 zlib1g-dev sudo"
    das heisst ich vermute mal das es auf deinem ersatz igel dabei ein problem gab aber trotzdem das file " /var/emu/conf/.oscam_compile_check.OK " erstellt wurde. daraufhin wurden die pakete nicht noch mal überprüft und deswegen fehlte dir vermutlich noch libusb-dev (durch das *-dev paket wird auch das hauptpaket installiert)


    ps: mein spruch dazu: über vergangene probleme nachdenken hilft manchmal es irgend wann auch zu verstehen und erst wenn man es versteht lernt man davon
     
    #9

Diese Seite empfehlen