1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Neue/Alte Oscam version

Dieses Thema im Forum "Archiv" wurde erstellt von Honda-Civic, 25. Mai 2011.

  1. Honda-Civic
    Offline

    Honda-Civic Board Guru Supporter

    Registriert:
    13. August 2008
    Beiträge:
    1.326
    Zustimmungen:
    1.259
    Punkte für Erfolge:
    113
    Hallo an alle!
    Wie kann ich die neueste Oscam version bei Debian runterladen? o version sind immer etwa 10 alte ver,,,angezeigt
    neuste bei mir ist 5254 ,, manuel eintragen habe auch schon probiert aber ohne erfolgt mit folgene fehler:
    /bin/o: Zeile 17: /var/emu/oscam/oscam.x86: Datei oder Verzeichnis nicht gefunden
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    Die OSCam konnte nicht gestartet werden.

    Prüfe ob der obige Pfad /var/emu/oscam vorhanden ist und dort eine Datei oscam.x86 liegt. Die Dateirechte kannst Du in diesem Zusammenhang auch noch prüfen, also ob die oscam.x86 ausführbar ist.
     
    #2
  4. RoterBaron
    Offline

    RoterBaron Stamm User

    Registriert:
    18. Mai 2011
    Beiträge:
    1.160
    Zustimmungen:
    478
    Punkte für Erfolge:
    0
    AW: Neue/Alte Oscam version

    "o version" von IPC 11.3 hat immer nur die um 00:00 eines jeden tages verfügbare version online, es wäre ein wenig übertrieben absolut jedes build zu kompilieren und via "o version" verfügbar zu machen

    wenn du eine eigene version wie zb eine neuere als die via "o version" verfügbar ist haben möchtest, kannst du dir die aber auch via "o compile" selber compilieren


    wenn du dir, wie du selber sagst, manuell eine oscam version einrichten willst, muss die auszuführende binary datei natürlich auch da liegen und so heissen wie die andere auch weil sonst kann das script was hinter "o" steckt, die datei nicht finden, wie dir auch die fehlermeldung bestätigt...

    "o" zeile 17: $OSBIN -b -c $CAMCONFIGS

    32bit functions.sh:
    CAMBINS=/var/emu
    CAMCONFIGS=/var/etc
    OSVERSION="oscam.x86"
    OSBIN=$CAMBINS/oscam/$OSVERSION
     
    #3
    Honda-Civic gefällt das.
  5. Honda-Civic
    Offline

    Honda-Civic Board Guru Supporter

    Registriert:
    13. August 2008
    Beiträge:
    1.326
    Zustimmungen:
    1.259
    Punkte für Erfolge:
    113
    AW: Neue/Alte Oscam version

    Hallo
    Ich hab IPC 11.5 und die neuste o version ist 5254 ,, in var/emu/oscam gebe bin datei rein und benene um auf oscam.x86 und setzte rechte auf 755 ,,pasiert aber fehler wie oben steht
    kommt vieleicht noch was rein??
    mfg
     
    #4
  6. RoterBaron
    Offline

    RoterBaron Stamm User

    Registriert:
    18. Mai 2011
    Beiträge:
    1.160
    Zustimmungen:
    478
    Punkte für Erfolge:
    0
    AW: Neue/Alte Oscam version

    IPC 11.5 ist von den Piraten und die haben soweit ich weiss nicht jeden tag jeweils die aktuelle und auch kein "o compile" - das hat nur die 11.3 von feiss

    von was benennst du die datei denn um?

    ...sonst wende dich an die Piraten - von denen kommt ja auch die IPC die du nutzt
     
    #5
  7. Honda-Civic
    Offline

    Honda-Civic Board Guru Supporter

    Registriert:
    13. August 2008
    Beiträge:
    1.326
    Zustimmungen:
    1.259
    Punkte für Erfolge:
    113
    AW: Neue/Alte Oscam version

    Richtig ,,,11.5 ist von Piraten benene von datei hoffe sind richtig --


    oscam-svn5299-x86_64-pc-linux --um auf oscam.x86 so wie derzeitig sind
     
    #6
  8. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    Welche Architektur hat Dein IPC Rechner?

    Ich würde es so machen:
    1. eine OSCam installieren wo Dir über das Update angeboten wird und starten um zu sehen ob es funktioniert.
    2. zur OSCam im System gehen per FTP, SSH oder was auch immer wo Du Rechte zum bearbeiten hast und diese nach dem Stoppen umbenennen
    3. die gewünschte OSCam ins Verzeichnis legen und den Namen geben welche die zuvor umbenannte hatte und abschließend die Dateirechte prüfen.

    Jetzt kannst Du diese starten und sehen was passiert.
     
    Zuletzt bearbeitet: 26. Mai 2011
    #7
  9. RoterBaron
    Offline

    RoterBaron Stamm User

    Registriert:
    18. Mai 2011
    Beiträge:
    1.160
    Zustimmungen:
    478
    Punkte für Erfolge:
    0
    AW: Neue/Alte Oscam version

    das ist falsch

    dein oscam script will eine 32bit binary starten aber du spielst eine 64bit auf - das kann so also auch garnicht gehen

    das dürfte aber nicht passieren wenn du "o version" benutzt - ansonsten ist die Piraten version fehlerhaft



    @utitily: warum muss bei dir alles so kompliziert sein? lese doch auch mal bitte zur abwechslung den ersten beitrag...
    weil selbst wenn er deine 3 punkte befolgen würde, würde er warscheinlich wieder die x86_64 binary in x86 umbenennen wie schlieslich die datei die da vorher drin lag auch schon hies und du ihm das ja so rätst.... viel geschreibsel für nix
     
    Zuletzt bearbeitet: 27. Mai 2011
    #8
  10. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    Kompliziert ist es auch nicht mehr wie was anderes.... ich fahre vielleicht anders nach Rom wie Du, aber das Ziel ist gleich :emoticon-0105-wink:

    Aber Du musst zugeben dass die Bezeichnung der Version auch nicht so glücklich gewählt ist. Und im ersten Beitrag den ich sehr wohl gelesen habe steht nichts von einer "x86_64"

    Mein Gedanke dabei war dass er es mit einer Version testet wo sein IPC Anbieter zur Verfügung stellt um zu sehen ob die OSCam überhaupt startet. Der Rest hätte sich dann auch ergeben, bzw. gefunden. Ob das System schon gelaufen ist oder nicht ersieht man nämlich nicht.

    Zumal ich weder IPC oder Orsis kenne und der Threadsteller nicht genug detaillierte Angaben gemacht hat wie ich finde ist der Vorschlag von mir bestimmt auch nicht falsch.

    Darum baue ich mir per Crosscompiler alle Versionen selber :emoticon-0116-evilg
     
    #9
  11. Honda-Civic
    Offline

    Honda-Civic Board Guru Supporter

    Registriert:
    13. August 2008
    Beiträge:
    1.326
    Zustimmungen:
    1.259
    Punkte für Erfolge:
    113
    AW: Neue/Alte Oscam version

     
    #10
  12. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    Er wusste es wohl :good:
     
    #11
  13. Honda-Civic
    Offline

    Honda-Civic Board Guru Supporter

    Registriert:
    13. August 2008
    Beiträge:
    1.326
    Zustimmungen:
    1.259
    Punkte für Erfolge:
    113
    AW: Neue/Alte Oscam version

    Danke Jungs!! Meine fehler!!!Shi...,,t hab falsche Binary von falsche forum runter geladen !!!
    Richtige sind oscam-1.00-trunk-svn5299-x86 !!!!!!!!!!!!!!!!!!!!!!!
    Funz,,,jetzt
     
    #12
  14. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    Schön, also doch noch ein Happy End.

    Jetzt weißt Du ja worauf zu achten ist.
     
    #13
  15. RoterBaron
    Offline

    RoterBaron Stamm User

    Registriert:
    18. Mai 2011
    Beiträge:
    1.160
    Zustimmungen:
    478
    Punkte für Erfolge:
    0
    AW: Neue/Alte Oscam version

    und wieder viel geschreibsel für nix...


    wie wir bereits in anderen threads merken konnten - liest du nicht aufmerksam genug die beitrag und dazu kommt auch noch das du tips für etwas vermitteln möchtest was du selber aber garnicht kennst oder nutzt...



    gutes beispiel ist auch dein vorletztes kommentar - was soll ich gewusst haben?
    das er ne 64bit und powerpc binary auf nem x86 system zu starten versucht und es deswegen an der ipc version liegen soll?
    lol
     
    #14
    ragan62 gefällt das.
  16. utiltiy
    Offline

    utiltiy Ist gelegentlich hier

    Registriert:
    2. August 2010
    Beiträge:
    66
    Zustimmungen:
    6
    Punkte für Erfolge:
    8
    Ort:
    Franken
    AW: Neue/Alte Oscam version

    :emoticon-0115-inlov
     
    #15

Diese Seite empfehlen