1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem IPC Weiterlung bei Apache2 ändern

Dieses Thema im Forum "IPC" wurde erstellt von keyt0st3r, 8. April 2012.

  1. keyt0st3r
    Offline

    keyt0st3r Ist gelegentlich hier

    Registriert:
    5. Februar 2012
    Beiträge:
    80
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Beruf:
    IT Ingenieur
    Ort:
    Im Ruhrpott
    Hallo,

    ich bin auf der Suche nach einer Möglichkeit die IPC Weiterleitung aus dem Apache2 rauszunehmen.
    Wenn ich die IP meines Servers aufrufe, werde ich gleich ins Verzeichnis /var/www/IPC weitergeleitet.

    Das will ich unterbinden, da ich da meine eigene Verwaltugssite mit php realisieren möchte.

    Leider gibts weder in der var/www/index.html noch in der /etc/apache2/sites-enables/000-default einen Hinweis, warum apache auf /ipc weiterleitet.

    Vielleicht kann mal kurz wer helfen.

    Besten dank...
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.951
    Zustimmungen:
    5.875
    Punkte für Erfolge:
    113
    das liegt wohl an der index.html im ordner /var/www die leitet weiter auf URL=./ipc
    Code:
    <html>
    <head>
    <meta http-equiv="refresh" content="0; [COLOR=#ff0000]URL=./ipc[/COLOR]"
    </head>
    <body>
    und dort liegt dann die index.php von ipc.

    frohe ostern
    janni1
     
    #2
    keyt0st3r und (gelöschter Benutzer) gefällt das.
  4. keyt0st3r
    Offline

    keyt0st3r Ist gelegentlich hier

    Registriert:
    5. Februar 2012
    Beiträge:
    80
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Beruf:
    IT Ingenieur
    Ort:
    Im Ruhrpott
    Hi,

    das kann nicht sein, da eine index.html im Ordner var/www nicht mehr existiert.
    Das WI von IPC brauche ich nicht mehr, daher habe ich derzeit alle Dateien und Ordner in Var/www gelöscht.

    Dennoch versucht der Browser beim aufruf meiner Server-IP auf /IPC umzuleiten.

    Klappt natürlich nicht, weil der ja weg ist.
     
    #3
  5. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.951
    Zustimmungen:
    5.875
    Punkte für Erfolge:
    113
    Wenn ich meine index.html umbenenne und eine standart index.html in var/www/ schiebe und nur die IP eingebe, siehts bei mir so aus

    mit ip-adresse/ipc/index.php komme ich trotzdem noch aufs IPC-Webif.

    Keine Ahnung was da bei dir schief läuft, vieleicht mal cache löschen?

    Gruß
    janni1
     
    #4
    keyt0st3r gefällt das.
  6. keyt0st3r
    Offline

    keyt0st3r Ist gelegentlich hier

    Registriert:
    5. Februar 2012
    Beiträge:
    80
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Beruf:
    IT Ingenieur
    Ort:
    Im Ruhrpott
    Leider kein Erfolg.
    Habe mir jetzt auch eine einfache index.hml geschrieben.
    Es erfolgt trotzdem eine Weiterleitung nach 192.168.1.10/ipc
    Die Weiterleitung muss irgendwo anders verankert sein.

    Das Webif wird und wurde nie gebraucht.

    Ich hab IPC nur wegen der fertigen Cronjobs und Oscam draufgezogen...

    ädit:

    Besten dank nochmal für den Tip mit dem Cache.
    Genau das wars (wohlbemerkt bei zwei verschiedenen Systemen)

    Chronik komplett gelöscht und siehe da, nun gehts.
     
    Zuletzt bearbeitet: 8. April 2012
    #5
  7. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.951
    Zustimmungen:
    5.875
    Punkte für Erfolge:
    113
    also wenn du in deiner /etc/apache2/sites-enabled/000-default diese Einträge hast
    Code:
    DocumentRoot /var/www/
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
        </Directory>
    und du unter /var/www/ zB.so eine index.html erstellst,
    Code:
    <html><body><h1>It works!</h1>
    <p>This is the default web page for this server.</p>
    <p>The web server software is running but no content has been added, yet.</p>
    </body></html>
    bekommst du beim ansurfen der IP-Adresse diese Seite nicht angezeigt?

    Gruß
    janni1

    Edit: hab dein edit überlesen schön das es geht. Wollte schon an mir zweifeln.
     
    #6
  8. joopastron
    Offline

    joopastron Administrator Digital Eliteboard Team

    Registriert:
    3. März 2011
    Beiträge:
    19.334
    Zustimmungen:
    12.423
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Immer bei der Sache
    Wenn das IPC nicht gebraucht wird lasse es doch einfach komplett weg. Cronjobs kann man sich auch selber erstellen. Dazu gibt es hier Anleitungen.


    Sent from my iPhone using Tapatalk
     
    #7

Diese Seite empfehlen