1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problema IPC-Webinterface via SSL (massima sicurezza!!!)

Dieses Thema im Forum "IPC (Italiana)" wurde erstellt von selespeed, 19. Februar 2012.

  1. selespeed
    Offline

    selespeed Newbie

    Registriert:
    22. November 2010
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ciao a tutti
    mi serve il vostro aiuto volevo installare il ssl sicuramente ho sbagliato qualcosa e ora non posso piu entrare sul webinterface del ipc?
    cosa mi consigliate di fare devo deinstallare il ssl? se si come si fa.
    Grazie
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. AZK24
    Offline

    AZK24 Moderator Digital Eliteboard Team

    Registriert:
    8. Januar 2009
    Beiträge:
    3.576
    Zustimmungen:
    1.867
    Punkte für Erfolge:
    113
    Beruf:
    ARGE
    Ort:
    ALCATRAZ
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    basta cercare vedi

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #2
  4. selespeed
    Offline

    selespeed Newbie

    Registriert:
    22. November 2010
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    Grazie per la risposta veloce
    ho fatto come ce scritto la pero non va
    mi esce dovo che facio restart mi esce failed restart
    che dici?
     
    #3
  5. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    scusa ma non capisco dove ce il problema? hai fatto anzi riprovato a seguire il mio how-to? cosa ti dice il browser quando apri la paggiana?

    se vuoi disattivare ssl apri la ports.conf e metti cosi:

    Code:
    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default
    # This is also true if you have upgraded from before 2.2.9-3 (i.e. from
    # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
    # README.Debian.gz
    
    [COLOR=#ff0000]NameVirtualHost *:80
    Listen 80[/COLOR]
    
    <IfModule mod_ssl.c>
        # If you add NameVirtualHost *:443 here, you will also have to change
        # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
        # to <VirtualHost *:443>
        # Server Name Indication for SSL named virtual hosts is currently not
        # supported by MSIE on Windows XP.
        Listen 443
    </IfModule>
    
    <IfModule mod_gnutls.c>
        Listen 443
    </IfModule>
     
    #4
  6. selespeed
    Offline

    selespeed Newbie

    Registriert:
    22. November 2010
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    ok ci sono riuscito ho fatto di nuovo tutto da capo e ha funzionato
    grazie a tutti
     
    #5
  7. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    su questo passaggio e rimasta cosí
    /etc/apache2/sites-available>


    do questo comando
    nano /etc/apache2/sites-available/ssl

    per visualizzare il contenuto ma nn a memorizato il dny e tutto il resto come mai?

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
     
    #6
  8. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    Hai fatto questa procedura -->

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    A me pare propio di no!
     
    #7
  9. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    si seguo il tuopost,
    quando arrivo qui mi rimane cosí
    root@Linux21 ~ > chmod 600 /etc/apache2/apache.pem
    root@Linux21 ~ > cd /etc/apache2/sites-available
    root@Linux21 /etc/apache2/sites-available >

    qui rimango bloccato
    root@Linux21 /etc/apache2/sites-available >
     
    #8
  10. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    Che significa che rimani bloccato???
     
    #9
  11. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    che mi rimane su quella in rosso ...
    andando avanti e seguendo il tuo tuo doc alla fine nn memorizza e rimane cosi

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
     
    #10
  12. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    Che succede quando dai questo kommando --> nano /etc/apache2/sites-available/ssl

    Ti da un errore???

    Cosa premi per memmorizare?
     
    #11
  13. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    root@linux9 ~ > chmod 600 /etc/apache2/apache.pem
    root@linux9 ~ > cd /etc/apache2/sites-available
    root@linux9 /etc/apache2/sites-available > cp -f /etc/apache2/sites-available/default /etc/apache2/sites-available/ssl
    root@linux9 /etc/apache2/sites-available >


    mi rimane cosi
     
    Zuletzt bearbeitet: 4. Juli 2012
    #12
  14. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    E normale! il comando cp -f /etc/apache2/sites-available/default /etc/apache2/sites-available/ssl ti copia solo il file default in ssl!

    continua con la procedura!
     
    #13
  15. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    se continuo con il comando


    nano /etc/apache2/sites-available/ssl

    non trovo niente modificato nn ce il mio dns e neppure la e-mail
     
    #14
  16. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: IPC-Webinterface via SSL (massima sicurezza!!!)

    Copi il contenuto del punto nr. 5 e non dimenticare a salvare! L´ip e l´indrizzo email lo devi modificare tu!
     
    #15

Diese Seite empfehlen