1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.3.0)

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von buckfush, 25. September 2013.

  1. buckfush
    Offline

    buckfush Ist gelegentlich hier

    Registriert:
    16. Juni 2009
    Beiträge:
    75
    Zustimmungen:
    50
    Punkte für Erfolge:
    0
    Hallo...

    Also ich habe hier bisher immer Lösungen und Hilfe gefunden wenn ich Probleme hatte.
    Aber jetzt komm' ich mit der Suche nicht mehr weiter.

    Was ich machen will:
    Mein CCcam-client soll EMM's an den Oscam-Server schicken damit die Kartenfreischaltung nicht irgendwann abläuft.

    Problem:
    1. Unter Oscam sehe ich war den DVBAPI aber bei Address steht 0.0.0.0. So wie ich das gelesen habe.. ist das wohl ok ? Stimmt das ?
    2. In der gleichen Zeile steht bei CAID:SRVID 0000:0000. Ob das ok ist.. weiss ich nicht. Dazu habe ich nichts gefunden.

    Habe mal einen Screenshot angefügt wie das momentan aussieht:
    [​IMG]
    Meine Configuration:

    Igel Thin client mit aktueller Oscam-Version
    ET4000 - Receiver mit OpenPLI - Image und CCcam 2.3.0

    Bei den Rot markierten Einträgen bin ich mir nicht sicher ob das so korrekt ist. Speziell der BOXTYPE. ist "PC" hier korrekt ?
    [TABLE="width: 500"]

    Oscam.conf
    oscam.user
    oscam.dvbapi


    [dvbapi]
    enabled = 1
    au = 1
    pmt_mode = 4
    request_mode = 0
    reopenonzap = 0
    delayer = 0
    user = USERNAME
    boxtype = pc
    [account]
    disabled = 0
    user = USERNAME
    pwd = XXXX
    description = XXXX
    hostname =
    caid = 09XC
    uniq = 0
    sleepsend = 0
    failban = 0
    monlevel = 4
    sleep = 0
    suppresscmd08 = 1
    umaxidle = 0
    keepalive = 1
    au = v14
    emmreassembly = 1
    expdate =
    allowedprotocols =
    allowedtimeframe =
    betatunnel =
    group = 1
    services =
    ident =
    chid =
    class =
    cacheex = 0
    cacheex_maxhop = 0
    cacheex_ecm_filter =
    cacheex_drop_csp = 0
    cacheex_allow_request = 1
    cccmaxhops = 2
    cccreshare = 1
    cccignorereshare = 1
    cccstealth = -1
    fakedelay = -1
    numusers = 0
    penalty = 0
    lb_nbest_readers = -1
    lb_nfb_readers = -1
    lb_nbest_percaid =
    P: 098C 1
    I: 0

    [/TABLE]

    Oscam Logfile nach dem Start:
    2013/09/25 10:33:30 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8930 (i486-linux-gnu)
    2013/09/25 10:33:30 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 18055
    2013/09/25 10:33:30 0 s services reloaded: 0 services freed, 5 services loaded, rejected 0
    2013/09/25 10:33:30 0 s userdb reloaded: 2 accounts loaded, 0 expired, 0 disabled
    2013/09/25 10:33:30 0 s signal handling initialized
    2013/09/25 10:33:30 0 s 152 service-id's loaded in 2ms
    *2013/09/25 10:33:30 0 s monitor: initialized (fd=6, port=9999, ip=1.2.3.4, prio=1)
    2013/09/25 10:33:30 0 s -> CAID: 098C PROVID: 000000
    *2013/09/25 10:33:30 0 s cccam: initialized (fd=9, port=4711, ip=1.2.3.4, prio=1)
    2013/09/25 10:33:30 0 s v14 [mouse] creating thread for device /dev/ttyUSB0
    2013/09/25 10:33:30 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/09/25 10:33:30 0 s waiting for local card init
    2013/09/25 10:33:30 8D32F68 h webif: decompressed 54249 bytes back into 154604 bytes
    *2013/09/25 10:33:30 8D32F68 h HTTP Server running. ip=1.2.3.4.5 port=12345
    2013/09/25 10:33:30 8D30E70 r v14 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2013/09/25 10:33:31 8D30E70 r v14 [mouse] card detected
    2013/09/25 10:33:32 8D30E70 r v14 [mouse] ATR: 3F FD 15 25 02 50 80 0F 41 B0 0A 69 FF 4A 50 F0 00 00 50 31 03
    2013/09/25 10:33:32 8D30E70 r v14 [mouse] Init card protocol T0, FI=1, F=372, D=16, N=2
    2013/09/25 10:33:32 8D30E70 r v14 [mouse] Setting baudrate to 153600 bps
    2013/09/25 10:33:32 8D30E70 r v14 [mouse] Calculated work ETU is 6.51 us
    2013/09/25 10:33:32 8D30E70 r v14 [mouse] ATR Fsmax is: 5 MHz, clocking card to wanted user cardspeed of 3.57 MHz (specified in reader->mhz)
    2013/09/25 10:33:33 8D30E70 r v14 [mouse] Card type: P1TV
    2013/09/25 10:33:33 8D30E70 r v14 [mouse] Rom version: 20AA
    2013/09/25 10:33:33 8D30E70 r v14 [mouse] parental lock setting: FF FF FF FF
    *2013/09/25 10:33:33 8D30E70 r v14 [mouse] type: VideoGuard S** Germany (0000), caid: 0000
    2013/09/25 10:33:33 8D30E70 r v14 [mouse] serial: ########, BoxID: ########, baseyear: 2004
    *2013/09/25 10:33:35 8D5C2E0 c plain dvbapi-client granted (USER, au=on (1 reader))
    2013/09/25 10:33:35 8D5C2E0 c ERROR: Could not detect DVBAPI version.
    *2013/09/25 10:33:35 8D70C88 c encrypted cccam-client 1.2.3.4 granted (USER, au=on (1 reader))

    Ist diese ERROR-Meldung relevant ? Oder deutet das vielleicht schon auf ein Problem hin ?
    Habe vorhin extra nochmal die aktuellste Version von Oscam compiliert und kontrolliert, dass dvbapi mit installiert wird.

    Unix starttime: 1380098010
    Starttime: 25.09.2013 10:33:30
    Version: oscam-1.20-unstable_svn-r8930


    Web interface support: yes
    Touch interface support: yes
    SSL support: no
    DVB API support: yes
    DVB API with AZBOX support: no
    DVB API with MCA support: no
    DVB API with COOLAPI support: no
    DVB API with STAPI support: no
    Anti-cascading support: yes
    Irdeto guessing: yes
    Debug mode: yes
    Monitor: yes
    Loadbalancing support: yes
    CW Cycle Check support: yes
    LCD support: no
    LED support: no
    IPv6 support: no
    Cache exchange support: yes


    camd 3.3x: no
    camd 3.5 UDP: yes
    camd 3.5 TCP: yes
    newcamd: yes
    CCcam: yes
    CCcam share: yes
    Pandora: yes
    ghttp: yes
    gbox: yes
    radegast: yes
    serial: yes
    constant CW: yes


    Reader support: yes


    Nagra: yes
    Irdeto: yes
    Conax: yes
    Cryptoworks: yes
    Seca: yes
    Viaccess: yes
    NDS Videoguard: yes
    DRE Crypt: yes
    TONGFANG: yes
    Bulcrypt: yes
    Griffin: yes
    DGCrypt: yes


    cardreader_phoenix: yes
    cardreader_internal_azbox: no
    cardreader_internal_coolapi: no
    cardreader_internal_sci: yes
    cardreader_sc8in1: yes
    cardreader_mp35: yes
    cardreader_smargo: yes
    cardreader_pcsc: yes
    cardreader_smartreader: yes
    cardreader_db2com: yes
    cardreader_stapi: no

    So.. ich hoffe ich habe alles zusammengetragen damit mir hier vielleicht jemand auf die Sprünge helfen kann.
     
    Zuletzt von einem Moderator bearbeitet: 25. September 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    Hallo,
    dvbapi hat auf dem Server nix zu suchen,... wenn du als client oscam nutzen würdest, bräuchtest du auf dem client dvbapi,...

    Gruß
    jensebub
     
    #2
  4. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    Hab euch in der OScam Bereich verschoben. Ist kein IPC "Problem" zu erkennen.
     
    #3
  5. buckfush
    Offline

    buckfush Ist gelegentlich hier

    Registriert:
    16. Juni 2009
    Beiträge:
    75
    Zustimmungen:
    50
    Punkte für Erfolge:
    0
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    F*ck.... da kann ich ja rum probieren.

    Hab ich total anders verstanden.

    OK.

    Oscam-client eingerichtet..

    und jetzt scheint es wohl auf Anhieb zu funktionieren.

     
    #4
  6. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    hi,

    also ich würde auf deiner Clientbox eine Cccam.prio mit den verfügbaren Karten erstellen!
    wie oben schon erwähnt auf einem reinen Server der kein Bild erhellen muss brauchst du keine dvbapi.

    lg, Laila
     
    #5
    buckfush gefällt das.
  7. buckfush
    Offline

    buckfush Ist gelegentlich hier

    Registriert:
    16. Juni 2009
    Beiträge:
    75
    Zustimmungen:
    50
    Punkte für Erfolge:
    0
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    Ja.. hab ich jetzt so gemacht.

    Oscam auf dem Client läuft bereits... Und es trudeln bereits EMM's ein.
    Bisher nur Globals und Uniques.

    Beim Reader ist jetzt auch alles grün:
    [​IMG]
    Vorher war hier der erste Eintrag expired.

    Vielen Dank für die Hilfe.

    Das Thema hab ich wirklcih TOTAL falsch verstanden.
    Der Thread wäre eigentlich nicht nötig gewesen ....

    Danke nochmal .. !
     
    #6
    mxer und laila-no1 gefällt das.
  8. buckfush
    Offline

    buckfush Ist gelegentlich hier

    Registriert:
    16. Juni 2009
    Beiträge:
    75
    Zustimmungen:
    50
    Punkte für Erfolge:
    0
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    So.. läuft also bisher sehr stabil.
    Eigentlich genauso gut wie die CCcam als client.

    Allerdings hab ich jetzt noch ein Problem.
    Wenn der Oscam-Server gebootet wird... kommt der client nicht mehr online.
    Erst wenn ich auf einen anderen Sender umschalte wird wieder weiter decodiert.

    Aber wenn der Receiver auf dem gleichen Sender stehen bleibt... wird das Signal nicht mehr entschlüsselt.
    Das Gleiche passiert wenn ich den User disable und danach wieder enable.

    Das ist zwar nicht so super tragisch.... aber bissl unschön... vielleicht gibts da ja eine Lösung ?

    Hier mal die Config vom Client:

    [TABLE="class: grid, width: 500, align: left"]

    Client - OSCAM.CONF
    Client - Oscam.user
    Client - Oscam.server

    [global]
    disablelog = 1
    disableuserfile = 1
    usrfileflag = 0
    maxlogsize = 10
    preferlocalcards = 1
    saveinithistory = 1
    lb_mode = 0
    clienttimeout = 15000

    [dvbapi]
    enabled = 1
    au = 1
    user = dvbapi
    request_mode = 0
    [account]
    disabled = 0
    user = XXXXXX
    pwd = XXXXXX
    description =
    hostname =
    caid = 098C
    uniq = 0
    sleepsend = 0
    failban = 0
    monlevel = 1
    sleep = 0
    suppresscmd08 = 1
    keepalive = 1
    au = 1
    emmreassembly = 2
    expdate =
    allowedprotocols =
    allowedtimeframe =
    betatunnel =
    group = 1
    services =
    ident =
    chid =
    class =
    cacheex = 0
    cacheex_maxhop = 0
    cacheex_ecm_filter =
    cacheex_drop_csp = 0
    cacheex_allow_request = 1
    cccmaxhops = 10
    cccreshare = -1
    cccignorereshare = -1
    cccstealth = -1
    fakedelay = -1
    numusers = -1
    penalty = -1
    [reader]
    label = Mein_Igel
    enable = 1
    protocol = cccam
    device = 192.168.X.X,18xxx
    user = dvbapi
    password = XXX
    services =
    inactivitytimeout = 30
    reconnecttimeout = 2
    caid = 098C
    ident =
    group = 1
    emmcache = 1,3,2
    lb_weight = 100
    cccversion = 2.3.0
    cccmaxhops = 2
    ccckeepalive = 1
    emmcache = 1,3,15
    audisabled = 0
    [/TABLE]

    Ich hab schon einige Einstellungen verändert.. und danach getestet... aber bisher noch kein Glück gehabt. Egal was ich einstelle.. der Client fängt nicht mehr an zu decodieren wenn man nicht auf einen anderen Sender umschaltet.
     
    #7
  9. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.382
    Zustimmungen:
    23.798
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    Hallo buckfisch,

    da kannst du als Server gar nichts machen.
    Das liegt am clienten.

    Ich hatte das mal mit meinem Pingulux als Client. Da gab es oscam Versionen, die ganauso reagierten, wie du beschrieben hast. Da half nur aiuf dem Pingulux die oscam Version zu wechseln.
    Was hat dein client für einen Receiver?
    Was für Emu läuft auf seinem Receiver?


    Mlg Pilot
     
    #8
    buckfush gefällt das.
  10. buckfush
    Offline

    buckfush Ist gelegentlich hier

    Registriert:
    16. Juni 2009
    Beiträge:
    75
    Zustimmungen:
    50
    Punkte für Erfolge:
    0
    AW: DVBAPI will nicht (Igel Thin client - IPC - Server: Oscam 8930, Client: CCcam 2.

    Hallo Pilot..

    Ich bin von DM800 auf xTrend ET4000 umgestiegen.
    Hab die bisher mit CCcam betrieben.
    Aber da geht ja nix mit EMM.

    Deswegen jetzt der Umstieg auf Oscam.

    Hmmm Werd ich mal kucken müssen ob ich ne andere oscam-Version finde für die ET4000.
    Beim Open-PLI gibts nur eine zum Downloaden....

    Gruß
    BF
     
    #9

Diese Seite empfehlen