1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Webinterface nach Neustart nicht mehr aufrufbar

Dieses Thema im Forum "IPC" wurde erstellt von Biland, 23. März 2012.

  1. Biland
    Offline

    Biland Ist gelegentlich hier

    Registriert:
    19. Mai 2009
    Beiträge:
    92
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Beruf:
    Projektleiter
    Guten Morgen zusammen,
    nach einem gestrigen neutart meines Servers kann ich leider das Webintervace meines IPCs nichtmehr aufrufen.
    Sonst funktioniert alles noch taldellos!
    Habt ihr einen Verdacht woran es liegen könnte (Apache?)?

    Danke für eure Infos.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.920
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    /etc/init.d/apache2 restart in der Console eintragen und Apache neu starten.
     
    #2
    Biland gefällt das.
  4. elcoro
    Offline

    elcoro Moderator Digital Eliteboard Team

    Registriert:
    1. Juli 2011
    Beiträge:
    1.628
    Zustimmungen:
    638
    Punkte für Erfolge:
    113
    Beruf:
    Storehouse
    Ort:
    nel Mondo
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    und wen immer automatic bei reboot startet muss, wie geht das Bitte.

    Danke
     
    #3
  5. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    kannst du das bitte genauer erklären?
    ich versteh nämlich den zusammenhang nicht mit diesem thread und deinem geschrieben "immer automatisch bei reboot startet"

    apache2 wird normalerweise so installiert das es immer automatisch gestartet wird. fals das mal nicht der fall war kann man das mögliche problem im apache2 log nachgucken zum beispiel /var/log/apache2/error.log




    ps: ständiges rebooten des server ist aber auch unnötig
     
    #4
  6. dersimlicemo
    Offline

    dersimlicemo Freak

    Registriert:
    13. Januar 2011
    Beiträge:
    274
    Zustimmungen:
    7
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    hi leute,

    Ich habe einen so ähnlichen fehler. Ich habe ein Update auf 11.5 gemacht soweit so gut Webif hat auch funktioniert ich habe an der i cfg etwas rumgespielt jetzt kommt nur noch ne komplett weise leere seite zu sehen.

    # ACHTUNG: Parameter immer zwischen Anfuehrungszeichen -> 'wert'

    #WebIf Control anzeigen als:
    # menue = eigener Menueeintrag
    # hide = versteckt unter Home
    # stay = immer sichtbar unter Home
    WEBIF_CON='menue'

    #WebIf Menue in welchem Style anzeigen:
    # new = neues design
    # old = altes design
    WEBIF_MENUE='new'

    #WebIf Logs Display Style (new/old)
    # new = with grep
    # old = without grep, each logfile an own button..
    WEBIF_LOGS='old'

    #Website Benutzer und Kennwort (.htaccess)
    # diese einstellung darf nicht leer sein sonst geht die website/webif nicht!
    HTTPUSER='xxxxx'
    HTTPPASS='xxxxx'

    #Cron-Steuerung bei EMU stop/start? (0/1)
    CRON='1'

    #Aenderungen in CCcam.cfg protokollieren? (0/1)
    CHANGELOG='1'
     
    #5
  7. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    so ein ähnliches problem? in diesem thread geht es darum das der webserver apache2 prozess nach reboot nicht gestartet wird.. bei dir läuft der prozess aber offensichtlich noch also hat das nichts mit dem thema in diesem thread zu tun!

    es hatte ja offensichtlich auch zuerst funktioniert nur nachdem du an "i cfg" herrum gespielt hast nicht mehr also: was heisst "in der i cfg herrum gespielt" ?
    "i cfg" ist aber auch umfangreicher als du gepostet hast also beschreib bitte ausführlicher was du verändert hast - und das in einem für dein problem passenden thread! wenn du keinen findest dann erstell dir einen!



    ps: die datei muss immer über den dafür vorgesehenen befehl " i cfg " bearbeitet werden!
     
    #6
  8. dersimlicemo
    Offline

    dersimlicemo Freak

    Registriert:
    13. Januar 2011
    Beiträge:
    274
    Zustimmungen:
    7
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    ich weis nicht mehr genau wo ich was verändert habe :(

    kann ich die 11.5 neu updaten? würde das nicht helfen?
     
    #7
  9. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    wenn du "i cfg" vollständig posten würdest und auch detailierter beschreiben würdest wie du vorgegangen bist usw könnte man dir geziehlter helfen aber SO ist das nur ein rätzelraten..


    natürlich kannst du ipc drüber installieren


    aber das war nun auch die letzte antwort die ich Dir hier in diesem thread gebe da das wie bereits erwähnt nichts mit dem thema hier zu tun hat!
     
    #8
  10. dersimlicemo
    Offline

    dersimlicemo Freak

    Registriert:
    13. Januar 2011
    Beiträge:
    274
    Zustimmungen:
    7
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    Das mit dem thread tut mir leid. Sorry :( hab ich wohl Falsch verstanden.

    ich hab jetzt ein neu update gemacht und alles funzt ;) danke!
     
    #9
  11. centrino
    Offline

    centrino Ist oft hier

    Registriert:
    26. September 2011
    Beiträge:
    187
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    das problem habe ich auch nach dem ich phpSysInfo installiert habe mit aktuelle 2012-10-28-wheezy-raspbian image

    nachdem reboot habe ich keine ipc web anzeige mehr
    hier meine logs vielleicht hilfts jemanden/var/log/apache2/error.log:
    /var/log/apache2/error.log:
    [Sun Nov 11 16:17:39 2012] [notice] Apache/2.2.22 (Debian) configured -- resuming normal operations
    [Sun Nov 11 16:17:49 2012] [notice] caught SIGTERM, shutting down
    [Sun Nov 11 16:17:51 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:18:46 2012] [notice] Graceful restart requested, doing restart
    apache2: apr_sockaddr_info_get() failed for raspbian2
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Sun Nov 11 16:18:47 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:21:45 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    sudo: unable to resolve host raspbian2
    [Sun Nov 11 16:26:05 2012] [notice] Graceful restart requested, doing restart
    [Sun Nov 11 16:26:06 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:26:16 2012] [notice] Graceful restart requested, doing restart
    [Sun Nov 11 16:26:17 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:48:21 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:51:04 2012] [notice] caught SIGTERM, shutting down
    [Sun Nov 11 16:52:04 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 16:54:48 2012] [notice] caught SIGTERM, shutting down
    [Sun Nov 11 16:55:04 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations
    [Sun Nov 11 17:09:22 2012] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-9 configured -- resuming normal operations

    unter
    Code:
     i jobs 
    Code:
    #Apache nochmal starten
    /etc/init.d/apache2 start &
    habe ich dies eingefügt ganz unten siehe da nach reboot habe ich web ipc wieder vor mir:ja

    edit:
    so ich muss mich nochmals korigieren ich habe nochmals image frisch installiert.
    phpSysInfo hat mit web ipc hat nichts mit zu tun.
    Nachdem ich ipc frisch installiert habe web ipc gings ...nach einem reboot ging web ipc wieder nicht als Hilfe siehe oben funktionierts wieder.
     
    Zuletzt bearbeitet: 11. November 2012
    #10
    ysimmerath und al-x83 gefällt das.
  12. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    für "i jobs" ist der eintrag aber ungültig.. meinst du vielleicht "i as"?
     
    #11
  13. centrino
    Offline

    centrino Ist oft hier

    Registriert:
    26. September 2011
    Beiträge:
    187
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    doch ich habes unter "i jobs" weiß nicht aber es funktioniert nach reboot


    jetzt habe ich unter
    "i as" auch drinnen

    "i as" habes von hier

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #12
  14. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    wenn es funktioniert hat es nichts mit dem eintrag in "i jobs" zu tun, denn das wird so 100% nicht funktionieren..
    "i jobs" ist die crontab und da muss die syntax eingehalten werden..
    wer das so wie du beschrieben hast in die crontab einträgt riskiert dass das komplette file nicht mehr beachtet sondern ignoriert wird

    wenn dann trägt man die zeile in "i as" ein, denn da stehen bei ipc bereits andere die auch so aussehen..
     
    #13
  15. centrino
    Offline

    centrino Ist oft hier

    Registriert:
    26. September 2011
    Beiträge:
    187
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: Webinterface nach Neustart nicht mehr aufrufbar

    also das ist eine komische box .ich wollte jetzt nochmals genau wissen.

    karte nochmals format und installieren siehe da jetzt läüfts ipc web sogar nach reboot phpSysInfo danach installiert ipc web läüfts
    ohne "i jobs" und "i as" zu ändern

    das ist ja echt.. :emoticon-0116-evilg obwohl ich immer gleiche install schritte ausführe


    servus
     
    #14
  16. aragorn
    Online

    aragorn Guest

    AW: Webinterface nach Neustart nicht mehr aufrufbar

    es kann trotzdem vorkommen das es beim 10.mal booten nicht mehr geht.. aber wenn möglich sollte man nie rebooten das ist unnötig

    das problem liegt am verändern des bootvorgangs ab debian squeeze.. zuvor wurde für den bootvorgang sysvinit genutzt aber bedingt durch die neuen kernels usw muss jetzt "upstart" oder "systemd" genutzt werden. leider sind sich die debian entwickler aber auch noch nicht einigen was sie nun verwenden wollen..
    hintergrund ist die bessere unterstützung und erkennung von handware beim bootvorgang in kombination mit den neueren kernels, das ist mit sysvinit in der form nicht möglich
    sysvinit wird zwar weiterhin unterstützt aber wird erst wesendlich später ausgeführt und somit kann es passieren das tmp2ram (also /etc/init.d/varlog) entweder zu früh oder zu spät gestartet wird und dann das verzeichnis /var/log/apache2 nicht verhanden is und apache2 somit nicht starten kann..

    mehr infos dazu:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?




    guck einfach mal eine seite zurück in dem thread wo du die "i as" anpassung her hast, da hab ich das bereits beschrieben und versucht ein workaround zu erstellen, leider mit nur mässigem erfolg..
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2012
    #15

Diese Seite empfehlen