1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem Samba share mounten

Dieses Thema im Forum "DM 500 HD Clones" wurde erstellt von m707, 17. Oktober 2011.

  1. m707
    Offline

    m707 Ist gelegentlich hier

    Registriert:
    31. Januar 2011
    Beiträge:
    43
    Zustimmungen:
    5
    Punkte für Erfolge:
    0
    Ich habe hier eine DM 500 Clone HD aus dem Boardshop und versuche auf Ihr verzweifelt einen samba share (PDC, debian squeeze) aus dem LAN zu mounten:
    Code:
    maik@t400:~$ smbclient -L work
    Enter maik's password: 
    Domain=[MAIK] OS=[Unix] Server=[Samba 3.5.6]
    [...]
        public          Disk      oeffentliches Verzeichnis
    [...]
    maik@t400:~$ telnet dm500
    [...]
    OpenDreambox  
    dm500hd login: root
    root@dm500hd:~# ls -ld /media/public
    drwxr-xr-x    2 root     root            0 Sep 24 14:44 /media/public
    root@dm500hd:~# mount -t cifs //work/public /media/public -o username=maik%XXXXXXX
    mount: mounting //work/public on /media/public failed: Invalid argument
    Neben der dm500 steht hier noch eine clarke-tech 9100 mit aktuellem openpli, wo ich das gleiche share über diesen fstab Eintrag:
    Code:
    //work/public        /media/public        cifs       username=maik%XXXXX   0  0
    problemlos eingebunden bekomme:
    Code:
    root@et9000:~# mount
    [...]
    //work/public on /media/public type cifs (rw,mand,relatime,unc=\work\public,username=maik,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.10.1,posixpaths,serverino,acl,rsize=16384,wsize=16384)
    Was habe ich denn hier übersehen?

    TIA
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. m707
    Offline

    m707 Ist gelegentlich hier

    Registriert:
    31. Januar 2011
    Beiträge:
    43
    Zustimmungen:
    5
    Punkte für Erfolge:
    0
    AW: Samba share mounten

    Also mache ich mal die Ingrid:

    Das da oben geht nicht weil das mount(.cifs) das dieses image mitbringt/installiert völlig kastriert ist. Es macht weder einen DNS lookup auf einen vorgegebenen Servernamen (auch nicht wenn full-qualified) noch versteht es die -o username=name%password Syntax :(:
    Code:
    root@dm500hd:/# mount -t cifs //192.168.10.1/public /media/public -o username=maik,password=XXXXXX
    root@dm500hd:/# mount | grep public        
    //192.168.10.1/public on /media/public type cifs (rw,mand,unc=\192.168.10.1\public,username=maik,rsize=16384,wsize=16384)
    Das mount des openpli macht einen vernünftigen DNS lookup für den Servernamen und kennt auch die % Syntax. Daher hätte ich nicht erwartet, dass sich das mount auf dieser clone box grundsätzlich anders verhält. Kenne mich noch nicht wirklich aus, aber vermute, dass dieses kastrierte mount von hier:
    Code:
    ---cut /etc/opkg/official-feed.conf---
    src/gz official [U]src/gz official http://feed.newnigma2.to/stable/dm500hd/3.2[/U]
    ---cut---
    stammt. HTH
     
    #2

Diese Seite empfehlen