1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problema Passare linea al server e gestire i client da li.

Dieses Thema im Forum "Zona: Linux-Server" wurde erstellt von fulvi0x, 16. April 2013.

  1. fulvi0x
    Offline

    fulvi0x Ist gelegentlich hier

    Registriert:
    20. März 2013
    Beiträge:
    96
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    Ciao a tutti, ho appena messo su un server..
    Ho provato a passare la linea ad un client passando per il server.. la mia intenzione era di portare tutti i client sul server..
    Però ho dei problemi..
    Vi spiego come ho fatto ..
    Passo al server la nline che arriva dal mio decoder, poi tramite protocollo cccam dal server passo la linea al client..
    Ho provato sia senza user dvbapi sia con user dvbapi.. perchè ho letto che sul server linux non serve avere il dvbapi..
    Il client si connette al server ma vede 0cards.

    Secondo voi sbaglio qualcosa nella parte teorica??
    Se volete vi posto le conf che mi chiedete.. o lato server o lato decoder..
    ciao grazie
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Passare linea al server e gestire i client da li.

    Posta per favore le configs del server e del decoder IN SPOILER
     
    #2
  4. fulvi0x
    Offline

    fulvi0x Ist gelegentlich hier

    Registriert:
    20. März 2013
    Beiträge:
    96
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    ################## DECODER ##################

    oscam.conf
    [global]
    #logfile = stdout
    fallbacktimeout = 2000
    failbantime = 5
    cachedelay = 120
    nice = -1
    maxlogsize = 2048
    preferlocalcards = 1
    saveinithistory = 1
    logfile = /media/usb/oscam/oscam.log
    usrfile = /media/usb/oscam/oscamuser.log
    usrfileflag = 1
    disableuserfile = 0


    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi
    pmt_mode = 0


    [monitor]
    port = 16500
    monlevel = 4
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.255.255


    [webif]
    httpport = xxxxx
    httphelplang = it
    httpuser = xxx
    httppwd = xxxx
    httpallowed = 0.0.0.0-255.255.255.255
    httphideidleclients = 1


    [newcamd]
    key = 0102030405060708091011121314
    port = 12345@09CD:000000


    [cccam]
    port = 12346
    version = 2.3.0
    reshare = 1
    reshare_mode = 0

    oscam.server
    [reader]
    label = skyitlocal
    protocol = internal
    device = /dev/sci0
    caid = 09CD
    boxid = xxxxx
    detect = cd
    ins7e11 = 15
    ident = 09CD:000000
    group = 1
    emmcache = 1,3,2


    [reader]
    label = vps
    protocol = cccam
    device = xxxxx,xxxxx
    #key = 0102030405060708091011121314
    user = lol
    password = loll
    group = 3
    cccversion = 2.3.0
    ccckeepalive = 1

    oscam.user
    [account]
    user = dvbapi
    group = 1,2,3
    au = 1

    [account]
    user = ns0
    pwd = ns0
    group = 1
    au = skyitlocal
    uniq = 3


    ################## SERVER ##################

    oscam.conf
    [global]
    #logfile = stdout
    nice = -1
    maxlogsize = 2480
    waitforcards_extra_delay = 1500
    preferlocalcards = 1
    dropdups = 1
    emmlogdir = /var/log/oscam/
    logfile = /var/log/oscam/oscam.log
    lb_mode = 10
    resolvegethostbyname = 1
    suppresscmd08 = 1


    [dvbapi]
    enabled = 1
    au = 1
    boxtype = pc
    user = dvbapi
    pmt_mode = 0




    [newcamd]
    port = 23000@09CD:000000
    key = 0102030405060708091011121314
    keepalive = 1


    [cccam]
    port = 12347
    #nodeid = B66798A0105314EB
    version = 2.3.0
    reshare = 1
    reshare_mode = 0
    #forward_origin_card = 1
    #minimizecards = 1


    [monitor]
    port = 16002
    aulow = 120
    monlevel = 4
    appendchaninfo = 1


    [webif]
    httpport = xxxx
    httpuser = xxxxx
    httppwd = xxx
    httphideidleclients = 1
    httpallowed = 0.0.0.0-255.255.255.255
    aulow = 120
    appendchaninfo = 1


    [cache]
    max_count = 5000
    wait_time = 09CD:100:0
    cacheexenablestats = 0
    cwcycle_check_caid = 09CD
    cwcycle_maxlist = 2000
    cwcycle_keeptime = 15
    cwcycle_onbad = 1
    cwcycle_dropold = 1

    oscam.server
    [reader]
    label = skyit0x
    protocol = newcamd
    device = xxxx,12345
    key = 0102030405060708091011121314
    user = ns0
    password = ns0
    group = 1


    [reader]
    label = m7+tivusat
    protocol = cccam
    device = xxxxx,xxxx
    #key = 0102030405060708091011121314
    user = xxxx
    password = xxxx
    group = 3
    cccversion = 2.3.0
    ccckeepalive = 1

    oscam.user
    [account]
    user = dvbapi
    group = 1,2,3
    au = 1


    [account]
    user = lol
    pwd = loll
    group = 2,3
    au = 1
    uniq = 3


    [account]
    user = pippog
    pwd = pippogpwd
    group = 1
    au = skyit0x
    uniq = 3
    cccignorereshare = 1
    cccreshare = 0

    al client ho dato questa cline
    C: ipserver 12347 pippog pippogpwd

    c'è qualcosa di sbagliato??

    [se non si capisce la gestione dei gruppi sul server.. gruppo 1 è quello che ricevo dal mio decoder.. gruppo 2 è la cache.. e gruppo 3 è quello che ricevo da altri che poi sharo al mio decoder.. l'ho messo in un gruppo a parte per non rishararmi anche la locale nel gruppo 1.. quindi le linee che ricevo le metto tutte nel 3 e poi le porto sul decoder con una cline.. invece ai client devo dare il gruppo 1 perchè do solo la mia locale..]

    speriamo di risolvere.. sembrava più semplice la configurazione.. invece pure c'è qualcosa di sbagliato!! :(
     
    Zuletzt bearbeitet: 17. April 2013
    #3
  5. fulvi0x
    Offline

    fulvi0x Ist gelegentlich hier

    Registriert:
    20. März 2013
    Beiträge:
    96
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    non so se può essere utile.. ma con quelle conf ho provato a passare la linea con cccam e funziona.. con newcamd e camd35 no..
    per quale motivo? ho provato a cambiare anche versione oscam sul server..
    sul decoder quella versione va sicuro perchè i miei client del decoder leggono da nline.. quindi il protocollo newcamd funziona sul decoder..
    quindi il problema si indirizza sui due protocolli newcamd e camd35 che non vanno sul server..
    quali possono essere le cause??

    ho notato che nello status della webif non mi riconosce proprio l'ip del decoder quando uso newcamd o camd35, quindi non si connette proprio..
    ip mi da 0.0.0.0 e status UNKNOWN.
    invece con cccam mi da connected e l'ip reale del decoder..
    ho visto nei log e riconosce il proxy camd35 o newcamd ma poi non chiede proprio la richiesta di dns verso l'hostname del decoder, quindi ho provato direttamente a mettere l'ip del decoder ma niente..

    ho fatto un po' di ricerche sul web e il problema è stato avuto anche da altre persone.. ma alla fine di tutte le discussioni che ho trovato nessuno mai ha trovato una soluzione.
    possibile che non si può scambiare oscam to oscam con protocollo camd35 o newcamd ?!?!?
    HELP ME!!
     
    Zuletzt bearbeitet: 17. April 2013
    #4

Diese Seite empfehlen