1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Oscam (Windows) beendet sich von Zeit zu Zeit ohne erkennbaren Grund

Dieses Thema im Forum "OScam Archiv" wurde erstellt von Rockwell, 26. Februar 2012.

  1. Rockwell
    Offline

    Rockwell Newbie

    Registriert:
    4. Februar 2012
    Beiträge:
    16
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Hallo zusammen, es gäbe sicherlich angenehmere Gründe für meinen ersten Beitrag hier im Forum, aber ich weiß mir einfach keinen Rat mehr :emoticon-0124-worri
    Habe seit längerer Zeit einen Cardserver am Start. Lange Zeit wars der mpcs, seit einem Jahr oder so ist es der Oscam. Soweit war auch alles stabil und problemlos. Abgesehen davon, dass der Rechner auf dem das Konstrukt beheimatet war, eher instabiler bzw. zickiger Natur war. Das hat sich erledigt, nachdem ich die Innereien des Rechner erneuert hatte. Mit dem Xeon und dem Sockel 775 Board war zum Jahresende hin alles in bester Form. Jetzt geht`s aber los: Ich hab gleichzeitig zwei (drei) Projekte angefangen, die potentielle Auslöser meines Problems sein können (oder aber auch nicht?). Sky HD ist ja so easy gewesen, dass es kaum erwähnt werden braucht. HD+ war da schon das bedeutend größere Kaliber. Bis das gelaufen ist, musste ich mir eine PCS-Steckkarte mit zwei seriellen Schnittstellen kaufen, weil die USB-Seriell Adapter alle nicht funktioniert haben. Habs aber hinbekommen, gibt ja gute Foren zum mitlesen. Und dann sind da noch drei Pingus (Edison Pingulux) neu auf dem Server, die ich im Verdacht habe, in irgendeiner Form am Oscam-Absturz beteiligt zu sein. Es ist so, dass Oscam machmal tagelang ohne gesundheitliche Beschwerden durchläuft und plötzlich, aus einem mir unerklärlichen Grund, beendet er sich sang- und klanglos. Hat nicht zwangsläufig mit der Anzahl der eingeloggten Teilnehmer zu tun, obwohl die Wahrscheinlichkeit während der Bundesliga am Samstag höher ist. Aber das kann auch mal gutgehen, so dass man (ich) glaubt, jetzt ist es überstanden. Und dann, aus dem Nichts heraus, ist er wieder weg, manchmal zweimal direkt hintereinander. :emoticon-0181-fubar
    Was ich probiert habe: Verschiedene Oscam Versionen. Je neuer die Versionen werden, umso schneller stürzt er wieder ab. Alle Versionen über 6xxx verschwinden direkt wieder, nachdem sie die beiden Karten erkannt und initialisiert haben. Standardversion ist die Stable 5954, hab mich jetzt weiter rückwärts gehangelt und bin bei SVN 5642 angelangt. Allerdings auch heute wieder mit einem unverhofften Absturz des Programms. Kartenleser sind für beide Karten einfache Smartmouse kompatible Geräte. Eins ist schon deutlich älter (deutlich über 10 Jahre) und lässt sich auch von der Taktfrequenz umstellen. Ist nur eine blanke Platine und beheimatet die Sky S02 Karte. Der andere Reader ist einer aus der Bucht, schwarz und original mit beiliegendem USB-Seriell Adapter. Der ist für die schwarze HD+ Karte zuständig. Beide Kartenleser sind an der o.g. PCI-Karte angeschlossen. Der Rechner läuft seit letzter Woche unter Win7 Professional, WinXP SP3 ist auf der anderen Partition als Option weiterhin vorhanden.

    Fehlen noch Infos? Ich bin wirklich für jeden Rat dankbar und würde das Problem endlich endlich gerne in den Griff bekommen.
    Anbei ein Screenshot von heute. Hilft das? Den Anhang 51459 betrachten
     
    Zuletzt bearbeitet: 26. Februar 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. dennyd
    Offline

    dennyd Hacker

    Registriert:
    18. Januar 2011
    Beiträge:
    460
    Zustimmungen:
    166
    Punkte für Erfolge:
    43
    Ort:
    DEB
    AW: Oscam (Windows) beendet sich von Zeit zu Zeit ohne erkennbaren Grund

    Nehm doch mal eine Stable Version. Nur weil die Build recht klein ist, heißt das ja noch nicht, dass die Version dadurch stabiler wird. Mit neuen Versionen habe ich auch immer wieder Probleme. Direktes Abstürzen nach dem Init habe ich auch bei jeder größer 1.20 Build 6100. Ich nutze nun Oscam 1.10 RC build 6089. Diese wird täglich um 04:30Uhr durch einen Task neu gestartet und läuft so schon monatelang stabil. Ohne den Neustart jeden morgen wäre es nicht so klasse, da Oscam sich auch in der Version manchmal nach mehreren Tagen aufhängt. Mit dem täglichen neustart läuft sie klasse und um 04:30 stört der auch keinen, hoffe ich ;). Leider muss man dann natürlich auf Features der 1.20 verzichten, was für sharing im normalen Rahmen aber nicht weiter schlimm ist, wie ich denke.
     
    #2
  4. zoid
    Offline

    zoid Newbie

    Registriert:
    9. Juni 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Oscam (Windows) beendet sich von Zeit zu Zeit ohne erkennbaren Grund

    Wenn schon Windows, dann schon mal eine kleine VirtualBox mit Linux in Betracht gezogen? Da läuft auch Oscam mit USB-Adaptern (zumindest mit Smargos) wochenlang ohne Probleme...
     
    #3
  5. blubah
    Offline

    blubah Ist oft hier

    Registriert:
    1. Juli 2010
    Beiträge:
    157
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Beruf:
    Security Engineer
    AW: Oscam (Windows) beendet sich von Zeit zu Zeit ohne erkennbaren Grund

    Soweit ich weiß kann man keine PCI-Karte über ne VM ansprechen. So wie er es schreibt bzw. ich es verstehe nutzt er eine um die Leser seriell anzusprechen.
    Bei mir gings mit ner PCI-Sat-Karte nicht ... .
     
    Zuletzt von einem Moderator bearbeitet: 27. Februar 2012
    #4
  6. Rockwell
    Offline

    Rockwell Newbie

    Registriert:
    4. Februar 2012
    Beiträge:
    16
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    AW: Oscam (Windows) beendet sich von Zeit zu Zeit ohne erkennbaren Grund

    Danke euch für die Antworten und Tipps. Ich nutze normalerweise eine Stable-Version von Oscam, jetzt auch wieder. Der Weg zurück zu einer älteren Version sollte nur ein (weiterer) Versuch sein, die Fehlerursache einzugrenzen. Da die SVN 5642 aber auch nicht stabiler ist, scheint die Ursache woanders zu liegen. Heute hab ich mal einen anderen Ansatz probiert und bin im Bios des Rechners ein wenig in die Details gegangen. Hab auf den Chipsatz ein wenig mehr Spannung gegeben und erwarte mir davon mehr Stabilität, obwohl es vorher keine Anzeichen einer Instabilität gab. Jetzt muss ich halt wieder warten und hoffen, dass die Abstürze nun ausbleiben. Direkt provozieren lässt es sich nicht. Eine VM (mit z.B. debian) unter Windows ist eine Alternative, aber so groß ist der Leidensdruck noch nicht, dass ich mir das gebe ;-) Dann mach ich wahrscheinlich eher den ganzen Rechner platt und mach einen Hackintosh draus. Wäre nicht der erste im Haushalt.^^
     
    #5
  7. Rockwell
    Offline

    Rockwell Newbie

    Registriert:
    4. Februar 2012
    Beiträge:
    16
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Als vorläufige (hoffentlich auch endgültige) Rückmeldung zu meiner eigenen Frage möchte ich das Problem als gelöst melden. Was ist passiert? Ich habe am vergangenen Mittwoch, mehr oder weniger freilwiilig, ein paar Stunden Zeit investiert. Meine Tochter braucht für ihren, bald entstehenden neuen Rehner ein Windows 7 64bit. Das war nun gerade frisch auf dem Wohnzimmer-Rechner. Da es aus anderen Foren so klang, als wäre Win7 64bit eher Kontraproduktiv für Produkte wie dvbviewer & Co., aber ich mich kurzfristig zu einer Umrüstung auf 32bit entschlossen. Das hat nun nicht unmittelbar beim Oscam Problem geholfen (und beim Ruckeln der HDTV-Wiedergaben des dvbviewers schon gar nicht), aber da gibt es eine PCI-Karte mit zwei seriellen Schnittstellen, die ich weiter oben schon mal erwähnt hatte. Nach der Installation wollte ein Kartenleser plötzlich nicht mehr (eine Geschwindigkeit von 178500 wird nicht unterstützt, der RSA Key ist verkehrt und überhaupt hab ich keinen Bock heute). Das war irgendwie absolut nicht in den Griff zu bekommen, selbst als ich Windows XP von der anderen Partition bootete, zeigte sich das gleiche Verhalten. Obwohl das mit der gleich Konfig vorher funktioniert hat, halt mit den sproradischen Abstürzen des Oscam. Als ich dann die Steckkarte mal einen Platz weiter nach oben verlegt hatte, neue Portnummern vergeben und diese auch in der Oscam.Server angepasst hatte, war auf einmal alles ganz problemlos und unauffällig. Und genau so ist es bis jetzt geblieben :)
     
    #6
  8. Rockwell
    Offline

    Rockwell Newbie

    Registriert:
    4. Februar 2012
    Beiträge:
    16
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Tja, leider war der Frieden nicht von langer Dauer :-( Seit einiger Zeit häufen sich plötzlich wieder die Abstürze von Oscam, ohne dass ich am Rechner selber was wesentliches verändert hätte. Vielleicht sollte ich doch mal den Versuch mit der Virtual-Box und Oscam auf einem (schlanken) Linux darin!? Aber welches Linux ist am besten in der Virtual-Box geeignet und ist die Virtual-Box überhaupt der geeignete Host? VM-Ware wird wohl eher zu belastend für den Rechner sein? Oder gibt es gar noch eine Möglichkeit, die ich übersehen habe?
     
    #7
  9. zoid
    Offline

    zoid Newbie

    Registriert:
    9. Juni 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ich habe gute Erfahrungen mit der Oracle VirtualBox gemacht, da hier zumindest im Gegensatz zur Hyper-V die USB-Ports direkt durchgeschleift werden können; damit laufen zumindest die Smargos problemlos. Wie es sich mit den seriellen Dingern verhält, musst Du wohl testen. Vermutlich tut es jedes schlanke Linux, ich hab Ubuntu Server (ohne GUI und sonstiges) im Betrieb. Das läuft recht genügsam auch auf älteren Rechnern. Bonus-Vorteil: Man kann auch einfach mal die VM auf einen anderen Rechner schieben, die Kartenleser einstöpseln und alles läuft auf Anhieb ;)
     
    #8

Diese Seite empfehlen