1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam update, neue Version läuft nicht?

Dieses Thema im Forum "OScam Archiv" wurde erstellt von bombadil, 15. September 2011.

  1. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    Hallo und Moin,
    da hier im Board immer mal wieder erwähnt wird die neueren Versionen des oscam zu nehmen, wollte ich da mal updaten.

    Erst mal zum System:

    Devicename: dm800se Enigma
    Version: 2011-03-21-3.1
    Image Version: Release 3.1.0 2011-03-23
    Frontprozessor Version: V3
    Webinterface Version: 1.6.6

    Darauf habe ich das GP3 Plugin installiert. Meine D09 und D02 Karten laufen mit CCcam_2.2.1/oscam_1.00.

    Die laufende oscam Version habe ich aus dem Gp-Cam- Feed_02_mips. Es ist die:

    oscam 1.00-unstable_by EasyBuild_svn build #5368

    damit werden die Sender hell, ich kann auch im WebInterface den Vorgang beobachten.

    Dann habe ich folgende Versionen ausprobiert:

    Oscam 1.10 stable SVN 5954 - mips-tuxbox
    oscam-stable-1.10(r5921)-mips-tuxbox-webif-Distribution
    Oscam-svn5460-light-Distribution

    folgende Vorgehensweise:


    1. Softcam auf Common Interface (Blue Panel), speichern
    2. per FTP auf die Box, in usr/bin oscam gelöscht
    3. neue Version in das Verzeichnis gesendet
    4. Rechte auf 755
    5. umbenannt in oscam_1.00 (wie der Dateiname vorher)
    6. Im Blue Panel CCcam_2.2.1/oscam_1.00. neu gestartet.
    Folge, bei allen drei binarys kein Start von oscam und auch kein WebInterface.

    Alles wieder rückgängig nach gleichem Schema, siehe da, alles wieder hell.

    Mache ich etwas verkehrt, oder laufen die oscams nicht. Gibt es bei jemandem hier im Board eine neuere Version, die auf diesem Systen arbeitet. Ich prügel mich schon seit ner Woche damit rum und würde mich über eure Hilfe freuen.

    Gruß an alle
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam update, neue Version läuft nicht?

    Eigentlich ist deine Vorgehensweise korrekt gewesen! Ich kann es mir nur daran erklären, dass du eventuell eine falsche Version genommen hast!

    mips-tuxbox muss es für die dm800se sein.
     
    Zuletzt bearbeitet: 15. September 2011
    #2
  4. giftstaub
    Offline

    giftstaub VIP

    Registriert:
    28. Januar 2010
    Beiträge:
    1.699
    Zustimmungen:
    1.656
    Punkte für Erfolge:
    113
    Ort:
    Ruhrpott
    AW: Oscam update, neue Version läuft nicht?

    Lässt sich die Stable OScam mit dem Parameter ./oscam_1.00 -h auf deiner DM800se Starten?

    Rechte 755 nicht vergessen!

    Alternative kannst du auch mal diese Stable 1.10rc Version nehmen.

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #3
  5. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam update, neue Version läuft nicht?

    Ich denke, das gilt auch für die Dream

    versions.txt

    available versions:
    - oscam-svnX-arm-coolstream Coolstream
    - oscam-svnX-x86_64-pc-linux 64 Bit Linux PC
    - oscam-svnX-i386-pc-linux 32 Bit Linux PC
    - oscam-svnX-mips-freetz Fritzbox Router
    - oscam-svnX-mips-freetz7390 Fritzbox 7390
    - oscam-svnX-mips-tuxbox DM500HD, DM800, DM7025, DM8000
    - oscam-svnX-mips-tuxbox-oe15 DM500HD, DM800, DM7025, DM8000 (for older images based on OE1.5, Openembedded 1.5)
    - oscam-svnX-powerpc-tuxbox DM600, DM7000, DM7020
    - oscam-svnX-powerpc-tuxbox-old Dbox2, DM500
    - oscam-svnX-sh4-qboxhd Duolabs Qbox
    - oscam-svnX-arm-dockstar Dockstar with ubuntu
    - oscam-svnX-arm-dockstar-openwrt Dockstar with openwrt
    - oscam-svnX-mips-wrt54g WRT54G router
    - oscam-svnX-mips-tplink tplink router
    - oscam-svnX-sh4-amino sh4 based stapi receiver like kathrein ufs
    - oscam-svnX-mips-azbox Azbox

    da ist zwar, die 800se nicht aufgeführt, aber ich denke das sollte trotzdem passen. Oder gibt es für die 800se ne eigene?
     
    #4
  6. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam update, neue Version läuft nicht?

    ja die sollte passen!
     
    #5
  7. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam update, neue Version läuft nicht?

    @giftstaub

    kannst du mir erklären, wie ich das mache? Telnet ist nicht sooo gaaanz der große Freund. Ich müßte ja auch CCcam/oscam starten, damit ich was sehen kann.

    Irgendwann stelle ich auch auf oscam only um. Da bni ich aber noch nicht weit genug.
     
    #6
  8. giftstaub
    Offline

    giftstaub VIP

    Registriert:
    28. Januar 2010
    Beiträge:
    1.699
    Zustimmungen:
    1.656
    Punkte für Erfolge:
    113
    Ort:
    Ruhrpott
    AW: Oscam update, neue Version läuft nicht?

    1. Unter Windows in der Ausführung cmd Eingeben und Enter.
    2. Telnet ip der Box Enter (z.B. telnet 192.168.0.1)

    Benutzername: root
    Passwort: dreambox

    Nun wechselst du in das Verzeichnis wo die oscam liegt (z.B cd /usr/bin)

    Jetzt Startest du die OScam mit ./oscam_1.00 -h ( OScam Rechte 755 nicht vergessen! )

    Sollte eine Fehlermeldung kommen Befehl Telnet nicht gefunden, dann musst du unter Systemsteuerung / Programme und Funktionen / Windows-funktionen den Telnet Client Hinzufügen.
     
    #7
    basque gefällt das.
  9. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    Werde ich dann mal testen. Bin grad wieder arbeiten. Vielleicht schaffe ich das morgen. Melde mich bei Erfolg und/oder bei nicht Erfolg.
    Danke schon mal für die Hilfe

    guten Morgen,
    ich habe die stable Version mit dem Parameter -h in Telnet gestartet. Die Hilfe wird angezeigt.
    Zweiter Schritt: Im Telnet die oscam (immer noch stable) gestartet.

    Meldung:
    warning
    demux, ca, socket in dvbapi section not recognized


    Mit ps laufende Prozesse abgefragt. Ausgabe: 4 Eintäge "/usr/bin/oscam_1.00

    Kein Webnterface

    CCcam_2.2.1 gestartet => ps : 4 Einträge oscam, 6 Einträge CCcam beilaufenden Prozessen. Keine Verbindung zwischen oscam und CCcam im WI des CCcam zu sehen.

    Alles wieder Retoure:

    laufende Prozesse
    unter anderem
    11x Oscam, 17x CCcam

    und die Verbindung CCcam/oscam steht.

    Was lüppt verkehrt ???????????????????

    Telnet könnte mein Freund werden

    Ich bins noch mal.

    Mir scheint, ich bin der einzige mit diesem Problem. Laufen bei euch sämtliche Revisionen der oscams? Oder müßt ihr auch mehrere ausprobieren, bis dann mal wieder eine funzt.

    Dann bleibt mir wohl oder übel nur noch die Möglichkeit, eine nach der anderen zu testen

    oder

    bei der Revision #5368 zu bleiben. (ist dann halt nicht so aktuell)

    Hat vielleicht noch einer ne andere, für die 800se funktionierende, Version. Ich wäre dankbar für ne Idee oder nen Tipp.

    Gruß ans Board
     
    Zuletzt von einem Moderator bearbeitet: 18. September 2011
    #8
  10. mr.nice53
    Offline

    mr.nice53 Hacker

    Registriert:
    19. Juni 2010
    Beiträge:
    329
    Zustimmungen:
    144
    Punkte für Erfolge:
    0
    AW: Oscam update, neue Version läuft nicht?

    Ich habe das gleiche Problem an meinen Pingulux bei mir hat es immer geholfen das ganze plugin zu löschen die neue oscam auf den Rechner in das plugin zu tun var/bin. Das plugin wieder aufspielen und die oscam.conf und alles andere wieder neu einzutragen. Dann ging auch das wifi und die neue oscam auch.
    Bitte eine Sicherung vorher machen um es wieder so einzutragen.
     
    #9
  11. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam update, neue Version läuft nicht?

    Der Tip ist gut. Danke dafür. Noch mal zum Verständnis.

    Du hast nur das GP3 Plugin entfernt. Richtig?
    Dann oscam ins Verzeichnis, danach GP3 wieder installiert.
    Danach war dann sowohl das WI und auch die Verbindung zu oscam wieder vorhanden?

    Oder hast du völlig neu geflasht und die cams händisch installiert?

    Ich hab inzwischen ca. 8 verschiedene oscams versucht. Ich kann alle mit telnet starten. Ebenso startet CCcam per telnet. Aber bei allen Rev. kein WebIf. Im Quelltext der versuchten oscam stand bei allen Das Webif unterstützt wird.

    Ich werde mal deinen Tip versuchen. War nur GP3 deinstallierern?
     
    #10
  12. mr.nice53
    Offline

    mr.nice53 Hacker

    Registriert:
    19. Juni 2010
    Beiträge:
    329
    Zustimmungen:
    144
    Punkte für Erfolge:
    0
    AW: Oscam update, neue Version läuft nicht?

    Ich habe es völlig neu geflasht. Und auf den Rechner schon die neue Oscam rein getan. So das alles wieder neu aufgespielt wurde. Alles runter und dann wieder drauf. Und neu booten lassen. Bei mir läuft zur zeit diese.

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    Zuletzt bearbeitet: 17. September 2011
    #11
  13. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    Werd dann morgen wohl noch mal neu flashen und die cams händisch installieren. Ich hoffe daß es dann funzt.

    hab ich doch den ganzen Sonntag (Buli-Zeit abgezogen), mit den oscams verbracht. Nach Neuflash und dem Installieren der oscams, Start über telnet kam die Meldung, daß oscam nicht startete, da er die Config in /var/tuxbox/config nicht öffnen konnte. Ging ja auch nicht, da waren ja auch keine. (Warum nicht im Ordner usr/keys? Vielleicht falsche Versionen?)
    Also Ordner config erstellt und die Dateien dorthin kopiert und oscam startete mit WebIf.
    Ich hatte aber keine Verbindung über Newcamd mit CCcam, so daß er die Proxiereader (ich hoffe, ich benutze den richtigen Ausfruck) nicht finden konnte (laut Log). Hab nat. oscam und dann auch CCcam gestartet. Laut telnet fanden sich auch beide in den laufenden Prozessen.
    Kann es sein, daß oscam die Daten von CCcam ebenfalls dort sucht? Kanns im Moment nicht testen, da ich nicht vor Ort bin. Ich kann ja nirgends einen Pfad angeben. Oder sind diese Versionen für oscam only?
    Hab jetzt erst mal wieder alles wie vorher, also mit oscam #5386.

    Ich hänge mal die Configs dran

    oscam.config

    [global]
    serverip =
    cachedelay = 0
    logfile = /var/log/oscam.log # ÄNDERUNG - CHANGE - MODIFICATIONS - MODIFICA 03/28/2011
    disablelog = 0
    maxlogsize = 512
    disableuserfile =
    usrfile = /var/log/oscamuser.log
    usrfileflag = 0
    cwlogdir = /var/log/cw.log
    clienttimeout = 7
    fallbacktimeout = 5
    clientmaxidle = 120
    bindwait = 120
    netprio = 0
    resolvegethostbyname =
    clientdyndns =
    failbantime = # IP Adresse wird für n Minuten geblockt. Neue Loginversuche werden ignoriert auch wenn das Login OK wäre. Es wird kein Clientthread erstellt.
    failbancount =
    sleep = 0
    unlockparental = 0
    nice = -1
    serialreadertimeout =
    waitforcards = 1
    preferlocalcards = 1
    readerrestartseconds =
    saveinithistory = 1
    double_check =
    lb_mode = 3
    lb_save =
    lb_nbest_readers =
    lb_nfb_readers =
    lb_nbest_percaid = # NEU - NEW - NOUVEAU - NUOVO svn 4787:03/04/2011
    lb_min_ecmcount =
    lb_max_ecmcount =
    lb_reopen_seconds =
    lb_retrylimit =
    lb_savepath =
    lb_stat_cleanup =
    lb_use_locking =

    [monitor]
    port = 16667
    serverip =
    nocrypt =
    aulow =
    monlevel = 2
    hideclient =
    appendchaninfo = 1

    [webif]
    httpport = 16666
    httpcert =
    httpuser = oscam
    httppwd = oscam
    httpcss =
    httptpl =
    httprefresh = 15
    httphideidleclients = 0
    httpscript =
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    httpdyndns =
    httpsavefullcfg = 0
    httpreadonly = 0
    httphelplang =

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi
    #pmt_mode = 0
    request_mode = 0


    [newcamd]
    port = 15001@1834:000000;15002@1834:000000
    key = 0102030405060708091011121314
    keepalive = 1
    mgclient = 0
    ###################################################################

    oscam.server

    [reader]
    label = skyhd
    protocol = cccam
    device = 127.0.0.1,12000
    account = oscam,oscamreader
    group = 1
    services = skyhd-mapping
    detect = none
    #CAID = 1722
    cccversion = 2.2.1
    cccbuild = 3165
    cccmaxhops =
    ccckeepalive = 1


    [reader]
    label = d09
    protocol = internal
    device = /dev/sci0
    #mhz = #600 ###
    #cardmhz = #600 ###
    detect = cd
    group = 2
    services = kdh #,kdhome,kdhd
    caid = 1834
    ident = 1834:000000,000401
    emmcache = 1,3,2
    rsakey = 8A5...711
    boxkey = 666...47B
    #lb_weight = 100

    oscam.user

    [account]
    user = userskyhd
    pwd = passskyhd
    description =
    hostname =
    betatunnel = 1834:1722
    uniq = 0
    sleep = 0
    sleepsend =
    caid = 1722,1834
    au = skyhd
    group = 1
    services = skyhd-mapping
    ident =
    class =
    chid =
    monlevel = 2
    expdate =
    disabled = 0
    allowedtimeframe =
    numusers =
    penalty =
    failban =
    suppresscmd08 =
    keepalive = 1
    cccmaxhops =
    cccreshare = # ÄNDERUNG - CHANGE - MODIFICATIONS - MODIFICA svn4841:03/19/2011
    cccignorereshare =

    [account]
    user = userkdh
    pwd = passkdh
    description =
    hostname =
    betatunnel =
    uniq = 0
    sleep = 0
    sleepsend =
    caid = 1834
    au = d09
    group = 2
    services = kdhome,kdhd
    #ident = 1834:000000
    class =
    chid =
    monlevel = 2
    expdate =
    disabled = 0
    allowedtimeframe =
    numusers = 0
    penalty = 0
    failban =
    suppresscmd08 =
    keepalive = 1
    cccmaxhops = 10
    cccreshare = # ÄNDERUNG - CHANGE - MODIFICATIONS - MODIFICA svn4841:03/19/2011
    cccignorereshare =

    [account]
    user = dvbapi
    group = 1,2
    au = d09

    CCcam.cfg

    N: 127.0.0.1 15001 userskyhd passskyhd 01 02 03 04 05 06 07 08 09 10 11 12 13 14 #Sky_HD
    N: 127.0.0.1 15002 userkdh passkdh 01 02 03 04 05 06 07 08 09 10 11 12 13 14 #KDH_HD
    F: oscam oscamreader #2 0 1

    Wieso bekomme ich keine Logfiles in /var/log für oscam.log und oscamusers.log. Oscamuser.log zwar da, aber leer. Oscam.log gar nicht da. Erstelle ich eine, ist die danach auch leer oder auf einmal wieder weg (ich dachte, sowas gibts nur bei Windoof). Hatte die Rechte auch schon mal auf 777, trotzdem keine Logs.

    Ich kann das Log nur im WebIf auslesen

    Kann noch jemand helfen?

    Gruß ans Board vom oscamnewbie
     
    Zuletzt von einem Moderator bearbeitet: 30. Oktober 2011
    #12
  14. mr.nice53
    Offline

    mr.nice53 Hacker

    Registriert:
    19. Juni 2010
    Beiträge:
    329
    Zustimmungen:
    144
    Punkte für Erfolge:
    0
    AW: Oscam update, neue Version läuft nicht?

    Gehe mal im webif auf CONFIGURATION und schau mal ob bei Log file / max size: auf enabled steht und dann unten mal auf Save und dann neu booten lassen.
     
    #13
  15. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Oscam update, neue Version läuft nicht?

    hatte ich gemacht, stand auf enabled. Trotzdem kein Log

    ???
     
    #14
  16. mr.nice53
    Offline

    mr.nice53 Hacker

    Registriert:
    19. Juni 2010
    Beiträge:
    329
    Zustimmungen:
    144
    Punkte für Erfolge:
    0
    AW: Oscam update, neue Version läuft nicht?

    Vergrößere mal die Zahl auf 500. Ist es auch der richtige Pfad? Bei mir ist es /root/plugin/var/log/oscam/oscam.log.
     
    Zuletzt bearbeitet: 19. September 2011
    #15

Diese Seite empfehlen