1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Hilfe bei Problem mit CGI Script

Dieses Thema im Forum "HTML - PHP - Java - Perl" wurde erstellt von DaDare, 25. April 2010.

  1. DaDare
    Offline

    DaDare Newbie

    Registriert:
    22. März 2009
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,
    Ich habe zurzeit ein Problem mit folgendem Vorhaben. Ich möchte gerne ein paar Formularfelder ausfüllen und die einzelnen Eingabewerte dann zu einem Befehl zusammenfügen, allerdings wird mir wenn ich folgenden Code in die main.cgi einfüge keine Seite mehr angezeigt, d.h. sie bleibt komplett weiß ohne Inhalt. Enferne ich allerdings die unten stehenden Zeilen, funktioniert alles wie es soll. Könnte sich einer von euch mal das unten stehen anguggen, komme selber nicht weiter und bin auch noch blutiger Anfänger in Sachen Perl/CGI...
    Code:
    ....
    
    ;;
    test2)
    echo '<h3>Mounten</h3>'
    my $point = $cgi->param('a');
    my $ip = $cgi->param('b');
    my $ordner = $cgi->param('c');
    my $benutzer = $cgi->param('d');
    my $passwort = $cgi->param('e');
    my $befehl = "mount -t cifs" + "" + "//$ip + "/" + $ordner + "" + "/media/$point" + "" + "-o username=$benutzer,password=$passwort,rsize=16384,wsize=16384";
    
    mkdir /media/$point
    $befehl
    
    DATEI="/opt/www/cgi-bin/lastmount.txt"
    echo "$befehl" > $DATEI
    cat $DATEI
    
    echo '<form method="post" action="main.cgi?test2">'
    echo 'Mountpoint:<input type="text" name="a"> IP des Zeilcomputers:<input type="text" name="b">Freigabeordner des Computers:<input type="text" name="c">Benutzer:<input type="text" name="d" value="guest">Passwort:<input type="text" name="e"> <input type="submit" value="mounten">'
    echo '</form>'
    
    .....
    Also um die einzelnen Textfelderinhalte abzufragen, habe ich beispielsweise den Code my $ordner = $cgi->param('c') mit dem entsprechendem Textfeld <input type="text" name="c"> verwendet. Geht das so, oder liegt das Problem hier? Desweiteren will ich den zusammengesetzen Befehl anschließend ausführen und eine Datei erstellen, welche diesen Mount Befehl enthält.
    Nun aber die Frage wo denn der Fehler liegt, damit es nicht klappt.
    Danke schon einmal!
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. joe128
    Offline

    joe128 Ist gelegentlich hier

    Registriert:
    1. Juni 2009
    Beiträge:
    49
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    AW: Hilfe bei Problem mit CGI Script

    soll das ein perl oder ein shell-script sein?

    perl benötigt ein semikolon (;) nach einem befehl. allerdings sieht es danach aus, dass hier die beiden sprachen (unix-shell u perl) vermischt sind.
     
    #2

Diese Seite empfehlen