1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem E2 kann mit OSCam 1.20 / CCCam keine NDS Smartcard lesen.

Dieses Thema im Forum "AZBox HD Premium / Elite" wurde erstellt von blueice_haller, 29. Juli 2012.

  1. blueice_haller
    Offline

    blueice_haller Ist gelegentlich hier

    Registriert:
    3. Juli 2011
    Beiträge:
    38
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Hallo,
    ich habe eine AZBox Premium Plus mit einer KBW V23 Karte.
    Ich habe jetzt verschiedene Image (RTi Core 1.7, OpenRSi OpenPLi 2.1 und Spaze 2.2) mit OSCam getestet.
    Aber bei allen kommt NEEDINIT. Die Karte natürlich ist freigeschalten.
    Ich spreche den leser mit /dev/sci0 und die Karte mit Protokoll internal an (wie das eben im Streamboard OSCam Wiki steht).

    Mit CCCam 2.2.1 und 2.3.0 klappt es auch nicht.
    Das einzige was klappt ist CCCam als Client von CCCam auf anderem Receiver.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. BadThinks
    Offline

    BadThinks Freak

    Registriert:
    9. April 2010
    Beiträge:
    260
    Zustimmungen:
    66
    Punkte für Erfolge:
    28
    Ort:
    Bayern
    AW: E2 kann mit OSCam 1.20 / CCCam keine NDS Smartcard lesen.

    Hallo ,
    verschiedene Image ist "UNINTERESSANT" da die sofcam zum CPU passen muss w.z.b. sh4 oder mipsel.
    Die Config's und Log's vom sofcam - DIE braucht man zum Helfen ! So kann man nur Raten oder in die Glaskugel schauen ......
     
    #2
  4. blueice_haller
    Offline

    blueice_haller Ist gelegentlich hier

    Registriert:
    3. Juli 2011
    Beiträge:
    38
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: E2 kann mit OSCam 1.20 / CCCam keine NDS Smartcard lesen.

    Ich habe bereits auf einem anderen Receiver OSCam laufen.
    Momentan läuft, auch wenn das unwesentlich ist, Spaze 2.2 und über Spaze Panel habe ich die OSCam Version heruntergeladen.

    Wenn ich in der oscam.conf waitforcards = 0 setze können sich andere CCCam verbinden und im Log steht OK.
    Setze ich nun waitforcards = 1 kommt das mit NEEDINIT und es passiert nichts mehr.

    In der oscam.server habe ich detect = cd (andere auch schon getestet), cardmhz und mhz = 357 und 500 getestet,

    Jetzt habe ich im Streamboard OSCam Wiki vom mode keyword gelesen:
    Code:
    mode
    Parameter wird abhängig vom Setup/Programmversion benötigt.
    Nur für AZBox
    mode = 1  # AzBox-Reader
         = 0  # default
    Setzt den Init-Mode für die Karte im internen AZBox-reader 
    
    Wenn ich das mache und ./oscam starte kommt dass er das keyword mode nicht kennt. Aber ich vermute daran liegt es.
    Und ich habe auch schon eine aktuelle svn Versionen von download.oscam.to mips-azbox versucht aber die lassen sich nicht starten mit ./oscam . Rechte sind schon auf 755.

    oscam.conf
    Code:
    [global]
    nice          = -1
    WaitForCards  = 1
    bindwait      = 120
    saveinithistory = 1
    lb_mode       = 1
    lb_save       = 100
    lb_nbest_readers = 1
    lb_nfb_readers = 1
    lb_min_ecmcount = 5
    lb_max_ecmcount = 500
    lb_reopen_seconds = 900
    
    # logging
    logfile       = /var/log/oscam/oscam.log
    usrfile       = /var/log/oscam/oscamuser.log
    cwlogdir      = /var/log/oscam/cw
    
    [monitor]
    port          = 988
    aulow          = 120
    monlevel      = 1
    
    # web interface
    [webif]
    httpport      = 8888
    httpuser      = xxx
    httppwd       = yyy
    httpallowed = 0.0.0.0-255.255.255.255 #Poner IP del PC o rango de IP´s aceptadas
    
    # anti-cascading
    [anticasc]
    enabled       = 1
    numusers      = 1
    sampletime    = 2
    samples       = 5
    penalty       = 1
    aclogfile     = /var/log/oscam/aclog.log
    denysamples   = 9
    
    # protocols
    [cccam]
    port          = 12001
    version       = 2.3.0
    reshare       = 2
    
    [dvbapi]
    enabled       = 1
    user          = root
    au            = 1
    #boxtype       = dreambox
    oscam.server
    Code:
    [reader]
    label      = kbw_v23_card
    protocol   = internal
    device     = /dev/sci0
    detect     = cd
    #cardmhz    = 500
    #mhz        = 500
    #deprecated = 1
    mode       = 1
    caid       = 098E
    group      = 1
    emmcache   = 1,1,2
     
    Zuletzt bearbeitet: 30. Juli 2012
    #3
  5. blueice_haller
    Offline

    blueice_haller Ist gelegentlich hier

    Registriert:
    3. Juli 2011
    Beiträge:
    38
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: E2 kann mit OSCam 1.20 / CCCam keine NDS Smartcard lesen.

    Irgendwie scheitern alle EMU (OSCam, NewCS, CCCam) am initialisieren der NDS Karte in /dev/sci0.
    Was jedoch witziger weise funktioniert: die BetaCrypt S02 CAID 1702 wurde erfolgreich als Irdeto hinzugefügt (NewCS) und bei OSCam erscheint CARDOK.
     
    Zuletzt bearbeitet: 3. August 2012
    #4

Diese Seite empfehlen