1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

Dieses Thema im Forum "CS Root & Vserver" wurde erstellt von joka312, 18. Juli 2012.

  1. joka312
    Offline

    joka312 Freak

    Registriert:
    17. Dezember 2008
    Beiträge:
    278
    Zustimmungen:
    41
    Punkte für Erfolge:
    28
    Ort:
    zu Hause
    Hallo,

    habe einen Server auf Futuro 400 mit Debian installiert.
    Nun hab ich das Problem, dass der Smargo keine Karte liest.
    Bei dmesg kommt in einer Zeile beim Smargo diese Meldung ftdi_sio ttyUSB0: Unable to read latency timer: -32.
    Habe in diesem thread

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    gelesen, dass es ein Kernel Bug ist.
    Kernel ist derzeit 2.6.32-486.
    Möchte nun ein downgrade machen auf ein Kernel < oder = 2.6.30-486.
    Habe dies versucht:
    apt-get update
    apt-cache search linux-image
    apt-get install linux-image-2.6.26-2-486

    findet aber kein Kernelpacket.

    Hat jemand eine Idee, bzw. eine Lösung für dieses Problem?

    Smartmouse hab ich getestet, die läuft ohne Fehler.
    Habe aber 3 Smargo die ich verwenden möchte.

    Danke im Voraus
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. gse85
    Offline

    gse85 Hacker

    Registriert:
    3. Oktober 2009
    Beiträge:
    379
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    Huhu zusammen,

    ich habe die ganze Nacht und den halben Samstag damit verbracht, meine 4 Smargos wieder am Debian zum Laufen zu bekommen. Leider Fehlanzeige. Ich nutze die CCcam 2.2.1, Debian 6.0.5, folgenden Kernel habe ich installiert: 2.6.32-5-486. Leider auch keinen Erfolg. Wenn ich einen dmesg Aufruf starte, bekomme ich für jeden Kartenleser folgendes zurück: ftdi_sio ttyUSB2: Unable to read latency timer: -32.

    Weiß jemand einen Rat?
     
    #2
  4. aragorn
    Offline

    aragorn Guest

    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    wie hast du denn deine smargos eingestellt? (hardware seitig)

    ansonsten google mal nach "ipc pebkac" registrier dich und guck dann im bereich Anleitungen. da ist ein thread "Debian Squeeze - Kernel wechseln" wo das downgrade auf den 2.6.26 ausführlich beschrieben wird..


    ps: nach installieren des kernels musst du es auch noch in grub einbinden und rebooten ;)
     
    #3
  5. gse85
    Offline

    gse85 Hacker

    Registriert:
    3. Oktober 2009
    Beiträge:
    379
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    Ich habe Debian jetzt auf einem anderen Server (64 Bit) als vorher auf einem Igel Thin Client (32 Bit) installiert.

    CCcam installiert und anschließend den Kartenleser angesteckt, es kam genau wie beim Igel Thin Client folgende Fehlermeldung:

    ftdi_sio ttyUSB0: Unable to read latency timer: -32

    Dann habe ich meine Smargos mit der Firmware 1.07 geflasht und siehe da, keine Fehlermeldung mehr, alle wurden sauber erkannt.

    Jetzt habe ich das Problem, dass die Zuordnung der Smargos nach einem Server Restart verloren gehen.

    Ich habe einem Smargo mit den Settings_1.07 einem Devicenamen zugeordnet, dieser Devicename hat 8 Zeichen und wird auch unter ATTRS{serial} angezeigt. Komisch ist nur, dass ich 2 Einträge vom ATTRS{serial} habe, der zweite Eintrag fängt mit 00:0012.... an. Wenn ich den Symlink in udev setze und dann in der CCcam.cfg /dev/12345678 bekomme ich:

    no or unknown card inserted

    Zur Zeit gehen die Kartenleser also wieder, ich werde, wenn ich demnächst dazu komme, mal in den udev monitor reinschauen, ob mein vergebener Devicenamen auch richtig erkannt wird. Ich denke, dass irgendetwas mit udev und der Zuordnung nicht richtig funktioniert.

    Ich werde berichten, wenn ich zeitlich dazu komme.
     
    #4
    1 Person gefällt das.
  6. aragorn
    Offline

    aragorn Guest

    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    bei vielen läuft die firmware 1.05 ebenfals sehr gut aber eben mit richtigem (486) kernel mit einem anderen beziehungsweise der vom debian installer installiert wurde haben/hatten die auch probleme..

    hast du udev überhaupt konfiguriert? du musst natürlich die rules anpassen und die iSerial angeben dann funktioniert das 100%
    iSerial auslesen mit dem befehl:

    lsusb -v|grep iSerial

    die udev rules datei (in /etc/udev/rules.d/) muss minimum 40- lauten kleiner sollte die zahl nicht sein (ich verwende immer 91-) und sollte inhaltlich so aussehen:

    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="iSerial", SYMLINK+="/dev/NAME"

    wenn die iSerial also zum beispiel so aussieht: " Reader 123 " oder " A400fRl8 "
    dann müsste die udev zeile wie folgt aussehen:
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="Reader 123", SYMLINK+="smargo"
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="A400fRl8", SYMLINK+="easymouse"

    auch solltest du darauf achten das du keine sonderzeichen wie "ß" oder "+" im NAME verwendest

    wenn du ubuntu nutzt muss bei KERNEL== folgendes stehen damit das funktioniert: KERNEL=="ttyUSB?*"

    wenn du cccam/oscam ausserdem nicht als root laufen lässt muss der shellbenutzer mitglied in der gruppe "dialout" sein um zugriff auf den reader zu haben..
     
    Zuletzt von einem Moderator bearbeitet: 20. September 2012
    #5
  7. gse85
    Offline

    gse85 Hacker

    Registriert:
    3. Oktober 2009
    Beiträge:
    379
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    Vielen Dank für deine Tipps, die ich alle bereits befolgt habe.

    Durch das Flashen der Firmware 1.07 ist die iSerial in der Form von Reader 123 oder A400fRl8 futsch.

    Dafür kann man ja in den Smargo Settings 1.07 einen Devicenamen vergeben, in dem ich keine Sonderzeichen drin habe.

    Ich melde mich demnächst bzgl. meiner weiteren Versuche.

    Vielen Dank!
     
    #6
  8. drtY
    Offline

    drtY Newbie

    Registriert:
    2. Mai 2011
    Beiträge:
    12
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    hab dass selbe Problem gehabt, ändere mal deine smargo Einstellungen dann sollte es laufen. serial hast du dann auch wieder. :)

    für Igel nehm ich

    fixed oder autofixed
    normal
    1
    0
     
    #7
  9. aragorn
    Offline

    aragorn Guest

    AW: Debian 6.0.5 Smargo wird nicht richtig eingebunden Kernel 2.6.32

    drtY: das ist von karte zu karte unterschiedlich wie die einstellungen auszusehen haben aber 1) is der thread hier 2 monate alt und 2) haben die einstellungen nichts mit der iSerial zu tun
     
    #8

Diese Seite empfehlen