1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem 7210 mit Navigon 7.7.5.447 kein TMC trotz MixSer 3.0

Dieses Thema im Forum "Navigon 7 Support" wurde erstellt von dorland, 9. Juni 2013.

  1. dorland
    Offline

    dorland Newbie

    Registriert:
    5. Oktober 2011
    Beiträge:
    2
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    Hallo zusammen,

    vor kurzem kaufte ich mir ein gebrauchtes Navigon 7210. Die Originalsoftware 7.4.2.820 (auf SD-Card) funktioniert mit TMC (TMCPort: 4, TMCBaudrate: 38400). Version 7.7.5 (auch von SD-Card) erkennt den TMC Empfänger nicht. Navigon und MixSer finden einfach nicht zusammen. Auch die Originale Wistron TmcHal.dll im Navigon 7.7.5 Verzeichnis bringt nichts. So langsam weiß ich nicht mehr weiter... Braucht man eine spezielle Wistron DLL?

    Auszug der UserSettings.xml:
    <TMC>
    <RadioStationScan>0</RadioStationScan>
    <AutoRecalculation>0</AutoRecalculation>
    <PreferPay>1</PreferPay>
    <TMCPort>3</TMCPort>
    <TMCBaudrate>38400</TMCBaudrate>
    <DRVPrefix>COM</DRVPrefix>
    </TMC>

    MixSerDrv log:
    [20030101-120013.004] MixSerDrv major: 3
    [20030101-120013.203] MixSerDrv minor: 0
    [20030101-120013.233] NOTE: timestamp's seconds and milliseconds are from different sources, so sometimes it looks like time is going backwards
    [20030101-120013.238] InstallPath
    [20030101-120013.242] \Storage Card\MixSer
    [20030101-120013.246] Index 3
    [20030101-120013.250] TmcPortName
    [20030101-120013.254] COM4:
    [20030101-120013.258] TmcBaudRate 38400
    [20030101-120013.262] TmcStartFreq 10300
    [20030101-120013.267] GpsSniffMode 0
    [20030101-120013.273] TmcSkipInit 0
    [20030101-120013.277] TmcNoWaitForResponse 1
    [20030101-120013.281] GnsTmcDataTimeout 10000
    [20030101-120013.289] PSNAME '........'
    [20030101-120013.300] OS major: 5
    [20030101-120013.304] OS minor: 0
    [20030101-120013.308] OS build: 0
    [20030101-120013.312]
    [20030101-120013.316] ~MXS_Init


    MixSerNaviStarter:
    # Enable all script error messages
    ErrorLevel ( "warn" )

    # -----------------------------------------
    # Adjust following variables to your system:

    NAVI_SW_WINDOW_TITLE = "Mobile Navigator"
    NAVI_SW_PROCESS_NAME = "navigon.exe"

    # If Navi SW already running, then bring Navi SW into foreground and exit this script
    If ( ProcExists( NAVI_SW_PROCESS_NAME ) = TRUE )
    Show( NAVI_SW_WINDOW_TITLE )
    Exit

    EndIf

    # INSTALLDIR must contain: MixSerDrv.dll , mixser_tmc.bin, activatedevice.exe
    INSTALLDIR = "\Storage Card\MixSer"

    # MIXSER_PORT must be a free COM port number in your system
    # Set the TMC port of your navigation software to this port!
    MIXSER_PORT = 3

    # COM port name and baudrate of the TMC chip
    TMC_PORT = "COM4:"
    TMC_BAUD = 38400

    # If AVANTEQ TMC chip, then uncomment following:
    # TMC_PORT = "AVQ1:"

    # Optional: Your favorite FM frequency. MixSerDrv will tune to this frequency when MixSerDrv is activated
    # Examples: 10520 means 105.2 Mhz; 9440 means 94.4 MHz, etc.
    TMC_START_FREQ = 10300

    # Optional: In case MixSerDrv does not work properly, try with following lines set to 1
    # e.g. Wistron chips need them to be 1
    # Skip sending initialisation commands to TMC chip
    TMC_SKIP_INIT = 0

    # MixSerDrv should not wait for responses from TMC chip after sending commands
    TMC_NOWAIT_FOR_RESPONSE = 1

    # Optional: GNS and AVANTEQ TMC chip only: Scan for next FM station if no TMC data received for x milliseconds
    # value of 0 deactivates this function
    GNS_TMC_DATA_TIMEOUT = 10000
    #GNS_TMC_DATA_TIMEOUT = 0

    # Navigation software executable
    NAVI_SW_PATH = "\Storage Card\NAVIGON\navigon.exe"

    # If DEBUG is 1 then a log file is written into INSTALLDIR every time when MixSerDrv is installed
    DEBUG = 1

    # -- Install MixSerDrv: Start ----------------------------------------

    # MixSerDrv used as a Serial Port Sniffer (deactivates all TMC functionality!)
    # GPS_PORT <==> MixSerDrv <==> MIXSER_PORT
    # GPS_PORT = "COM4:"
    # GPS_BAUD = 38400
    # GPS_SNIFF_MODE = 1

    # copy MixSerDrv driver DLL to Windows directory, if not already exists
    If ( FileExists("\Windows\MixSerDrv.dll") = FALSE )
    Copy( INSTALLDIR & "\MixSerDrv.dll", "\Windows\MixSerDrv.dll", TRUE )
    Copy( INSTALLDIR & "\Navigon_startup.wav", "\Windows\Navigon_startup.wav", TRUE)
    #Copy( INSTALLDIR & "\ATMC_CE.DLL", "\Windows\ATMC_CE.DLL", TRUE )
    #Copy( INSTALLDIR & "\AVQTMC.DLL", "\Windows\AVQTMC.DLL", TRUE )
    #Copy( INSTALLDIR & "\TMCGPS.DLL", "\Windows\TMCGPS.DLL", TRUE )

    EndIf

    # write settings for MixSerDrv to registry
    RegWriteString( "HKLM", "\Drivers\MixSer", "FriendlyName", "MixSerDrv" )
    RegWriteString( "HKLM", "\Drivers\MixSer", "Dll", "MixSerDrv.dll" )
    RegWriteString( "HKLM", "\Drivers\MixSer", "Prefix", "COM" )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "Index", MIXSER_PORT )
    RegWriteString( "HKLM", "\Drivers\MixSer", "InstallPath", INSTALLDIR )
    RegWriteString( "HKLM", "\Drivers\MixSer", "TmcPortName", TMC_PORT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcBaudRate", TMC_BAUD )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcStartFreq", TMC_START_FREQ )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcSkipInit", TMC_SKIP_INIT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcNoWaitForResponse", TMC_NOWAIT_FOR_RESPONSE )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "GnsTmcDataTimeout", GNS_TMC_DATA_TIMEOUT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "DebugMode", DEBUG )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "GpsSniffMode", GPS_SNIFF_MODE )
    #RegWriteString( "HKLM", "\Drivers\MixSer", "GpsPortName", GPS_PORT )
    #RegWriteDWord ( "HKLM", "\Drivers\MixSer", "GpsBaudRate", GPS_BAUD )

    # activate the new COM port
    RunWait ( INSTALLDIR & "\activatedevice.exe", "\Drivers\MixSer" )

    # -- Install MixSerDrv: End ----------------------------------------

    # start the navigation software

    RunWait ( NAVI_SW_PATH )

    PowerOff
    # wait for Navigon to start up until the STVO disclaimer is shown
    # you can lower the timeout if your Navigon boots up faster than 30sec
    #Sleep( 30000 )

    # press the "OK" button of Navigon STVO disclaimer (un-comment the line for your screen resolution)
    # 800x480 screen
    #MouseClick(NAVI_SW_WINDOW_TITLE, 610, 430 )
    #480x272 screen
    # MouseClick(NAVI_SW_WINDOW_TITLE, 337, 231 )
    # 320x240 screen
    # MouseClick(NAVI_SW_WINDOW_TITLE, 235, 212 )

    Auch TMC_SKIP_INIT = 1 brauchte keine Abhilfe

    MixSerTester Log:
    (Port 4, 38400 Baud)

    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTS,0,438*40
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55
    $PLTTQ,8750,0,0,1,0*6A
    $PLTSR,0*55

    Weiß noch jemand Rat?
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. voyi1994
    Offline

    voyi1994 Stamm User Supporter

    Registriert:
    29. Juni 2009
    Beiträge:
    1.199
    Zustimmungen:
    1.216
    Punkte für Erfolge:
    113
    Ort:
    im grünen von B
    AW: 7210 mit Navigon 7.7.5.447 kein TMC trotz MixSer 3.0

    @dorland,
    lese bitte folgendes
    Dieses Tool ist NUR um mit NAVIGON auf Fremdgeräten TMC Empfang zu bekommen
    den MixSer kannst du demnach entfernen.

    Gruß voyi1994
     
    #2
    ghosty69 und mustique gefällt das.
  4. Boss71
    Offline

    Boss71 Moderator Digital Eliteboard Team

    Registriert:
    30. Mai 2009
    Beiträge:
    10.748
    Zustimmungen:
    27.964
    Punkte für Erfolge:
    113
    Ort:
    Vor Ort
    AW: 7210 mit Navigon 7.7.5.447 kein TMC trotz MixSer 3.0

    @voyi1994
    Ich kenne das Tool nicht und habe mich damit auch nicht beschäftigt.
    Spydd Schreibt aber in seinem Angebot das dank dem MixSerDrv läuft die MN 7.7.5 Version mit TMC auf dem 7210:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #3
  5. voyi1994
    Offline

    voyi1994 Stamm User Supporter

    Registriert:
    29. Juni 2009
    Beiträge:
    1.199
    Zustimmungen:
    1.216
    Punkte für Erfolge:
    113
    Ort:
    im grünen von B
    AW: 7210 mit Navigon 7.7.5.447 kein TMC trotz MixSer 3.0

    @Boss71,
    ich hatte das nur im Thread vom MixSer gefunden. Habe ich wieder was dazu gelernt. Danke. :ja

    Gruß voyi1994
     
    #4
  6. dorland
    Offline

    dorland Newbie

    Registriert:
    5. Oktober 2011
    Beiträge:
    2
    Zustimmungen:
    2
    Punkte für Erfolge:
    3
    AW: 7210 mit Navigon 7.7.5.447 kein TMC trotz MixSer 3.0

    @voyi1994
    Für Navigon 7.7.5 ist die 7210 Hardware ja ein Fremdgerät ;-) Hatte es vorher auch ohne MixSer probiert, was leider keinen Erfolg brachte.

    @Boss71
    Danke für den Link. Es läuft :) Habe die Navigon Verzeichnisse verglichen und festgestellt, daß meine Version nicht komplett gewesen ist. Es fehlten zwei Avanteq Dll Dateien (atmc_ce.dll und tmcgps.dll). Nur die GNS gpstmc.dll war vorhanden. Auf fehlende Avanteq Bibliotheken wäre ich so schnell aber nicht gekommen...

    @all
    Danke! :)
     
    #5
    voyi1994 und mustique gefällt das.

Diese Seite empfehlen