1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Win7; VM=Ubuntu LTS; VM-Player, usb hub problem

Dieses Thema im Forum "Archiv" wurde erstellt von osdgap, 17. Oktober 2010.

  1. osdgap
    Offline

    osdgap Hacker

    Registriert:
    2. November 2009
    Beiträge:
    390
    Zustimmungen:
    36
    Punkte für Erfolge:
    28
    Hi @all,

    habe mir eine ubuntu-vm auf meiner win7-kiste eingerichtet, Bridging; cccam; web-inf alles soweit ok.
    WEnn ich einen USB-Stick an meinen freien usb 2.0-port anschliese dann sehe ich den stick wenn ich "lsusb" eingebe als zusätzliche line in der Ausgabe jedoch finde ich den stick nicht unter "media" wenn ich per ftp auf die VM gehe.

    WEnn ich den könig 7-port-usb-hub amschliesse und den stick zum testen anschliesse, meldet sich zwar vmplayer und fragt ob ich den stick in der vm nutzen möchte, jedoch wirde in der Ausgabe von "lsusb" nicht mit aufgeührt!
    Wie bekomme ich den usb-hub unter vm zum laufen?
    Und natürlci meine 3 smargo's

    thnx in advanced
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. r00t
    Offline

    r00t Hacker

    Registriert:
    17. August 2010
    Beiträge:
    398
    Zustimmungen:
    75
    Punkte für Erfolge:
    0
    AW: Win7; VM=Ubuntu LTS; VM-Player, usb hub problem

    USB Unterstützung gibt es erst seit ca. 2 Jahren in VMs, ist also vergleichsweise recht frisch und somit leider auch noch fehlerhaft

    Wieso hast du denn Ubuntu installiert und nicht Debian?
    Die Pakete von Ubuntu sind nicht wirklich aktuell und sind teilweise auch nicht so stabil wie die unter Debian
    Ubuntu ist primär ein Desktop System mit grafischer Oberfläche und nicht so gut als Server geeignet!

    Dann wäre auch noch die Frage welche VMware du benutzt
    ESX?
    VMWare-Server?
    VMware Workstation (welche version?)?
    VMware Player (version?)?
    oder VMware ACE?

    :)

    Für USB2.0 Unterstützung unter VMWare musst du deine VM-Hardware auf Version 6 upgraden (mit Workstation 6 öffnen und HW upgraden) und der EHCI Controller enabled werden
    VMware Workstation: Click VM > Settings > USB Controller > Deselect Enable high-speed support for USB 2.0 devices

    Ausserdem solltest du der VM etwas Zeit lassen wenn du ein USB Device das erste mal anschliest - es kann durchaus etwas dauern bis er es resettet und die Verbindung das erste mal hergestellt hat

    Und poste mal bitte auch die ausgabe von " dmesg " wenn du den HUB und einen Smargo anschliest


    Für mehr Diagnosemöglichkeiten kannst du in der VM-configurationsdatei (.vmx) auch noch folgende Zeile hinzufügen:

    usb.analyzer.enable = "TRUE"

    Aber nicht vergessen auch wieder aus zu machen weil das die Performance der VM beeinträchtigt!

    Es gibt auchnoch ein weiteres Setting was für dich vielleicht wichtig ist:

    usb.generic.autoconnect = "TRUE"

    Allerdings connected VMware die USB Geräte nur dann automatisch an die VM, wenn die auch den Eingabefokus in diesem Moment hat


    Eine weitere Möglichkeit wäre auch noch folgendes:
    Geh in "Edit virtual machine settings"
    Auf der linken Seite siehst Du eine Auflistung der in der VM verwendeten Hardware. Ein Klick auf "Add" und "USB Controller" auswählen
    Bevor Du den letzten Dialog schliesst (also auf "Finish" klickst), ließ Dir den Dialog durch
    Dort wird beschrieben, wie Du USB-Geräte verwendest


    Um herauszufinden, welche Module durch das Einstecken des Sticks geladen wurden, kannst du folgendermaßen vorgehen:

    1. In einem Terminal 'lsmod >mods_vorher' eingeben
    Dadurch wird die Liste der zur Zeit geladenen Module in die Datei 'mods_vorher' geschrieben
    2. Stick einstecken
    3. In einem Terminal 'lsmod >mods_nachher' eingeben
    4. Mit 'diff mods_vorher mods_nachher' beide Listen vergleichen. Die Ausgabe sollte die Module enthalten, die durch das Einstecken geladen wurden

    ABER:
    Ich nehme an, mit USB-Stick meinst du einen Memory-Stick. Dieser wird warhscheinlich beim Einstecken automatisch gemountet. Eventuell reicht es schon, wenn du ihn einfach "unmountest"
    z.b. "umount /dev/sda1".
    Den vergebenen Devicenamen findest du in der Datei '/var/log/messages'


    Eine weitere Möglichkeit wäre auch noch ein Eintrag in der /etc/fstab

    usbfs /proc/bus/usb usbfs auto 0 0
     
    #2

Diese Seite empfehlen