1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Webif funktioniert nicht

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von errut, 26. Juli 2013.

  1. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    ubuntu 12.04 mit osiris auf Alix3.
    Bekomme kein Oscam-Webif. Putty und winscp ist ok. Ebenso funktioniert auch die installierte Oscam - bis auf webif.
    Habe mal das Apache2.log eingesehen, das funktioniert anscheinend auch nicht.

    im putty wird folgender Fehler angezeigt:
    E: der dpkg-Prozess wurde unterbrochen; Sie müssen manuelldpkg _
    -- ausführen, um das problem zu beheben.
    Kann mir jemand erklären, was das bedeutet?
     
    Zuletzt bearbeitet: 26. Juli 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.877
    Zustimmungen:
    6.209
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    Fehlende Pakete, würde ich sagen.
    Mach mal im Putty:
    apt-get -y install dpkg
    Oder Apache2 nochmal drüberziehen.
     
    #2
  4. Radagast
    Offline

    Radagast Elite User

    Registriert:
    11. Mai 2013
    Beiträge:
    1.628
    Zustimmungen:
    903
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    Hi,

    bei solchen Fehlermeldungen ist die Wiedergabe des kompletten Fehlercodes wichtig. Wahrscheinlich hat dir dein System bereits gesagt was du machen solltest.
    Gib in der Konsole mal ein (mit root Rechten)
    Code:
    dpkg --configure -a
    
    Wenn das nicht hilft bitte die komplette Fehlermeldung posten und nicht nur einen Ausschnitt davon.

    @mxer
    dpkg ist die Debian Paketverwaltung, welche im Hintergund von z.b. aptitude oder auch apt verwendet wird. Sie neu zu installieren bringt nichts. Hier stimmen die Abhängigkeiten wohl nicht mehr.
    dpkg wurde ehemals nur von Debian verwendet, findet aber inzwischen auch bei anderen Distributionen Anwendung.

    Edit:
    Apache wird aber nicht benötigt zur Darstellung des WebIf von OScam. Von daher kann das eigentlich nicht der Fehler sein.
    Beinhaltet deine OScam Version überhaupt die Ausgabe auf das interne WebIf? Was sagt oscam.version zu dem Thema?
     
    Zuletzt bearbeitet: 27. Juli 2013
    #3
    dodo83 gefällt das.
  5. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: Webif funktioniert nicht

    dpkg --configure -a mit diesem Befehl kommt keinerlei Fehlermeldung.Apache2 hatte ich nochmals installiert. Die installierte Oscam enthält das Webif und in oscam.conf
    "[webif]
    httpport = 10001
    httptpl = /var/etc/picon/
    httphelplang = de
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.178.2

    müßte auch richtig sein.
     
    #4
  6. Brainbug01
    Offline

    Brainbug01 Board Guru

    Registriert:
    26. Februar 2013
    Beiträge:
    1.486
    Zustimmungen:
    831
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    192.168.178.2, ist das auch die IP mit dem PC von dem du aufs Webif schauen möchtest? Da ja nur diese eine es darf... besser wäre den Bereich anzugeben 192.168.178.0-192.168.178.255 und noch etwas weiter 192.168.0.0-192.168.255.255
     
    #5
  7. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: Webif funktioniert nicht

    Korrekt, das hätte ich gleich dazuschreiben sollen. Was bringt der Bereich? Habe ja feste IP.
     
    #6
  8. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.942
    Zustimmungen:
    5.860
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    Hi,
    ist das " durch's Kopieren entstanden oder ist das wirklich mit in der config?
    Auf jedenfall gehört das da nicht hin.

    Guß
    Janni1
     
    #7
  9. Brainbug01
    Offline

    Brainbug01 Board Guru

    Registriert:
    26. Februar 2013
    Beiträge:
    1.486
    Zustimmungen:
    831
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    Der IP Bereich hilft dir von jedem Gerät das in deinem internen Netzwerk angemeldet ist sich einzuloggen. Sollte deine feste IP also mal nicht stimmen kommst du trotzdem drauf.
     
    #8
  10. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: Webif funktioniert nicht

    @janni1
    sorry mein Fehler, steht aber auch nicht in meiner oscam.conf
     
    #9
  11. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: Webif funktioniert nicht

    Habe noch folgenden Fehler gefunden
    /etc/init.d/apache2 restart
    apache2: Syntax erroron line210 of /etc/apache2/apache2.conf: Syntax erroe on line 1 of /etc/apche2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open sharedobject file: No such file or drectory
    Action `configtest`failed.
    The Apache error log may have more information.
    ... fail!

    aber es gibt leider keinen log.
     
    Zuletzt bearbeitet: 28. Juli 2013
    #10
  12. Brainbug01
    Offline

    Brainbug01 Board Guru

    Registriert:
    26. Februar 2013
    Beiträge:
    1.486
    Zustimmungen:
    831
    Punkte für Erfolge:
    113
    AW: Webif funktioniert nicht

    Was suchst du beim Apache2?
     
    #11
  13. errut
    Offline

    errut Meister

    Registriert:
    24. Mai 2008
    Beiträge:
    862
    Zustimmungen:
    20
    Punkte für Erfolge:
    18
    AW: Webif funktioniert nicht

    Ich hatte (siehe oben) den Apache2 nocheinmal installiert. Dachte , daß webif mit Apache2 zusammenhängt, jetzt fand ich die Fehleranzeige und daß lein log geschriben wird.
     
    #12

Diese Seite empfehlen