1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem WebIF 403 Forbidden Access denied.

Dieses Thema im Forum "OScam Archiv" wurde erstellt von marspoki, 21. Februar 2012.

  1. marspoki
    Offline

    marspoki Freak

    Registriert:
    25. Dezember 2009
    Beiträge:
    213
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    Hi Leute,

    ich habe ein kleines Problem mit dem WebIF von OSCAM. ich würde darauf gerne aus der Ferne zugreifen. Ich habe dazu auch die Ports im Router weitergeleitet und dachte nun das ich über -> meine.dyndn.com:15000 auf das Webif zugreifen kann.

    Da bekomme ich aber einen
    [h=4]403 Forbidden
    [/h] Access denied.

    Weiß jemand was ich falsch mache?

    [webif]
    httpport = 15000
    httpuser = username
    httppwd = Passwort
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.2.103-192.168.2.105
    httpdyndns = meine.dyndns.com
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. meister85
    Offline

    meister85 Chef Mod

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: WebIF 403 Forbidden Access denied.

    Ich empfehle es zwar nicht, aber das bleibt jedem selber überlassen....

    pass mal die Zeile an:

    httpallowed = 0.0.0.0-255.255.255.255

    Und tuh dir selber einen Gefallen und benutze eine Verschlüsselung -->

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #2
  4. marspoki
    Offline

    marspoki Freak

    Registriert:
    25. Dezember 2009
    Beiträge:
    213
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: WebIF 403 Forbidden Access denied.

    Ups - ich dachte das ginge einfacher - Brauche ich da echt Ubuntu um den Server SSL fähig zu machen?
     
    #3
  5. meister85
    Offline

    meister85 Chef Mod

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: WebIF 403 Forbidden Access denied.

    Achso du benutzt eine Dreambox oder ähnliches....

    Klar für die SSL Variante brauchst du ein Linux PC!

    Wenn nicht möglich, musst du halt ohne Verschlüsselung arbeiten...

    Dann halt nur die Zeile die ich dir oben gepostet habe abändern...
     
    #4
  6. marspoki
    Offline

    marspoki Freak

    Registriert:
    25. Dezember 2009
    Beiträge:
    213
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: WebIF 403 Forbidden Access denied.

    Na da muss ich mal ne Virtual Maschine installieren :)

    oder kann ich das Zertifikat dann nicht dort hinkopieren?
     
    #5
  7. meister85
    Offline

    meister85 Chef Mod

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: WebIF 403 Forbidden Access denied.

    Müsstest du ausprobieren, habe leider keine Dream mit SSL im Einsatz, aber ich denke dass sollte gehen...
     
    #6
  8. Bulldog3001
    Offline

    Bulldog3001 Meister Supporter

    Registriert:
    19. Juni 2010
    Beiträge:
    860
    Zustimmungen:
    570
    Punkte für Erfolge:
    93
    AW: WebIF 403 Forbidden Access denied.

    Ändere einfach die Zeile wie folgt ab:

    httpallowed = 127.0.0.1,192.168.xxx.yyy

    wobei xxx.yyy die IP Deines Rechners ist, wovon Du connecten willst. Bei mehreren Rechnern dann die IPs separat oder sie IP Range eintragen. Oscam nach dem einspielen neustarten.

    Mit der Zeile httpallowed = 0.0.0.0-255.255.255.255 öffnest Du Dein WebIF für JEDEN USER also alle IPs. Nur mit Vorsicht zu handhaben!!!

    Gruß,

    Bulldog3001
     
    #7
    Freys gefällt das.
  9. meister85
    Offline

    meister85 Chef Mod

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: WebIF 403 Forbidden Access denied.

    @Bulldog3001: Er schreibt ja:

    Dabei kommt er garnicht um rum, den Parameter httpallowed = 0.0.0.0-255.255.255.255 zu setzten.
     
    #8
  10. Bulldog3001
    Offline

    Bulldog3001 Meister Supporter

    Registriert:
    19. Juni 2010
    Beiträge:
    860
    Zustimmungen:
    570
    Punkte für Erfolge:
    93
    AW: WebIF 403 Forbidden Access denied.

    Aber sicher doch. httpdyndns = nutzen und auf z.B: Handy oder Laptop eine dyndns einrichten.
     
    #9
    meister85 gefällt das.
  11. meister85
    Offline

    meister85 Chef Mod

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: WebIF 403 Forbidden Access denied.

    Achso du meinst eine eigene DynDns für das jeweilige Gerät einrichten...

    Klar das wäre natürlich auch ne Lösung.
     
    #10
  12. Bulldog3001
    Offline

    Bulldog3001 Meister Supporter

    Registriert:
    19. Juni 2010
    Beiträge:
    860
    Zustimmungen:
    570
    Punkte für Erfolge:
    93
    AW: WebIF 403 Forbidden Access denied.

    Und somit auch sicherer als die Freigabe aller IPs.

    httpallowed = # Hier die IPs des internen Netzwerkes eintragen, die Zugriff auf das WebIF haben sollen
    httpdyndns = # dyndns.org Adresse eintragen, die Zugriff haben soll

    Auf dem z.B. Handy noch ein APP für Dyndns laden und einrichten. Über den Browser des Handy kann man dann mit der dyndns auf das WebIF des Receivers zugreifen. Der Port des WebIF muss natürlich im Router zum Receiver forwarded werden.

    Das ist die sicherste Methode ohne unnötige Freigaben.

    Gruß,

    Bulldog3001
     
    #11
    mrwong und marspoki gefällt das.
  13. marspoki
    Offline

    marspoki Freak

    Registriert:
    25. Dezember 2009
    Beiträge:
    213
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: WebIF 403 Forbidden Access denied.

    Genau das habe ich ja gedacht :)

    Also einfach ne dyndns fürs Handy einrichten und dann von dort zugreifen?

    Das wäre ja genial - doof natürlich das man nicht von öffentlichen rechnern dran kommt. Aber wens vom Handy geht ist das schonmal i.O.
     
    #12
  14. Bulldog3001
    Offline

    Bulldog3001 Meister Supporter

    Registriert:
    19. Juni 2010
    Beiträge:
    860
    Zustimmungen:
    570
    Punkte für Erfolge:
    93
    AW: WebIF 403 Forbidden Access denied.

    Ganz genau so. Dein Router hat vermutlich bereits eine Dyndns (für cs) dann im Browser nur die dyndns.Port_WebIF eingeben. Dann noch mit dem Usernamen und Passwort einloggen, wie es im Abschnitt Webif in der oscam.conf eingestellt ist, einloggen.

    Gruß,

    Bulldog3001
     
    #13
    schwob1983 gefällt das.

Diese Seite empfehlen