1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk VMware ESXi 5.0.1 - CCcam 2.1.3 - card detect fail

Dieses Thema im Forum "CS CCcam" wurde erstellt von gse85, 24. Juli 2013.

  1. gse85
    Offline

    gse85 Hacker

    Registriert:
    3. Oktober 2009
    Beiträge:
    379
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    Hallo,

    ich wollte meine physikalische Debian 6 CCcam Maschine in einer virtuellen VMware Umgebung betreiben.

    Ich habe im o. g. ESXi Server eine neue virtuelle Maschine (Debian 6.0.7 64 Bit) erstellt und installiert.

    VMware Tools wurden installiert, der Smargo (Firmware v1.7) wurde erkannt und wird unter lsusb angezeigt und als /dev/tty/USB0 eingebunden.

    Bis jetzt ist alles wie bei der physikalischen Maschine.

    Wenn ich CCcam starte, spuckt das Log immer:

    card detect fail

    aus.

    ---

    Probiert habe ich in der CCcam.cfg unter SERIAL READER den Zusatz "smartreader+" einzusetzen, leider kein Erfolg.

    Der Smargo ist auf "Normal" gestellt und soll eine Viaccess Karte auslesen.

    Verschiedene Smargos (alle die 1.7er Version) habe ich getestet, ohne Erfolg.

    Debian 7 habe ich ebenfalls probiert, gleiches Problem.

    ---

    Wenn ich den Kartenleser wieder in meine physikalische Debian 6 Maschine stecke und CCcam restarte, wird die Karte einwandfrei erkannt.

    ---

    Der Kartenleser wird sowohl von VMware als auch vom Debian richtig erkannt, aber die CCcam erkennt keine Karte.

    Woran könnte ich noch schrauben?

    Danke schonmal.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. monfire
    Offline

    monfire Ist gelegentlich hier

    Registriert:
    4. März 2009
    Beiträge:
    79
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: VMware ESXi 5.0.1 - CCcam 2.1.3 - card detect fail

    Hallo, hast Du auch den / die USP Ports für den Reader an den Gast weiter geleitet ? Ich selber habe auch ESXi im Einsatz und da gab es bisher keine Probleme.
     
    #2
  4. gse85
    Offline

    gse85 Hacker

    Registriert:
    3. Oktober 2009
    Beiträge:
    379
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: VMware ESXi 5.0.1 - CCcam 2.1.3 - card detect fail

    Ja, habe ich.

    Ich bin so vorgegangen:

    Zuerst habe ich den USB-Controller der virtuellen Debian 6 Maschine im vSphere Client auf dem ESXi zugeordnet.

    Nun habe ich den Smargo an einen USB-Port gesteckt und bin wieder zu den Einstellungen, wo auch der USB-Controller aufgelistet ist, den man ja braucht, damit überhaupt USB-Geräte erkannt werden können und habe ein USB-Gerät hinzugefügt, laut VMware hat das USB-Gerät folgende Bezeichnung:

    Future Technology Devices

    Wenn ich in der virtuellen Maschine lsusb aufrufe, wird der Smargo genauso aufgelistet, wie in der physikalischen Maschine. Der Reader wird im Debian als /dev/tty/USB0 eingebunden.

    Ich könnte die Smargo Einstellungen mal von "Normal" auf Dreambox ändern, viel mehr fällt mir nicht mehr ein.
     
    #3
  5. lullu08
    Offline

    lullu08 Elite Lord

    Registriert:
    31. Mai 2010
    Beiträge:
    4.347
    Zustimmungen:
    1.276
    Punkte für Erfolge:
    113
    AW: VMware ESXi 5.0.1 - CCcam 2.1.3 - card detect fail

    müsste doch unter Win /dev/ttyS0 heissen für Com1

    Oder verwendest die Serial:Reader 7F049A6 für Smarrgo Soft 1.5, 1.7

    über 52 Rules lässt er sich auch verlinken
    Code:
    /etc/udev/rules.d/52-smargo-reader.rules
    Code:
    SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{serial}=="Reader 7F049A6", SYMLINK+="Reader1"
    dann nennt er sich
    Code:
    device = /dev/Reader1
    alles andere ist schon mal falsch für Smargo, einfachhalber mal auf den Link klicken in oscam,
    steht dort alles beschrieben unter diverse
     
    Zuletzt bearbeitet: 25. Juli 2013
    #4

Diese Seite empfehlen